15:00:17 <noonedeadpunk> #startmeeting openstack_ansible_meeting
15:00:17 <opendevmeet> Meeting started Tue Sep 13 15:00:17 2022 UTC and is due to finish in 60 minutes.  The chair is noonedeadpunk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:17 <opendevmeet> The meeting name has been set to 'openstack_ansible_meeting'
15:00:25 <noonedeadpunk> #topic rollcall
15:00:28 <noonedeadpunk> o/
15:00:32 <damiandabrowski> hi!
15:00:41 <noonedeadpunk> I finally managed to set my alarm :D
15:02:21 * damiandabrowski waiting for winter time change :D
15:02:50 <noonedeadpunk> OH NO
15:02:57 <rgunasekaran> Hi
15:03:09 * noonedeadpunk googles if Croatia has summer time
15:03:40 <rgunasekaran> Who is from Croatia?
15:04:09 <noonedeadpunk> ¯\(◉◡◔)/¯
15:04:50 <noonedeadpunk> #topic office hours
15:05:13 <noonedeadpunk> So, first thing is that rocky9 job has failed. And I broke it even more now :D
15:05:28 * noonedeadpunk somebody need to reacall bash
15:07:44 <noonedeadpunk> The issue is that Rocky 9 defines VERSION_ID as 9.0 while it used to have bare 8 before. And CentOS also does have bare 9
15:08:58 <noonedeadpunk> So we somehow need to have regular expression in case statement https://review.opendev.org/c/openstack/openstack-ansible/+/857191/3/scripts/bootstrap-ansible.sh
15:09:06 <noonedeadpunk> and I obviosly did it wrong
15:10:16 <noonedeadpunk> another thing is that I made release for yoga that is broken because of keepalived version
15:10:38 <damiandabrowski> does case statement even support regex?
15:11:08 <noonedeadpunk> it should support shel patterns... https://www.gnu.org/savannah-checkouts/gnu/bash/manual/bash.html#Pattern-Matching
15:12:51 <NeilHanlon> o/ - double booked today but I saw your message earlier noonedeadpunk re: rocky, makes sense.. that's "expected" because Stream doesn't have minor releases, it's always just a whole number vs RHEL (and rocky/alma) which have the concept of minor releases
15:13:35 * jamesdenton reminder to discuss keepalived/vrrp 8 character auth truncation when the time is right
15:13:39 <noonedeadpunk> NeilHanlon: I'm pretty sure that full version used to be in CentOS elsewhere then in VERSION_ID?
15:14:02 <mgariepy> 9*(.*[0-9]))
15:15:09 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible master: Add Rocky Linux 9 to zuul and docs  https://review.opendev.org/c/openstack/openstack-ansible/+/857191
15:15:13 <noonedeadpunk> let's try it out :D
15:15:29 <noonedeadpunk> ok, yes, 8 char auth
15:15:39 <noonedeadpunk> do we want to leave auth at all :D?
15:16:18 <mgariepy> or more: 9*(.+[0-9])
15:16:25 <noonedeadpunk> as 1 - it's not _really_ working. Given another keepalived will run in the same multicast domain, auth won't be really respected
15:16:49 <noonedeadpunk> ah, yes, makes sense mgariepy
15:16:53 <ThiagoCMC> Folks, my setup-infrastructure.yml (Ubuntu 20.04) is failing to mount /var/www/repo in the repo container. I can't see any gluster being configured by OSA, should I do this in advance before OSA? Or can I just ignore this?
15:17:10 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible master: Add Rocky Linux 9 to zuul and docs  https://review.opendev.org/c/openstack/openstack-ansible/+/857191
15:17:54 <noonedeadpunk> and eventually auth has been dropped from VRRP 3
15:18:06 <noonedeadpunk> So maybe we should look into switching to VRRP 3 isntead?
15:19:45 <jamesdenton> we could do that
15:21:03 <noonedeadpunk> so what we saw one day - is keepalived was flapping because of another keepalived was running in same network with same router ids (but different auth password)
15:21:18 <noonedeadpunk> so auth kind of useless anyway imo
15:21:48 <noonedeadpunk> and switching to vrrp3 will be step forward into ipv6 only deployments
15:21:57 <jamesdenton> that makes it easy, then
15:21:59 <noonedeadpunk> Which I guess we should set as a goal one day
15:22:21 <noonedeadpunk> ok, great then agreed? :)
15:22:37 <jamesdenton> # Note: authentication was removed from the VRRPv2 specification by RFC3768 in 2004.
15:22:41 <anskiy> noonedeadpunk: well, that's why I set unicast_peers :)
15:22:53 <jamesdenton> lol, yes, agreed
15:23:54 <noonedeadpunk> #agreed drop auth from keepalived and work on switching to VRRPv3
15:25:32 <noonedeadpunk> And I will release bugfix for yoga as it's now broken because of keepalived
15:25:48 <jamesdenton> sounds good
15:26:25 <jamesdenton> should we consider unicast or stick with multicast?
15:27:07 <noonedeadpunk> Um, not really sure
15:27:30 <noonedeadpunk> I wonder about possible overhead when having unicast
15:28:04 <anskiy> https://review.opendev.org/c/openstack/openstack-ansible/+/854370 with this, there could be just a mention in docs
15:28:32 <jamesdenton> good compromise
15:28:50 <noonedeadpunk> well, feel free to add usecase to docs ;)
15:28:53 <jamesdenton> is that how you configured yours?
15:29:36 <anskiy> jamesdenton: I think, I'm still overriding the whole thing... But that was the purpose, yeah
15:30:00 <jamesdenton> cool cool
15:33:50 <noonedeadpunk> Eventually it's also time to fill in topics for upcoming PTG.
15:34:19 <noonedeadpunk> I;ve jsut created etherpad page - will put some content soon
15:34:20 <noonedeadpunk> #link https://etherpad.opendev.org/p/osa-antelope-ptg
15:37:21 <noonedeadpunk> Regarding that - I think we might want to add operator hour as well
15:37:46 <noonedeadpunk> This might be useful to hear back from operators. I'm not sure how that initiative will fly, but worth trying
15:38:02 <noonedeadpunk> I'm thinking to sign-up osa on wednesday. wdyt?
15:38:42 <damiandabrowski> fine for me
15:40:05 <mgariepy> works for me also
15:41:05 <mgariepy> wenesday is oct 19 tho ;)
15:42:33 <noonedeadpunk> I'm talking about operators hours I was talking about. For the team PTG I've signed up on Tuesday as usual
15:42:47 <noonedeadpunk> But it's not written in stone - I can change that if needed?
15:45:01 <damiandabrowski> so PTG on Tuesday and operator hours on Wednesday? ok for me
15:45:10 <mgariepy> ha ok . sorry not following 100%, i'm in a meeting
15:45:35 <noonedeadpunk> yup, nice
15:57:58 <noonedeadpunk> #endmeeting