15:08:41 <noonedeadpunk> #startmeeting openstack_ansible_meeting
15:08:41 <opendevmeet> Meeting started Tue Jun 20 15:08:41 2023 UTC and is due to finish in 60 minutes.  The chair is noonedeadpunk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:41 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:41 <opendevmeet> The meeting name has been set to 'openstack_ansible_meeting'
15:08:46 <noonedeadpunk> sorry for being late
15:08:50 <noonedeadpunk> #topic rollcall
15:08:52 <noonedeadpunk> o/
15:08:57 <NeilHanlon> hiya
15:09:32 <jrosser> o/ hello
15:10:18 <noonedeadpunk> #topics bug triage
15:10:36 <noonedeadpunk> we've been reported quite some bugs lately, including 2023.1 release
15:11:13 <noonedeadpunk> The first one related to ceph_client has been already merged and backport proposed
15:11:15 <noonedeadpunk> #link https://bugs.launchpad.net/openstack-ansible/+bug/2024339
15:11:43 <noonedeadpunk> Next one, is that I clean forgot to bump plugins collection version to match 2023.1
15:11:45 <noonedeadpunk> #link https://bugs.launchpad.net/openstack-ansible/+bug/2024407
15:12:16 <noonedeadpunk> I plan to do that during bump for next release
15:12:31 <damiandabrowski> hi
15:12:45 <noonedeadpunk> But good to mention that now, as in case I will forget about it again someone would stop bump during review
15:12:49 <jrosser> how did that
15:13:07 <jrosser> sorry - where should we have bumped that? in a-r-r?
15:13:14 <noonedeadpunk> a-c-r
15:13:18 <jrosser> ok
15:13:28 <noonedeadpunk> as we install it as a collection
15:13:49 <noonedeadpunk> and I didn't touch collections as didn't want to bring in untested things
15:14:13 <noonedeadpunk> and it works in CI as we take version from zuul required-projects rather then clone I believe
15:14:57 <jrosser> hmm ok
15:15:34 <noonedeadpunk> and last, but not least this one regarding nova failing on password update
15:15:40 <noonedeadpunk> #link https://bugs.launchpad.net/openstack-ansible/+bug/2023370
15:16:12 <noonedeadpunk> as a solution to that I've proposed to just add a variable that will control if password should be forcefully set or not.
15:16:22 <noonedeadpunk> with changing default behaviour
15:18:08 <noonedeadpunk> also worth updating doc I believe - I can recall we've stated somewhere that password rotation is not supported
15:18:17 <noonedeadpunk> so might be worth adding details in there
15:18:29 <noonedeadpunk> have hard times finding where it was
15:19:06 <noonedeadpunk> Also, during summit I've promised to create a bugs for irrelevant documentation, so that contributors could step in fixing it
15:19:26 <noonedeadpunk> #action noonedeadpunk to create bug reports for irrelevant documentation
15:21:58 <noonedeadpunk> #topic office hours
15:22:43 <noonedeadpunk> I think main things we might wanna do now, is to kill focal tests, and finally update ansible-core version
15:22:48 <noonedeadpunk> along with collections
15:23:25 <jrosser> yes that would be good
15:24:16 <noonedeadpunk> I've started looking into where we use focal explicitly and using topic:osa/sunset-focal
15:24:45 <noonedeadpunk> was checking integrated repo right now
15:28:08 <noonedeadpunk> I've also tried to update doc on releasing activities, to make it more clear and somewhat a checklist of what we need to do when
15:28:09 <noonedeadpunk> https://review.opendev.org/c/openstack/openstack-ansible/+/885376
15:31:16 <noonedeadpunk> The question is though - when we wanna have a new release for 2023.1?
15:31:31 <noonedeadpunk> Should we make one right away once determined bugs are covered?
15:31:41 <noonedeadpunk> or should we wait for some more reports?
15:32:11 <jrosser> we have usually made a .1.0 release when we think most things are shaken down
15:32:43 <jrosser> not sure if we are early for that or not tbh
15:33:42 <noonedeadpunk> I'm kinda in favor of a .0.1, but given we have a "feature" backports - releases team don't like making a bugfix release with such release notes
15:34:17 <noonedeadpunk> and https://review.opendev.org/c/openstack/openstack-ansible-plugins/+/886458 is smth worth backporting I believe
15:34:54 <jrosser> feels like that resolves a bug really
15:35:38 <noonedeadpunk> but also changes a behaviour
15:35:49 <noonedeadpunk> so yeah...
15:36:12 <noonedeadpunk> maybe I can drop a release note for 2023.1 bump, but that's kinda nasty thing to do
15:36:20 <NeilHanlon> do we have an incompatible upgrades policy ?
15:37:12 <noonedeadpunk> yeah, kinda
15:37:29 <noonedeadpunk> though this specific change does not break anything per say
15:37:48 <NeilHanlon> True...
15:39:25 <noonedeadpunk> but per say yes, we try to avoid doing incompatible upgrades
15:39:32 <noonedeadpunk> *in general
15:41:06 <NeilHanlon> no one deploys .0 releases anyways!!
15:41:41 <noonedeadpunk> hehe, yeah, that's what we don't suggest for sure :D
15:42:15 <noonedeadpunk> usually what we say is that .1.0 is usually good enough to upgrade to
15:57:21 <noonedeadpunk> #endmeeting