15:05:06 <noonedeadpunk> #startmeeting openstack_ansible_meeting
15:05:06 <opendevmeet> Meeting started Tue Sep 19 15:05:06 2023 UTC and is due to finish in 60 minutes.  The chair is noonedeadpunk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:06 <opendevmeet> The meeting name has been set to 'openstack_ansible_meeting'
15:05:15 <noonedeadpunk> #topic rollcall
15:05:19 <noonedeadpunk> o/
15:05:48 <mgariepy> hey
15:05:52 <mgariepy> half there.
15:05:53 <noonedeadpunk> Sorry folks, I got my laptop dead couple of hours ago, so will be pretty much away until will get a new one
15:06:14 <noonedeadpunk> In the meanwhile - we can catch up on what's going on
15:07:22 <jamesdenton> o/
15:07:29 <jrosser> o/ hello
15:09:20 <noonedeadpunk> # topic office hours
15:09:34 <noonedeadpunk> Ugh
15:09:45 <noonedeadpunk> #topic office hours
15:10:24 <noonedeadpunk> So, we had good progress on merging ansible-core 2.15, but I've pushed patches that break linters again
15:10:34 <noonedeadpunk> So some more reviews are needed
15:10:59 <noonedeadpunk> And maybe we should prevent from merging other things until then?
15:11:18 <noonedeadpunk> As it starts to be annoying...
15:13:17 <jrosser> it is these https://review.opendev.org/q/topic:osa%252Fcore-2.15
15:13:25 <noonedeadpunk> Yes
15:13:48 <noonedeadpunk> We also have deploy guide job broken now
15:14:45 <noonedeadpunk> But, seems the fix works
15:15:33 <noonedeadpunk> Aha, it's already in gates
15:15:44 <noonedeadpunk> Then we need to decide on PTG time
15:16:51 <noonedeadpunk> I'd suggest October 24
15:17:02 <noonedeadpunk> (it's Tuesday)
15:18:03 <mgariepy> would work for me.
15:18:03 <noonedeadpunk> Smth like 14-17 UTC?
15:18:14 <noonedeadpunk> Or 15-18
15:18:44 <jrosser> oct 24 looks ok
15:19:38 <mgariepy> either of the time are ok with me.
15:21:11 <noonedeadpunk> Awesome
15:21:22 <noonedeadpunk> I will book a time slot then
15:21:42 <noonedeadpunk> Do we want to have an operator hour? As this seems to not work in fact
15:22:17 <noonedeadpunk> Will also create an etherpad for topics
15:22:38 <noonedeadpunk> #action noodeadpunk to book ptg slot and create an etherpad
15:23:30 <noonedeadpunk> Right before my laptop went down, I was trying to come up with cycle highlights
15:24:49 <noonedeadpunk> I was about to mention: Debian 12, Ansible core 2.15, rabbitmq 3.12 and quorum queues
15:25:13 <noonedeadpunk> Was thinking about skyline, but I put zero effort there as of today
15:25:35 <noonedeadpunk> Anything else worth to mention?
15:25:55 <noonedeadpunk> I hate timing when we should push these, but we have what we have...
15:26:01 <jrosser> feels somehow like we spend most of this cycle stabilising 2023.1
15:26:07 <noonedeadpunk> Yeah
15:26:26 <noonedeadpunk> And it was only partially our fault
15:27:05 <opendevreview> Merged openstack/openstack-ansible master: [doc] Fix deployment guide renderring  https://review.opendev.org/c/openstack/openstack-ansible/+/895769
15:27:33 <noonedeadpunk> A lot of keystone regressions as well
15:27:49 <noonedeadpunk> Though, might be this time we release in time...
15:28:31 <jrosser> quorum queues is probably the big thing to get completed
15:29:05 <jrosser> there is also some test improvements, i fixed a load of mess in os_tempest for more complex scenarios
15:29:08 <jrosser> not sure that is all merged
15:29:31 <noonedeadpunk> Yeah, not sure it fits in highlights...
15:29:44 <noonedeadpunk> As not sure plenty of ppl care about that
15:30:13 <jrosser> likley not
15:30:50 <noonedeadpunk> Will add skyline I guess... still plenty of time to work on that 😅
15:32:03 <jrosser> good luck
15:32:27 <jrosser> i think there is 'interesting' stuff to unpick there
15:32:45 <noonedeadpunk> Yeah... I can imagine...
15:32:55 <noonedeadpunk> But it was asked quite a lot
15:33:03 <noonedeadpunk> So worth trying
15:33:06 <jrosser> though actually we might have made it all a bit easier with haproxy maps now
15:33:21 <noonedeadpunk> Ah. Also, do we want to enable quorum queues by default now?
15:33:40 <noonedeadpunk> As this is smth that teases me
15:33:54 <jrosser> if we can make that work on 3.x then the upgrade to 4.x would be smooth
15:34:19 <jrosser> like switch to quorum independantly of the major version upgrade of rabbitmq
15:34:24 <noonedeadpunk> Yeah, that's true. I guess it works, in general, but not sure about defaults
15:34:40 <noonedeadpunk> They're quite some improvements to oslo regarding that from OVH
15:34:45 <noonedeadpunk> That are not merged yet
15:36:07 <noonedeadpunk> https://review.opendev.org/q/topic:bug-2031497
15:37:12 <noonedeadpunk> And they should make quite a difference imo
15:37:42 <noonedeadpunk> So maybe we should disable quorum by default once we merge the topic and add another job to check that?
15:38:05 <noonedeadpunk> Or dunno
15:38:20 <noonedeadpunk> Really afraid after OVN
15:39:45 <jrosser> that would be lower risk
15:40:05 <jrosser> we could also switch to quorum pretty quick after we release
15:40:25 <noonedeadpunk> Yeah, that as well
15:40:26 <jrosser> like get the code and default setting merged before release
15:40:35 <jrosser> then switch the default afterwards
15:40:54 <noonedeadpunk> Well, not sure how much lower, given that rabbit is a nasty thing on it's own
15:41:15 <noonedeadpunk> And you can understand if it's working or not only at scale at day2 ops
15:42:29 <noonedeadpunk> Ok, sounds like a plan then
15:42:51 <noonedeadpunk> That's all for me, does anybody has smth to discuss?
15:45:26 <jrosser> we have some bugs
15:46:26 <jrosser> like https://bugs.launchpad.net/openstack-ansible/+bug/2034714
15:50:26 <jrosser> i can only think that they have overridden `memcached_servers` there to point to the internal VIP
15:53:52 <noonedeadpunk> Yeah, we have doc for that for "balancing" memcached through haproxy
15:54:22 <noonedeadpunk> No idea why that would cause such issue..
15:54:23 <noonedeadpunk> But maybe it relies on a cache in a way...
15:54:48 <noonedeadpunk> Worth checking that for sure
15:54:57 <noonedeadpunk> Or well, asking about that at least
15:59:22 <noonedeadpunk> #endmeeting