15:01:00 <noonedeadpunk> #startmeeting openstack_ansible_meeting
15:01:00 <opendevmeet> Meeting started Tue Nov  7 15:01:00 2023 UTC and is due to finish in 60 minutes.  The chair is noonedeadpunk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <opendevmeet> The meeting name has been set to 'openstack_ansible_meeting'
15:01:06 <noonedeadpunk> #topic roll call
15:01:08 <noonedeadpunk> o/
15:01:09 <NeilHanlon> o/ heya
15:01:18 <mgariepy> hey
15:01:20 * NeilHanlon resists urge to use other meetbot's commands
15:04:04 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible-plugins master: Set the default domain for the role_assignment  https://review.opendev.org/c/openstack/openstack-ansible-plugins/+/900329
15:04:13 <noonedeadpunk> #topic office hours
15:04:28 <noonedeadpunk> so. I have barely catched up with what happened last wekk
15:07:11 <jrosser> o/
15:07:39 <NeilHanlon> heya jrosser
15:08:05 <noonedeadpunk> From what I see we've almost landed quorum_queues, with very valid comment on the ceilometer role
15:08:50 <NeilHanlon> there was also a question last week about quorum queues for Keystone and Swift
15:08:53 <noonedeadpunk> We also do have zun, magnum and manila roles broken
15:09:07 <noonedeadpunk> yeah, I guess that's related to the comment
15:09:39 <noonedeadpunk> I think I've skipped these 2 because neither keystone nor swift do not use them for RPC
15:09:49 <noonedeadpunk> but I think they indeed should be covered
15:10:11 <noonedeadpunk> #action noonedeadpunk to propose quorum_queues patches for keystone and swift
15:10:35 <NeilHanlon> depending on the work required, I think it'd be ok to postpone to after release, since as you said they are not used for RPC
15:10:48 <noonedeadpunk> For broken roles I had a look only at manila, and it's broken due to ceph-ansible being incompatible with ansible-core 2.15
15:11:27 <NeilHanlon> also FYI RHEL 9.3 released today. So.. Rocky 9.3 will come at some point. I'll give advanced notice
15:11:28 <anskiy> NeilHanlon: yeah, instead of remembering that thing, I've manaaged to put valid comment :)
15:11:30 <noonedeadpunk> And I even proposed PR: https://github.com/ceph/ceph-ansible/pull/7466
15:12:00 <NeilHanlon> anskiy: thank you :D I did also put it on our last PTG etherpad so I would remember (somehow)
15:12:44 <noonedeadpunk> But I kinda concerned if it will merge and if it will - I highly doubt it would be backported by release due time...
15:13:45 <noonedeadpunk> regarding magnum and zun - they seem to both fail with DB upgrade. I haven't looked there yet. And that has also happened after updating SHAs...
15:14:25 <noonedeadpunk> Would need to have a closer look what's wrong there.
15:14:48 <NeilHanlon> hm
15:16:00 <noonedeadpunk> from good news - distro path seems to "just work" after switching to Bobcat :)
15:16:10 <NeilHanlon> 🥳
15:17:35 <noonedeadpunk> oh, well, magnum is slightly different. but not less confusing
15:17:55 <jrosser> something odd is happening there
15:18:29 <jrosser> `The container-infrastructure-management service for default:RegionOne exists but does not have any supported versions.`
15:19:15 <noonedeadpunk> yeah
15:19:25 <noonedeadpunk> but sometimes it pass...
15:19:33 <noonedeadpunk> so would need to reproduce this one
15:20:37 <jrosser> that error actually is from the SDK, so it could be trouble anywhere from SDK onward
15:21:16 <noonedeadpunk> For openstack-resources topic: trove seems good except upgrade jobs. Apparently, role trying to change the network that's in use and fails. Likely I've missed something, as that works nicely for octavia which is pretty much simmilar: https://review.opendev.org/c/openstack/openstack-ansible-os_trove/+/899284
15:21:48 <noonedeadpunk> so magnum and standalone playook left to reach the minimum par for the role
15:32:29 <noonedeadpunk> no progress regarding skyline so far
15:33:35 <anskiy> for some reason I've been poking at the Vagrantfile inside openstack-ansible: I've added some cache (which breaks a bit at simultaneous package installation in containers) and roles/collections passthrough: https://github.com/dbalagansky/openstack-ansible/commit/b9168a5d022a5321c7bca4b7f5bbb470eccbaa7c
15:38:40 <noonedeadpunk> anskiy: to be frank - we didn't maintained that for quite a while now
15:39:59 <noonedeadpunk> so I can hardly comment on that and I was kinda thinking to clean that up with functional tests repo and functional jobs from tox
15:40:09 <jrosser> i think there was even the start of an effort to remove all of that
15:40:56 <noonedeadpunk> and now with vagrant being BSL-licensed...
15:41:36 <NeilHanlon> yeahhhh
15:42:54 <nixbuilder> Anyone have any ideas where I can start looking to fix this error: "infra01 neutron-rpc-server[8037]: SQL connection failed. 10 attempts left." Keeps repeating over and over.  Plus connecting to port 9696 yet that port is open on the server.
15:46:54 <noonedeadpunk> I think it 's a good idea to have some easy way to spawn aio is some kind of VM on the localhost without much fuss. But I kinda failed to find a good option except virt-manager....
15:51:39 <anskiy> noonedeadpunk: well, I was hoping to fix two thing: eliminate running with patches between the host and VM, and ability to easily instantiate MNAIO
15:52:36 <anskiy> and the last part is what I've had previously, but with some additional roles in the middle (which rendered openstack_user_config, for example)
15:53:33 <anskiy> I can probably try rewriting this thing on plain ansible with `community.libvirt` collection, if this is really something that's welcome :)
15:55:59 <noonedeadpunk> I actually was thinking about re-writing MNAIO for quite a while but never had a chance
15:56:44 <noonedeadpunk> And my idea was also to have some test_openstack_user_config that would be parsed by dynamic_inventory and provided as input to some role that will spawn resources
15:56:44 <jrosser> i think jamesdenton has looked also at the MNAIO
15:56:49 <noonedeadpunk> yeah
15:57:46 <NeilHanlon> crap forgot to bring up my thing but it's not very long or important.. I made some progress on Incus for Fedora and Enterprise Linux, and made a connection with someone who did a much better job than I at packaging it, too :) so -- will be working on that in my spare time to get it ready for Rocky 9 and friends
15:58:00 <noonedeadpunk> and yeah, community.libvirt was on the radar as one "driver", while another "driver" was to use already existing openstack project (and probably leverage openstack_resources role for that purpose)
15:58:20 <noonedeadpunk> NeilHanlon: oh, these are great news!
15:58:52 <NeilHanlon> there is apparently some *drama* happening with some of the dependencies of LXD, so will be interesting to see how it plays out
15:59:06 <NeilHanlon> `cowsql` and `raft`, specifically
15:59:38 <noonedeadpunk> I assume that incus folks should be also quite interested to provide some help with that effort
15:59:57 <NeilHanlon> I assume so as well
16:00:12 <noonedeadpunk> yeah, I think I've read smth about cowsql at least in one of their blogposts
16:00:27 <NeilHanlon> raft apparently has had two ABI changes this year without a soname bump, which is.. ugh
16:00:46 <NeilHanlon> #link https://github.com/ganto/copr-lxc4
16:01:03 <NeilHanlon> mostly that's for me, but, yeah. that's where I'll be looking to build some crap on EPEL with :)
16:01:38 <NeilHanlon> notably, it also should mean we can eventually remove the dependency on my personal copr for lxc4
16:02:06 <NeilHanlon> (https://opendev.org/openstack/openstack-ansible-lxc_hosts/src/branch/master/vars/redhat-host.yml#L19)
16:02:11 <noonedeadpunk> at some point I think I've proposed patch for that....
16:02:32 <noonedeadpunk> I _think_ it was build for epel even?
16:03:09 <noonedeadpunk> https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-968b01292a
16:03:41 <noonedeadpunk> #endmeeting