15:01:31 <noonedeadpunk> #startmeeting openstack_ansible_meeting
15:01:31 <opendevmeet> Meeting started Tue Feb 13 15:01:31 2024 UTC and is due to finish in 60 minutes.  The chair is noonedeadpunk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:31 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:31 <opendevmeet> The meeting name has been set to 'openstack_ansible_meeting'
15:01:39 <mgariepy> hey !
15:01:45 <jrosser> o/ hello
15:01:52 <damiandabrowski> hi!
15:01:57 <noonedeadpunk> Well, since our bug fighting day co-located with our regular meeting - let's combine these 2 things I guess?
15:02:25 <noonedeadpunk> But before that we have 1 thing to discuss I guess
15:02:49 <noonedeadpunk> As you might seen, unmaintained/yoga branch was created as part of the new process by TC
15:03:00 <NeilHanlon> o/
15:03:01 <noonedeadpunk> right now kinda nobody have permissions there
15:03:31 <noonedeadpunk> So idea by TC was that unmaintained branches are "maintained" by separate group of individuals if they want to
15:04:44 <noonedeadpunk> But probably it makes sense to add just osa-core group to osa-unmaintained-cores?
15:05:00 <NeilHanlon> that makes sense to me
15:05:16 <NeilHanlon> if the time comes that we have people really wanting to take care of those and we (current cores) don't want to, we can reevaluate ;)
15:05:17 <mgariepy> to me as well.
15:05:18 <noonedeadpunk> Why it was not done by default, is because some teams feel too accountable and resopnsible when they're assigned somewhere as cores
15:06:10 <noonedeadpunk> so if we don't have cultural issues for being "responsible" for unmaintained/* I will propose to combine these 2 for now
15:06:12 <noonedeadpunk> ok
15:06:29 <jrosser> sounds ok
15:06:57 <damiandabrowski> +1
15:07:02 <noonedeadpunk> #agreed to assign current cores to unmaintained cores
15:07:06 <noonedeadpunk> ok, great
15:07:21 <noonedeadpunk> does anybody want to raise smth before bug triage starts?
15:08:01 <noonedeadpunk> (except that it's time to tag 28.1.0)
15:08:54 <opendevreview> Merged openstack/openstack-ansible-plugins master: Add role to do common setup tasks for lxc containers  https://review.opendev.org/c/openstack/openstack-ansible-plugins/+/900529
15:09:08 <noonedeadpunk> #topic bug triage
15:09:30 <noonedeadpunk> So, I guess we might want to go through bugs based on their last update date
15:09:32 <noonedeadpunk> #link https://bugs.launchpad.net/openstack-ansible/+bugs?orderby=-date_last_updated&start=0
15:10:20 <noonedeadpunk> And probably we can split between pages and then beginning/end of the page?
15:10:44 <NeilHanlon> sounds good
15:11:07 <mgariepy> there are a lot of them :) haha
15:11:46 <noonedeadpunk> Yeah, but we potentially can start from older ones, saying pre-2020
15:12:04 <noonedeadpunk> or starting 2020
15:12:21 <noonedeadpunk> There's extreme chance to just close them with Fix released
15:12:36 <noonedeadpunk> or Won't fix because it's about smth we've re-worked havily lately
15:13:08 <noonedeadpunk> If not sure about anything - just throw link here and let's have short discussion
15:13:23 <noonedeadpunk> or.. we can have an etherpad
15:13:45 <noonedeadpunk> #link https://etherpad.opendev.org/p/osa-feb-2024-bug-triage
15:14:46 <noonedeadpunk> so we can organize/record better
15:15:03 <noonedeadpunk> the ones we're not sure about
15:15:29 <jrosser> so things that are obviously out of date we can just deal with without discussing? or shall we record everything there?
15:16:16 <noonedeadpunk> no-no, jsut record what we are unsure about
15:16:30 <noonedeadpunk> as old =! invalid in some cases
15:16:48 <noonedeadpunk> Like https://review.opendev.org/c/openstack/ansible-role-systemd_networkd/+/908815 was good example of 5yo buld...
15:16:54 <noonedeadpunk> *bug
15:17:01 <noonedeadpunk> no need to record everything
15:17:05 <mgariepy> some have patches but lp wasn't updated to fix released.
15:17:14 <noonedeadpunk> yup
15:21:54 <noonedeadpunk> plenty of Rocky issues actually
15:22:49 <noonedeadpunk> just for the record - we've started with 265 bugs
15:33:39 <damiandabrowski> how can we avoid verifying same bug report multiple times?
15:33:45 <damiandabrowski> for ex. person A looks at a bug report and decides that there's no update required.
15:34:07 <noonedeadpunk> Let's split efforts by pages?
15:34:08 <damiandabrowski> how to avoid person B spending time on this bug report?
15:34:52 * noonedeadpunk trying to find away to configure bugs per page
15:35:34 <noonedeadpunk> but there're 4 pages...
15:35:47 <noonedeadpunk> So you can say - working on page # from beggining/end
15:36:46 <damiandabrowski> but pages are dynamic :D if you mark few bugs with "fix released" and refresh page, you'll get different output
15:37:50 <noonedeadpunk> yeah....
15:37:52 <noonedeadpunk> I know.
15:40:44 <noonedeadpunk> I don't have good answer unfortunatelly.
15:41:01 <noonedeadpunk> So if you have an idea it's always welcome
15:44:16 <damiandabrowski> no, i also don't see any good solution :/
15:44:16 <damiandabrowski> i'll start from the top of this page: https://bugs.launchpad.net/openstack-ansible/+bugs?orderby=-importance&memo=75&start=75
15:50:00 <opendevreview> Merged openstack/openstack-ansible-os_ironic master: Fix a typo in pxe_redfish definition  https://review.opendev.org/c/openstack/openstack-ansible-os_ironic/+/906353
15:56:25 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible-openstack_hosts master: Place sysctl options to it's own file  https://review.opendev.org/c/openstack/openstack-ansible-openstack_hosts/+/908912
15:58:54 <NeilHanlon> bit distracted fixing some networking things here, but should be able to help out more in a few minutes
16:03:24 <opendevreview> Merged openstack/openstack-ansible master: Remove tempest concurrency exception for Octavia AIO  https://review.opendev.org/c/openstack/openstack-ansible/+/908831
16:28:10 <opendevreview> Merged openstack/openstack-ansible master: Fix formatting issue for SPICE HAProxy httpcheck  https://review.opendev.org/c/openstack/openstack-ansible/+/908746
16:29:04 <opendevreview> Merged openstack/openstack-ansible-os_nova stable/2023.1: Always distribute qemu config file  https://review.opendev.org/c/openstack/openstack-ansible-os_nova/+/908266
16:30:25 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible stable/2023.2: Fix formatting issue for SPICE HAProxy httpcheck  https://review.opendev.org/c/openstack/openstack-ansible/+/908922
17:19:56 <mgariepy> back to deprecated.. https://github.com/ceph/ceph-ansible/commit/a9d1ec844d24fcc3ddea7c030eff4cd6c414d23d
17:40:31 <jrosser> do we need to end the meeting?
17:42:48 <noonedeadpunk> oh, yes
17:42:52 <noonedeadpunk> #endmeeting