15:31:05 <j^2> #startmeeting openstack-chef
15:31:06 <openstack> Meeting started Fri Aug 29 15:31:05 2014 UTC and is due to finish in 60 minutes.  The chair is j^2. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:31:09 <openstack> The meeting name has been set to 'openstack_chef'
15:31:18 <j^2> #topic General Discussion
15:31:27 <j^2> Hey everyone
15:31:58 <j^2> #action auto-op openstack it seems it isn’t
15:32:25 <j^2> So the openstack ops meetup was in San Antonio this last Monday Tuesday
15:32:51 <j^2> There was a great oppertunity for discussion and debate about running Openstack
15:33:04 <j^2> I even met some of yall face to face which is great :)
15:33:12 <markvan> j^2: hi
15:33:20 <j^2> markvan: hey!
15:33:30 <j^2> here’s a link to the etherpad if you’re curious
15:33:33 <j^2> #link https://etherpad.openstack.org/p/SAT-ops-meetup
15:33:55 <j^2> and a link to the openstack-chef one:
15:34:02 <j^2> #link https://etherpad.openstack.org/p/SAT-ops-chef
15:34:56 <j^2> We talked about quite a few things in the 45 min session dedicated to openstack-chef, the most interesting one is the Templates section on line 42
15:35:26 <j^2> PaulCzar: suggested leveraging hashes to make the templates, just like on line 42
15:35:34 <j^2> #link https://github.com/rackerlabs/cookbook-openstack-paas/blob/master/templates/default/solum.conf.erb
15:35:56 <j^2> it’ll probably be a good amount of work, but i think it it might be worth looking into at least
15:37:01 <j^2> In some other discussions I discovered there is some interest with creating a RDO type build with chef as the underlying technology.
15:37:18 <j^2> #action j^2 should follow up with carlp about this
15:37:44 <carlp> yes please :)
15:38:04 <j^2> carlp: was there anything you’d like to mention about the meetup?
15:38:28 <markvan> not sure I follow the hash template idea, but I'm interested in knowing more at some point.
15:38:37 <carlp> nope, I think it's all covered in the etherpad
15:39:23 <j^2> markvan: yeah i think it’s very much in its infancy, but we can discuss it on the live meeting if you’d like. I think it’s gonna be an on going discussion
15:39:44 <j^2> carlp: awesome
15:39:49 <markvan> sure, sounds good
15:40:40 <j^2> ok, so i’d like to open this up to any other topics that would like to be discussed
15:41:52 <openstackgerrit> Mark Vanderwiel proposed a change to stackforge/cookbook-ceph: Add Testing.md   https://review.openstack.org/115083
15:44:11 <libsysguy> as a newb here, it seems like a lot of the vagrant examples are out of date
15:44:28 <libsysguy> I didn't know if those accepted PR's to update
15:44:28 <j^2> libsysguy: yep, and there’s some nasty issues with it
15:44:51 <j^2> that’s where my singlestack build comes into play it leverages chef-metal to build the vagrant instances
15:44:59 * libsysguy goes to ctrl - c that install
15:45:00 <j^2> instance i should say
15:45:13 <j^2> #link https://github.com/jjasghar/singlestack
15:45:49 <j^2> it’s almost ready for “official” blessing, i need to work on the neutron piece. nova networking is flaky at best
15:45:57 <libsysguy> awesome, ty
15:46:09 <j^2> libsysguy: if you’d pull it down and hack on it i’d be greatlly appreciated i need more eyes on it
15:46:34 <markvan> j^2: did you get past that glance db issue now?
15:46:37 <j^2> it’s the begining of the integration tests that PaulCzar and i where talking about durring the meeting
15:46:38 <libsysguy> yeah I'll be happy to take a look at it from a newcomers perspective
15:46:40 <j^2> markvan: yep :D
15:47:07 <j^2> oh! and i confirmed that every DB should be _by_default_ be UTF8
15:47:14 <j^2> so if you see ANYTHING that isn’t please report it
15:47:23 <markvan> j^2: be aware, there's also one coming for neutron db....there messy with in a big way right now.
15:47:35 <j^2> #info All DBs should be UTF8 according to the OpsMeetup
15:47:48 <j^2> markvan: lovely
15:48:02 <markvan> hopefully it will only be a small hit to our network cookbook server recipe to change how we do db migration script.
15:48:43 <j^2> ah nice
15:48:50 <markvan> j^2: have you tried Juno with your single stack yet?
15:49:24 <j^2> the pkgs arent built in the repos last i checked, and i havent spent any time to attempt to build them myself
15:50:24 <markvan> ah, ok.  Maybe next week I'll try this with the ibm juno repo's to see how that looks.
15:50:59 <j^2> God speed sir, you have a more adventurous mind then me :P
15:51:52 <j^2> #action markvan will attempt the singlestack repo with IBMs juno repo
15:56:34 <markvan> quick update on gate issue?
15:56:38 <j^2> sure
15:56:43 <j^2> #topic Gate Issue
15:57:04 <markvan> latest patch/hack for this is https://review.openstack.org/#/c/117274/2
15:57:36 <markvan> basically the gates have switched to Trusty and at about the same time we switch to Berkshelf 3.x.
15:58:36 <markvan> This caused an issue where Berks 3.x has a ton more deps to bring in and the gecode one was using dep-selector-libgecode gem to resolve it.
15:59:56 <markvan> Well this gem is quite the piece of work, it's basically all the gecode 3.x source and runs thru a make to build it.    This fails quite a bit as it's a very large chunk of source to compile and it usually runs our of memory or disk doing so.
16:00:45 <j^2> oh that’s not fun
16:00:57 <markvan> There is a switch to force that gem to skip the compiles and use the system libraries.
16:01:32 <markvan> but those libraries must be the gecode 3.x version, which is available on precise and not trusty.
16:02:12 <j^2> have we looked into the projects to see when support is expected?
16:02:15 <markvan> net, my patch is pushing all our gates to precise AND if berkshelf 3.x, will install the gecode system libs and use them instead of compiling.
16:02:52 <markvan> This is short term, as precise will be removed from the gates at some point next year.
16:03:53 <markvan> Long term, need to look at using either Chef DK on Trusty (not sure when that will happen yet), or get Berkshelf to use the newer 4.x version of gecode (basically be supported on Trusty).
16:04:18 <markvan> clear as mud?
16:04:22 <j^2> heh
16:04:32 <j^2> yeah Trusty isn’t supported in 14.04 yet
16:04:39 <j^2> that’s from Chef :(
16:05:32 <markvan> yeah, that seems to be the blocker on this....but if we can get by on precise for juno, maybe Chef will support it for "k" dev cycle timeframe.
16:07:03 <j^2> #action j^2 follow up with chef-dk guys to see when 14.04 will be supported and report back
16:07:32 <markvan> Not sure what it means to our stable branches when/if they pull precise nodes from the gate.   Something we need to continue trying to understand.
16:08:35 <markvan> and I have it on my todo list from last time to figure out how to have different jobs for various branch levels  (stable vs master).
16:08:41 <j^2> i’m suprised this is so confusing, i thought i had a grasp of this from the get go, the gates in general, but something isn’t clicking recently
16:09:40 <markvan> and I worry a bit about using precise....as I'm sure the number of those nodes will be reduced and might become a bottleneck.
16:11:29 <j^2> i have this gut feeling that won’t be an issue for a while
16:15:22 <markvan> I don't have anything else for a topic right now.....   just keep up work on Reviews, Bugs and Specs.   I suspect in the coming weeks there will be increased amount of activity for Juno once rc3 is past.
16:18:19 <markvan> unless there is a specific review or bug question that someone wants some help with....
16:21:25 <j^2> i’m personally walking through the reviews today myself
16:21:31 <j^2> i don’t know of any off hand
16:22:41 <markvan> and there are only 2 specs out there, but each are marked at wip, so not much there right now.
16:26:55 <j^2> oh we discussed the specs process at the meetup
16:27:05 <j^2> it looks like it’s going to be adopted more or less everywhere
16:30:40 <markvan> ok.  did you discuss the process of what happens once a spec is approved and merged.....what fields/content in the blueprint should be updated.
16:31:00 <markvan> I don't think we have that spellout yet, or did I miss that?
16:31:02 <j^2> iirc the conversation basicly said copy paste the whole thing in
16:31:07 <j^2> and that should be it
16:31:32 <markvan> ah ok, and maybe a link back to the spec review.
16:32:18 <markvan> #action markvan will cut/paste 2 approved specs in their blueprints
16:33:54 <j^2> :D
16:34:17 <j^2> awesome any other topics to discuss or should i bring the meeting to an “official” end?
16:35:00 <markvan> done here.
16:35:33 <markvan> just a thought for next time...
16:35:47 <markvan> we could go thru last weeks/open actions that were taken
16:36:03 <j^2> sounds good
16:43:58 <j^2> #endmeeting