15:33:52 <markvan> #startmeeting openstack-chef
15:33:52 <openstack> Meeting started Fri Sep 12 15:33:52 2014 UTC and is due to finish in 60 minutes.  The chair is markvan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:33:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:33:56 <openstack> The meeting name has been set to 'openstack_chef'
15:34:12 <markvan> Howdy, time for the meeting
15:36:18 <markvan> @core any topics for today irc meeting?
15:36:18 <os-chef-bot> @j^2 @markvan_ @mattray @ctracey @galstrom @alanmeadows @andymccr @iartarisi @carlp
15:36:18 <os-chef-bot> any topics for today irc meeting?
15:36:46 <galstrom> markvan: ive got nothing
15:36:52 <iartarisi> I guess j^2 proposed we discuss the Rakefile
15:36:58 <mattray> I'd encourage folks to kick the tires on Chef 12 release candidates
15:37:29 <markvan> ok, lets start with the rakefile
15:37:41 <markvan> #topic Rakefile support within the cookbook repis
15:37:52 <j^2> Rakefile +1
15:38:01 <iartarisi> https://review.openstack.org/#/c/120112/6/Rakefile
15:38:14 <iartarisi> I disagree with having distro-specific packages in there
15:38:42 <j^2> For the initial appointment I disagree we should put logic in later
15:39:01 <j^2> Let's just get it to work
15:39:34 <iartarisi> this has nothing to do with the gerrit jobs
15:39:35 <markvan> iartarisi: what is a better approach for something like that?  Is the same type of issue as for rvm setup?
15:39:58 <iartarisi> j^2: you seem to be saying that this is failing in jenkins?
15:40:04 <iartarisi> it's not even being run there yet
15:40:43 <j^2> Bbiab
15:41:02 <markvan> I was thinking we could maybe provide a new image for CI, that would be trusty and the ChefDK pre installed.  That seems to be the way others have done this.
15:41:11 <iartarisi> markvan: I think the choice of ruby should be done outside that Rakefile.
15:41:34 <markvan> iartarisi: yup, part of the image environment we select for the gate
15:41:42 <iartarisi> right!
15:42:51 <markvan> I'll admit, I don't know the steps for getting something like that done in infra, but seems like a good approach for this.
15:43:37 <iartarisi> j^2: for the "Let's just get it to work" part. I think it's easier to get the Rakefile to work without involving chef-dk at this stage.
15:44:27 <markvan> iartarisi: yup, agree.  first introduce it into the current ruby19x env stream, and then go from there.
15:45:24 <markvan> I was initially thinking one new rake job, but that could mean multiple tests in one job, is that ok?    and then what about fail first?
15:46:04 <iartarisi> markvan: what rake job are you talking about now?
15:46:17 <iartarisi> chef-dk setup?
15:46:51 <markvan> I have a patch in the works that simple adds a new generic rake job to our check gate.  It simple checks for Rakefile and then calls "rake test"
15:47:21 <markvan> it uses the existing ruby-191-prep step (that is hopefully working now).
15:48:26 <iartarisi> why not add the three separate rake jobs next to the Strainer if branches as we discussed in Monday's meeting?
15:50:02 <markvan> yup, could also do something like that....but not sure how many levels of if branches infra will tolerate.    I was also thinking of how we could allow a new type of test in the future without having to change the gate def's.
15:50:29 <iartarisi> well it wouldn't be a new level of if branch it would just replace the existing non-Strainerfile one
15:51:11 <iartarisi> and for adding a new type of test we'd have to change the gate definition anyway since we would want a separate jenkins job
15:51:22 <markvan> we have to be careful about changing the jobs in that way as that could break the stable branches that still use the strainer file.
15:51:25 <iartarisi> but we could change the existing jobs inside the rakefile
15:51:32 <j^2> hey guys sorry, i’m back
15:51:51 <iartarisi> markvan: I was saying we would change the non-Strainerfile jobs.
15:52:28 <j^2> iartarisi: markvan ah ok, well if we move like that, put the rakefile in, and not chef-dk, that’s fine. I was just trying to fix two things at once
15:52:29 <markvan> iartarisi: humm, not sure what you mean by that, right now they are all the same jobs for all the branches
15:54:03 <iartarisi> https://github.com/openstack-infra/config/blob/master/modules/openstack_project/files/jenkins_job_builder/config/macros.yaml#L177
15:54:27 <iartarisi> we have those if branches for Strainerfile-git-branches and non-Strainerfile ones
15:54:54 <iartarisi> we could replace the else branch there with a 'rake style' command
15:56:53 <markvan> yup, that would work.  our current stable branches all have a Strainerfile, and master does not.
15:57:00 <iartarisi> exactly
15:57:15 <iartarisi> here's a diff :) https://gist.github.com/mapleoin/6b2e36ddec19cb9331ad
15:58:28 <markvan> yup, I think the other change required for that would probably be to make sure the rake gem is installed, just like we're doing for bundler in the ruby-191-prep step
15:58:50 <markvan> https://github.com/openstack-infra/config/blob/master/modules/openstack_project/files/jenkins_job_builder/config/macros.yaml#L136
15:59:36 <iartarisi> FWIW it's already a foodcritic dependency
15:59:40 <iartarisi> so it gets installed by bundle install
16:00:16 <iartarisi> it's in Gemfile at the top-level actually..
16:00:22 <iartarisi> *Gemfile.lock
16:01:17 <iartarisi> s/at the top-level//
16:02:32 <markvan> yeah, was just think that deps can change all the time and we explictly call out rake, we should then add it to Gemfile or in env to make sure it's always there.
16:02:41 <iartarisi> we could just put it in Gemfile for good measure, but I don't thin we need to install it outside
16:02:43 <iartarisi> right!
16:04:15 <iartarisi> I think we should aim for the Rakefile to be easily useable for developers locally as well
16:04:16 <markvan> ok, one last question...my patch had a if Rakefile exist check before the call to rake, such that it would be a noop if not in the repo.  is that needed?  or we decide that we must have rake files now in all repos.
16:04:50 <markvan> yes, like using a "rake test"   and that would be a bundler install and then the 3 tests?
16:04:53 <iartarisi> I think we can just assume we'll have Rakefiles from now on
16:05:00 <iartarisi> right
16:05:40 <markvan> ok
16:06:40 <markvan> #action markvan will continue work on rake patch for infra, but we need skeleton Rakefiles/Gemfile update in master before gate goes in
16:07:11 <markvan> sound about right?
16:07:17 <iartarisi> yup!
16:07:21 <iartarisi> then I can do the skeletons
16:07:36 <markvan> great, thx.
16:08:00 <iartarisi> #action iartarisi will send changes to all repositories' master branches with the new Rakefile
16:09:19 <markvan> #topic Chef 12
16:09:32 <markvan> anything you want to add mattray?
16:09:43 <mattray> nope
16:10:24 <iartarisi> Chef 12 YAY! # end meeting
16:10:26 <iartarisi> :)
16:10:33 <markvan> #info  http://www.getchef.com/blog/2014/09/07/chef-12-release-candidate/
16:10:51 <markvan> #topic gate patch
16:11:31 <markvan> Well, sigh, looks like it failed again, but we're close.   This time it's a permission issue I believe.  see https://jenkins04.openstack.org/job/gate-cookbook-openstack-block-storage-chef-lint/49/console
16:12:00 <iartarisi> forgot the sudo :)
16:12:36 <iartarisi> that's quite funny that nobody noticed that actually
16:12:49 <iartarisi> it was even in red since the sudo was there before
16:13:19 <markvan> yup...the ugly part was that I had it in there, but did not think I needed it anymore
16:13:30 <iartarisi> hehe
16:13:55 <markvan> #action markvan will get (yet another) infra patch to fix the sudo gem install
16:14:02 <markvan> #topic open discssion
16:14:19 <markvan> Anything else right now  (besides our growing backlog of patches!)
16:15:30 <markvan> ok, thx all
16:15:34 <markvan> #endmeeting