16:30:42 <j^2> #startmeeting openstack-chef
16:30:43 <openstack> Meeting started Fri Nov 14 16:30:42 2014 UTC and is due to finish in 60 minutes.  The chair is j^2. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:30:47 <openstack> The meeting name has been set to 'openstack_chef'
16:30:58 <j^2> hey everyone!
16:31:06 <markvan> Howdy
16:31:07 <jklare> hi j^2
16:32:02 <j^2> So i only have a couple things on the agenda i’d like to discuss, i’ll open it up to topics from yall first. jklare i have your note that you’d like to discuss something specific?
16:32:13 <j^2> jklare: you can start, i guess after me typing that all out
16:32:40 <j^2> #topic jklare: a we should find a better way to always catch all cookbooks when we do gem updates or patches like adding the rakefile
16:32:53 <j^2> can you elaborate etc on this?
16:33:32 <jklare> basically its about the simple issue that we miss some cookbooks from time to time when we do these Gem updates or adding rake
16:33:53 <jklare> we completely missed the integration-testing cookbook for example
16:34:16 <j^2> markvan: this has happened a couple times right?
16:34:44 <jklare> so basically it would be great if there would be an easy way of adding all the cookbooks into the blueprint when creating it
16:34:58 <j^2> like a template?
16:35:11 <jklare> yeah something like that
16:35:13 <markvan> yeah for the newer cookbooks.   Maybe we need a basic checklist template to add to a blueprint/bug to track this.
16:36:08 <j^2> I’d tihnk we should have it on the wiki? Have a way just to copy paste it out?
16:36:26 <jklare> is there an implementation for blueprint templates in gerrit or a plugin?
16:36:34 <markvan> not sure if there's an automated way to add cross project dependencies in launch pad.
16:37:25 <j^2> yeah that’s one of the largest complaints about launchpad
16:37:41 <j^2> so many projects interact with one another and there’s no way to create depenancies
16:38:01 <j^2> that’s way i suggest the wiki….
16:38:21 <j^2> i really think we should focus some time/effort on making our pages on the wiki our one stop shop
16:38:38 <markvan> yup, that sounds reasonable
16:38:55 <j^2> and it’s so easy for us to keep it up-to-date etc etc
16:39:09 <jklare> is it?
16:39:13 <j^2> yep
16:39:22 <jklare> why?
16:39:24 <j^2> you have an account, that’s all you need
16:39:46 <j^2> gives you a little wsiwg editor, and you can create pages easily
16:39:47 <jklare> ah ok, i thought you were talking about some automation i didnt know about ;)
16:39:54 <j^2> ha!
16:40:04 <j^2> sorry divered the conversation a little bit :P
16:40:47 <j^2> jklare, markvan second the idea for focusing on the wiki?
16:40:56 <markvan> +1
16:41:02 <j^2> jklare: this ties in with your template btw
16:41:15 <jklare> ok, so i will just copy the list from the berks update (which should be complete) and write up a short chapter for creating blueprints for gem updates and stuff
16:41:15 <j^2> one thing we can start is just a template page :)
16:41:17 <jklare> +1
16:41:44 <j^2> jklare: on that would be perfect
16:42:00 <j^2> can you branch it off: https://wiki.openstack.org/wiki/Chef/Contributing ?
16:42:17 <jklare> i hope so, but i have to admit that i never worked with the wiki
16:42:24 <j^2> it’s crazy simple
16:42:31 <jklare> cool
16:42:35 <j^2> hell i’ll create the page for you now if you want
16:42:46 <jklare> i think i can do that ;)
16:43:29 <j^2> markvan and i discussed this at summit; the https://wiki.openstack.org/wiki/Chef/Contributing should become our base page where we referance everything from. if you have an account and commit/help etc, thats the page that should get you the answer
16:43:33 <j^2> markvan: right?
16:43:44 <j^2> jklare: awesome, i’m giving you an action item for it :)
16:44:07 <markvan> yup, I like the idea of a base page and branch out from there.
16:44:10 <j^2> #action jklare will create a template for creating over arching blueprints
16:44:40 <j^2> awesome, next topic?
16:45:01 <frickler> btw., the meeting time at https://wiki.openstack.org/wiki/Meetings/ChefCookbook seems to need an update ;)
16:45:08 <frickler> or is that outdated anyway?
16:45:18 <j^2> frickler: noted :) thanks!
16:45:49 <j^2> i’ll take that action item
16:45:57 <j^2> #topic meeting times
16:46:08 <j^2> I’d like to take this moment to discuss the meeting times
16:46:34 <j^2> as i said in the hangout we are moving the Monday meetings from 1630UTC to 1530UTC
16:46:46 <j^2> i’ll still post the links like i normally do
16:47:21 <markvan> I'm ok with new Monday meeting time
16:47:24 <j^2> I’d like to keep the IRC meeting at 1630UTC unless there are any objections to this
16:48:09 <frickler> is there a possibility to move away from Fridays?
16:48:37 <j^2> frickler: i’m open to this; i tihnk our logic was a good way to “end up the week"
16:49:03 <j^2> the chef-hacking moved to thursdays because of the friday EOB being a problem
16:49:18 <frickler> well, for me it is slightly into already being kind of weekend
16:49:31 <jklare> same for me
16:49:46 <j^2> and it also seemn that the hangout lag for irc isnt a viable either, upwards to 2mins lag
16:50:00 <j^2> frickler, jklare would thursday be better for you?
16:50:06 <frickler> yep
16:50:10 <jklare> +1
16:50:28 <j^2> anyone opposed to Thursdays 1630UTC?
16:50:49 <markvan> fine with me
16:51:00 <j^2> I’ll post this to the mailing list too and give a week for debate. if there are no objections i’ll enforce the change
16:51:06 <j^2> good?
16:51:26 <markvan> +1
16:51:34 <j^2> :D
16:52:07 <j^2> awesome, is there another topic someone else would like to discuss?
16:52:39 <markvan> update on the Changelog issue.
16:52:44 <frickler> I would like do a bit of work on openstack-dashboard, splitting out the Apache related bits from server.rb
16:53:02 <frickler> in preparation of allowing nginx to be used instead
16:53:18 <openstackgerrit> Zhu Zhu proposed stackforge/cookbook-openstack-common: Set openrc with OS_VOLUME_API_VERSION with cinder v2  https://review.openstack.org/134426
16:53:39 <j^2> ok, frickler please take the “floor”
16:53:46 <j^2> #topic openstack-dashboard
16:54:01 <j^2> markvan: we can talk about the changelog after frickler :)
16:54:11 <frickler> so currently openstack-dashboard::server.rb does two things:
16:54:33 <frickler> 1) install the horizon package and set up its config
16:55:01 <frickler> 2) use the apache2 cookbook to setup the webserver part for the dashboard
16:55:37 <j^2> yeah that seems heavy handed
16:55:39 <frickler> I would like to split this so that part 2) can be replaced by a different recipe that sets up nginx instead
16:55:46 <frickler> does that sound reasonable?
16:55:50 <j^2> extremely
16:56:39 <j^2> #action frickler will break up the openstack-dashboard server.rb to help move towards nginx instead of apache
16:56:45 <j^2> :D
16:56:55 <j^2> any opposed to this?
16:57:10 <frickler> do you need a blueprint for that or should I just prepare some patch for discussing it first?
16:57:27 <j^2> a blueprint would be good so we have somethning to referance
16:57:48 <j^2> them have the patch referance the blueprint
16:57:58 <frickler> ok
16:58:00 <j^2> markvan: right?
17:00:06 <j^2> cool,
17:00:17 <j^2> so markvan you’d like to talk about the changelog issue?
17:00:27 <j^2> #topic Changelog and the pain that is it
17:01:38 <markvan> Just that I believe the summit conversations concluded with the plan that we remove the Changelogs from the repos when we branch for stable/juno.
17:02:09 <jklare> +1
17:02:15 <markvan> And it would be replaced by folks using git log directly AND making changes to the Readme for bigger changes
17:02:32 <j^2> yep agreed
17:03:47 <jklare> off-topic: do we include all these monasca cookbooks?
17:04:11 <j^2> markvan: weren’t you going to write up a doc on what constitues as a “bigger” change?
17:04:18 <j^2> i vaguely remember that
17:04:27 <jklare> and ceph? or just everything that start with cookbook-openstack?
17:04:28 <j^2> jklare: link?
17:04:39 <j^2> oh!
17:05:00 <j^2> if it’s on stackforge/cookbook-openstack-* that falls under us
17:05:17 <jklare> https://github.com/stackforge/?query=cookbook-monasca
17:05:19 <j^2> or at least that’s what i understand
17:05:35 <j^2> ah yeah that’s another company iirc
17:05:40 <markvan> Yup, I was going to add a bit to the wiki about the Readme's...and how we want to encourage folks to add short use case descriptions/explainations
17:05:44 <j^2> they copy’d us
17:05:54 <j^2> cookbook-openstack-* is us
17:06:08 <j^2> markvan: awesome just checking
17:06:57 <markvan> The monasca cookbok not something we need to mess with, but they DO share our gates.
17:07:15 <j^2> yep
17:07:19 <jklare> so we would not include it in the blueprint list
17:07:20 <j^2> jklare: ^^^ that
17:07:24 <j^2> correct
17:07:24 <jklare> same for ceph?
17:07:35 <j^2> ceph? that’s in a grey area right now
17:07:55 <j^2> i’d leave it out for the time being
17:09:37 <j^2> nice, is there anything else that needs to be discussed?
17:09:59 <j^2> #topic General Discussion
17:12:03 <libsysguy> ceph cookbooks on stackforge
17:12:14 <libsysguy> and the upstream ones that ceph provides
17:12:25 * j^2 stares daggers at libsysguy
17:12:32 * libsysguy ducks
17:12:42 <j^2> ok, so let me talk about ceph real fast
17:12:49 <libsysguy> I haven't read back yet
17:12:57 <libsysguy> meeting_overlap—
17:12:57 <j^2> i found the community manager at summit for ceph
17:13:24 <j^2> turns out that we forked the ink-(somethingorother) cookbook a while ago and put it in stackforge
17:13:43 <j^2> we assumed that it would be the center of truth for chef-ceph
17:14:09 <j^2> turns out ceph internally continued with their own fork and kept it updated and didnt keep ours in sync
17:14:22 <j^2> if you look at them you’ll see simularitys but there are some strong differances
17:14:47 * libsysguy noticed this
17:15:06 <j^2> so, i’ve ping’d the manager to talk about how we can figure out how we move to a agreed upon set of code
17:15:20 <j^2> i don’t know what the correct answer is, but taht’s where we are
17:15:33 <j^2> hopefully soon i can sync up with him, and we can propose something
17:15:41 <libsysguy> yeah that'd be awesome.  As it stands now, it's super confusing.
17:16:01 <j^2> yeah took me a while to straighten it all out
17:16:30 <j^2> any objections to the path i’m going down?
17:16:33 <libsysguy> well it didn't take too long to see one hasn't been updated in 4 months and the other was update 29 hours ago
17:16:54 <j^2> libsysguy: yep, which helps with the sales pitch, but we’ll see
17:17:19 <j^2> heh, we looks ceph but gain pacemaker….
17:17:34 <j^2> aspiers: yeah i’m calling you out :P
17:17:44 <j^2> s/looks/loose/
17:18:51 <aspiers> maybe I can slap Neil with a smelly fish
17:19:11 <j^2> :D
17:19:44 <j^2> nice, 11 mins, any other topics?
17:21:42 <j^2> I’ll be sending out a meeting notes sometime today
17:22:03 <j^2> if there are anything you’d like to referance later
17:24:58 <j^2> 5ish mins
17:25:04 <frickler> o.k., thx and cu, weekend is calling :D
17:25:14 <j^2> sounds great thanks for being here :)
17:25:22 <j^2> #endmeeting