16:05:23 <sc`> #startmeeting openstack_chef
16:05:23 <openstack> Meeting started Mon Mar 28 16:05:23 2016 UTC and is due to finish in 60 minutes.  The chair is sc`. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:27 <openstack> The meeting name has been set to 'openstack_chef'
16:06:02 <sc`> ohai! anyone here for the meeting?
16:06:12 <markvan> yo
16:06:17 <sc`> howdy markvan
16:08:16 <akravets> Hi
16:08:29 <sc`> cloudscaling is done with the ec2-api cookbook and asked about next steps. i asked them to join this week's meeting to discuss a little more real-time
16:08:58 <akravets> Yes, I'm Anastasia, I'm here
16:09:02 <sc`> hi!
16:09:24 <sc`> i think it's going to be a pretty small group
16:09:57 <sc`> since it's late for you akravets, how about we focus on that first
16:10:26 <akravets> Thank you.
16:10:44 <sc`> i've been reading over the documentation, but being that this is all new to me, i'm still getting my head wrapped around it
16:11:26 <sc`> i'll be bugging infra and possibly j^2 if he has time since he's gone through this before
16:12:01 <sc`> to make way, i submitted reviews to deprecate the api-ec2 recipe in the compute cookbook, as well as the role definitions in repo
16:13:57 <sc`> #action sc` to get a new repo created for cookbook-openstack-ec2
16:14:34 <sc`> #topic ci
16:15:04 <sc`> as you've no doubt noticed, i've been spamming the ever-living-fuck out of our channel trying to get ci working for both centos and ubuntu, and it's a game of whack-a-mole
16:15:41 <sc`> get one working, the other fails somewhere. currently ubuntu is failing trying to upload the cirros image to glance. this failure is not seen on the centos gate
16:16:12 <akravets> For now our cookbook is working in ubuntu
16:17:12 <alevine> Hi everybody. Sorry to be late. Was on a call. I probably can answer questions in regard to EC2
16:17:18 <sc`> a lot of it is just accounting for naming discrepancies and adding conditionals for those variances
16:17:36 <sc`> we're targeting both ubuntu and centos support for mitaka
16:18:44 <sc`> so ec2 support may not make it to mitaka without that. of course, there's nothing that says it can't be backported
16:19:14 <alevine> sc`: Could you please repeat without what?
16:19:59 <sc`> being able to support both distros
16:20:49 <alevine> sc`: So is it a hard requirement or not?
16:21:17 <sc`> i, personally, don't want to add features that are only available on one platform
16:21:59 <alevine> sc`: Can a more concrete decision be made because we are very short on resources right now and we need to understand if it's a hard one or not.
16:22:52 <alevine> sc`: And what is a deadline for contributing for Mitaka to understand how much time we have if it's a hard requirement.
16:23:04 <sc`> it's a semi-soft requirement from my perspective. we don't have to hold up the mitaka release just because of that, but not having centos support leaves a good swathe of downstream out in the cold
16:23:06 <alevine> sc`: And what else?
16:23:46 <alevine> sc`: I understand everything you're saying I just don't understand if it's `required` to support centos to get into Mitaka or not.
16:23:56 <markvan> I would vote for having both distros supported in mitaka whereever we can.  Not sure if this function is that big of deal or not.
16:24:18 <sc`> it's not a big of a deal where we have to hold up the release
16:24:33 <alevine> markvan: Again "wherever we can" doesn't help much. Should or should not?
16:24:35 <sc`> i mean, we're already shipping mitaka sans swift
16:25:46 <markvan> I guess my point would be that we try to get "buy" in for support in the next release so we don't create more platform holes
16:26:18 <markvan> and yeah, we could then backport if folks wanted it
16:26:23 <j^2> sc`: the apache2 cookbook was released yesterday
16:26:29 <sc`> j^2: woo! thank you!
16:26:35 <alevine> We don't have resources for much further development for chef EC2 so unless something is a concrete hard must have we won't even consider it.
16:26:51 * j^2 wonders back to his hole
16:26:55 <alevine> in this cycle at least
16:27:18 <sc`> alevine: understood. we all have more pressing obligations. increasingly so over the past cycle or so
16:28:06 <alevine> sc`: Yes, as  usual. So a decision should be made about this.
16:28:34 <sc`> alevine: so if we bring this cookbook in with just ubuntu support, will we be able to get any support from your team?
16:29:07 <sc`> otherwise, we need to let this slip to newton and move on
16:29:14 <alevine> sc`: And also, we don't even have an unofficial project in Openstack to put it in yet. And we wouldn't want to create it ourselves obviously.
16:29:42 <alevine> sc`: Yes, we'll provide support for everything that is done by now and probably we'll add support for centos later.
16:30:17 <alevine> sc`: EC2 for Ubuntu in Mitaka we'll support, yes.
16:31:35 <sc`> alright. sounds good. i already have an action item to chase, so i'll do that and keep you apprised via email
16:32:20 <alevine> sc`: Perfect, thank you.
16:32:26 <sc`> back to ci, the biggest problems i'm facing are just dealing with image quirks
16:32:36 <alevine> sc`: alexandrelevine@gmail.com and rtikitavi@gmail.com
16:33:10 <sc`> alevine: cool. thanks
16:35:14 <sc`> markvan: i was expecting a DRY comment. thanks :)
16:35:54 <markvan> sc`: yeah, minor one, but would be nice cleanup
16:36:17 <sc`> yup
16:38:47 <sc`> since there's a new release of apache2, i'll be getting repo off of master so we don't have any more fun times
16:39:11 <markvan> sc`: +1
16:39:59 <sc`> #topic cutting stable/mitaka
16:40:13 <sc`> this needs to happen this week
16:41:00 <sc`> i think jklare is still tagged as release meister
16:41:17 <sc`> but that should probably be me, unless it's already done
16:45:45 <sc`> i'm less than enthusiastic about some of things we're initially leaving out of mitaka, but it just means that stuff spills over into newton and gets backported
16:46:16 <sc`> fortunately, not many downstream users are going to feel this pain, unless they make the jump to mitaka immediately
16:51:48 <sc`> unless anyone has anything else, i'll be happy to give back the next 8 minutes
16:52:39 <sc`> thanks for attending. see you next time
16:52:42 <sc`> #endmeeting