15:12:06 <zhipeng_> #startmeeting openstack-cyborg
15:12:07 <openstack> Meeting started Wed May 31 15:12:06 2017 UTC and is due to finish in 60 minutes.  The chair is zhipeng_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:12:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:12:10 <openstack> The meeting name has been set to 'openstack_cyborg'
15:12:22 <zhipeng_> jkilpatr about the packaging
15:12:30 <zhipeng_> could you elaborate a little bit more ?
15:12:36 <zhipeng_> #topic packaging options
15:12:52 <jkilpatr> So I was wondering how we easily setup the project while we're doing dev
15:13:19 <jkilpatr> I don't know what you guys have for test environments but I can stand them up and tear them down very easily, so an ansible playbook that just uses pip to install the components would make me happy.
15:13:39 <jkilpatr> I don't know what other sort of distribution system we would use. So suggestions are welcome.
15:14:19 <zhipeng_> pip would be the common practice for OpenStack, right ?
15:14:42 <jkilpatr> I'm not actually sure never installed a project not packaged by someone for me...
15:15:07 <jkilpatr> but yes it's python I don't see what else they would use, except maybe some sort of heat / mistral stuff.
15:15:29 <crushil> I use devstack for dev or RDO if I want to test it in a production style environment
15:15:41 <zhipeng_> mistral got a different system ?
15:15:45 <zhipeng_> hey crushil
15:15:59 <jkilpatr> well you could do it with mistral I have no idea if it's a good idea, never did anything with it myself.
15:16:10 <jkilpatr> anyways sounds like no one has an issue with pip
15:16:19 <zhipeng_> yep I guess so
15:17:14 <zhipeng_> #agreed pip for packaging options
15:17:40 <zhipeng_> #topic development process
15:18:31 <zhipeng_> I will address ChirsD and Justin's comment on the api spec
15:18:51 <zhipeng_> so after spec freezes, how should we coordinate on the code development ?
15:19:07 <zhipeng_> shall we write each part first ?
15:20:10 <jkilpatr> I think we should start and put up a review quickly, wait until it's possible to use all the different reviews together and then merge them and move on from there.
15:20:18 <jkilpatr> it's important we have a good test/integration workflow
15:20:48 <jkilpatr> um what about standards, I assume most of pep8 (longer line length limit maybe) + some unit test coverage?
15:21:12 <zhipeng_> that would be reasonable
15:21:26 <zhipeng_> what do you mean by start and put up a review quickly ?
15:21:55 <jkilpatr> I mean don't go off and code everything then put it up for review. Ideally we start playing around with and testing each others code very early.
15:22:24 <jkilpatr> it's kinda embarassing to put up unfinished stuff, everyone want's to come in and micdrop great code. But it's not the best way to work.
15:23:30 <zhipeng_> okey that I agree
15:24:30 <zhipeng_> we will need multiple patches for the spec anyways
15:24:57 <zhipeng_> no patch would be too small :P
15:34:20 <jkilpatr> any other business? I know we still haven't managed to fully define the nova workflow but I need to find time to play with that, ideally with skeleton versions of the rest of cyborg, which is what we agreed on last week.
15:36:40 <zhipeng_> i don't have any other stuff on the plate
15:39:22 <zhipeng_> so I will leave the channel open for another hour, then I'll close it
15:39:59 <crushil> Ok
15:40:01 <jkilpatr> cool, we can get the api commit in and meet next week to start putting things together sound good?
15:40:14 <crushil> Sounds good to me
15:42:33 <zhipeng_> yes
15:42:56 <crushil> Does nova accelerators work well with virtIO today?
15:43:33 <zhipeng_> I'm not aware Nova got vanila virtio based drivers
15:43:39 <zhipeng_> for accelerators
15:44:17 <zhipeng_> I think for Nova, it mainly means see if kvm got virtio support
15:44:21 <crushil> Ok. I'll look. I have created stubs for the code that I am going to fill in the next couple months
15:45:20 <zhipeng_> i think as Justin suggested, if you got the stubs and basic virtio ops ready
15:45:29 <zhipeng_> you could commit the patch
15:45:35 <zhipeng_> and then iterate around it
15:45:58 <zhipeng_> since we need the stub to align with agent/conductor/api
22:25:27 <zhipeng> #endmeeting