15:07:46 <zhipeng> #startmeeting openstack-cyborg
15:07:46 <openstack> Meeting started Wed Aug 23 15:07:46 2017 UTC and is due to finish in 60 minutes.  The chair is zhipeng. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:49 <openstack> The meeting name has been set to 'openstack_cyborg'
15:08:12 <zhipeng> let me start with some info on the ptg first, then we circle back to the patches
15:08:25 <zhipeng> #topic Denver PTG prep
15:08:59 <zhipeng> guys plz check my previous email, we have a room booked for Wed and Thur morning
15:09:23 <jkilpatr> cool.
15:09:44 <crushil> That's awesome
15:10:13 <zhipeng> #link https://etherpad.openstack.org/p/cyborg-queens-ptg
15:10:14 <zhuli> cool
15:10:25 <zhipeng> plz provide your information re ptg on the etherpad
15:10:50 <zhipeng> the reason for a morning session is that for folks like zhuli to be more easier to join the meeting online
15:11:19 <zhipeng> so the format would be that, we will concentrate on the irc meeting. I will stay in our booked room
15:11:37 <zhipeng> and crushil and jkilpatr if you have other team meeting you guys could run around
15:11:44 <zhipeng> just keep the irc open :)
15:11:54 <zhipeng> this way we have the maximum flexbility
15:12:02 <jkilpatr> Not totally sure about the schedule but I think I'll be good.
15:12:04 <zhuli> zhipeng thanks for that for me
15:13:19 <zhipeng> another big thing is that I will do a presentation on Cyborg to OpenStack TC
15:13:51 <zhipeng> so you guys are welcomed to chime in :P
15:14:00 <crushil> Oh, that's awesome
15:14:11 <jkilpatr> nice, anything specific you know they will want to go over?
15:14:14 <zhipeng> not sure if it is on Monday or Tuesday tho
15:14:26 <zhipeng> they just want an update
15:14:54 <zhipeng> so it will be a pretty great opportunity for exposure
15:15:05 <zhipeng> before we officially apply for official project
15:15:23 <crushil> I would be timesharing with Ironic at the PTG, but should be available at those times
15:15:48 <zhipeng> cool :)
15:15:54 <zhipeng> another another big thing :P
15:16:10 <zhipeng> there folks from RedHat that is organizing interviews for project teams
15:16:27 <zhipeng> i fill out my name at the moment but the interview generally permits 2- 3 people
15:16:45 <jkilpatr> I'll see if I can make it.
15:16:45 <zhipeng> so if the interview will indeed happen I will grab you guys
15:16:49 <zhipeng> if you could make it
15:17:04 <crushil> cool
15:17:05 <zhipeng> gr8t :)
15:17:34 <zhipeng> Okey any question on PTG arrangment ?
15:17:57 <jkilpatr> how long until we get stickers?
15:18:00 <jkilpatr> #priorities
15:19:04 <zhipeng> haha what do you have in mind ?
15:19:33 <zhipeng> shall we poll for a mascot first ? lol
15:20:56 <jkilpatr> no idea!
15:22:20 <zhipeng> hahaha
15:22:26 <zhipeng> then I will come up with something
15:22:53 <zhipeng> shock and awe stickers
15:24:10 <zhipeng> #topic patch discussion
15:24:23 <zhipeng> okey back to (somewhat) serious topic
15:24:37 <zhipeng> #link https://review.openstack.org/#/q/status:open project:openstack/cyborg
15:25:12 <zhipeng> jkilpatr sir could you give us a brief introduction of the deploy patch ?
15:29:23 <jkilpatr> sure so it's just an ansible playbook that deploys the various components
15:29:55 <jkilpatr> to use make a hosts file with categories [controller] and [compute] and it will deploy the api and conductor onto the controller and the agent onto the computes
15:30:08 <jkilpatr> it also verifies that all the services are started, sets them to start at boot, templates systemd unit files etc
15:30:13 <jkilpatr> creates the cyborg user to run it under
15:30:45 <jkilpatr> oh you do have to run the playbook from it's place in the repo since it installs your current version of the repo, which is good for testing but probably bad for prod
15:31:24 <zhipeng> lol
15:31:32 <zhipeng> i was wondering about that
15:31:51 <crushil> Btw I was going to write a devstack plugin soon as soon as I get some time
15:32:05 <crushil> I have done it for other projects
15:32:34 <jkilpatr> well the great thing is that right now zhuli's commit places us on a sqllite database and such so there's no config required.
15:33:05 <zhipeng> i belive from zhuli's comment, it is pretty much pluggable right ?
15:33:10 <crushil> And one of my colleagues wrote a script to bring up kubernetes and openstack. I was going to make some changes to make it work for Cyborg and Ironic
15:33:11 <zhipeng> sqlite is by default
15:33:18 <jkilpatr> yeha but until we start scraping the cnofig devstack/tripleo are the same.
15:33:26 <zhipeng> crushil hey that's cool
15:33:26 <jkilpatr> config*
15:34:02 <zhipeng> #link https://review.openstack.org/#/c/496787/
15:34:28 <zhipeng> #info starting piece for deployment of cyborg services and testing
15:34:36 <crushil> The link to the tool is here if y'all want to look at it https://review.openstack.org/#/c/487972/
15:34:55 <zhipeng> #info crushil mentions that he will help develop a devstack plugin that could make it work for Cyborg and Ironic
15:35:13 <zhipeng> #link https://review.openstack.org/#/c/487972/
15:35:22 <crushil> devstack plugin already works for Ironic
15:35:55 <crushil> This is a tool to automate your kubernetes and openstack installation. Unlike devstack, this is a real installation not an emulated one
15:36:27 <zhipeng> so that will be a containerized cyborg deployment on baremetal via kubernetes ?
15:37:37 <crushil> Exactly
15:37:48 <crushil> The cyborg will reside in a pod
15:38:24 <zhipeng> could we then provide service to another pod ? :P
15:38:29 <crushil> technically I have only tested it for AIO, but it should work on multiple baremetal machines
15:38:46 <crushil> What do you mean?
15:39:18 <crushil> cyborg-api and cyborg-conductor would both reside in separate pods on the same baremetal node in the AIO installation
15:39:30 <zhipeng> understood
15:39:47 <zhipeng> crushil keep us updated
15:40:37 <crushil> will do
15:41:04 <crushil> I'm planning to work on this once my customer engagements are over
15:41:13 <zhipeng> cool man
15:41:35 <zhipeng> I might have another of my team member start developing SPDK driver for Cyborg
15:43:03 <zhipeng> so basically the usecase is something like if user uses Ceph as the Cinder backend but would like to have SPDK for userspace acceleration
15:43:42 <zhipeng> the user could use Cyborg to automatically setup/config/deploy SPDK
15:44:12 <crushil> I have a suggestion
15:44:21 <crushil> Let's put up a wiki page or etherpad
15:44:36 <crushil> Where we put all of our future work items there
15:44:49 <zhipeng> crushil that would be great
15:45:14 <zhipeng> #action zhipeng to setup an etherpad for future work item
15:45:18 <crushil> We can do it like a sprint and maintain all our work items currency by changing them from To Do to In Progress to Done
15:45:36 <zhipeng> shall we have a trello board for that ?
15:45:42 <crushil> Done should translate to a patch being upstream
15:45:43 <crushil> Sure
15:45:50 <crushil> Whatever tool you want to use
15:45:53 <zhipeng> cool
15:46:33 <zhipeng> okey any other topics we want to cover for development ?
15:47:47 <crushil> Nope
15:47:59 <crushil> zhipeng, Are you still going to be at the summit
15:48:24 <zhipeng> yes I suppose to
15:49:17 <zhipeng> If we could apply for official project before Sydney, then we could do project update at the Forum session I think
15:50:42 <zhipeng> #topic release/stable branch cut
15:51:10 <zhipeng> so I think we could cut our first non-actually-working code release before PTG ?
15:51:21 <zhipeng> after crushil's patch merged ?
15:51:36 <jkilpatr> we could do a toy release that shows the workflow for ptg sure
15:51:37 <crushil> Hmmm
15:51:41 <crushil> Ya sure
15:51:56 <crushil> So, technically we would have a session?
15:51:59 <jkilpatr> anything we put out for summit will have to have a bunch of warning labels on it
15:52:08 <jkilpatr> right now I wouldn't bring this thing inside of a mile of a production cloud
15:52:16 <crushil> yup
15:52:24 <zhipeng> crushil yes if we were accepted as official in Oct
15:52:26 <crushil> jkilpatr, ++
15:52:42 <zhipeng> jkilpatr that is for sure
15:53:28 <zhipeng> okey then if I got time I will provide some patch on doc
15:54:13 <zhipeng> #topic AoB
15:55:02 <jkilpatr> try and think if mascots for next week, or maybe it could be the last subject on the agenda at ptg?
15:55:25 <zhipeng> haha it could well be
15:55:54 <zhipeng> just put it on the etherpad :P
15:56:17 <jkilpatr> maybe a Cheetah with cyborg parts? I don't think that animal is taken by any openstack project
15:56:38 <zhipeng> cybor-cheetah ?
15:57:07 <zhipeng> boston dynamics comes into my mind lol
15:57:17 <jkilpatr> sure, sounds fun to me. Whats the etherpad link again?
15:57:33 <zhipeng> https://etherpad.openstack.org/p/cyborg-queens-ptg
15:57:46 <jkilpatr> thanks
15:58:29 <zhipeng> no problemo
16:00:13 <zhipeng> jkilpatr FYI https://sk.pinterest.com/pin/229191068511052645/
16:01:00 <zhipeng> https://sk.pinterest.com/source/coolrobots.net/
16:01:30 <zhipeng> or this one http://orig14.deviantart.net/bb0a/f/2015/018/e/7/cyborg_cheetah_by_corex13-d8eftlw.jpg
16:01:35 <zhipeng> epic ~~
16:01:37 <crushil> or this one https://wallpapers.wallhaven.cc/wallpapers/full/wallhaven-478018.jpg
16:01:51 <zhipeng> haha
16:01:54 <zhipeng> I will be back
16:01:59 <zhipeng> to close the meeting ...
16:03:24 <zhipeng> ohhh, we have a winner
16:03:27 <zhipeng> https://i.ytimg.com/vi/C-iW1VocW48/maxresdefault.jpg
16:04:39 <crushil> that one is pretty cool
16:07:03 <crushil> or this https://images-na.ssl-images-amazon.com/images/I/21fd3gerXPL.jpg
16:07:11 <crushil> If you're into futurama
16:07:24 <crushil> we can block one eye out
16:07:41 <jkilpatr> don't think we can use any of these copyrighted ones, we'll have to get one drawn up
16:25:32 <zhipeng> we could use it for stickers
16:25:38 <zhipeng> not for official mascot
16:26:28 <crushil> Somebody for Ironic designed their own thing
16:26:42 <crushil> I know some folks who could do the design for us
16:27:40 <zhipeng> for free right ? lol
16:48:19 <crushil> Ya
17:53:07 <jkilpatr> zhipengh[m], https://docs.google.com/spreadsheets/d/18DmI9ydq6dKr4hAcoAN83vYXWn8TV1NEvy09Ll02_Y0/edit#gid=0
19:17:56 <crushil> zhipengh[m], Do it on monday or tuesday
19:18:21 <crushil> Or tuesday. Can't do it on monday
02:58:32 <zhipeng> jkilpatr crushil okey seems like I need to re-register since only Tuesday and Wed showing here
03:01:48 <zhipeng> ah no worries, i misunderstood
03:02:41 <zhipeng> put it down on Tuesday right before lunch
03:02:46 <zhipeng> #endmeeting