15:01:30 <zhipeng> #startmeeting openstack-cyborg
15:01:30 <openstack> Meeting started Wed Dec  6 15:01:30 2017 UTC and is due to finish in 60 minutes.  The chair is zhipeng. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:34 <openstack> The meeting name has been set to 'openstack_cyborg'
15:01:57 <zhipeng> #topic Roll Call
15:02:02 <zhipeng> #info Howard
15:02:12 <zhipeng> anyone else here for the cyborg team meeting ?
15:02:30 <Vipparthy> I am here for meeting /join
15:02:55 <zhipeng> Vipparthy could you introduce yourself a little bit ?
15:03:57 <zhipeng> guhcampos could you introduce yourself a little bit ?
15:04:12 <Vipparthy> My Name is Vipparthy, I work for NVXL which creates FPGA for running Deep learning frameworks
15:04:28 <guhcampos> Hi zhipeng, hi all
15:04:42 <crushil> #info Rushil
15:05:22 <Vipparthy> we are working on private and public cloud infrastructre to run Our Accelerators
15:05:27 <jkilpatr> #info jkilpatr
15:05:36 <jkilpatr> hi everyone.
15:05:52 <guhcampos> I work with Vipparthy on NVXL, previously on Cadence Design Systems. I'm a software developer with a long devops and infrastructure background
15:06:06 <zhipeng> Vipparthy and guhcampos that is great to hear, welcome !
15:06:18 <zhipeng> you are the professionals here :)
15:06:19 <Vipparthy> Thank You
15:06:43 <guhcampos> I hope to be able to contribute whatever code we need to add to Cyborg for our own FPGA's to work with Openstack back to the community.
15:07:19 <Vipparthy> we have one more team member Amol Wagh who is on vacation and will be joining this meeting next week onwards as wel
15:09:11 <guhcampos> zhipeng, I've never wrote code to the Openstack project before, so I'm going to mostly listen at first =)
15:10:58 <Vipparthy> Zhipeng, let's us know what we can help on this, thank you
15:15:40 <zhipeng> sorry was disconnected
15:15:48 <Vipparthy> I was part of OpenStack user @ Cisco few yrs before where we started running Nova Compute instances for Our SAAS Product Clusters
15:18:20 <zhipengh[m]> Sounds great !
15:18:30 <Vipparthy> Zhipeng... Can you let me know what is agenda here today
15:23:11 <zhipengh[m]> We will mainly discuss the dev progress for Queens cycle
15:23:50 <Vipparthy> Ok, sure
15:24:05 <zhipengh[m]> #topic Queens development progress
15:24:43 <zhipengh[m]> crushil jkilpatr lead us away ?
15:25:21 <jkilpatr> So I've been super busy with other things and haven't had much cyborg time
15:25:37 <jkilpatr> crushil, needed some agent/conductor api examples so I busted out a spec for it.
15:25:39 <crushil> So, I was writing the generic driver and was unable to leverage the API
15:25:48 <jkilpatr> https://review.openstack.org/#/c/525598/
15:25:54 <jkilpatr> which needs to be fleshed out
15:26:10 <jkilpatr> zhuli, has stubs for the conductor and agent, maybe he can implement some of these calls on a faster timeline than I  can?
15:26:27 <crushil> jkilpatr gave me some agent/conductor examples, but I am blocked till we have proper APIs that can be fleshed out and Nova-Cyborg interaction needs to be fleshed out too
15:26:44 <zhipengh[m]> u mean zhuli has patches in place ?
15:27:34 <jkilpatr> the stubs are already merged.
15:27:45 <jkilpatr> so the
15:27:59 <jkilpatr> so the 'api code' is sort of there, but needs real calls to be implemented.
15:28:01 <jkilpatr> make sense?
15:32:36 <zhipengh[m]> Not entirely sure about the real calls you meant ?
15:33:16 <Li> #info Li
15:34:57 <crushil> zhipengh[m], By real APIs, we mean that I can't call the APIs directly from an API manager like postman
15:35:07 <crushil> zhipengh[m], That still needs to be fleshed out
15:36:26 <zhipengh[m]> Understand now
15:41:47 <crushil> I think we can move on to the next item zhipengh[m]
15:45:58 <zhipeng> sorry again
15:46:06 <zhipeng> i will talk to zhuli about this problem
15:46:21 <zhipeng> but I think he tried success with postman before
15:46:25 <zhipeng> so I will ask him
15:46:36 <zhipeng> any other blockers ?
15:46:36 <crushil> Isn't zhuli here today?
15:47:50 <zhipeng> no he's not here
15:47:57 <jkilpatr> zhipeng zhuli probably got it to work with a test call. But we need real ones now
15:48:10 <zhipeng> jkilpatr I know the problem now
15:48:20 <zhipeng> #action zhipeng to check with zhuli on api calls
15:48:31 <zhipeng> any other blockers I could help with ?
15:48:48 <crushil> Nope, thanks zhipeng
15:49:26 <zhipeng> great
15:49:31 <zhipeng> Li are you there?
15:50:31 <zhipeng> okey looks like Liu Li is not there
15:50:49 <zhipeng> Liu Li is from our Canada Research Center that is working on a FPGA data model proposal
15:51:59 <zhipeng> I will tell him to post the patch
15:52:19 <zhipeng> and Vipparthy guhcamps you guys could help review it
15:52:33 <zhipeng> #topic AoB
15:55:16 <guhcampos> zhipeng, sure, sounds like a nice way to start
15:56:56 <zhipeng> ok if there is no other buisness let's conclude the meeting today
15:57:05 <zhipeng> i will run my action item with zhuli
15:57:17 <Vipparthy> sure we can help
15:58:43 <Vipparthy> Zhipeng, I will send you email so we can discuss on this on Our tasks which you would like Our help, thank you
15:59:02 <Vipparthy> can you share your email ID please
16:01:14 <zhipengh[m]> zhipengh512@gmail.com
16:12:16 <Vipparthy> Thank you
17:01:15 <zhipeng> #endmeeting