15:00:05 <zhipeng> #startmeeting openstack-cyborg
15:00:06 <openstack> Meeting started Wed Jan 24 15:00:05 2018 UTC and is due to finish in 60 minutes. The chair is zhipeng. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <openstack> The meeting name has been set to 'openstack_cyborg'
15:00:24 <zhipeng> #topic Roll Call
15:00:41 <crushil> \o
15:00:48 <zhipeng> #info Howard
15:01:40 <crushil> #info Rushil
15:01:50 <Li_Liu> #info Li Liu
15:03:02 <zhipeng> let's wait for a few minutes for others to show up
15:05:59 <zhipeng> guys if you are here for the meeting
15:06:09 <zhipeng> please use #info to identify yourself
15:06:33 <helloway> #info helloway
15:06:55 <Dutch> #info Dutch
15:07:20 <Amol> #info amol
15:07:47 <Vipparthy> #info Vipparthy
15:07:59 <zhipeng> Amol which company are you from ?
15:09:51 <Amol> Hi Zhipeng . I am from nvxltech
15:10:16 <zhipeng> ah thx, same with Vipparthy right ?
15:10:25 <Amol> Yup
15:11:54 <zhipeng> cool :)
15:12:10 <zhipeng> Ok I see Intel folks flowing in, let's start the discussion
15:12:21 <zhipeng> #topic Queens Release Final Push
15:13:00 <dolpher> Hi
15:13:38 <zhipeng> #info Generic Driver
15:13:43 <zhipeng> #link https://review.openstack.org/525057
15:13:58 <shaohe_feng_> hello all
15:14:01 <zhipeng> crushil have you look at the comments from shaohe_feng_ and others ?
15:15:06 <crushil> zhipeng, yup. I'm working on the patch rn. Will push a new patchset by this week
15:15:46 <zhipeng> I have to cut the release branch Monday next week, so the window is pretty tight :)
15:16:15 <zhipeng> I will need your workflow+1 during the weekend crushil :P
15:16:32 <crushil> Hmmm. Ok
15:16:43 <crushil> I will be online on the weekend
15:16:47 <zhipeng> This is the final frenzy kicks in
15:16:52 <zhipeng> gr8t thx :)
15:16:57 <zhipeng> okey moving on
15:17:07 <zhipeng> #info Intel FPGA driver
15:17:19 <zhipeng> #link https://review.openstack.org/531129
15:17:54 <zhipeng> Li_Liu has shaohe_feng_ addressed your comments ?
15:18:57 <Li_Liu> I havn't had the chance to look at the new patch yet
15:19:05 <Li_Liu> Doing it now
15:19:22 <zhipeng> okey
15:19:46 <zhipeng> shaohe_feng_ other than the comments you received, code-wise is your patch ready ?
15:19:52 <Dutch> I can also add some input to help keep things vendor neutral
15:20:05 <zhipeng> Dutch absolutely
15:20:39 <shaohe_feng_> zhipeng: I have test it on our platform, it can works.
15:21:06 <shaohe_feng_> zhipeng: but maybe we still need to introduce rootwraper
15:21:07 <zhipeng> okey then here are my suggestions:
15:21:27 <zhipeng> no rootwrapper for queens :)
15:21:33 <zhipeng> we need to discuss that in Dublin
15:21:47 <zhipeng> So here are my suggestions at the patch :
15:22:02 <shaohe_feng_> the program need root for both intel and xilinx
15:22:05 <zhipeng> again due to the tight release window, we will have to land this patch this weekend
15:22:17 <dolpher> Li_Liu, Dutch: current implementation in fpga/intel is specific to intel FPGA, for Xilinx, we may need to create a directory of fpga/Xilinx
15:22:44 <Li_Liu> dolpher, I agree
15:22:44 <zhipeng> as I understand the comments are mostly on vendor neutral, as dolpher just mentioned
15:23:00 <dolpher> we need to make the interface generic in the end.
15:23:06 <zhipeng> so I would suggest to change the patch accordingly to reflect that this is an Intel FPGA driver
15:23:15 <Li_Liu> only issue I have is in cyborg/accelerator/drivers/fpga/util.py
15:23:26 <zhipeng> and let's try to harmonize it in the long run
15:23:40 <zhipeng> poor gerrit
15:24:22 <shaohe_feng_> gerrit need rest :)
15:25:27 <zhipeng> anyway, shaohe_feng_ you captured my suggestion ?
15:26:14 <shaohe_feng_> yes
15:26:24 <zhipeng> great :)
15:26:29 <zhipeng> next item
15:26:45 <zhipeng> #info Justin leftovers: conductor interaction with Placement
15:26:51 <zhipeng> not sure if zhuli is here
15:27:32 <zhipeng> but as I have discussed with zhuli and Li_Liu offline previously, we will need to quick modify and copy-paste of nova-sched report.py
15:28:00 <zhipeng> and also an extension at the agent level to implement the discover function in full
15:28:22 <zhipeng> This is also another big hole we need to fix in a short time
15:28:36 <zhipeng> shaohe_feng_ can your team help on the agent side ?
15:29:07 <zhipeng> what we need is an equal counterpart of "resource_tracker.py" in cyborg
15:29:19 <shaohe_feng_> OK
15:29:32 <zhipeng> which I assume is the discover interface that is very basic at the moment
15:29:57 <shaohe_feng_> yes.
15:30:33 <zhipeng> okey thx :) zhuli and Li_Liu will coordinate on the conductor side
15:30:38 <zhipeng> moving on
15:30:40 <Li_Liu> sure
15:30:44 <zhipeng> #info fix on devstack
15:31:10 <shaohe_feng_> resource_tracker.py will check resource periodically
15:32:12 <zhipeng> shaohe_feng_ we can simplify that for queens
15:32:23 <zhipeng> and write to db instead of a provider-tree like cache
15:32:33 <zhipeng> but anyways, back to the topic
15:32:43 <zhipeng> #link https://review.openstack.org/536251
15:32:56 <zhipeng> another good patch from Jinghan to make devstack working
15:33:16 <zhipeng> crushil if you thinks it ok you could just land it :)
15:34:55 <crushil> zhipeng, Ok. Will look at it later today
15:35:15 <zhipeng> gr8t thx :)
15:35:50 <zhipeng> okey folks that is all we need to do for Queens, I see Nova is still panicking on landing patches, so we are not alone :)
15:36:05 <zhipeng> let's try to wrap it up before next Mon
15:36:18 <dolpher> :)
15:36:49 <zhipeng> release is always driving people insane
15:37:53 <zhipeng> #action crushil to update the generic driver patch, and work with Howard to land all the remaining patches
15:38:21 <crushil> I thought the release data was feb 4th?
15:38:24 <zhipeng> #action shaohe_feng_ to update the patch to reflect the patch is Intel FPGA driver
15:38:44 <zhipeng> crushil that is like hard cutof, we have to run through the CIs and other stuff
15:38:47 <zhipeng> docs ...
15:38:53 <crushil> Hmmm
15:39:08 <zhipeng> so I left out a week of time for more panicking stuff lol
15:39:11 <crushil> Ok, so are we cutting RC1, RC2, etc.
15:39:12 <crushil> ?
15:39:18 <zhipeng> not for this release
15:39:22 <crushil> Ok
15:39:29 <crushil> We need to start doing that from Rocky
15:39:30 <zhipeng> but for Rocky we are gonna use the MS1,MS2,...
15:39:37 <crushil> Ok, makes sense
15:39:42 <zhipeng> yes, so that things are not so in chaos
15:40:39 <zhipeng> #action zhuli Li_Liu and shaohe_feng_ works on the Placement interaction patch (report and discovery)
15:41:09 <crushil> I can help review all the patches
15:41:30 <zhipeng> crushil counting on you man lol
15:41:55 <zhipeng> okey now moving away from the crazy real world problem
15:42:07 <zhipeng> #topic Dublin Rocky PTG Planning
15:42:30 <crushil> zhipeng, I won't be there most probably
15:43:06 <zhipeng> crushil waaaaat !
15:43:12 <zhipeng> #link https://etherpad.openstack.org/p/cyborg-ptg-rocky
15:43:29 <crushil> zhipeng, Ya. We have MWC the same week
15:43:36 <zhipeng> ah shit
15:43:44 <zhipeng> forget about MWC
15:44:14 <zhipeng> so Dutch Amol Vipparthy will you guys be present at Dublin ?
15:44:30 <Li_Liu> In case I can not work out the VISA.. do you guys have video conference in PTGs?
15:44:41 <zhipeng> Li_Liu I could set that up
15:44:43 <Dutch> I'll see if I can make it
15:45:18 <Li_Liu> ok
15:45:50 <zhipeng> so in any case, please propose the topic you would like to discuss on the etherpad
15:46:46 <zhipeng> other than the specific topics
15:47:01 <zhipeng> the important general topic we will cover is the planning for Rocky
15:47:29 <zhipeng> and the items are 1. finishing up Nova interaction bits 2. Burn fucntionality 3. Quota support
15:47:44 <zhipeng> these are the major general items I could think of for the next release
15:47:58 <zhipeng> any other suggestions ?
15:49:30 <shaohe_feng_> does
15:50:17 <shaohe_feng_> cyborg support multi tenant?
15:51:02 <zhipeng> shaohe_feng_ that questions should be divides in two
15:51:28 <zhipeng> functionality wise, cyborg should definitely support multi-tenancy, hence the quota feature planning
15:51:55 <zhipeng> but client wise, I haven't see strong use case for a tenant consuming client necessary for cyborg now
15:52:51 <Li_Liu> Howard, by "Burn Functionality", you mean program FPGA right?
15:54:55 <zhipeng> Li_Liu yes
15:55:42 <Li_Liu> ok, if we don't have a proposal yet. I can submit a spec later next week or so
15:55:42 <Dutch> Would that be for the role (partial reconfig.) or the shell (static) region?
15:55:53 <Li_Liu> I think so Dutch
15:55:59 <zhipeng> Li_Liu no hurry :)
15:56:22 <zhipeng> Dutch would also need your input for Rocky cycle :)
15:56:40 <zhipeng> to make the driver interface more vendor neutral
15:56:51 <Dutch> Yeah, no problem. I can help.
15:57:23 <Dutch> We could have the option to program both shell and role.
15:57:50 <Dutch> Any way something to think about
15:58:37 <zhipeng> and feel free to post the idea on the etherpad
15:58:45 <zhipeng> okey we had a full meeting today :)
15:58:50 <zhipeng> #topic AoB
15:59:01 <shaohe_feng_> zhipeng leverage glance to store the image?
15:59:03 <Vipparthy> Zhipeng, Sorry for lte respone, I can help on Rocky planning
15:59:04 <zhipeng> any other buisness before I cry to sleep ?
15:59:22 <zhipeng> Vipparthy much appreciated ! :)
15:59:37 <zhipeng> shaohe_feng_ yes definitely part of the discussion
15:59:52 <zhipeng> glance should be the default choice
16:00:09 <Vipparthy> please update me with specifics so WE can take it from here
16:00:18 <Vipparthy> you can always reach me on my email
16:00:30 <Vipparthy> amvipparthy@gmail.com
16:02:22 <zhipeng> we will usually update it via the community dev mailinglist
16:02:30 <zhipeng> so also stay tuned on that :)
16:02:59 <Vipparthy> Sure
16:03:32 <zhipeng> okey if there are no other questions, meetings adjourn , thanks everyone :)
16:03:35 <zhipeng> #endmeeting