03:04:51 <Sundar> #startmeeting openstack-cyborg
03:04:52 <openstack> Meeting started Wed Mar 20 03:04:51 2019 UTC and is due to finish in 60 minutes.  The chair is Sundar. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:04:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:04:55 <openstack> The meeting name has been set to 'openstack_cyborg'
03:05:18 <Li_Liu_> Hi Sundar
03:05:39 <Sundar> Hi Li_Liu_
03:05:55 <Li_Liu_> Anyone else around?
03:05:59 <Sundar> #topic Roll Call
03:06:10 <Sundar> #info Sundar
03:06:18 <Li_Liu_> #info Li_Liu
03:06:50 <Li_Liu_> just 2 of us today?
03:06:59 <xinranwang> Hi Sundar Li_Liu_
03:07:08 <xinranwang> I'm here :)
03:07:12 <Sundar> Hi xinranwang
03:07:13 <Li_Liu_> There we go xinranwang :P
03:07:22 <xinranwang> #info xinranwang
03:07:30 <Sundar> We got a 50% improvement in attendance :)
03:07:45 <Sundar> Just pinged the rest of the team
03:08:26 <Yumeng> # info Yumeng
03:08:28 <Yumeng> hi all
03:09:00 <Sundar> Hi Yumeng
03:09:09 <Li_Liu_> Hi Yumeng
03:09:38 <Sundar> Just 1 more minute, and then we'll get started
03:10:27 <Sundar> #topic Stein Status
03:11:09 <Sundar> #link https://review.openstack.org/#/q/status:open+project:openstack/cyborg+branch:master
03:11:36 <Sundar> We seem to be in good shape. Start with https://review.openstack.org/#/c/574075/
03:12:07 <Li_Liu_> is it merged yet?
03:12:23 <Sundar> It is dependent on #link https://review.openstack.org/641529 . So not merged yet
03:12:39 <Sundar> I need to ask Coco about the second patch
03:12:58 <Li_Liu_> Need to follow up with coco then
03:13:20 <Sundar> xinranwang: ANy update on https://review.openstack.org/#/c/624340/ ?
03:14:14 <wangzhh> Sorry for late. Meeting conflict just now.
03:14:58 <wangzhh> Anyone else?
03:14:58 <Sundar> wangzhh: Hi, np
03:15:04 <xinranwang> this is taken over by Coco, it's almost the make diff part.
03:15:34 <xinranwang> As she said in Wechat group, may need more tests .
03:15:37 <Sundar> xinranwang: Too much on Coco's plate? May be we can help her?
03:16:56 <Sundar> Only 3 days to go
03:17:26 <Li_Liu_> Sundar, I think we can add more test later
03:17:33 <Li_Liu_> but get it in first
03:18:12 <Li_Liu_> Hi Coco
03:18:30 <Sundar> Hi Coco_gao
03:18:30 <xinranwang> I am willing to help if needed
03:18:43 <Coco_gao> Hi all
03:19:12 <Coco_gao> I am working on fixing the bug, sorry for the joining late.
03:19:27 <Sundar> Coco_gao: Could we help you by having Xinran focus on https://review.openstack.org/624340, while you focus on https://review.openstack.org/641529 ?
03:20:51 <Coco_gao> I almost finish bug fix, will test it today.
03:21:30 <Sundar> Coco_gao: for 641529? Great. If that gets in, wangzhh's patch gets merged too!
03:21:50 <wangzhh> :) Great
03:21:50 <Coco_gao> Both two
03:22:06 <Coco_gao> Then add UT next
03:22:27 <Li_Liu_> Coco_gao, we can add the  UT after the RC cut
03:22:45 <Sundar> Coco_gao: Li_Liu_: Agreed ^
03:22:54 <Coco_gao> OK.
03:23:33 <Sundar> #topic cyborg client
03:23:45 <Sundar> What do we need to do for the client?
03:23:58 <Sundar> Do we have any owners?
03:24:11 <Li_Liu_> you mean the python  client?
03:24:15 <Sundar> Yes
03:25:02 <Li_Liu_> Right now I think we should be good for acc and deployable's v1 APIs
03:25:29 <Li_Liu_> 1 extra thing I can add is the fpga programmmg command
03:25:36 <Sundar> Has anybody tried it out of late?
03:26:02 <Sundar> Li_Liu_: Thanks
03:26:03 <xinranwang> Hmmm, i think the client is not complete
03:26:40 <Li_Liu_> all we can do is listing and update right? xinranwang
03:27:03 <xinranwang> just have accelerator list
03:27:28 <Sundar> xinranwang: What is missing?
03:28:04 <xinranwang> like accelerator show/ delete, and all related to deployables
03:28:27 <Li_Liu_> https://git.openstack.org/cgit/openstack/python-cyborgclient/tree/cyborgclient/v1/deployables.py
03:28:54 <Li_Liu_> This should do it right?
03:29:21 <xinranwang> yes, but also missing shell part
03:29:48 <Sundar> I think so. My suggestion is to let things be as they are, and  take care of v2 APIs in Train. That will be quite some work
03:30:16 <xinranwang> my question is: if we make v1 API deprecated, is it necessary to complete V1 client
03:30:17 <Li_Liu_> ok sure
03:30:21 <wangzhh> +1
03:30:56 <Li_Liu_> not worth the effort and we don't have time for that neither...
03:31:11 <Sundar> +1
03:31:47 <Sundar> Any differing opinions?
03:31:54 <Coco_gao> +1
03:31:58 <Yumeng> nope from me +1
03:31:59 <xinranwang> agree
03:32:09 <Sundar> #agreed Leave the python client as is
03:32:15 <Sundar> #topic Documentation
03:32:27 <Sundar> Yumeng, thanks for bringing up documentation
03:32:38 <Yumeng> Sundar,Li_Liu_: About the api-doc. admin/api.rst is already updated. However if new contributors wants to see how to make a api request, that might not be enough.  they might want to see more details like this https://developer.openstack.org/api-ref/compute/?expanded=suspend-server-suspend-action-detail#suspend-server-suspend-action
03:33:12 <Yumeng> Dowe want to have some doc-api-progress now? if so, we can do some work that needs to be done both for v1 and v2 , that maybe efficient.  the work will include: api-ref creation, deployable api CURD.
03:33:25 <Yumeng> if not, then just let it go. ^_^
03:33:30 <Coco_gao> #info Coco_gao
03:34:53 <Li_Liu_> sounds good to me
03:34:57 <Sundar> Yumeng maybe api-ref creation first? We can do deployables if we have time
03:35:42 <Sundar> Yumeng: Only 3 days to go, and we don't want you to kill yourself :)
03:35:42 <Yumeng> Sundar: ok, agree. then I will do api-ref creation
03:35:47 <Sundar> +1
03:35:54 <Li_Liu_> +1
03:36:15 <yikun> ++
03:36:28 <Yumeng> Sundar: lol, then maybe buy insurance first
03:36:30 <Sundar> #AoB
03:36:33 <Coco_gao> Do we have guides on how to write a driver?
03:37:08 <Li_Liu_> can wangzhh help on this?
03:37:21 <Sundar> Coco_gao: Good point. We should start compiling a list of missing docs.
03:37:50 <wangzhh> Li_liu_, Of course.
03:38:18 <Li_Liu_> Thanks a lot
03:38:21 <Sundar> wangzhh: Thanks!
03:38:25 <Coco_gao> thx
03:38:42 <Sundar> China Mobile wants to do a demo of ONAP with Cyborg at MWC Shanghai in June :)
03:38:43 <wangzhh> Do we have deadline this part?
03:38:58 <Li_Liu_> I think that's T release target
03:39:16 <Li_Liu_> but since we want to get vendor to work on driver in T
03:39:34 <Li_Liu_> having it earlier would be great
03:39:48 <wangzhh> It makes sense. I'll try my best.
03:39:55 <Li_Liu_> thanks
03:40:10 <Sundar> +1. Any issues if the doc gets submitted before Stein gets released?
03:40:29 <Sundar> May be we could hold the merge till Stein release
03:41:58 <Sundar> wangzhh: Please propose a draft and we can iterate over time.
03:43:12 <wangzhh> Yep.
03:43:35 <Sundar> wangzhh: Thanks again
03:43:38 <Sundar> wangzhh: China Mobile wants to do a demo of ONAP with Cyborg at MWC Shanghai in June. They want to use Cyborg GPU driver for Tesla 100. Do you think the GPU driver can be validated by, say, May beginning?
03:46:05 <wangzhh> I think it will be OK if the demo just like Vancouver summit. Of course, still need 'diff' part improved.
03:46:34 <Sundar> OK
03:46:42 <Coco_gao> I will update my patch today.
03:46:48 <Sundar> Any thing else to discuss?
03:48:14 <Sundar> Thanks, everybody
03:48:28 <Sundar> #endmeeting