03:02:53 <Sundar_> #startmeeting openstack-cyborg
03:02:54 <openstack> Meeting started Wed Apr  3 03:02:53 2019 UTC and is due to finish in 60 minutes.  The chair is Sundar_. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:02:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:02:57 <openstack> The meeting name has been set to 'openstack_cyborg'
03:03:03 <Sundar_> #topic Roll Call
03:03:08 <xinranwang> hi Li_Liu  Sundar_
03:03:13 <xinranwang> #info xinranwang
03:03:17 <Sundar_> #info Sundar
03:03:21 <Sundar_> Hi xinranwang
03:03:24 <Li_Liu> #info Li_Liu
03:03:37 <Sundar_> Let's wait a moment for others to join
03:03:58 <Yumeng> #info Yumeng
03:04:02 <Yumeng> hi all
03:04:23 <wangzhh> Hi all.
03:04:32 <yikun> #info yikun
03:04:41 <wangzhh> #info wangzhh
03:04:41 <yikun> hello
03:04:51 <Sundar_> Hi everybody, let's get started
03:04:54 <Sundar_> #topic Status
03:04:56 <Sundar_> https://review.openstack.org/#/q/status:open+project:openstack/cyborg+branch:master
03:05:11 <Sundar_> It looks clean to me. Great job, everybody!
03:05:24 <Li_Liu> We should be cutting the RC2 within a couple of days
03:05:52 <Sundar_> One question I have: What do we do with the patches with merge conflict, which will never really be merged?
03:05:52 <Li_Liu> any hope on https://review.openstack.org/#/c/645499/  ?
03:06:51 <Sundar_> Li_Liu: We should do a bit more testing IMHO. We are working on a CI setup
03:07:07 <xinranwang> Sundar_:  my patches related to PoC will never get merged.
03:07:22 <Sundar_> xinranwang: Do you agree on OPAE driver patch?
03:07:53 <xinranwang> Li_Liu:  the current opae still has some bugs, we'd better wait for next release of OPAE
03:08:45 <Sundar_> xinranwang: I think the origial idea for the non-mergeable patches was to share with the team. They can download it and refer.
03:08:52 <Li_Liu> xinranwang, sure
03:09:05 <xinranwang> Sundar_:  yes
03:09:20 <Sundar_> What do others think about these non-mergeable patches?
03:11:05 <Sundar_> Li_Liu, wangzhh, Yumeng, yikun, anybody?
03:11:19 <wangzhh> Yes.
03:11:58 <Li_Liu> We can keep them there for reference for now
03:12:11 <Yumeng> +1
03:12:21 <Li_Liu> Might need to find a cleaner way to back log them
03:12:30 <yikun> +1, It's better merge thoese in next release for me
03:13:28 <Sundar_> #agreed Leave the non-mergeable patches as they are, for now
03:13:43 <zhipeng> +1
03:13:45 <Sundar_> Any other patch to discuss?
03:14:11 <Li_Liu> I think we are good
03:14:19 <Li_Liu> I will cut RC2 tomorrow
03:14:28 <Sundar_> Yes, thanks Li_Liu.
03:14:33 <Li_Liu> np
03:14:35 <Sundar_> #topic PTG preparation
03:14:51 <Sundar_> #link https://etherpad.openstack.org/p/cyborg-ptg-train
03:14:58 <Sundar_> We need to fill the schedule
03:15:33 <Sundar_> Some folks have asked for a demo
03:15:57 <Li_Liu> Can Intel provide some infrastructure for the demo?
03:16:04 <Sundar_> https://etherpad.openstack.org/p/ptg-train-xproj-nova-cyborg
03:16:23 <Sundar_> I am preparing 2 demos -- was meant to be one, but will probably be 2 :)
03:16:38 <Coco_gao> Hi all
03:16:53 <Coco_gao> #info Coco_Gao
03:17:11 <Sundar_> Hi Coco_gao
03:17:13 <Sundar_> One is at the Intel booth, with a real-world app (genomics) + CYborg + Nova in upstreamable form. Probably no programming here.
03:17:44 <Li_Liu> is it on-site server or off-site server?
03:17:49 <Sundar_> Other is for the Nova folks. There have been several asks, and I am trying to show programming. But we don;t have full discovery
03:17:56 <yikun> so this one including the e2e device attach demo? :)
03:18:10 <yikun> I mean the 1st one
03:18:34 <Sundar_> Nova folks want to see discovery but we have to say the Intel OPAE driver is WIP. I have some setup scripts to populate the Cyborg db and Placemen directly
03:19:08 <Sundar_> yikun: First one also does not have discovery
03:19:42 <Li_Liu> demo is always hacky :P
03:19:46 <Sundar_> Li_Liu: on-site server : I'll either do a live demo or use a some video for backup
03:20:18 <Sundar_> Yes, a few hacks but, IMHO, Nova's real interest should be in Cyborg APIs and how they get called
03:20:39 <Li_Liu> I see
03:20:39 <Sundar_> Internals of device discovery shouldn;t matter -- except that Cyborg should not conflict with PCI whitelist
03:21:15 <Sundar_> Li_Liu: my question is, is it too late to get a room for the demo?
03:21:23 <Li_Liu> We can just pre-populate the DB as if the discovery is happening
03:21:39 <Li_Liu> you mean during the PTG or summit?
03:21:54 <Sundar_> PTG
03:21:58 <yikun> Sundar_: agree, so the key is show cyborg api/client and the key interface of attachment.
03:22:41 <Li_Liu> Do we need an extra room for thedemo?
03:22:58 <Li_Liu> I thought each team should be getting a room and we can just use that
03:23:36 <Sundar_> A room with a projector, which can potentially accommodate a large #people. ( I am thinking of the bw provider demo for Neutron at last PTG)
03:24:02 <Sundar_> Li_Liu: Ok, does that room have a projector?
03:24:05 <Li_Liu> Another option is to show it during our project update session during summit
03:24:18 <Li_Liu> I will ask them
03:24:26 <Sundar_> I think Nova folks will have tons of questions
03:24:44 <Sundar_> Would be good to do this at the PTG, drive discussion and closure
03:25:04 <yikun> Maybe you could send a mail to ML, and arrange it in the beginning cyborg meeting/(or nova-cyborg meeting)
03:25:11 <Sundar_> Li_Liu: Thanks
03:25:23 <zhipeng> Please please use your phone to record it
03:26:10 <yikun> if the demo video is available, and we can also send it to ML, and let the tons of question comes before PTG. :)
03:26:15 <Sundar_> yikun, all: Yes, we need to set a time in consultation with Nova. May be Thursday or Friday, since many folks will not be there on Sat -- including yours truly.
03:27:27 <Sundar_> On a related note, I am thinking of setting a cross-project with Ironic, because (a) Ironic deployments are going up, (b) people want accelerators in bare metal, and (b) this may a path to host K8s + accelerators on Cyborg
03:27:39 <Sundar_> That would also require setting a specific time
03:28:22 <Sundar_> Request to all of you: please fill out https://etherpad.openstack.org/p/cyborg-ptg-train , so that we can estimate how much time each will take.
03:29:05 <Sundar_> I'll stop here, and let you folks speak -- for a change :)
03:29:10 <Li_Liu> sure will do
03:29:15 <yikun> ok
03:29:53 <yikun> Sundar_: Note that 4.5 ~ 4.7 is china Chingming festival (So, Friday Sat Sun is vacation in China)
03:30:08 <Sundar_> I see
03:30:55 <zhipeng> Sundar_ big +1 on Ironic thought
03:31:14 <Sundar_> zhipeng: :)
03:31:24 <zhipeng> I've tried to get this started a while ago (Julia was not convinced back then )
03:32:11 <Sundar_> I spoke to Julia too a couple of times. I agree, it was a bit premature without getting Nova fully lined up
03:33:25 <zhipeng> Keep up the great work !
03:33:39 <Sundar_> Another big thing coming up -- Intel PAC N3000 https://www.anandtech.com/show/13958/intel-fpga-pac-n3000
03:34:24 <Sundar_> I'd like to present it in tomorrow's Zoom call. This has *huge* interest from telcos, and also represents quite some changes for CYborg.
03:34:48 <Li_Liu> great, looking forward to it
03:34:56 <Sundar_> I tried to fold this into our device model, but the details kept changing
03:35:51 <wangzhh> Great!
03:36:06 <Coco_gao> Sounds good.
03:36:16 <Coco_gao> What about the demo, do you need any help?
03:37:00 <Coco_gao> I think the discovery part may be functional, but not the nova interaction part.
03:37:41 <Coco_gao> Could you pls introduce you demo a little bit in tommorows meeting?
03:37:59 <Sundar_> Coco_gao: Yes. I am about to make one more set of changes, including support for programming with v2 API. Please review the pilot branch patches after that!
03:38:56 <Sundar_> Coco_gao: I need to merge the master with the feature branch, and then we can see what parts ork
03:39:44 <Sundar_> Re. Intro the demo tomorrow, please give me some more time. Because only today I got permission to merge master onto the pilot.
03:40:17 <Coco_gao> Thank you, take your time.
03:40:57 <zhipeng> The glorious git rebase
03:42:16 <Sundar_> I tried a rebase, and #infra folsk said no, I need to do a merge. I tried the merge and that failed, because I need permissions. Then I have to figure out how to get those permissions. Now that is done -- so onto the glorious merge :)
03:42:20 <openstackgerrit> Merged openstack/python-cyborgclient master: fix service name in client  https://review.openstack.org/649493
03:43:00 <Coco_gao> aha, I see the gerrit information.
03:43:41 <Sundar_> Any other topic on PTG preparation?
03:44:40 <Sundar_> #topic AoB
03:45:59 <Sundar_> Li_Liu, loking forward to the room info. All the best for the RC2 cut.
03:46:34 <Li_Liu> I have sent the email to confirm
03:46:45 <Li_Liu> Will let you know once they get back to me
03:46:51 <Sundar_> Thanks, Li_Liu
03:47:24 <Li_Liu> np
03:47:54 <Sundar_> Great job on Stein, and thanks everybody! Good day (or good night). Enjoy the Chingming festival!
03:48:04 <Sundar_> #endmeeting