03:09:18 <Sundar> #startmeeting openstack-cyborg
03:09:19 <openstack> Meeting started Wed May 22 03:09:18 2019 UTC and is due to finish in 60 minutes.  The chair is Sundar. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:09:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:09:22 <openstack> The meeting name has been set to 'openstack_cyborg'
03:09:29 <Sundar> #topic Roll Call
03:09:42 <Li_Liu> #info liliu
03:09:46 <wangzhh> #info wangzhh
03:10:11 <Sundar> #info Sundar
03:10:19 <Sundar> Hi Li_liu, wangzhh
03:10:34 <Li_Liu> Hi Sundar
03:10:37 <wangzhh> Hi Sundar, Uncle Li.
03:11:15 <Sundar> Wait a min for other folks?
03:11:41 <wangzhh> Yep.
03:12:34 <xinranwang> #info xinranwang
03:12:45 <Sundar> Hi Xin-ran
03:13:00 <xinranwang> HI all
03:13:14 <Sundar> Ok, let's get rolling
03:13:18 <Sundar> Agenda: https://wiki.openstack.org/wiki/Meetings/CyborgTeamMeeting#Agenda
03:13:24 <Sundar> Any thing to add to it?
03:14:07 <Li_Liu> looks good
03:14:23 <Sundar> #topic Cyborg specs
03:14:25 <Sundar> https://review.opendev.org/#/q/status:open+project:openstack/cyborg-specs
03:15:05 <Li_Liu> I have reviewed most of them
03:15:18 <Li_Liu> only one left is Yikun's patch
03:15:40 <Sundar> Cool. Any more comments on https://review.opendev.org/602978?
03:15:43 <Li_Liu> at a glance, it looks good. will look into it
03:16:28 <Sundar> Cool. I suspect that and https://review.opendev.org/658263 will be quasi-prerequisites to merging Nova spec
03:17:15 <Sundar> #Nova spec
03:17:30 <Sundar> #topic Nova spec
03:17:32 <Sundar> https://review.opendev.org/#/c/603955/
03:18:37 <Sundar> I presume all of you have looked at it. The main issue now is that a quarum of Nova developers want to move the binding into nova compute, which gives less time for FPGA programming or other device prep
03:18:45 <Sundar> *quorum
03:19:11 <Sundar> It may work for Neutron, because port binding is not a time-consuming op.
03:19:36 <Li_Liu> when FPGA is programming, nova is waiting for the external event
03:19:58 <Li_Liu> is there a requirement on how long this process could take?
03:21:15 <Sundar> There are no firm requirements. We want to minimize the Nova wait of course. The times vary widely depending on the device, bitstream size, etc. Somewhere between seconds and a few tens of seconds would be in the ballpark
03:21:53 <Li_Liu> I think around 10s is totally acceptable
03:23:04 <Sundar> The VM spawn is held up for that period of time. That will cut into bulk VM creation rate, which matters for some scenarios
03:23:23 <Sundar> Anyways, Li_Liu, when can we have the patches for Nova notification? I was hoping to use them to do some measurements.
03:23:54 <Li_Liu> I am still working on it.
03:24:07 <Li_Liu> give me some time
03:24:29 <Li_Liu> still in China, my working hour is in pieces...
03:24:40 <xinranwang> can we use os profile to test how long program will take?
03:24:55 <xinranwang> is it helpful?
03:25:13 <Sundar> I see. Understand. The problem is, the Nova spec is held up for that time.
03:25:48 <Sundar> xinranwang: The question is not, how long programming will take. It is: how much of it can we overlap with other tasks? The older model overlapped more than the newer proposed model
03:26:11 <Sundar> Anyways, I'll try to hack up something meanwhile and get some data
03:27:18 <Sundar> Anything else to discuss about Nova spec?
03:27:47 <Sundar> #topic Pilot merge plan
03:28:33 <Sundar> If I understood correctly, the consensus is to apply some comments and merge the pilot into master?
03:28:57 <Sundar> i.e. no need to re-submit it as smalle rpatches into master, right?
03:30:58 <Sundar> Silence means yes? :)
03:31:51 <wangzhh> Fine.
03:32:20 <Sundar> Thanks, wangzhh.
03:33:16 <Sundar> #agreed Merge pilot into master rather than re-submit it as patches.
03:33:29 <Sundar> #topic Python 3 transition
03:33:55 <Sundar> ikuo_o mentioned somebody else from NTT wll join
03:34:15 <ikuo_o> yuki is my colleague yes
03:35:02 <Sundar> ikuo_o: You are here ;) Cool. Do you want to discuss the steps for Python 3 transition?
03:36:28 <Sundar> It could be a multi-step process IMHO. You are all welcome to suggest changes or alternatives.
03:37:11 <Sundar> A. Submit some CI tests for Python 3 compliance. They may break at the start, so they may have to be disabled temporarily.
03:37:24 <ikuo_o> yeah, but gm now moving and have only my small phone.
03:37:39 <Sundar> B. Make the changes to let Py3 pass, and submit those patches.
03:38:29 <Sundar> C. While B is going on, developers may have submitted more patches, which may cause breakage because tests were disabled. So, perhaps another patch to fix them?
03:38:45 <Sundar> D. Enable CI tests, so that every patch will be Py3-compliant after that
03:38:51 <Sundar> Does that make sense?
03:39:13 <ikuo_o> yuki_t, do you understand the steps?
03:39:45 <Sundar> Welcome yuki_t :)
03:39:56 <yuki_t> yes, i understand.
03:40:12 <yuki_t> hi, sundar
03:40:35 <Sundar> Great. Thanks. wangzhh, Li_Liu, xinranwang: any comments?
03:41:22 <wangzhh> It's great.
03:41:40 <Li_Liu> I am good
03:41:46 <Li_Liu> Thanks a lit
03:41:49 <Li_Liu> lot*
03:42:04 <Sundar> Thank you :)
03:42:17 <Sundar> #topic AoB
03:42:23 <yuki_t> May I say the progress of python3 migration?
03:42:31 <Sundar> Do we have any topics for the Zoom call tomorrow?
03:42:37 <xinranwang> I am good, thanks a lot
03:43:36 <Sundar> If there are no topics, shall we cancel the call tomorrow?
03:44:45 <wangzhh> Sure.
03:45:23 <wangzhh> Depends on others.
03:46:21 <Sundar_> Sorry, lost connectivity briefly
03:46:31 <Sundar_> No other topics, right?
03:47:22 <Sundar_> Thanks everybody. Have a great day!
03:47:26 <Sundar_> #endmeeting
03:47:32 <wangzhh> Bye, all
03:48:04 <Sundar_> Hmm, I will re-login with my old nickname to end the meeting later
03:49:07 <Sundar> #endmeeting