03:03:36 <Sundar__> #startmeeting openstack-cyborg
03:03:37 <openstack> Meeting started Wed May 29 03:03:36 2019 UTC and is due to finish in 60 minutes.  The chair is Sundar__. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:03:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:03:40 <openstack> The meeting name has been set to 'openstack_cyborg'
03:03:46 <Sundar__> #topic Roll call
03:04:17 <Sundar__> #info Sundar
03:04:20 <wangzhh> #info wangzhh
03:04:36 <ikuo_> #info ikuo_
03:04:49 <Sundar__> #topic Agenda
03:04:52 <Sundar__> https://wiki.openstack.org/wiki/Meetings/CyborgTeamMeeting
03:04:53 <Coco_gao> #info Coco_gao
03:05:05 <Sundar__> Anything to add to this agenda?
03:05:36 <Sundar__> #topic Nova spec update
03:05:41 <ikuo_> It's good
03:06:29 <Sundar__> There was a feedback to move the Cyborg binding to Nova compute manager. I implemented it and made some measurements on 1 2-node system, but that doesn't predict scaling impact
03:07:11 <Sundar__> Meanwhile, several folks gave that feedback. SO, I have changed the spec to match that
03:07:22 <Sundar__> Does anybody have any concerns or comments?
03:08:17 <Sundar__> The spec is close to finish, so please provide your comments soon
03:08:36 <ikuo_> Where do you mean in the spec?
03:09:36 <Sundar__> https://review.opendev.org/#/c/603955/13/specs/train/approved/nova-cyborg-interaction.rst,unified Line 240
03:10:01 <wangzhh> Fine with me.
03:10:03 <Sundar__> Lines 240-263
03:10:29 <Sundar__> Good
03:10:44 <Sundar__> #topic python cyborg client
03:10:54 <Sundar__> Thanks to ikuo_ for starting http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006543.html
03:10:55 <yikun> #info yikun
03:11:02 <Sundar__> Hope you all had a chance to catch up
03:11:27 <Coco_gao> still need to some time to catch up, sorry.
03:11:50 <Sundar__> Coico_gao, NP. I'll try to summarize.
03:12:26 <Sundar__> python-cyborgclient should be rewritten as an OSC plugin or a new repo should be created for that: http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006574.html
03:13:07 <Sundar__> Dean tTroyer (http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006577.html) suggests we could write a plugin to OSC, as part of OSC repo itself.
03:13:39 <Li_Liu> #info Li_Liu
03:13:56 <Coco_gao> Thanks for the summay~
03:14:00 <ikuo_> So we should rewrite the whole cyborgclient.. In fact, I cannot imagine the impact.
03:14:05 <Sundar__> Either way, it is good for Cyborg to implement OpenStack SDK, so that the client can use it to call the API
03:14:45 <Sundar__> First, do we all agree that we should use the OpenStack SDK (independent of other options)?
03:15:26 <xinranwang> #info xinranwang
03:15:35 <xinranwang> Hi all, sorry for late
03:15:56 <ikuo_> Is it other thing but OSC plugin?
03:16:24 <Sundar__> ikuo_ : It seems like a large impact. In practice, current client is mostly v1. So its objects either don't exist (like accelerators) or have changed a lot (like deployables). Plus, there are new pones like device profiles
03:16:43 <Sundar__> So, I suspect anyway it will be a big change
03:16:43 <wangzhh> Sundar, if we rewrite cyborgclient  as an OSC plugin, who guys are responsible for the milestone?
03:17:00 <Coco_gao> Agree to use openstack sdk first.
03:17:21 <Li_Liu> is this a train target?
03:17:35 <Sundar__> wangzhh: Good question, I don't know :). It means we are not in control, as Dean says. Or, we could write our own plugin from scratch -- more work but more control.
03:17:42 <Sundar__> Li_Liu: Yes
03:18:38 <Sundar__> ikuo_: "Is it other thing but OSC plugin?" <-- OpenStack SDK and OSC plugin are 2 different things
03:18:50 <Sundar__> SDK is a way for other services (or cyborg client) to call CYborg API
03:19:01 <ikuo_> OK, I agree Use openstack sdk
03:19:10 <Sundar__> Whereas OSC plugin is a way to implement the client using standard mechanisms
03:19:54 <Sundar__> Coco_gao, ikuo_: Thanks for voting on SDK. Anybody disagrees?
03:20:31 <wangzhh> Agree SDK +1
03:20:37 <Li_Liu> sounds good
03:20:52 <Sundar__> Great :) I like consensus :)
03:21:03 <xinranwang> Agree
03:22:06 <ikuo_> But rewriting for OSC plugin by only NTT, it is difficult, I think.
03:22:50 <Sundar__> ikuo_: I understand
03:23:11 <Sundar__> Now, for the difficult question -- should we write a separate osc plugin (like many other projects have done) or try to make this a part of osc repo? Dean says: "if Cyborg were completely backed by the SDK we would consider adding its commands directly to the OSC repo."
03:23:37 <Sundar__> Once we adopt the SDK, may be it gets easier? Plus, I agree others should support NTT
03:24:16 <wangzhh> ikuo, can u help to split the task on storyboard?
03:24:45 <Sundar__> I suspect there will be less UT and functional tests if we use the OSC repo. If there is concern about dependence and timelines, I could ask Dean.
03:24:56 <Sundar__> (Or any of you could respond on the ML.)
03:26:43 <ikuo_> Wangzhh: so we should split our cyborgclient task to 1) use openstacksdk and 2) OSC plugin /repo?
03:27:07 <Coco_gao> Maybe more smaller tasks.
03:28:19 <wangzhh> Coco, Yep.  So that others can take part of them to support NTT.
03:28:35 <ikuo_> I got it.
03:29:10 <Coco_gao> I will first finish my part and then join you to finish other tasks.
03:29:22 <wangzhh> Thx. ikuo_.
03:29:39 <ikuo_> All right. thanks.
03:30:03 <Sundar__> Sounds like a plan. Should I ask on the ML what is the risk to timeline from using osc repo?
03:30:21 <ikuo_> Yes, please!
03:30:31 <Sundar__> Will do
03:30:49 <Coco_gao> Yes
03:31:01 <Sundar__> #agreed Cyborg will implement OpenStack SDK. The client will call the API through that
03:31:26 <Sundar__> #action Sundar: gets pros and cons of using the osc repo, vs. writing a plugin
03:31:49 <Coco_gao> BTW, does engineering meeting still exist?
03:31:51 <Sundar__> #action: ikuo_  will create storyboard tasks
03:32:41 <Sundar__> Coco_gao: We can convene it any time if there is a need. IMHO, it is good to keep it as a placeholder. The networked FPGA stuff is still open
03:33:00 <Sundar__> What do you all think?
03:33:12 <Coco_gao> Sounds good for me.
03:33:17 <ikuo_> Yes, we should talk when we need.
03:33:49 <Sundar__> OK, thanks
03:33:57 <Sundar__> #topic Communication updates
03:34:26 <Li_Liu> I am still working on the nova's external_event_api patch
03:34:41 <Sundar__> As you may know, there are some restrictions on communication, and some of us have been asked not to use WeChat by default
03:35:17 <Coco_gao> What do you suggest?
03:35:34 <Li_Liu> lol
03:35:37 <ikuo_> Yes, my colleague cannot use WeChat. Thank you for proposing the topic.
03:35:41 <Sundar__> It would be good to use IRC and ML by default. For IRC, does it make sense to have a window of time where we all login? For example, it could be morning 9-12 am by CHina time?
03:35:46 <Li_Liu> I think irc is our only option now
03:36:07 <Sundar__> Li_Liu and all: yes
03:36:19 <Li_Liu> can we still talk in zoom meetings?
03:36:41 <xinranwang> Sundar__:  Hi Sundar, I have pull your pilot branch in local, and find some bugs, for example, we cannot delete extended_arq when deleting vm, and some other. I have done some bug-fix. Do you want me to leave comments where bug occurs , or I can co-author with you if you want. Which way you prefer?
03:36:59 <Sundar__> Li_Liu: My guidelines are that public meetings are ok. I have put the Zoom URL in wiki along with the times. SO it is open to all
03:37:14 <ikuo_> That's sounds good staying 9-12 am.
03:37:44 <Sundar__> ikuo_: Thanks. Others ok with that time?
03:38:09 <Li_Liu> yup, I will be on irc all the time now
03:38:20 <Sundar__> Cool.
03:39:46 <Sundar__> xinranwang_: The Cyborg code to delete ARQs exists. Bu the Nova code to call the DELETE for ARQs is not done yet. If you want to take that up, NP. But please be aware that this will be on the critical path.
03:40:27 <Sundar__> If you want to leave comments, that is also fine
03:40:53 <Sundar__> Or you cold make it a patch on top of this patch series, kinda like what Li_Liu plans to do
03:41:23 <Sundar__> xinranwang: ^
03:42:05 <xinranwang> Ok, it's fine for me to submit  patch on your patch series.
03:42:16 <Sundar__> Thanks, xinranwang.
03:42:23 <xinranwang> NP :)
03:42:49 <Coco_gao> 9-12am every day?
03:43:23 <Sundar__> Coco_gao: :) As much as we can. Or perhaps you post on IRC and ping the other person on WeChat
03:43:45 <ikuo_> I think it is not mandatory. Sundar's plan +1
03:43:55 <Sundar__> This is just to facilitate communication -- not meant to be a binding rule
03:44:05 <Coco_gao> got that
03:44:27 <xinranwang> 9-12am sounds good
03:44:32 <Sundar__> Li_Liu: For developing patches in a series, please look at https://docs.openstack.org/contributors/code-and-documentation/patch-series-tutorial.html
03:44:46 <Li_Liu> Thanks a lit
03:44:46 <xinranwang> Sundar__:  got it, thanks
03:44:49 <Li_Liu> lot*
03:45:54 <Sundar__> Sorry that the pilot code is still not merged. I feel like I should write more UT and implement all comments. That has been a stretch. But I'll make it a priority
03:46:04 <xinranwang> I remember there is a tools that can run irc background all the time, which nova guys usually use. I will check it
03:46:35 <Sundar__> irccloud can notify when offline, but only in paid version, right?
03:47:09 <Coco_gao> I see, 5$ for permanet use.
03:47:13 <xinranwang> I am not sure, cause i didn't pay for it. lol
03:47:16 <ikuo_> I want to know such a tool, if possible, for free :)
03:47:47 <xinranwang> I think the tools i mentioned before is a kind of extension
03:48:32 <xinranwang> ikuo_: I will let you know if I find it :)
03:48:44 <ikuo_> Thanks, xinranwang!
03:48:54 <Sundar__> xinranwang: Please share after you find out about this. Thanks!
03:49:02 <Li_Liu> I paid for Irccloud
03:49:02 <xinranwang> Sure
03:49:07 <Sundar__> #topic Cyborg patches
03:49:09 <Li_Liu> it works great so far
03:49:45 <Sundar__> https://review.opendev.org/659233 -- xinranwang, can you rewrite this to use our own placement calling code?
03:50:07 <ikuo_> I see. thanks Li_Liu!
03:51:52 <xinranwang> Sundar__:  Yes, will do it. I am working on a cyborg DEMO which required by customers recently, and do not have much time on this.  I will update it ASAP.
03:54:28 <Sundar__> Thanks
03:54:46 <Sundar__> I have provided some comments on other specs and patches
03:55:09 <Sundar__> Any questions or comments on specs or patches?
03:55:17 <ikuo_> I post some comments and questions to the spec yesterday, pls see them.
03:55:27 <ikuo_> in here: https://review.opendev.org/#/c/659233/
03:55:58 <ikuo_> soryy
03:56:00 <ikuo_> https://review.opendev.org/#/c/626057/
03:57:09 <Sundar__> Thanks, ikuo_ and all. Yes, I'll respond and fix them as much as practical.
03:57:37 <Sundar__> #topic AoB
03:57:46 <Sundar__> Anything else for today?
03:58:02 <ikuo_> fine. thanks.
03:58:26 <Sundar__> Have a good day (or night), everybody!
03:58:31 <Sundar__> #endmeeting