03:03:18 <Sundar> #startmeeting openstack-cyborg
03:03:19 <openstack> Meeting started Wed Aug 14 03:03:18 2019 UTC and is due to finish in 60 minutes.  The chair is Sundar. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:03:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:03:21 <wangzhh> Hi Sundar.
03:03:22 <openstack> The meeting name has been set to 'openstack_cyborg'
03:03:30 <Sundar> #topic Roll call
03:03:40 <Sundar> o/
03:03:57 <Yumeng> #info Yumeng
03:03:59 <wangzhh> #info wangzhh
03:04:17 <Sundar> Seems like thin attendance today, at least to start with
03:04:38 <Sundar> #topic New time for weekly IRC meeting
03:04:50 <xinranwang> #info xinranwang
03:05:08 <Yumeng> hi xinran
03:05:16 <xinranwang> Hi all :)
03:05:56 <Sundar> We did a Doodle poll to pick the best time for al: https://doodle.com/poll/6t279f9y6msztz7x
03:06:59 <Sundar> There were 2 slots with 6 votes each. I pinged Shaohe and Coco individually. Both agreed on Thu 11 am China time.
03:07:16 <yikun> #info yikun
03:07:23 <Sundar> Any objections to choosing that as the new time?
03:08:40 <Sundar> Since no objections were raised, I'll send a notice. From next week onwards, this is the new meeting time.
03:09:03 <Sundar> #topic os-acc discontinuance
03:10:31 <Sundar> A patch was filed to fix Python 3 issues in os-acc. To avoid such hassles, I propose to discontinue os-acc. If there are no objections, I'll start the process of retiring the repository right away.
03:10:37 <Sundar> Are there any objections?
03:12:03 <Sundar> Since no objections were raised, I'll send a message in openstack-discuss and start the process.
03:12:37 <Sundar> We are following the agenda in: https://wiki.openstack.org/wiki/Meetings/CyborgTeamMeeting#Agenda
03:12:55 <Sundar> Since we don't have NTT folks here today, we'll jump ahead by one topic.
03:13:02 <Sundar> #topic Tempest CI
03:14:11 <Sundar> Our (my?) current plan is to kick off tempest with the fake driver for Nova patches and tempest with real FPGA hardware for Cyborg patches. Do you think we should both types of CI for both kinds of patches?
03:14:44 <Sundar> Yumeng, wangzhh, xinranwang, yikun: ^
03:17:06 <Sundar> Pretty silent group today :)
03:18:07 <wangzhh> Thinking...
03:19:15 <wangzhh> Does nova guys agree with only tempest with real hardware?
03:19:43 <Sundar> Nova wants the fake driver tempest primarily.
03:20:08 <Sundar> Cyborg may also want the same.
03:20:15 <yikun> the real device driver is implemented as the 3rd party ci?
03:20:30 <Sundar> Yumeng: Yes, for Intel FPGAs
03:20:42 <Sundar> Sorry, yikun :)
03:21:14 <Yumeng> for the real FPGA hardware for Cyborg patches,  we mainly use it to test the  discover and report part, while for the fake driver for Nova patches, we mainly use it to test the attach_detach part,right ?
03:21:15 <yikun> OK, no objection from me, I think it's same as the original plan, isn't it?
03:21:47 <wangzhh> Uh-huh, it's better to imply them one by one, fake driver first?
03:22:07 <Sundar> It was not clear to me that we agreed on fake driver tempest for Cyborg patches too. If so, do we need to file a new patch for that?
03:23:17 <Sundar> Yumeng: The fake driver part will test the whole flow from Nova till Cyborg agent, using the fake driver. WHile 3p CI with real hardware will ensure real FPGA driver and functionality like programming are not broken
03:24:27 <Sundar> wangzhh: Agreed - let's start with fake driver for both. We will have 3p CI going for Cyborg 'soon'.
03:24:56 <xinranwang> I consider the fake driver is a solution for nova-side requirements, it mainly aims at nova-cyborg interaction.
03:26:13 <Sundar> xinranwang: When we submit a Cyborg patch, we want to ensure that does not break Nova-Cyborg interaction either.
03:26:43 <Sundar> Nova requirements are the forcing function, but it helps to have it for Cyborg too, right?
03:28:27 <xinranwang> So we will always keep it, even if we finished the 3p CI?
03:30:19 <Sundar> Are you advocating that we do only the 3p CI for Cyborg? That would be the minimum.
03:31:07 <Sundar> That is what I have currently planned for. Just checking in with all of you.
03:31:28 <xinranwang> No, I just want make sure the fake driver is a long term solution or not.
03:33:10 <Sundar> OK. The minimum for Nova is fake-driver. The minimum for Cyborg, IMHO, is 3p CI with real hardware. As long as the hardware setup is always available and functional, we don't need the fake driver tempest for Cyborg. Are we all aligned on that?
03:35:18 <Sundar> wangzhh, yikun, Yumeng, xinranwang: ^
03:35:24 <xinranwang> Agree with you
03:35:47 <wangzhh> Agree +1
03:36:08 <Yumeng> yes,agree with that.
03:37:00 <Sundar> Great, we have a quorum. Let's stick with the minimum for Train and build on it later, if needed
03:37:36 <Sundar> #agreed Will implement only fake-driver tempest for Nova patches and 3p CI with Intel FPGA for Cyborg patches in Train.
03:37:45 <Sundar> Yumeng: Can you update https://review.opendev.org/#/c/670999/ to reflect the comments? i.e. mark it as WIP, and place a dependency on my patch series?
03:38:18 <Yumeng> ok,np
03:38:23 <Sundar> Thanks
03:38:31 <Sundar> #topic Storyboard tasks
03:38:52 <Sundar> There are 3 important tasks: RBAC, Cyborg functional tests, Nova functional tests that mock Cyborg API
03:39:48 <Sundar> For RBAC, can any of you sign up? It is important for security. Our common/policy.py is all for v1 API. But it needs to be fixed for v2.
03:41:15 <Sundar> wangzhh or yikun: Will be ideal if one of you can pick up :)  because Yumeng and Xinran have chosen other activities
03:42:27 <wangzhh> I can take policy releated work next week.
03:42:38 <Sundar> Excellent, wangzhh. Thanks :)
03:42:50 <wangzhh> Np :)
03:43:47 <Sundar> Nova functional tests that mock Cyborg API: I think we need this to be done for the Nova patches to merge.
03:44:14 <Sundar> Nobody has raised this yet but I remember this from PTG.
03:44:44 <Sundar> yikun: If this is a game of musical chairs, you are the last person left. :)
03:47:50 <Sundar> OK, no pressure. We need to revisit this later.
03:47:58 <Sundar> #topic AoB
03:48:17 <Sundar> Please note that the IRC meeting time shifts next week as agreed.
03:49:08 <Sundar> Python 3 is super-important for Train. Apparently, Cyborg missed adding Py3 tests, which was a goal in Pike release.
03:50:59 <Sundar> If we make Python 3 job as a voting job, we have to expend work now to keep it all fixed. If we make it a non-voting job, there is a risk because there is apparently a plan to disable all py27 testing early in next cycle.
03:51:33 <Sundar> wangzhh, Yumeng, xinranwang, yikun: what do you favor?
03:53:00 <xinranwang> It depends on how much time we left. But I do know there's some bugs need to fix when i run py3 tests.
03:54:04 <Sundar> If we have time, we also have Cyborg functional tests to do -- basic for good quality.
03:54:48 <xinranwang> those are all nice to have. Let's focus on critical path.
03:55:13 <xinranwang> We need more review on nova-cyborg integ patches and placement report patch.
03:56:53 <Sundar> Yes. IIUC, you are suggesting to keep Python 3 jobs as no-voting for now and make them voting in the next cycle, right?
03:58:32 <xinranwang> Yes, after we finish the important things, if we have more time, we can work on it in this release as well, but it's not obligate. That's my suggestion :)
03:58:52 <Sundar> Got it. Any objections?
03:59:28 <Sundar> Any objections from wangzhh, yikun, Yumeng?
03:59:55 <wangzhh> Fine with me.
04:00:17 <Sundar> OK, let's go with that plan.
04:00:29 <Sundar> Thanks, everybody. Have a good day! Bye.
04:00:32 <Sundar> #endmeeting