03:02:31 <Sundar> #startmeeting openstack-cyborg
03:02:32 <openstack> Meeting started Thu Mar  5 03:02:31 2020 UTC and is due to finish in 60 minutes.  The chair is Sundar. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:02:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:02:35 <openstack> The meeting name has been set to 'openstack_cyborg'
03:02:47 <Sundar> #topic Agenda
03:02:55 <chenke> #info chenke
03:03:04 <Sundar> #info Sundar
03:03:14 <Li_Liu> #info Li_Liu
03:03:29 <brinzhang> #info brinzhang
03:03:36 <Yumeng> #info Yumeng
03:04:10 <xinranwang> #info xinranwang
03:04:26 <Sundar> What do people have to discuss today?
03:05:18 <brinzhang> About remove  v1 API
03:05:19 <brinzhang> https://review.opendev.org/#/c/711232/
03:05:22 <Sundar> BTW, the time for PTG reservation is up. I didn't hear confirmation that even 3 people plan to go to Vancouver, SO I haven't confirmed anything.
03:07:27 <shaohe_feng> encourage developers to access the PTG
03:07:31 <shaohe_feng> if possible.
03:09:59 <chenke> V1's API is now worthless, and v2 can also be seen. v2's deployable api, Shogo is also doing it, I think it can be removed. Even if the v1 api is retained, the call may not necessarily be as expected. https://review.opendev.org/#/c/698190/
03:10:04 <chenke> brinzhang
03:10:04 <Sundar> To have focused discussion on V release goals and plans, we could either do it in IRC and etherpads or in openstack-discuss ML. If we do a Zoom call.  or WeChat discussion, they should be posted on IRC or ML. Otherwise, other projects will not have know what we do.
03:10:37 <Sundar> brnzhang, chenke: Agree v1 API can be removed.
03:10:47 <Sundar> brinzhang: ^
03:10:52 <chenke> OK
03:11:16 <brinzhang> Sundar, but in v2 we dont have the deployable, right?
03:11:44 <brinzhang> if we remove now, I think it's too early to do this.
03:11:52 <chenke> https://review.opendev.org/#/c/698190/
03:12:59 <brinzhang> IMO, we should done all things in v2, then to deal with the v1
03:13:01 <Sundar> brinzhang: There is a deployable object in v2, but it means something else than the v1 deployable.
03:13:28 <Sundar> I think we plan to have APIs for patching deployables in v2.
03:14:00 <brinzhang> Sundar: sure
03:14:32 <brinzhang> If all agree to remove now, I am ok too.
03:15:15 <Sundar> brinzhang: I think it is better to remove api/controllers/v1/deployables.py and add api/controllers/v2/deployables.py
03:15:53 <chenke> shogo is doing this
03:16:04 <brinzhang> Sundar: I also agree, but I just think it's earlier
03:16:30 <Sundar> brinzhang: I see. What should we wait for, before we remove the v1 API?
03:16:46 <brinzhang> I think so
03:18:00 <chenke> do you use v1?
03:19:22 <brinzhang> chenke, Sundar: Need a process here, right?
03:19:38 <Yumeng> brinzhang: Brin, if I didn't remember it wrong, we've made an agreement Train version that we make an deprecation anounce and remove the code in U release.
03:21:05 <brinzhang> Yumeng, Ah, if so, I think I missed this message, ignore my comments
03:21:24 <Yumeng> But I forgot where the discussion was happen.
03:21:30 <Sundar> Yes, we followed the process of deprecating in Stein itself and reinforced the deprecation in Train.
03:21:53 <Yumeng> yes, it's safe to remove now. Don't worry.
03:22:17 <Sundar> Yumeng: We have discussed this in IRC before (I need to look up when). But our API docs clearly say v1 is deprecated, both in Stein and Train.
03:23:37 <Yumeng> ok. good that we have announcement!
03:24:18 <brinzhang> Sundar: that should an ML or etherpad to recore this aggrement, otherwise will have different opinion
03:24:47 <Sundar> https://docs.openstack.org/cyborg/stein/admin/api.html
03:24:55 <brinzhang> And we should add that links to the commit message, that reviewer can get more info
03:25:27 <chenke> Ok. I will update message
03:26:34 <brinzhang> Sundar, chenker, Yumeng: ok, we can continue next topic
03:26:36 <Sundar> brinzhang: The above link is published already. I have said this to Nova developers in ML too, not sure when.
03:26:54 <chenke> ok
03:27:12 <Sundar> For example, Sean mooney and others are testing Nova with Cyborg v2. No expectation of v1 support.
03:27:39 <Sundar> #topic PTG
03:28:33 <Sundar> To reinforce what I said: To have focused discussion on V release goals and plans, we could either do it in IRC and etherpads or in openstack-discuss ML. If we do a Zoom call.  or WeChat discussion, they should be posted on IRC or ML. Otherwise, other projects will not have know what we do.
03:29:02 <Sundar> Does anybody disagree?
03:29:31 <xinranwang> We can create a ether pad
03:29:52 <xinranwang> To list the goals
03:31:11 <Sundar> Ok, so everybody agrees to this ^, right?
03:31:19 <Yumeng> agree.  etherpad, zoom are always good.
03:31:31 <brinzhang> agree, wWe can publish content on etherpad regularly
03:31:47 <brinzhang> send that info to ML
03:32:07 <s_shogo> agree.
03:32:22 <Sundar> #agree V release planning process above ^
03:32:33 <Sundar> Thanks, all
03:32:55 <Sundar> Any other topic before I move to Nova and related stuff?
03:33:17 <Yumeng> ^^
03:33:24 <Yumeng> Sundar, xinranwang, chenke: I will abandon this:https://review.opendev.org/#/c/709286/3
03:33:33 <Yumeng> but we still need to update the valid controlpath_id_type values herehttps://github.com/openstack/cyborg/blob/master/cyborg/objects/control_path.py#L26, do you agree?
03:34:07 <Yumeng> we should remove "MDEV" in cureent valid values
03:34:25 <Yumeng> */from
03:34:43 <chenke> Agree
03:34:47 <Yumeng> https://github.com/openstack/cyborg/blob/master/cyborg/objects/control_path.py#L26
03:34:52 <Sundar> Yumeng: agree
03:35:00 <Sundar> to both
03:35:14 <Yumeng> ok. great! will do.
03:35:38 <brinzhang> agree
03:36:13 <xinranwang> Agree
03:37:58 <Yumeng> ok. thanks all!
03:38:29 <Sundar> Ok, on the Nova series: it is a bit mixed news. One patch got merged, one more got +2. But we are still spinning on UT details. Sometimes seems like too much detail or nits.
03:40:00 <Sundar> I was hoping to wrap this up by Feb. I have offers for a next role, but yet to decide. But  I will be moving to a different role in March. So, I am looking to wrap it up one way or the other.
03:41:53 <Yumeng> wow, congrats!
03:41:58 <chenke> Sundar congratulate!
03:44:13 <s_shogo> congrats! >> the merged patch
03:44:25 <Sundar> Thanks, mixed feelings for me, after putting so much effort into Cyborg.
03:45:07 <Sundar> Can one of you volunteer to be an additional PTL after I move on?
03:45:18 <brinzhang> Sundar, congrats! That is a new beginning and it will be brilliant.
03:45:32 <Sundar> Thanks, brinzhang.
03:45:52 <shaohe_feng> So what‘s your next role?
03:46:18 <shaohe_feng> still about cloud related work?
03:46:38 <chenke> Yes, you spend a lot of energy on cyborg, about 16 hours a day. Good luck cares for those who work hard.
03:47:44 <Sundar> Not decided on next role, yes still about cloud,
03:48:19 <Sundar> chenke: I was doing CYborg plus some Kubernetes work till about a month ago
03:48:37 <Sundar> That's why it took long hours
03:49:11 <chenke> Got it.
03:49:13 <xinranwang> Thanks for your great efforts!
03:50:19 <Sundar> Thanks, xinranwang
03:50:45 <Sundar> OK, maybe you all can discuss offline on additional PTL. We still have time.
03:50:50 <Yumeng> Sundar: I can help with the rest work after you move on. But not sure if we need more volunteers. we can discuss the tasks and seperate them.
03:51:32 <shaohe_feng> kubernets is popular in cloud.
03:51:42 <Sundar> Yumeng: Ok. We need to inform the OpenStack Foundation so that they can send all communication to two people, not just me alone.
03:52:30 <Sundar> That's all, folks. Anything else before we wrap up?
03:53:20 <shaohe_feng> can anyone who attend PTG can tell something about Cyborg and Neutron integration?
03:53:59 <shaohe_feng> on smartnic
03:54:11 <shaohe_feng> I have look into it.
03:54:53 <Sundar> shaohe_feng: I have rescinded (cancelled, taken back) my proposals for Cyborg Neutron integ. It would not be easy to drive a 3-way change across Nova, neutron and Cyborg.
03:55:39 <Sundar> The next best approach would be to assume a static programming model, and use Nova to create the resource providers for smart NICs using the provider config (YAML-based) approach.
03:55:41 <shaohe_feng> The neutron Docs tells us, it support a new vif type smartnic
03:56:29 <shaohe_feng> that's means cyborg should not manage these kind of accelerators?
03:57:01 <shaohe_feng> I have  think it how to  support it.
03:57:31 <shaohe_feng> any method, nova can not do many help
03:58:03 <shaohe_feng> some one want to know details about it.
03:58:13 <shaohe_feng> or we can discuss offline
03:58:25 <Sundar> shaohe_feng: First, to my knowledge, most folks do not plan to dynamically program smart NICs, i.e., change its image based on VM type, traffic type, workload, time of day, etc.
03:58:55 <Sundar> Instead they'll do it statically, maybe even offline when no VMs are present and the host is in maintenance mode
03:59:14 <Sundar> The strength of CYborg is dynamic programming.
03:59:16 <shaohe_feng> I know other company will support it. and maybe they are work in progress, not sure they will upstream.
03:59:51 <shaohe_feng> the cyborg is only for program?
03:59:58 <Sundar> Ok, if you have concrete proposals, and plan to follow up with Nova/neutron community, along with other developers, that would be good.
04:00:19 <Sundar> Yea, we can take this offline, or in the next IRC call.
04:00:32 <Sundar> I need to go now. And it is lunch time for you all :)
04:00:40 <shaohe_feng> No, it will do more not only program.
04:00:57 <Sundar> Anything else, folks?
04:01:48 <Yumeng> nothing from me.
04:02:00 <Sundar> Have a good day! Bye for now.
04:02:03 <Sundar> #endmeeting