14:01:21 <shaohe_feng> #startmeeting openstack-cyborg-driver
14:01:22 <openstack> Meeting started Mon May 14 14:01:21 2018 UTC and is due to finish in 60 minutes.  The chair is shaohe_feng. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:26 <openstack> The meeting name has been set to 'openstack_cyborg_driver'
14:01:50 <shaohe_feng> #topic Roll Call
14:02:10 <shaohe_feng> #info shaohe
14:02:20 <xinran__> #info xinran__
14:02:26 <Li_Liu> #Li_Liu
14:02:28 <Helloway> #info Helloway
14:02:31 <Li_Liu> #info Li_Liu
14:03:11 <sundar_> #info Sundar
14:03:12 <shaohe_feng> sundar_: morning.
14:03:23 <sundar_> Good eve, Shaohe
14:03:41 <shaohe_feng> I have create a wiki for driver meeting.
14:03:47 <shaohe_feng> #link https://wiki.openstack.org/wiki/Meetings/CyborgDriverTeamMeeting
14:03:55 <shaohe_feng> sundar_: :)
14:05:01 <sundar_> shaohe: Sounds good. Are HPTS drivers still in plan?
14:05:35 <shaohe_feng> sundar_: not sure. need to check with yumeng
14:06:02 <shaohe_feng> sundar_: will rodrigo will join this meeting?
14:06:03 <sundar_> Who is working on VGPU support in Rocky?
14:06:21 <sundar_> shaohe: I'll ask him
14:07:05 <shaohe_feng> sundar_: need to Volunteer for VGPU
14:07:41 <wangzhh> I'm working on VGPU support. But just cut-through.
14:07:55 <shaohe_feng> sundar_: the meeting frequency, weekly or biweekly? which do you prefer?
14:08:12 <shaohe_feng> wangzhh: good, thanks.
14:08:45 <sundar_> shaohe: Either is fine by me. Probably depends on the work involved. Perhaps we should start with weekly calls, and then move to biweekly
14:09:13 <wangzhh> Agree with sundar_.
14:09:24 <shaohe_feng> OK.  so let start with weekly first.
14:10:03 <sundar_> shaohe: Can you ask folks to review the agent-driver spec?
14:10:10 <dolpher> Next week is the summit time, I guess we need to skip that one?
14:10:30 <shaohe_feng> sundar_: yes. can you put the the link here?
14:10:41 <shaohe_feng> dolpher:  agree.
14:10:58 <dolpher> BTW, who else is attending this meeting? I see Sundar, shaohe, wangzhh
14:10:58 <Li_Liu> Who will go to the summit?
14:11:12 <Li_Liu> <--- me
14:11:17 <sundar_> #link https://review.openstack.org/#/c/561849/ Cyborg agent/driver API spec. Please review
14:11:21 <dolpher> see ya :)
14:11:36 <sundar_> I'll be there too
14:11:55 <wangzhh> I will attend with Jinghua Gao.
14:12:19 <sundar_> rorojo: Rodrigo, you may want to say '#info rorojo' :)
14:12:39 <rorojo> #info rorojo
14:12:57 <shaohe_feng> welcome rorojo
14:13:06 <rorojo> Hi
14:13:16 <shaohe_feng> rorojo is an Intel FPGA experts.
14:13:23 <dolpher> @info dolpher
14:13:23 <Li_Liu> welcome
14:13:34 <dolpher> #info dolpher
14:13:56 <shaohe_feng> OK, let's start our topic.
14:13:58 <shaohe_feng> #topic current status of drivers
14:14:35 <shaohe_feng> Now cyborg support two drivers at present. Intel's FPGA, and SPDK
14:15:09 <shaohe_feng> So cyborg need to support more drivers.
14:15:36 <shaohe_feng> #action wangzhh will help to work on VGPU driver.
14:16:11 <Li_Liu> are there any xilinx folks here?
14:16:37 <shaohe_feng> Yes. any xilinx folks?
14:17:13 <shaohe_feng> they can help on xilinx FPGA driver.
14:17:29 <Li_Liu> I remember chuck and Dutch was attending our regular meetings
14:17:36 <Li_Liu> I will send email to them
14:17:46 <shaohe_feng> thanks Li_Liu
14:18:15 <shaohe_feng> #action Li_Liu will send an email to chuck and Dutch for xilinx FPGA drivers.
14:18:35 <shaohe_feng> for other drivers
14:18:59 <shaohe_feng> any one is working work smart nic, QAT etc?
14:20:19 <shaohe_feng> for intel FPGA driver, rorojo can help to improve it by OPEA API
14:20:21 <sundar_> shaohe: We will be working on enabling a NIC
14:20:40 <rorojo> yes
14:20:52 <shaohe_feng> Great, thanks sundar_
14:21:20 <sundar_> shaohe: rorojo: It will be good to structure our work to go in paralle. Can the OPAE Pyhton API integration go in parallel to driver/agent API changes?
14:21:48 <sundar_> I will help rorojo set up an environment and get started
14:21:56 <shaohe_feng> #action rorojo will improve intel FPGA driver.
14:22:23 <rorojo> Yes, I plan to ramp up on OpenStack this week
14:22:59 <shaohe_feng> great, any problem you an get help here.
14:23:12 <rorojo> thanks :)
14:23:41 <sundar_> shaohe:  Is anybody working on driver/agent API changes?
14:24:22 <shaohe_feng> sundar_: not at present.
14:24:43 <shaohe_feng> sundar_: we need a volunteer there.
14:24:48 <Li_Liu> what's the coresponding spec on that?
14:25:12 <sundar_> #link https://review.openstack.org/#/c/561849/
14:26:09 <shaohe_feng> sundar_: Li_Liu: maybe we need to list all specs, here.  And let's others volunteer to take some task.
14:26:37 <sundar_> #link https://review.openstack.org/#/q/status:open+project:openstack/cyborg All specs
14:27:52 <shaohe_feng> sundar_: you have 3 specs, will you code for all these specs?
14:28:19 <rorojo> sundar: I believe then can go in parallel and they probably should
14:28:38 <shaohe_feng> rorojo: can you give a brief introduce for OPEA API?
14:28:39 <sundar_> shaohe: The os-acc needs Nova changes. Just spoke to Nova folks for their review
14:28:52 <sundar_> For agent/driver API, yes, I can do that
14:28:55 <shaohe_feng> rorojo: The status
14:29:19 <shaohe_feng> Is it ready for cyborg intel fpga driver?
14:29:24 <sundar_> Nova/Cyborg scheduling: I can contribute, but I suspect multiple people will be involved
14:29:46 <rorojo> There is a pull request on github that describes the API
14:30:04 <Li_Liu> let me know if you need help. I prob will be focusing on the spec I wrote first
14:30:25 <rorojo> #link https://github.com/OPAE/opae-sdk/pull/413
14:30:52 <shaohe_feng> rorojo: thanks.
14:31:02 <rorojo> yw
14:31:16 <sundar_> shaohe and all: it may help to define some milestones, right? Shall we say that the first step is just discovery and assignment, which will help us get a basic VM up and running?
14:32:19 <shaohe_feng> sundar_: yes. agree.
14:33:08 <shaohe_feng> zhipengh[m]: ping.
14:33:33 <shaohe_feng> Li_Liu: do you know the code dead line?
14:33:57 <Li_Liu> better ask zhipengh..
14:34:15 <sundar_> shaohe: Good. So, there are three parallel tasks as I see it: driver/agent API changes, invoke update_provider_tree() to publish resources, and enhancements (like OPAE integration, anythine else?)
14:34:26 <Li_Liu> https://releases.openstack.org/rocky/schedule.html
14:34:58 <Li_Liu> Jun 04 - Jun 08 is when ms 2 ends
14:35:12 <Li_Liu> which is 3 weeks from now
14:35:26 <sundar_> Yes, the specs need to be approved by then, IIUC
14:35:30 <Li_Liu> can we as least get the discovery working?
14:35:52 <Li_Liu> I thought the spec should be done by ms1 already
14:36:27 <shaohe_feng> Let do more reviews on spec first.
14:37:11 <sundar_> Li_Liu: I was told that MS-2 is when specs freeze. That  is true for other projects at least
14:37:13 <shaohe_feng> Jul 23 - Jul 27	is Feature freeze.
14:37:21 <Li_Liu> I see
14:37:54 <Li_Liu> but feature freeze doesn't mean spec freeze tho
14:38:07 <Li_Liu> we should start implementation way before that
14:38:35 <Li_Liu> there's only 1 month between feature freeze and Rocky official release...
14:38:47 <sundar_> Li_Liu: Agreed. If we can aim to get discovery done by MS-2, as you suggested, that would be good
14:39:31 <Li_Liu> since unlike scheduling, which involves nova folks, discovery should be totally self contained
14:39:50 <sundar_> Yes
14:40:17 <sundar_> Even scheduling can start a bit earlier: we can update the Nova provider tree without waiting for nRP support
14:40:32 <Li_Liu> yes, agree
14:40:41 <shaohe_feng> agree.
14:41:23 <shaohe_feng> Helloway: are you here?
14:42:06 <Helloway> yes]
14:42:31 <shaohe_feng> you have contributed a spdk driver.
14:42:42 <shaohe_feng> can you give us some introduce about it.
14:45:31 <shaohe_feng> ^ Helloway:
14:45:36 <Helloway> spdk driver can help cyborg to discovery the  resources  about spdk_based app(like nvmf_tgt, iscsi_target)
14:46:06 <sundar_> helloway: Is there any specific hardware for this?
14:46:40 <shaohe_feng> Does it need a REST API?
14:47:03 <Helloway> include the nvme device and subsystems..and more
14:49:00 <sundar_> helloway: So, is the expectation that Cyborg will discover the NVMe device as a PCIe device, and publish its properties as traits in Nova?
14:51:19 <Helloway> currently It does not have rest api?
14:51:32 <Helloway> currently It does not have rest api.
14:52:10 <shaohe_feng> will it report NVME device to placement?
14:53:39 <Helloway> sundar: not local pcie device, maybe it is more like nvme over fabric
14:53:40 <sundar_> My understanding is, SPDK drivers are bit like DPDK poll mode drivers that run in user space. Something else needs to discover the PCI device. Helloway, please confirm if what you have is a user mode SPDK driver
14:55:08 <jiapei> I guess Helloway means something over fabric, through REST API
14:55:35 <jiapei> I'm also interested in this
14:56:08 <sundar_> jiapei: I thought helloway said earlier that there is no REST API for this.
14:56:40 <sundar_> Helloway: Appreciate if you can give us a writeup with some description of what you have and what you want
14:58:44 <shaohe_feng> let start next topic?
14:59:11 <sundar_> What is the conclusion on SPDK and NVMe -- is it in plan for Rocky?
14:59:38 <shaohe_feng> #action improvement on driver
14:59:54 <shaohe_feng> Helloway: any play for Rocky?
15:00:32 <Helloway> ok, sorry I type slowly. I will write something for you guys through the email
15:00:46 <sundar_> I need to join my next call. I'll try to keep an eye on this page.
15:00:52 <Helloway> ok?
15:01:09 <shaohe_feng> Helloway: good, thanks.
15:01:31 <shaohe_feng> sundar_: OK.
15:01:35 <Helloway> thanks :)
15:01:49 <wangzhh> Helloway: Thanks.
15:02:47 <shaohe_feng> now we will support more and more drivers. maybe we need a schema check for different drivers's report info.
15:03:55 <shaohe_feng> And currently we lookup the cyborg specific module path for multi-driver.
15:04:20 <shaohe_feng> should we change it to entry points?
15:05:04 <shaohe_feng> and another improvement for the current drivers?
15:06:19 <shaohe_feng> Li_Liu: oh, we should leverage your new pf/vf implementation to report accelerators info to conductor.
15:06:48 <Li_Liu> yes
15:07:20 <Li_Liu> It should be ready to use
15:07:40 <shaohe_feng> Good. Let's start to change it.
15:07:55 <shaohe_feng> Ok, next topic.
15:08:32 <shaohe_feng> #topic code review
15:08:34 <shaohe_feng> Pending patch: https://review.openstack.org/#/q/status:open+project:openstack/cyborg
15:12:04 <shaohe_feng_> AoB?
15:12:17 <shaohe_feng_> something wrong with my network?
15:12:40 <shaohe_feng_> I rejoin
15:14:28 <shaohe_feng_> okey meeting adjourned
15:14:51 <shaohe_feng_> #endmeeting