14:00:31 <shaohe_feng> #startmeeting openstack-cyborg-driver
14:00:32 <openstack> Meeting started Mon Jul 30 14:00:31 2018 UTC and is due to finish in 60 minutes. The chair is shaohe_feng. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <openstack> The meeting name has been set to 'openstack_cyborg_driver'
14:00:44 <shaohe_feng> #info shaohe_feng
14:00:58 <shaohe_feng> #topic Roll Call
14:01:28 <Sundar> #info Sundar
14:01:46 <wangzhh> #info wangzhh
14:02:21 <Sundar> Hi wangzhh
14:03:01 <Li_Liu> Hi guys
14:03:10 <Sundar> Hi Li Liu
14:03:11 <Li_Liu> Sundar, long time no see
14:03:25 <Sundar> Yes, I was on 2-week vacation
14:03:26 <dolpher_> Hi
14:03:39 <wangzhh> hi Sumdar, long time no see.
14:04:03 <shaohe_feng> Guess you have a happy vacation. :0
14:04:09 <shaohe_feng> :)
14:04:09 <Sundar> wangzhh: Yes :) Just came back from vacation
14:04:19 <Li_Liu> Good for you :)
14:04:21 <Sundar> Hi Shaohe, yes :)
14:04:42 <shaohe_feng> any thing interesting during your vacation?
14:05:19 <shaohe_feng> #link agenda https://wiki.openstack.org/wiki/Meetings/CyborgDriverTeamMeeting#Agenda_for_next_meeting_:_June_30th.2C_2018
14:05:56 <Sundar> I went to the east coast and met my parents/sister after a long time. Travel, lunch/dinner with friends/colleagues, original Indian cuisine, ,...
14:05:56 <shaohe_feng> #topic unify the report info from different drivers
14:06:42 <Sundar> I saw the email about Inspur colleague wanting to contribute
14:07:11 <Sundar> However, Rodrigo is doing mostly the same thing. That's why I had asked if the Inspur person can do something else
14:07:12 <shaohe_feng> Sundar, Indian cuisine, I know curry rice.
14:07:34 <Sundar> shaohe: That's only one of it
14:08:08 <shaohe_feng> Sundar, yes, so anything else Inspur colleague can help?
14:08:42 <Sundar> Of course. We have lots of stuff in the driver/agent and agent/conductor side. That is not Intel-specific.
14:08:58 <shaohe_feng> Sundar, also roti prata
14:09:33 <shaohe_feng> Sundar, seem hongbo is not online
14:09:45 <Sundar> Yes, that too
14:09:50 <shaohe_feng> Sundar, maybe we need to take with him off line.
14:09:59 <Sundar> Sure
14:10:12 <shaohe_feng> now there will be more and more drivers cyborg will support
14:10:44 <shaohe_feng> we had better unify the return info from different drivers.
14:11:03 <Sundar> I think one thing we missed in the spec is that the objects exchanged by the driver and the agent should be Oslo versioned objects (ovo), not plain dictionaries
14:11:27 <shaohe_feng> ^ Sundar, Li_Liu dolpher wangzhh any suggestion on it.
14:11:34 <shaohe_feng> Coco, is working on it.
14:12:22 <Sundar> Coco is working on OVOs for driver/agent API?
14:13:08 <shaohe_feng> Sundar, can your VAN model be used for return data?
14:14:09 <shaohe_feng> Coco, are you available?
14:14:30 <Sundar> Yes, VANs can be used to return data. Are you still referring to driver/agent API? Or the plugins?
14:15:06 <shaohe_feng> driver/agent API
14:15:23 <Sundar> shaohe: BTW, I saw your comments on the os-acc spec. I will reply. I am looking to reconcile with Eric Fied first because that is the larger picture. Changes there can affect the details we are discussing
14:16:09 <Sundar> I pinged efried last week and got a reply. I will try to close the loop with him today and tomorrow, and will update the spec based on that
14:16:11 <shaohe_feng> great, hard work. Thanks.
14:16:51 <Sundar> NP
14:17:04 <shaohe_feng> Sundar, So the VANS can also be used for os-acc and cyborg driver, right?
14:17:19 <Sundar> Yes.
14:17:24 <shaohe_feng> great.
14:18:10 <shaohe_feng> seem Coco is not on line, we can discuss it by mail.
14:18:18 <shaohe_feng> night xinran__
14:18:47 <shaohe_feng> LI_Liu, wangzhh, dolpher any suggestion on this topic?
14:20:26 <shaohe_feng> jiangguocai, evening
14:20:29 <wangzhh> Sorry. I lost connection just now.
14:20:32 <LI_Liu> Regarding the driver/agent API. I don't have much comments, one thing needs to be aware of is to make sure the data structure from driver is understandable by the agent
14:20:36 <shaohe_feng> and welcome.
14:21:06 <LI_Liu> e.g. Physical_Functions/Virtual_Functions
14:21:16 <shaohe_feng> LI_Liu, agree.
14:21:20 <LI_Liu> but not Deployables tho
14:21:25 <wangzhh> Yep. Agree.
14:22:16 <Sundar> Li_Liu: "but not Deployables tho" Can you elaborate on what you mean here?
14:22:28 <jiangguocai> hello everyone
14:22:31 <LI_Liu> Other than that, Driver can do pretty much w/e they feel like to do
14:22:52 <dolpher> Using oslo version object would be part of that? I think using ovo is good
14:23:22 <LI_Liu> Deployable is a data type not exposed to others out side of Cyborg DB/Object
14:23:23 <wangzhh> Do we need extra ovo for driver data structure? I mean could we reuse the exists acc and deployable?
14:24:16 <Sundar> Wangzhh: The existing objects exchanged by driver/agent should be come OVOs. That basically means the fields become well-defined, a version and a namespace get added
14:24:42 <shaohe_feng> and will rebase on LI_Liu's original client.
14:24:45 <Sundar> We could use the same namespace for all driver/agent objects, but whether that should be the same namespace as for os-acc plugin is something we can discuss
14:25:47 <Sundar> Li_Liu: I think you are saying Deployables need not be converted into OVOs. Sounds reasonable,
14:26:00 <Sundar> Sure
14:26:53 <LI_Liu> hmm But Deployable is super class of Physical_Function and Virtual_Functions
14:27:15 <wangzhh> SundarLet me see. Something is different between them,
14:27:22 <shaohe_feng> Sundar, OK, can you send an email or spec to elaborate how driver/agent use VANs?
14:27:36 <wangzhh> I'll add comment later in the spec.
14:28:04 <shaohe_feng> jiangguocai, any things want to talks about the placement.
14:28:50 <Sundar> shaohe: yes, I will expand os-acc spec and driver/agent spec to address that
14:29:02 <shaohe_feng> xinran__, is here. she know well about how placement works during the how process in openstack.
14:29:25 <shaohe_feng> Sundar, good thanks.
14:30:02 <shaohe_feng> any others want to discuss on placement?
14:30:11 <wangzhh> Li liu, we should have a clear name for the acc unit(deployable). Now, we use the deployable which will make user confused.
14:30:33 <LI_Liu> well, I know..
14:31:23 <LI_Liu> But given that we should not let them know at the first place anyways...
14:32:02 <shaohe_feng> #action Sundar will expand os-acc spec and driver/agent spec to address VANs usage
14:33:29 <wangzhh> IMHO, If we had doc to explain it, I think call it deployable is OK. :)
14:33:32 <xinran__> sorry I lost the connection for a while
14:33:53 <Sundar> Li_Liu and wangzhh: trying to understand the discussion here. I think you are saying this: "PF/VF objects are inherited from Deployables, but PF/VFS are exchanged between driver/agent. So, how can we make PF/VFs into OVOs, but not Deployables? " Is this right?
14:34:53 <Coco> #info Coco
14:35:04 <LI_Liu> Yes, that's kinda what we meant
14:35:06 <shaohe_feng> Coco, evening.
14:35:15 <xinran__> jiangguocai: plz feel fee to let us know if you wanna ask something about placement
14:35:24 <xinran__> #info xinran__
14:35:40 <jiangguocai> shaohe_feng: l reviewed your code about placement client. but not called in other code
14:35:56 <LI_Liu> #info Li Liu
14:36:46 <wangzhh> Hi, xinran__, PLZ look at the comment in line. I have the same question.
14:36:56 <Sundar> Li_Liu: The PF/VF stored in the DB will be a different object than the OVO exchanged between drivers/agent for PF/VF. The latter is exposed, the former is Cyborg-internal.
14:37:04 <jiangguocai> shaohe_feng: do you want to design it for a service?
14:37:21 <edleafe> #info Ed Leafe
14:37:28 <shaohe_feng> jiangguocai, no, it just a lib
14:37:30 <wangzhh> Welcome!
14:37:35 <shaohe_feng> morning efried
14:37:54 <efried> shaohe_feng: ō/
14:38:07 <Coco> what's the topic now? can't catch much of your discussion.
14:38:07 <LI_Liu> Sundar: Thank you for the clearification
14:38:08 <efried> We having a meeting?
14:38:31 <xinran__> wangzhh: which comment? Sorry, I just lost the connection...
14:39:27 <wangzhh> https://review.openstack.org/#/c/585146/
14:39:35 <shaohe_feng> edleafe, we have add many amazing features theses days, os-acc, cyborg-client. will be ready for the interaction with nova in next release.
14:39:36 <wangzhh> Here.
14:39:55 <shaohe_feng> edleafe, and we need your help on nova side. :)
14:39:58 <Sundar> efried: yes, this is the Cyborg drivers meeting, which happens Mondays 7 am PDT.
14:40:34 <edleafe> shaohe_feng: My involvement with the Nova project has been greatly reduced. You will probably have more success with efried
14:40:52 <xinran__> wangzhh: let me have a look
14:41:26 <shaohe_feng> edleafe, ok, thanks.
14:42:04 <shaohe_feng> Sundar, have talked with efried on nova interaction?
14:42:44 <Sundar> shaohe: the entire os-acc spec discussion is an extended conversation with efried :)
14:43:05 <shaohe_feng> these days we are so busy, sorry for the delay.
14:44:28 <shaohe_feng> but any one wants to learn more about how placement work during the cyborg/nova interaction. can discuss with xinran__
14:44:54 <Sundar> shaohe: NP.
14:45:01 <Sundar> efried: Saw your reply in the spec. I can explain the Cyborg driver model. Would you be available at 9 am PDT?
14:45:02 <LI_Liu> I have to drop guys. Have a good night/day
14:45:26 <shaohe_feng> LI_Liu, have a good day. Bye.
14:45:35 <wangzhh> Bye, Uncle li.
14:45:49 <efried> Sundar: I.e. 1:15 from now? Yes, wfm.
14:46:22 <shaohe_feng> Coco, you miss the refacor of driver return data. Sundar suggested to use his VANs model. You can discuss it with him about more details.
14:46:28 <jiangguocai> shaohe_feng: for driver to call?can you take a simple for us, thanks
14:46:56 <shaohe_feng> jiangguocai, yes. will come out soon.
14:47:03 <Sundar> Great, efried. I'll catch you on #openstack-nova
14:47:15 <efried> Sundar: Here is probably more appropriate.
14:47:28 <efried> unless it will interrupt something else.
14:47:38 <xinran__> wangzhh: you mean how cyborg report the resource to placement?
14:47:48 <shaohe_feng> jiangguocai, can you discribe your drivers? Let me give you a solution.
14:47:50 <shaohe_feng> here.
14:48:03 <Coco> OK, I will talk with Sundar about more details of the VANs model.
14:48:49 <wangzhh> xinran__, Yes. I want to know the data structure and how we call it.
14:49:40 <shaohe_feng> welcome jiapei
14:50:19 <jiapei> hey, morning Shaohe
14:50:33 <shaohe_feng> wangzhh, do you just pass the physical GPU to VM?
14:50:44 <shaohe_feng> nvdia?
14:50:47 <wangzhh> Yes。
14:51:38 <shaohe_feng> One card is one GPU?
14:52:06 <wangzhh> Yes. No share mode now.
14:52:21 <xinran__> wangzhh: you can check the provider_report in resource_tracker.py
14:54:32 <xinran__> wangzhh: oh sorry these code is not in this patch
14:54:56 <xinran__> wangzhh: let me check and tell you after meeting
14:55:06 <shaohe_feng> wangzhh, that's a not a complex use case.
14:55:09 <wangzhh> OK.
14:55:22 <shaohe_feng> next topic:
14:56:02 <shaohe_feng> #topic Traits and attribution format.
14:57:08 <shaohe_feng> maybe Coco and Sundar should pay a attention on this .
14:57:40 <Sundar> I need to drop off in 3 min. What is this topic about?
14:57:55 <shaohe_feng> if we want to the cyborg pick up the expect accelerators
14:58:24 <shaohe_feng> we should have enough info in the attribution of deployable .
14:59:06 <shaohe_feng> and driver return dates should report them.
14:59:40 <shaohe_feng> so we should add a new fields for the return VANs model?
15:00:46 <shaohe_feng> and if we want to scheduler pick up the right host. we should also report the correct traits.
15:00:59 <Sundar> Not sure I follow. The Cyborg drivers return enough data for the agent to create traits and RPs for that device
15:01:15 <shaohe_feng> Sundar, yes.
15:01:22 <Sundar> Anyways, I'll catch up on this. Please start an email thread on this
15:01:26 <xinran__> wangzhh: device name, rc, trait, total number, these should be passed to placement by calling placement client
15:01:45 <Sundar> Bye for now.
15:01:51 <shaohe_feng> So who will report these infos?
15:02:55 <jiangguocai> shaohe_feng: Ok,I pushed hpts driver tonight,with review 587994. I need to add 'Custom_accelelerator_hpts' and Tairst,acc resource number to novi, can you give me some suggest.
15:02:56 <wangzhh> OK, xinran__, when will you commit the patch about it?
15:03:39 <xinran__> Tmr morning
15:04:22 <wangzhh> Good! Thx.
15:04:31 <shaohe_feng> So let's please make our own tasks go well.
15:04:33 <xinran__> :)
15:04:54 <shaohe_feng> #topic AoB
15:05:10 <shaohe_feng> ^ jiangguocai, wangzhh, Coco
15:05:28 <Coco> shaohe_feng, ?
15:05:54 <shaohe_feng> any things else want to talk?
15:06:15 <wangzhh> Nothing.
15:06:29 <shaohe_feng> OK, if no let's end the meeting.
15:06:39 <shaohe_feng> have a good night, every one.
15:06:42 <shaohe_feng> Bye.
15:06:46 <wangzhh> Bye, everyone.
15:06:59 <shaohe_feng> #endmeeting