14:08:14 <shaohe_feng_> #startmeeting openstack-cyborg-driver
14:08:15 <openstack> Meeting started Mon Aug 6 14:08:14 2018 UTC and is due to finish in 60 minutes. The chair is shaohe_feng_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:08:17 <edleafe> I understand. Many non-native speakers, though, have told me that it is easier for them to type in English than speak it
14:08:20 <openstack> The meeting name has been set to 'openstack_cyborg_driver'
14:11:02 <shaohe_feng_> So let's have the meeting both by zoom and IRC.
14:12:01 <shaohe_feng_> #link https://zoom.us/j/236172152
14:14:20 <shaohe_feng_> edleafe: Many developers think zoom may be more efficient. let's have a try on zoom.
14:15:26 <edleafe> It's fine with me :)
14:17:13 <shaohe_feng_> efried: #link https://zoom.us/j/236172152 Today, coco will introduce her new driver design.
14:17:45 <efried> shaohe_feng_: is this happening right now?
14:18:38 <edleafe> efried: yes
14:26:18 <shaohe_feng_> #link https://etherpad.openstack.org/p/cyborg-rocky-development
15:09:39 <shaohe_feng_> #action sunwill update the spec https://review.openstack.org/#/c/561849/
15:10:00 <shaohe_feng_> #action Sundar will update the spec https://review.openstack.org/#/c/561849/
15:40:47 <shaohe_feng_> How update the DB schema to reflect acc info changes from driver.
15:41:15 <shaohe_feng_> Sunder's suggestions as follow:
15:41:31 <shaohe_feng_> The agent should send the diff to the conductor. The conductor updates the DB and then updates placement. Reasons: * If the conductor does the diff, it can become the scalability bottleneck. The agent needs to store the previous config in local host. * It is more efficient for the agent to make one RPC call than many separate calls once for each deployable, trait etc. The diff include a new acc on line or a exi
15:41:56 <shaohe_feng_> The agent should send the diff to the conductor. The conductor updates the DB and then updates placement. Reasons:
15:42:09 <shaohe_feng_> * If the conductor does the diff, it can become the scalability bottleneck. The agent needs to store the previous config in local host.
15:42:17 <shaohe_feng_> * It is more efficient for the agent to make one RPC call than many separate calls once for each deployable, trait etc.
15:42:37 <shaohe_feng_> The diff include a new acc on line or a exist acc off line?
15:42:52 <shaohe_feng_> Yes. Also, changes to existing devices.
15:42:59 <shaohe_feng_> Then how does agent to present these diff?
15:43:14 <shaohe_feng_> It needs to indicate the list of added devices, the list of deleted ones, and the list of modified ones. How we indicate the modifications to existing devices is open to q. :)
15:43:30 <shaohe_feng_> Yes, modification is more complex than others(add/delete)
15:43:40 <shaohe_feng_> Agreed. That's why I thought it is easier for the conductor to do the diff, because it can compare the db fields, field by field
15:43:50 <shaohe_feng_> But, for the agent to send it, it should send a dictionary that also indicates what got added, deleted or changed for an existing device.
15:43:59 <shaohe_feng_> E.g. a region got programmed, so the function type trait changed. So, the diff must indicate the old function type trait must be deleted, and a new one added
15:58:20 <shaohe_feng_> #endmeeting