15:00:11 <mattmceuen> #startmeeting openstack-helm
15:00:12 <openstack> Meeting started Tue Oct 10 15:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:15 <openstack> The meeting name has been set to 'openstack_helm'
15:00:26 <portdirect> o/
15:00:30 <xek> o/
15:00:31 <mattmceuen> #topic rollcall
15:00:38 <jayahn> o/
15:00:43 <srwilkers> \o/
15:01:02 * portdirect opens another can
15:01:16 <v1k0d3n> o/
15:01:25 <korzen_> hello
15:01:41 <portdirect> hey korzen_
15:03:11 <mattmceuen> Welcome everyone - here's the agenda: https://etherpad.openstack.org/p/openstack-helm-meeting-2017-10-10
15:04:11 <mattmceuen> Ok, here's a big one:
15:04:14 <mattmceuen> #topic OpenStack-Helm soon to be submitted for TC governance
15:04:45 <mattmceuen> So I've been working on wordsmithing a submission to the TC governance repo for OpenStack-Helm
15:05:07 <mattmceuen> Would like y'all's input on the mission statement -- we want something concise and end-goal-oriented
15:05:23 <mattmceuen> "To provide a collection of Helm charts that simply, resiliently, and flexibly deploy OpenStack services on Kubernetes. "
15:05:37 <mattmceuen> ^ is what I cooked up thus far.  Thoughts?
15:05:43 <portdirect> I like it
15:06:22 <mattmceuen> I am 99% sure that flexibly is a real word.
15:06:28 <korzen_> maybe add OpenStack and ifra services?
15:06:36 <korzen_> infra*
15:06:48 <portdirect> S.R.F - openstack-helm's K.I.S.S
15:07:03 <mattmceuen> Good point korzen_, since OSH will include OpenStack-Infra and -Addons
15:07:09 <korzen_> from what I;ve seen OSH is trying to manage infra as well, and kolla-k8s would like to drop the infra burden
15:07:15 <v1k0d3n> mattmceuen: do you think it could be useful to clear up some confusion between OSH and kolla in some page or w/the mission statement somehow?
15:07:19 <mattmceuen> "To provide a collection of Helm charts that simply, resiliently, and flexibly deploy OpenStack and related services on Kubernetes. "
15:07:25 <portdirect> ++
15:07:36 <jayahn> +1
15:07:52 <mattmceuen> Yup - I have a little blurb on that later on in the submission (after the mission statement) - the thing I shot out on Friday @v1k0d3n
15:07:53 <v1k0d3n> there still is a lot of confusion on this. i think a mission statement or project description page could really help with this, and ease developers from having to explain it as the project grows.
15:08:17 <portdirect> I'd like to keep away from comparing us to other projects if possible in the mission statement
15:08:46 <korzen_> we do not need to compare them in mission statement
15:08:49 <srwilkers> yeah, that needs to be kept separate.  the TC can manage the messaging there, as they've pointed it out to me in past discussions about moving OSH into governance
15:08:56 <mattmceuen> +1 to both thoughts.  Mission statement = short, and description of our design philosophy will help clarify as well
15:09:22 <mattmceuen> Cool beans guys - if any more thoughts on this, please let me know in the chat!
15:09:33 <mattmceuen> That was the easy one
15:09:40 <mattmceuen> #topic What release model
15:10:02 <mattmceuen> So
15:10:14 <mattmceuen> The choices are really cycle-trailing or release independent
15:10:45 <mattmceuen> The way I personally think of it is -- I think we aspire to be cycle-trailing, at least in spirit (one OSH release per OpenStack release), but we're not quite there yet.
15:11:21 <portdirect> as we are not an OpenStack project, but an openstack deployment project i think tiing ourselves to the formalised release schedule is gonna be hard.
15:11:45 <portdirect> but we should aim to be as close to cycle-trailing as possible
15:11:48 <jayahn> one thing for sure. openstack-helm does not follow openstack release schedule as a deployment project. we need to "release-aware" in someway though.
15:12:02 <portdirect> yup
15:12:06 <mattmceuen> Is that because of the "two week window to get aligned to the release" window @portdirect, or additional reasons?
15:12:25 <portdirect> yes
15:12:31 <mattmceuen> :-D
15:12:37 <portdirect> there is always fallout as a result of that
15:12:45 <portdirect> so we need to wait for the dust to settle
15:13:26 <portdirect> i think we should aim for it though - but its very easy to become cycle-trailing at any point
15:13:27 <mattmceuen> If we model cycle-trailing as closely as we can as an independent project, I assume there would be opportunity to formally switch over when we're comfortable, right?
15:13:33 <portdirect> much harder to stop being it
15:13:49 <portdirect> yup
15:14:26 <mattmceuen> Cool.  Any other concerns with that plan of record (independent but modeling cycle-trailing for now)?
15:15:11 <srwilkers> nope, i think that's the best path forward
15:15:28 <mattmceuen> What's the convention on hashtag-agreed in a meeting -- do we need to formally rollcall, or "speak now or forever hold your peace"?
15:16:10 <portdirect> there is a vote option somewhere
15:16:24 <portdirect> but I think we are all aligned? v1k0d3n ?
15:17:27 <mattmceuen> Also xek and korzen_ -- if you +1 it as well I'll consider it agreed
15:17:46 <korzen_> I'm ok
15:17:53 <xek> +1
15:18:39 <mattmceuen> ok -- v1k0d3n let us know if you have any thoughts on this in the chat.
15:18:43 <mattmceuen> #agreed OpenStack-Helm will start as an independent project, modeling after cycle-trailing
15:19:01 <mattmceuen> #topic Gate rework
15:19:06 * v1k0d3n reading back...
15:19:11 <mattmceuen> take it pete
15:19:33 <portdirect> so - I've been hammering the gates recently
15:19:56 <v1k0d3n> i want to be clear...no comparing projects. defining what OSH is... (i missed it so backing down and i'll talk it over with mattmceuen later).
15:19:57 <portdirect> and think I've got a pretty good grasp on where your failures have been
15:20:20 <portdirect> you want to go now v1k0d3n ?
15:20:35 <portdirect> I've not really started yet
15:20:48 <mattmceuen> Yeah, go for it, didn't mean to skip ya man
15:21:54 <mattmceuen> v1k0d3n -- agree, I'm going to leave project comparisons out of the mission statement
15:22:46 <mattmceuen> portdirect the floor is yours
15:22:50 <v1k0d3n> no it's cool. sorry was pulled in different directions at once. had someone in my cube. 1). we're aligned on releases...
15:23:07 <mattmceuen> v1k0d3n awesome :)
15:23:17 <v1k0d3n> 2). mission statement and description page of project should never make comparisons to other projects. that's shady...
15:23:54 <v1k0d3n> but defining one's self is perfectly acceptable. selling it is acceptable. this helps by default, and allows people to draw their own conclusions based on their needs.
15:24:37 <v1k0d3n> that's all. sorry to bring things back. not intentional at all.
15:24:43 <v1k0d3n> :(
15:24:43 <mattmceuen> Here's what I did say in the (post-mission statement) writeup: A number of OpenStack deployment projects pave the way for OpenStack-Helm, including OpenStack Ansible[3], Kolla-Kubernetes[4], and Puppet OpenStack [5]. OpenStack-Helm occupies a unique space in its exclusive use of Kubernetes-native constructs during the deployment process, including Helm packaging and gotpl templating.  This tradeoff enables it to be as
15:24:43 <mattmceuen> lightweight and simple as possible, at the expense of operator choice of deployment toolsets.  The project team is eager to work with other OpenStack deployment projects to solve common needs and share learnings.
15:25:26 <mattmceuen> No worries v1k0d3n
15:25:28 <mattmceuen> #topic Gate rework
15:25:41 <portdirect> like it - though we stole the endpoints lookup from the chef cookbooks
15:25:53 <portdirect> so they should get a shout too ;D
15:25:59 <mattmceuen> WIll do, good catch :)
15:26:19 <portdirect> so and think I've got a pretty good grasp on where our failures have been
15:26:38 <portdirect> and have reworked the kubeadm to be a lot more robust
15:26:59 <portdirect> it now just installs kube on the hosts - and we dont run the kubelet in a container
15:27:19 <portdirect> its still a wip as I've not added the node join login in
15:27:21 <portdirect> or docs
15:27:34 <portdirect> but would be great to get some feedback at this stage
15:27:48 <portdirect> https://review.openstack.org/#/c/509985/
15:27:52 <mattmceuen> oh interesting.  Thanks for the info - will do
15:28:22 <mattmceuen> Looking forward to that.
15:28:30 <portdirect> once this is tidyed up - i'll get back on the zuulv3 ps
15:28:43 <portdirect> and get ceph sorted in that
15:28:56 <portdirect> for this i propose two changes:
15:29:10 <portdirect> 1) in aio mode - use the docker0 interface for everything
15:29:16 <korzen_> would it be able to work on RBAC in gates? meaning that kubeadm docker was applying the RBAC open rules and how disable the open rule when working on RBAC per service rules
15:29:32 <portdirect> korzen_: they are now moved outside of the aio :)
15:29:49 <korzen_> ok nice :) sorry for interupting
15:29:52 <alraddarla> o/ (sorry i'm late)
15:30:06 <portdirect> all good - line 51: https://review.openstack.org/#/c/509985/55/tools/gate/setup_gate.sh
15:30:38 <portdirect> 2) in multinode set the cidr to 0.0.0.0/0
15:31:13 <portdirect> the logic behind using docker0 for aio is partly to help devs using the gate scripts to bring up osh on their laptops
15:31:22 <portdirect> as it will allow them to walk around again :D
15:31:28 <mattmceuen> +1
15:31:42 <portdirect> also by moving the kube deploy to a 'real' one
15:31:53 <portdirect> I'd lik to get the gates rebooting the nodes
15:32:05 <portdirect> and ensuring that all services come back up correctly
15:32:12 <korzen_> also question about ceph subnet_range and issue with /32 IPs in OVH datacenter
15:32:13 <portdirect> though this would add about 15mins to a run
15:32:35 <portdirect> korzen_: I think if we swap out any 32's with 24 this should fix a lot of the gate failures we've seen?
15:32:49 <portdirect> could just be a simple sed in the legacy secripts?
15:33:10 <korzen_> should be ok, but I did not have tested it yet
15:33:26 <portdirect> I could put a ps in for it - unless you have time before calling it a day?
15:33:48 <korzen_> I can take a look with PS
15:33:53 <mattmceuen> portdirect my 2 cents is that 15mins is well worth it
15:34:34 <portdirect> mattmceuen: part of the resiliently you mentioned above?
15:34:44 <portdirect> korzen_: thanks dude that would be awesome
15:34:55 <mattmceuen> Definitely
15:34:58 <portdirect> ok - I'm done i think
15:35:08 <mattmceuen> excellent, thanks pete
15:35:30 <mattmceuen> #topic Review needed
15:35:58 <mattmceuen> portdirect already mentioned https://review.openstack.org/#/c/509985/
15:36:51 <mattmceuen> https://review.openstack.org/#/c/508932/ <- some tweaks for using nfs in the gate scripts
15:38:21 <korzen_> neutron's tunnel logic again ;)
15:38:52 <portdirect> korzen_: never a dull moment with that :)
15:38:59 <mattmceuen> That's this one, right korzen_? https://review.openstack.org/#/c/510906/
15:39:09 <korzen_> yep
15:40:07 <mattmceuen> Any others we need eyeballs on?
15:40:45 <korzen_> https://review.openstack.org/510541 we have updated the entrypoint to use new image
15:41:14 <korzen_> kubernetes-entrypoint with cross namespace dependencies checking
15:41:48 <mattmceuen> Thats awesome korzen_!
15:42:22 <korzen_> the second step is to work on passing the namespace from OSH to k8s-entrypoint
15:43:01 <korzen_> https://review.openstack.org/#/c/510810/3 still a WIP debugging the issues
15:43:43 <korzen_> we will continue tomorrow
15:43:53 <renmak__> This PS could use some reviews please. Few other US are dependent on getting this PS merge.
15:43:53 <renmak__> Ceph OSD disk targeting (Ceph 1 OSD per POD)
15:43:53 <renmak__> https://review.openstack.org/#/c/457754/
15:45:13 <mattmceuen> Thanks renmak_. Will take a look.
15:45:25 <mattmceuen> Any others?
15:45:32 <portdirect> renmak__: will d
15:45:33 <portdirect> o
15:45:40 <mattmceuen> #topic open discussion
15:46:24 <mattmceuen> Other thoughts as we seek Official status and the Sydney summit approaches?
15:46:45 <mattmceuen> For one -- we're working to put together another hands-on OSH install workshop like we did in Boston
15:47:21 <jayahn> if there is anything we can help on that. pls let us know
15:47:34 <mattmceuen> Hope to attract more interest in, and contributors to our project
15:48:28 * jayahn btw, can someone introduce mattmceuen to me? :) I have been away for 10 days, and it seems something around here has changed. ;)
15:48:58 <mattmceuen> :-)
15:49:43 <mattmceuen> Hey jayahn, srwilkers has passed the torch to me
15:50:01 <mattmceuen> 10 days is a long time
15:50:02 <jayahn> we can add short version of our story to attract more interest. i am happy to discuss/help workshop agenda.
15:50:19 <jayahn> yeap. it is long time. i almost forgot what i was working on.
15:50:22 <korzen_> jayahn, and we have moved from OpenStack to AWS ;)
15:50:23 <jayahn> ;0
15:50:26 <srwilkers> you should show off your amazon echo stuff jayahn
15:50:33 <mattmceuen> would definitely appreciate that jayahn
15:50:45 <jayahn> okay. i can do that. :)
15:50:59 <srwilkers> also jayahn, mattmceuen will also happily drink beer with you in sydney and talk about austin :)
15:51:01 <mattmceuen> we want to make it engaging for new users, and would love to include you on that if you're interested
15:51:05 <mattmceuen> fact
15:51:09 <jayahn> it is aligned to we moving to aws. korzen_ :)
15:51:15 <srwilkers> sadly i will not be there
15:51:26 * srwilkers isn't so sad to miss that flight ;)
15:51:40 <jayahn> four of us will be there from skt.
15:52:12 <mattmceuen> that's great to hear - we will definitely sync up while we're there
15:52:50 <mattmceuen> Any other topics guys?
15:53:09 <mattmceuen> Alright -- see you in the chat room.  Thanks!
15:53:29 <mattmceuen> #endmeeting