15:01:00 <mattmceuen> #startmeeting openstack-helm
15:01:01 <openstack> Meeting started Tue Oct 24 15:01:00 2017 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <openstack> The meeting name has been set to 'openstack_helm'
15:01:09 <mattmceuen> GM/GE everyone!
15:01:13 <srwilkers> o/
15:01:38 <alraddarla> o/
15:01:39 <mattmceuen> here's the agenda -- please take a moment to update w/ anything you'd like to discuss today  https://etherpad.openstack.org/p/openstack-helm-meeting-2017-10-24
15:01:54 <mattmceuen> #topic rollcal
15:01:58 <mattmceuen> #topic rollcall
15:02:46 <portdirect> o/
15:02:59 <alraddarla> o/
15:03:06 <srwilkers> o/
15:03:40 <mateuszb> o/
15:04:12 <jayahn> o/
15:04:29 <mattmceuen> #topic update to official project status
15:04:42 <mattmceuen> The update to the status is that the project is official :)
15:04:56 <jayahn> great!!!
15:05:21 <mattmceuen> Congrats everyone - this is going to be a great opportunity to get more folks using and contributing to our project
15:05:26 <raymaika> \o/
15:05:30 <mateuszb> :)
15:06:09 <mattmceuen> on the coattails fo that:
15:06:15 <mattmceuen> #topic who is going to sydney
15:06:35 <mattmceuen> Sydney will be a good opportunity to make folks aware of OSH as well
15:07:01 * portdirect tries to set topic to "whos coming back from sydney"
15:07:15 <mattmceuen> https://www.irccloud.com/pastebin/jXdjNFjI/
15:07:39 <mattmceuen> jayahn who is the +3?
15:08:14 <jayahn> seungkyu ahn, robert (our ci guy), and one network guy
15:08:27 <mattmceuen> awesome
15:08:45 <portdirect> staceyf is going as well
15:09:09 <portdirect> and bomman from juniper
15:09:45 <lrensing> o/
15:09:46 <jayahn> this would be great at sydney
15:09:57 <mattmceuen> Madhukar from Juniper will be there too
15:09:59 * jayahn who wants to do sky diving with us?
15:10:12 <portdirect> jayahn: when?
15:10:24 <jayahn> we are targeting sunday
15:10:38 <portdirect> jayahn: before?
15:10:50 <jayahn> portdirect: good point
15:10:51 <portdirect> if so I'll need to check when my flight gets in :D
15:11:11 <mattmceuen> #topics summit talks of note
15:11:25 <jayahn> it will be good discussion with staceyf since we are trying to do basic HA test automated in ci pipeline
15:11:47 <mattmceuen> I won't paste them here -- if anyone has any talks they think would be relevant to OSH folks, please add them into the etherpad!  https://etherpad.openstack.org/p/openstack-helm-meeting-2017-10-24
15:12:01 <mattmceuen> jayahn: yes definitely
15:12:31 <jayahn> at&t keynote in the morning will mention osh?
15:12:50 <mattmceuen> We'll see :)
15:13:12 <jayahn> pls put a work "skt" in your keynote.. :)
15:13:30 <mattmceuen> Just run up on stage jayahn
15:13:40 <jayahn> i can do that :)
15:13:48 * srwilkers imagines jayahn pulling a kanye west
15:14:49 <mattmceuen> #topic Log-based metrics
15:14:53 <jayahn> okay, community meeting. need to be a bit more serious
15:14:57 <mattmceuen> The floor is yours mateuszb!
15:15:19 <mattmceuen> log-based metrics is a serious topic
15:15:24 <mateuszb> Ok thanks
15:15:26 <mateuszb> https://review.openstack.org/#/c/514655/
15:15:42 <mateuszb> I prepared a PS with the demonstration of fluent-prometheus plugin for log-based metrics purposes. @srwilkers - may I ask you to please take look at it to see if it's heading toward a good direction? There's a detailed description in PS's comment.
15:16:11 <srwilkers> mateuszb: definitely
15:16:34 <jayahn> i really would like to suggest to separate our logging effort into several steps
15:16:55 <jayahn> it seems like we are thining too much in one shot
15:17:27 <v1k0d3n> o/ sorry late this morning.
15:17:32 <mateuszb> @srwilers thank you. @jayahn for example?
15:17:40 <mateuszb> IMO the scope is minimal - I may only separate a Docker image from the PS. Apart from that I don't even touch integration with nagios and alarms. It just presents the simplest use case of prometheus-fluent plugin
15:18:32 <jayahn> there will be more discussion and several ways of implementing alerts. we can totally do that after we first get "fluentbit-fluentd" gathering pipeline done
15:19:35 <mateuszb> Sure, I don't want to push the change together with fluentbit-fluentd
15:20:13 <mateuszb> My PS is done on top of fluentbit-fluentd and I assume it will be merged only after fluentbit work is done
15:20:30 <jayahn> i know. i was happy to see your ps.
15:21:30 <mateuszb> Cool. I also wanted to make sure @jayahn you accept the usage of fluent-prometheus plugin. Last time you talked about writing our own plugin for fluent-bit but I don't know anyone willing to do that :)
15:22:48 <jayahn> i was not suggesting we must develop our own plugin, i was presenting that idea just to back-up my reasoning of doing alert on either on edge or on log store.
15:22:55 <jayahn> :)
15:23:22 <mattmceuen> ah gotcha.
15:23:40 <mateuszb> Ok. btw @jayahn how about alarms definitions?
15:24:18 <jayahn> i am preparing that right now. i can probably upload the first ps at the beginning of next week
15:24:29 <mateuszb> awesome
15:25:25 <mateuszb> I have seen you asked @srwilers about a reference implementation for alerting system. Is anything established in this matter?
15:25:30 <jayahn> btw, we all agree on this >> https://review.openstack.org/#/c/507023  moving fluent-logging from openstack-helm addons to openstack-helm repo
15:25:48 <mattmceuen> great
15:25:48 <mattmceuen> Anything else we can hash through on that one, mateuszb?
15:26:23 <jayahn> mateuszb: not really. we might need to setup some separate meeting (probably web-conference) for that topic
15:26:40 <mateuszb> @jayahn yes, once it's moved I'll also move my PS
15:26:44 <mateuszb> ok
15:26:59 <mateuszb> that's all from my side :)
15:27:06 <mattmceuen> (please disregard me, was having some connectivity issues and missed your messages :) )
15:27:13 <mattmceuen> ok cool
15:27:20 <mattmceuen> thanks mateuszb
15:27:37 <mattmceuen> #topic Nova placement service
15:27:49 <jayahn> pls review it.
15:27:55 <mattmceuen> This PS was getting some discussion in the etherpad, thought I'd bring it here
15:28:28 <jayahn> my quesiton would be not limited to nova placement
15:28:47 <jayahn> as portdirect wrote on etherpad, i have listed things we need to do for ocata.
15:29:27 <jayahn> getting these done would be not difficult, however, then gating should have a separate ocata build
15:29:44 <portdirect> jayahn: +2 to that
15:29:49 <mattmceuen> agree
15:29:51 <jayahn> what is our plan on completely switching to ocata
15:29:57 <portdirect> can you have a look at the gate work ive been doing in osh-infra
15:30:30 <jayahn> portdirct: i can ask our ci guy to look at the gate work
15:30:55 <mattmceuen> Re: when is our plan to completely switch to ocata -- once we get Newton done :)
15:31:04 <mattmceuen> And we're getting close
15:31:14 <mattmceuen> But still more work to be done
15:31:33 <mattmceuen> I'd like to work to "catch up" to master over time
15:32:22 <jayahn> then, i would like to have "the list" stating what means done. (we probably had similar discussion on ptg, but i think we just need to have more concrete "task list" for this)
15:32:56 <mattmceuen> Good idea.
15:33:03 <portdirect> Would we not want to move to master?
15:33:14 <mattmceuen> #action Matt will work on a consolidated task list for OSH Newton
15:33:19 <portdirect> and have a gate for each of the releases leading from netwon to that?
15:33:55 <jayahn> i am sure we definitely want to move to master.
15:34:40 <srwilkers> portdirect: that would be ideal
15:35:53 <mattmceuen> #topic Review Needed
15:36:11 <mattmceuen> Jay already brought up     https://review.openstack.org/#/c/493422/
15:36:59 <mattmceuen> Anyone patiently waiting for reviews that could use a nudge?
15:38:13 <jayahn> okay, then we need to have a stair to heaven - steps we would like to take from current state (newton) to ideal state (catching up master)
15:39:10 <mattmceuen> Agree.  Along with an understanding of which releases our users are most interested in
15:39:19 <mattmceuen> (and when-ish)
15:40:35 <mattmceuen> And again - hopefully we'll be getting a lot more users, and hence a lot more input soon :)
15:41:22 <mattmceuen> #topic Open Discussion
15:41:26 <jayahn> since we just started seeing EOL on newton discussion on mailing-list, probably we need to move up to more recent release soon
15:41:58 <alanmeadows> I have no doubt we can fast follow a 1.0 newton release with the next
15:42:01 <mattmceuen> +1
15:42:29 <alanmeadows> in really short order given the latest handling of config templates
15:42:50 <alanmeadows> I think the only thing we are waiting for is an official cut of newton
15:43:15 <portdirect> and that mostly releys on moving things to the correct repos
15:43:21 <portdirect> *relies
15:45:33 <mattmceuen> portdirect:  is your thought that we'd branch OSH repo per-release, but have OSH-Infra for example usable by multiple OSH versions?  Or am I reading in too much?
15:46:08 * jayahn i think i am doing really good after four pints of beer and three Tequila shots
15:46:13 <portdirect> def +2 to the latter
15:46:41 <portdirect> I hope we could do the former via overrrides, which would not require a branch
15:46:47 <mattmceuen> jayahn the next OS Summit needs to be in South Korea, that's all I know :-D
15:47:04 <portdirect> so a version of osh, could work with multiple versions of OS
15:47:12 <portdirect> but I need to think about this more
15:47:15 <mattmceuen> ahh
15:47:53 <jayahn> hm.. multiple versions of openstack can be done only via overrides. that would be ideal.
15:48:06 <jayahn> but, as portdirect said, we probably need to think a bit more.
15:49:04 <mattmceuen> Any other topics you all would like to discuss?
15:50:00 <mattmceuen> Hey @renmak__ :)
15:50:10 <renmak__> Hey Matt
15:50:13 <renmak__> Just joined in
15:50:34 <mattmceuen> Just in time - unless you have any roundtable, I think we're ready to call it a meeting!
15:50:54 <renmak__> Yeah one thing.
15:51:03 <mattmceuen> go for it
15:51:12 <renmak__> Looking for more feedback on this PS
15:51:13 <renmak__> https://review.openstack.org/#/c/457754/
15:51:19 <renmak__> This is for Ceph OSD per POD
15:51:35 <renmak__> It needs to be reviewed and merge. Few other US are depending on this change.
15:51:57 <renmak__> So it would be great if folks take some time and provide feedback on this PS
15:52:16 <mattmceuen> Agree - let's try to round this out this week if possible
15:53:55 <renmak__> That's all
15:54:13 <mattmceuen> Ok, thanks team - good meeting.  Have a great day (and go lay down jayahn :) )
15:54:16 <mattmceuen> #endmeeting