15:04:22 <mattmceuen> #startmeeting openstack-helm
15:04:23 <openstack> Meeting started Tue Nov 21 15:04:22 2017 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:26 <openstack> The meeting name has been set to 'openstack_helm'
15:05:48 <srwilkers> o/
15:06:08 <lamt> \o
15:06:11 <mattmceuen> #topic rollcall
15:06:18 <srwilkers> o/
15:06:31 <lamt> \o
15:06:39 <mattmceuen> Sorry for the late start guys, US time change took my calendar by surprise :)
15:06:44 <mattmceuen> https://etherpad.openstack.org/p/openstack-helm-meeting-2017-11-21
15:06:57 <portdirect> \o\
15:06:58 <mattmceuen> ^agenda -- please go ahead and add anything you'd like to discuss today!
15:10:00 <mattmceuen> also a holiday week in the US, so we may be missing a few familiar faces
15:11:12 <mattmceuen> #topic Summit highlights for OpenStack-Helm
15:11:52 <mattmceuen> Alright -- so a few notes we should share about the summit of interest to the OSH crew
15:12:10 <mattmceuen> First, we sure did get Keynote mention, with some live demo goodness
15:12:41 <mattmceuen> #action mattmceuen will get links into the meeting notes
15:13:26 <mattmceuen> There were several talks either directly or tangentially related to OSH
15:13:40 <portdirect> overall feedback was very +ve i felt
15:13:46 <jayahn> o/  sorry, late.
15:14:05 <mattmceuen> portdirect, alanmeadows, & bommen gave a talk on OSH, which was really my favorite talk from the summit period
15:14:10 <portdirect> I spoke to a couple of folks who are planning on moving their production workloads to osh
15:14:14 <mattmceuen> Definitely recommend that one
15:14:34 <mattmceuen> that's fantastic.
15:15:16 <jayahn> I was able to talk with sprint, orange, nec at lcoo working group meeting. they were so positive on osh.
15:16:01 <portdirect> thats awesome jayahn - we should start a support company ;)
15:16:08 <jayahn> and, skt had a presentation on kubespray and openstack-helm. :)
15:16:20 * jayahn that is my big plan b.
15:16:33 <srwilkers> :D
15:16:47 <mattmceuen> Hey now don't anyone stop developing :)
15:17:09 <mattmceuen> We need something to be supported after all!
15:17:28 <mattmceuen> We also had a great OSH workshop session
15:17:39 <jayahn> that is why it is plan b. we need plan a >> make everyone use osh.
15:17:49 <jayahn> workshop was fantastic.
15:18:03 <mattmceuen> me agrees with plan a 100% :)
15:18:13 <portdirect> plan c - sit by the pool drinking tequila
15:18:25 <mattmceuen> I feel like these plans area actually sequential
15:18:37 <mattmceuen> Can't spell today, with this meeting a whole hour earlier
15:18:38 <portdirect> the workshop was great for a few reasons
15:19:11 <portdirect> 1) it tested out the new dev env I've been working on  which deployed 150 machines with a single provision failure
15:19:39 <portdirect> 2) it then deployed osh about ~125 times on top of that without a single failure
15:19:48 <portdirect> 3) there were cat pictures
15:20:22 <mattmceuen> Does it count as the cat pic going viral if we are copying it via automation?
15:20:29 <portdirect> https://imgflip.com/s/meme/Cute-Cat.jpg
15:20:51 <mattmceuen> Really great job on all the prep work portdirect
15:21:36 <portdirect> I was wondering - should we rework the dev env docs to use a version of the scripts we developed for this?
15:21:37 <mattmceuen> For anyone who'd like to play along at home:  https://github.com/portdirect/sydney-workshop
15:21:59 <mattmceuen> I think so
15:22:04 <srwilkers> portdirect: yes
15:22:25 <mattmceuen> Let's get reuse out of this - made for a very educational experience, and goes a few steps farther than the dev docs to date
15:22:36 <mattmceuen> e.g. cat picture
15:22:39 <portdirect> cool - I can try to get that going this week - and I also need to document the `infra` work thats been ging on too
15:23:57 <lamt> portdirect I started a ps for the doc work https://review.openstack.org/#/c/521370/ - will submit the ps to remove the legacy multinode gate from infra today
15:24:29 <mattmceuen> awesome - if there's anything any new OSH developers can do to help with that work, portdirect, might be a good opportunity for them
15:24:40 <portdirect> lamt: thats awesome!
15:25:02 <mattmceuen> nice, thanks lamt!
15:25:15 <portdirect> mattmceuen: agreed - getting new folks writing the docs is awesome - they ask the right questions!
15:25:40 <mattmceuen> Speaking of which - we had an OSH project onboarding session as well :)
15:25:52 <mattmceuen> at the summit.  Went quite well.
15:26:19 <mattmceuen> Do we happen to have any new folks interested in OSH joining us today?  If so, welcome!
15:27:20 <v1k0d3n> o/ sorry late
15:27:41 <mattmceuen> hey v2k0d3n no worries, you're in good company!
15:27:48 <mattmceuen> v1k0d3n
15:27:55 <mattmceuen> didn't mean to upgrade you
15:28:14 * srwilkers resists the urge to make a joke
15:28:14 <portdirect> hes got laser vision now
15:28:49 * jayahn ditto with srwilkers
15:28:57 * portdirect failed
15:29:09 <srwilkers> and you didnt even fail fast
15:29:11 <srwilkers> you're so outdated
15:29:19 <portdirect> i did shift left
15:29:39 <mattmceuen> that's shift-tab, right?
15:29:49 <mattmceuen> #topic V3 Gate/Dev env in infra is done - now we just need docs
15:29:59 <mattmceuen> I will get portdirect back on topic by giving him the stick
15:30:11 * portdirect ohhh errr
15:30:32 <portdirect> so the gate in infra is pretty solid now i hope
15:30:44 <portdirect> lamt and some others are using it for local dev as well
15:31:27 <portdirect> it does away with the old kubeadm-aio and its continerised kubelet and replaces it with a pretty (I hope) solid set of ansible roles
15:31:58 <portdirect> that sets up a k8s cluster with some services deployed as charts - dns, tiller etc
15:32:11 <portdirect> tin has been working on the docs here:
15:32:21 <portdirect> https://review.openstack.org/#/c/521895/
15:32:41 <portdirect> which so how to use the makefile to simply setup a dev env
15:33:01 <portdirect> we have also been working on pulling this into osh itself
15:33:23 <portdirect> https://review.openstack.org/#/c/516450/
15:33:29 <srwilkers> https://review.openstack.org/#/c/521370/1 is the right doc link
15:33:36 <portdirect> whoops
15:33:40 <portdirect> cheers srwilkers
15:33:57 <portdirect> the work to use this in osh is close - we just need to publish logs
15:34:07 <mattmceuen> fantastic
15:34:19 <portdirect> and then can start to retire the oiginal gate scripts i hope
15:34:37 <lamt> \o/
15:34:54 <portdirect> the primary advantage the new work brings is that we can use an `armada` liek format to instantiate charts - and test upgrades
15:35:16 * portdirect eg: https://github.com/openstack/openstack-helm-infra/blob/master/tools/gate/chart-deploys/default.yaml
15:35:46 <portdirect> meaning we can test many more combos that we did previously - and also address some big gaps we had
15:35:52 <portdirect> 1) upgrade testing
15:36:00 <portdirect> 2) node/cluster reboot
15:36:20 <mattmceuen> So right now, the new OSH gate scripts delegate to the (updated) existing setup_gate.sh.  Are you saying that script would be retired, or just the old invocation of that script?
15:36:43 <mattmceuen> (by right now, I mean right now in your and lamt's new PS)
15:36:51 <portdirect> when possible the old scripts would be totally retired
15:37:02 <portdirect> but I think we need to move there gradually
15:37:04 <mattmceuen> gotcha.  I like the migration path.
15:37:12 <portdirect> ++
15:37:30 <portdirect> this work also needs to go hand in hand with updating the docs
15:38:00 <portdirect> so that we smoothy retire the original kubeadm-aio
15:38:29 <portdirect> it would be good to get an idea of how many people are using that outside of att at present
15:38:45 <portdirect> are you folks jayahn ? v1k0d3n ?
15:39:37 <v1k0d3n> using what, armada or kubeadm-aio?
15:39:43 <v1k0d3n> sorry, was distracted.
15:39:51 * v1k0d3n reads back
15:39:54 <portdirect> the current kubeadm-aio
15:40:04 <v1k0d3n> haven't touched it in a while.
15:40:11 <jayahn> we are not using the current kubeadm-aio
15:40:34 <portdirect> nice - what are you guys using? bootkube v1k0d3n ?
15:40:34 <v1k0d3n> bootkube projects only. although will look at kubeadm self-hosted at some point...but it's a mess in it's current state.
15:41:05 <v1k0d3n> bootkube as a base. starting a custom deployment projects around self-hosted concepts.
15:41:18 <jayahn> we are all kubespray here in skt
15:41:49 <portdirect> awesome
15:42:07 <portdirect> one of the things we added with the new work was a `make dev-deploy charts`
15:42:15 <portdirect> that should work with any k8s env
15:42:24 <jayahn> although we have some plan to get serious with osh gate tools.
15:42:32 <portdirect> w00t :)
15:42:33 <jayahn> okay. good to know. :)
15:43:01 <mattmceuen> #topic default docker version
15:43:13 <mattmceuen> all you srwilkers
15:44:21 <srwilkers> just wanted to point out that the default docker version for ubuntu is 1.13, which caused some issues with k8s <1.8 if i recall.  portdirect mentioned a patchset that lamt has in flight for using whats in the gates as the version we pin to, which makes this a nonissue i think
15:44:49 <srwilkers> that's all really
15:44:58 <mattmceuen> Excellent.  Here's the RFC so y'all can C:  https://review.openstack.org/#/c/521233/
15:45:04 <srwilkers> was going to mention it in the docs, but the docs rework already covers it
15:45:20 <mattmceuen> #topic reviews needed
15:45:31 <mattmceuen> So - the summit got us a bit behind
15:45:58 <mattmceuen> also some vacation, and we're entering the holiday season for some of us
15:46:03 <srwilkers> just in time for the holidays to let us play catch up :)
15:46:21 <v1k0d3n> nice work portdirect on keeping the kube env agnostic.
15:46:25 <mattmceuen> Yeah, some folks will probably do more reviews over the holidays rather than less :-D
15:46:41 * srwilkers is guilty
15:46:42 <mattmceuen> But we def need a concerted effort to catch up & clean up our backlog of WIP
15:47:13 <mattmceuen> In the meantime:  any PS that need eyes sooner than later, or are stuck and anyone present would like to call out?
15:47:38 <mattmceuen> As mentioned, tlams RFC:  https://review.openstack.org/#/c/521233/
15:47:44 <srwilkers> im going to review the fluent-logging stuff after this -- vacation took me away, and the hotel wifi was a bit dodgy
15:47:53 <srwilkers> but think that's just a matter of getting the rbac stuff tied in
15:48:01 <mattmceuen> And to get the gate work completed: https://review.openstack.org/#/c/521895/
15:48:10 <jayahn> I think I am officially good at forking cores.
15:48:15 <jayahn> :)
15:48:31 <srwilkers> i've got a few changes to make to https://review.openstack.org/#/c/517645/, then will be ready for a proper review
15:48:49 <jayahn> srwilkers: fluent-logging stuff is okay, but we are having some probleme with fluent-bit - fluentd version matching.
15:49:03 <srwilkers> hmm
15:49:23 <jayahn> we will probably need to be away from kolla-image, and using official fluent images.
15:49:38 <srwilkers> jayahn: right.  that's been an issue with their non-openstack images for awhile
15:49:40 <jayahn> chart itself is okay and working :)
15:49:42 <srwilkers> ES was the same way I think
15:50:01 <portdirect> a lot of the outstanding reviews are to do with opencontrail - mattmceuen can we invite them to the next meeting to ensure we get a good strategy in place
15:50:05 <mattmceuen> OH
15:50:38 <portdirect> would a be good tie in to our first ci/cd focused meeting
15:50:43 <srwilkers> ++
15:50:46 <jayahn> ++
15:51:17 <v1k0d3n> ++
15:51:27 <mattmceuen> portdirect:  yep
15:51:28 <v1k0d3n> and this is something we would really like to be included in
15:51:59 <mattmceuen> cool beans v1k0d3n will do
15:52:19 <v1k0d3n> we're doing a lot of work around CI/CD, although we're taking a bit of a different approach. and on the opencontrail bits...we're trying really hard to work with juniper on this as well.
15:52:28 <mattmceuen> #topic open discussion
15:52:46 <jayahn> does anyone go to kubecon?
15:52:52 <v1k0d3n> i know some discussions are happening with skt and att on ci, but if there are meetings that could be open...it would really help us as well.
15:52:55 <srwilkers> jayahn: yeah, ill be there
15:53:01 <v1k0d3n> yes, we have 3 coming to kubecon.
15:53:14 <srwilkers> v1k0d3n: as far as im aware, the meetings mentioned would be part of the OSH community meeting
15:53:15 <v1k0d3n> ah, actually 4 coming.
15:53:17 <srwilkers> unless im mistaken?
15:53:25 <mattmceuen> v1k0d3n - def take a watch of the summit presentation I mentioned above -- that had some great OpenContrail live demoing
15:53:36 <v1k0d3n> yeah saw that mattmceuen
15:53:42 <jayahn> i happen to meet with some deis related folks here in asia area. it seems like we are probably having a meeting with them at kubecon.
15:53:49 <v1k0d3n> beyond demo...working together with juniper would help
15:53:56 <v1k0d3n> we're getting a sales wall
15:54:09 <srwilkers> jayahn: does this mean i get to drink with you? in austin?
15:54:14 <jayahn> anyone will be welcome to join that meeting, once it is confirmed
15:54:20 <v1k0d3n> and we would like to break through that. meaning, they don't even know what work is occurring in this community, and are recommending things that don't really fit.
15:54:30 <jayahn> noep, i cannot go to Austin this time. sadly..
15:54:30 <portdirect> v1k0d3n: we'll we are beynd that, they are really starting to do some cool things now
15:54:34 <srwilkers> jayahn: :(
15:54:38 <jayahn> one of my team will be there.
15:54:55 * srwilkers will be sure to send jayahn tons of drinking photos with the crocodiles he never knew existed in austin
15:54:58 <v1k0d3n> and srwilkers on the ci parts...not sure they're happening here. maybe some...maybe some nit?
15:55:21 <portdirect> v1k0d3n: they are all happening in the open
15:55:33 * jayahn crocodiles.. damn i was away from Austin too long
15:55:37 <portdirect> andreys ps's are really worth a look ;)
15:56:21 <v1k0d3n> oh...i thought there was mention of a followup meeting with CI in denver that i never heard anything else on.
15:56:38 <v1k0d3n> ok...well, i guess i'll just look out for them. nevermind then :)
15:56:52 <jayahn> srwilkers: I will make sure my colleague contacts you for a drink.
15:57:04 <srwilkers> jayahn: that would be great :)
15:57:09 <portdirect> jayahn: mattmceuen and i will be in austing as well ;)
15:57:18 <mattmceuen> looking forward to seeing you @ kubecon v1k0d3n!
15:57:21 <jayahn> v1k0d3n: that has not been happen. there were only saying, not happening. :)
15:57:29 <jayahn> this ci focused meeting will be the first one
15:57:57 <jayahn> austing.. good word
15:57:59 <v1k0d3n> ah that works. didn't really hear see anything else on it, so just figured we missed it.
15:58:11 <v1k0d3n> yeah mattmceuen see you there too.
15:58:18 <mattmceuen> it's a verb now!  "Let's go austing the heck out of kubecon"
15:58:23 <v1k0d3n> larry will be there as well.
15:58:24 <portdirect> yup 27th for the 1st ci/cd meeting
15:58:27 <mattmceuen> awesome
15:58:53 <mattmceuen> 2 minute warning all
15:58:57 <mattmceuen> anything else?
15:59:27 <mattmceuen> sounds good - thanks everyone, have a great Thanksgiving!
15:59:30 <mattmceuen> #endmeeting