15:01:04 <srwilkers> #startmeeting openstack-helm
15:01:04 <openstack> Meeting started Tue Jan 16 15:01:04 2018 UTC and is due to finish in 60 minutes. The chair is srwilkers. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <openstack> The meeting name has been set to 'openstack_helm'
15:01:10 <srwilkers> #topic rollcall
15:01:15 <srwilkers> o/
15:01:16 <jayahn> o/
15:01:18 <alanmeadows> o/
15:01:18 <d|k> o/
15:01:42 <srwilkers> hey everyone -- mattmceuen is tied up today, so im going to go through the motions for him today
15:01:49 <powerds0111> o/
15:01:59 <srwilkers> today's the ci/cd focused meeting, and here's the agenda https://etherpad.openstack.org/p/openstack-helm-meeting-2018-01-16
15:02:13 <srwilkers> let's take a few minutes and add any other items to it before we get going
15:04:00 <srwilkers> alright
15:04:08 <srwilkers> #topic testing in osh-gates
15:04:14 <srwilkers> portdirect: take er away
15:04:29 <portdirect> o/
15:04:43 <portdirect> so the gate rework for zv3 has now merged
15:05:09 <portdirect> though still needs some work, and I'm currently putting together an updated deployment guide based off it
15:05:16 * jayahn feels so happy
15:05:18 <portdirect> in the same way we did for the single node guide
15:05:55 <portdirect> after playing with ansible for a bit in the osh-infra gate, i felt it was clear that we should not got the whole way for osh
15:06:09 <portdirect> as though ansible is great for helping us setup a working k8s env
15:06:28 <portdirect> it makes it really hard to discern whats going on after that
15:06:45 <portdirect> so now the playbook that we use looks really simple :)
15:07:04 <portdirect> https://github.com/openstack/openstack-helm/blob/master/tools/gate/playbooks/multinode-deploy.yaml
15:07:31 <portdirect> the only thing we do other than running some scripts, is deploying ipcalc on the hosts so we can get the storage subnet for ceph
15:07:49 <portdirect> for setup we use the playbooks from osh-infra
15:07:59 <portdirect> which also define the nodegroups to use
15:08:02 <portdirect> and...
15:08:16 <portdirect> ... we now have voting five node gates!
15:08:29 <portdirect> for everything except centos
15:08:40 <d|k> woot!!
15:09:06 <portdirect> as the nodepool images have some funkery going on with unbound that i need to resolve (not an intentional pun)
15:09:30 <portdirect> I hope to have the docs up later today, and would really appreciate eyes on them
15:09:43 <portdirect> also - there are some other things going on
15:09:59 <powerds0111> cool :)
15:10:18 <portdirect> one of my colleagues is adding a gate to keystone, that uses LOCI and OSH to perform functional testing
15:10:42 <portdirect> and I am in the final stages of validation of LOCI images here
15:10:59 <portdirect> once thats complete I'll make a PS that changes the images we can over to LOCI
15:11:06 <portdirect> and add documentation for building them
15:11:27 <portdirect> we will also have images built and pushed for use to the docker.io/openstackhelm ns
15:11:31 <portdirect> by the LOCI project
15:11:37 <srwilkers> thats great
15:11:38 <portdirect> :)
15:11:48 <jayahn> so osh changes default image from kolla to loci?
15:11:56 <jayahn> or have both running in gate?
15:12:02 <portdirect> Id really like to
15:12:12 <portdirect> the intent would be to have the default as loci
15:12:18 <portdirect> but still keep a kolla gate
15:12:58 <jayahn> as long as kolla has gate, changing default would be less influencing. anyway, we probably need some discussion over it
15:13:27 <portdirect> ++
15:13:57 <portdirect> I'm the worst person for an unbiased opinion, but i think LOCI makes much more sense for OSH
15:14:34 <srwilkers> alright, on to the next topic
15:14:34 <alanmeadows> absolute requirement we continue to support a kolla-based gate given the wide usage and in the future to ensure we're delivering on an upgrade to catch any image-based snags
15:14:42 <srwilkers> #topic: Planned prod deployment leveraging OSH
15:14:45 <srwilkers> all you jayahn :)
15:15:18 <jayahn> what i wrote in etherpad is all. :)
15:15:37 <jayahn> at the end of last year, we got request from cloud pc (vid) service team to do poc.
15:15:45 <jayahn> they already did with helion openstack.
15:15:54 <jayahn> we did it, and they liked it so much over helion.
15:16:37 <srwilkers> nice
15:16:50 * portdirect resists urge to make snarky comment
15:16:52 <jayahn> so now, it is decided that we will build osh-based production openstack for them, service opens on July this year, and if things goes well as marketing plans, it will be targeting 30,000 VMs in a year. :)
15:17:04 * portdirect probably just failed
15:17:12 <jayahn> wants to hear it from portdirect
15:17:16 <jayahn> :)
15:17:29 <portdirect> I have no love for helion.... ;)
15:17:47 <jayahn> that is why we just did PS on adding spice console. :)
15:18:04 <jayahn> totally agrees on portdirect. no love left for helion
15:18:30 <powerds0111> it looks everyone have no love for helion
15:19:02 <jayahn> okay. let's not mention a specific name on official meeting :)
15:19:20 <jayahn> that is all. :)
15:19:35 <srwilkers> awesome
15:19:50 <srwilkers> #topic Dublin PTG Preperation? - Schedule, Participants, etc.
15:19:56 <jayahn> srwilkers: so not lma is getting so important for us
15:20:02 <jayahn> not -> now
15:20:14 <srwilkers> jayahn: yeah, makes sense completely
15:20:48 <srwilkers> that's a good segue into the PTG topic -- would be really great to sit down face to face and talk about it in dublin
15:20:49 <powerds0111> Spice console is an important requirement for our customers.
15:21:11 <jayahn> I saw most of other projects already started etherpad to set the PTG agenda.
15:21:24 <jayahn> thought we also need to start that.
15:21:41 <srwilkers> i agree -- i'll get one started now and make sure mattmceuen has it at the forefront of his mind
15:21:42 <portdirect> i think mattmceuen has started one
15:21:48 <srwilkers> even better
15:21:53 <jayahn> oh.
15:22:01 <jayahn> in maingling list?
15:22:25 <portdirect> not sure jayahn I'll ping him soon as hes esaped the meeting he is in
15:23:44 <jayahn> okay. :)
15:25:50 <srwilkers> any other PTG related items to discuss? i dont have much until we get mattmceuen's etherpad
15:26:34 <jayahn> definitely wants to discuss osh cut-off (the first release) plan.
15:26:45 <jayahn> anyway, let's look at mattmceuen's etherpad first.
15:26:53 <jayahn> then, we can discuss more around that
15:27:28 <srwilkers> works for me
15:28:16 <srwilkers> #topic reviews needed
15:28:28 <jayahn> ceph: add manifest optional for job-rbd-pool: https://review.openstack.org/#/c/531947/ >> need workflow.
15:28:41 <jayahn> almost done. :) just one more step to go.
15:28:46 <jayahn> thanks in advance
15:28:49 <srwilkers> just workflowed
15:29:04 <srwilkers> this one was mentioned earlier: https://review.openstack.org/#/c/532933/
15:29:09 <jayahn> now, we can run our gate (in skt) again. :) big thanks
15:29:41 <srwilkers> turns off the pvc for setting up a snapshot repository as the default
15:29:50 <srwilkers> should have a better solution for this soon
15:29:59 <jayahn> srwilkers: yeap. we need that as the first step.
15:30:37 <srwilkers> that's the only one i have for now
15:30:54 <srwilkers> anyone else have patches theyd like reviewed?
15:31:25 <jayahn> portdirect: i have a queston.
15:31:55 <jayahn> really wants to ask "are you a human".
15:32:00 <jayahn> :)
15:32:17 <jayahn> do you know if we can somehow automatically put some people as a reviewer on ps?
15:32:19 <portdirect> I change the powercell once in a while
15:33:29 <jayahn> i think putting reviewer (for better, right reviewers for a certain type of PS) when PS is up will be good .
15:34:23 <srwilkers> im not sure if it can be done automatically, but i know you can add reviewers through gerrit for a particular patchset and they'll get a notification
15:34:55 <jayahn> I know I can do that manually on each patchset.
15:35:44 <jayahn> I was just asking, cause i thought it will be good if we can do automatically
15:36:23 <jayahn> anyone has something to ask for the next meeting?
15:36:47 <jayahn> pre-request stuff. we said we would ask it a week before, wouldn't we?
15:36:58 <srwilkers> yep :)
15:37:11 <srwilkers> #topic roundtable
15:37:21 <srwilkers> we can put it in the etherpad if there's anything
15:38:33 <jayahn> i remember the discussion around "how we can make osh more visible to everyone". and remembered there was a etherpad for that discussion
15:39:19 <jayahn> I am looking at 01-02 etherpad for the meeting, however, it is not there.
15:39:26 <srwilkers> hmm
15:39:29 <jayahn> anyone remembers etherpad link?
15:40:13 <jayahn> probably just need to dig meeting log. or my bad memory.
15:41:33 <srwilkers> https://etherpad.openstack.org/p/osh-onboarding-brainstorming this is the only other etherpad i see in the logs for that meeting
15:42:04 <jayahn> srwilkers: that is correct one
15:42:55 <jayahn> do we want to follow-up on this?
15:43:23 <jayahn> probably just need to share within a team, and get more brains for brainstorming.
15:43:37 <jayahn> or sharing in mailing list as well.
15:44:31 <jayahn> I will post on mailing list. :)
15:44:49 <srwilkers> i'm personally a fan of the office hours approach, although i cant speak for others' available time for doing so
15:45:05 <srwilkers> but i'd like to see it happen at some point
15:45:29 <jayahn> okay. we can probably collaborate on this.
15:46:00 <srwilkers> yeah. ill bug mattmceuen more about it and have him follow up on continuing to move this
15:46:19 <jayahn> let's get this out in mailing list, to get more wish list, and re-visit after that.
15:46:21 <srwilkers> #action mattmceuen to follow up on onboarding-brainstorming discussion
15:46:30 <srwilkers> jayahn: agreed
15:46:31 <jayahn> and yeap. bugging mattmceuen also good.
15:46:58 <jayahn> i am all done today. :)
15:48:00 <srwilkers> ive got one more thing
15:48:06 <srwilkers> here's the agenda for next week: https://etherpad.openstack.org/p/openstack-helm-meeting-2018-01-23
15:48:19 <srwilkers> figured this gives us a week to start throwing things on it :)
15:48:24 <srwilkers> thats it for me
15:48:43 <srwilkers> anyone else?
15:50:01 <srwilkers> alright, good chatting :)
15:50:04 <srwilkers> see you in the chatroom
15:50:06 <srwilkers> #endmeeting