15:01:26 <mattmceuen> #startmeeting openstack-helm
15:01:27 <openstack> Meeting started Tue Jan 23 15:01:26 2018 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:30 <openstack> The meeting name has been set to 'openstack_helm'
15:01:49 <mattmceuen> #topic rollcall
15:01:53 <srwilkers> o/
15:01:56 <gmmaha> o/
15:02:00 <icolwell> o/
15:02:00 <powerds0111> o/
15:02:01 <mattmceuen> Good morning/evening!
15:02:18 <mattmceuen> Here's our agenda for today: https://etherpad.openstack.org/p/openstack-helm-meeting-2018-01-23
15:03:30 <mattmceuen> #topic Revisit onboarding ideas
15:04:01 <mattmceuen> So a couple weeks ago, we started an etherpad with some ideas on how to accelerate new team members' grokking of both OSH as well as the technologies it uses
15:04:04 <mattmceuen> https://etherpad.openstack.org/p/osh-onboarding-brainstorming
15:04:34 <portdirect> o/
15:04:37 <mattmceuen> Thanks for your ideas folks - there are a number of good things in there and I think we can treat this like a living document and continue to implement them one or two at a time
15:04:52 <mattmceuen> One I'd like to start with, which got a lot of positive feedback, is Office Hours
15:05:11 <portdirect> ++
15:05:25 <mattmceuen> https://www.irccloud.com/pastebin/4UPK78jc/
15:05:53 <mattmceuen> How would you all refine this?
15:06:16 <portdirect> I mean the /me fu is a bit much
15:06:22 <portdirect> but other than that :)
15:06:33 <roman_g> o/
15:06:34 <portdirect> I think the wiki is pretty much /dev/null tbh
15:06:41 <srwilkers> i think the only bit i'd add is the requirement you wear a blazer with elbow patches while you do it
15:07:01 <portdirect> but announcing it in irc much like we do the meeting would be good
15:07:06 <srwilkers> ++
15:08:00 <lamt`> am late but o/
15:08:00 <mattmceuen> srwilkers I'll bring said blazer to our STL office, everyone else must fend for themselves
15:08:30 <srwilkers> byob -- bring your own..blazer
15:09:04 <mattmceuen> portdirect I like putting it in the wiki because folks might find it via google, and just as importantly, it's more of a commitment from the office hour-er
15:09:42 <portdirect> sure - I'm not saying dont do it - but we should advertise it more than that ;)
15:09:48 <mattmceuen> I'm going to try to find an hour on my outlook calendar and treat it like a first-class citizen of my schedule.  Is that what you guys had in mind, or something more flexible?
15:09:55 <mattmceuen> gotcha -- agree!
15:11:14 <mattmceuen> Since the proposal would be for this to be a obligatory expectation of any core, and optional for anyone else -- any cores object to committing to this?
15:12:04 <portdirect> so would we have two - to account for tz diffs?
15:12:10 <portdirect> if/when we require that
15:12:50 <mattmceuen> my thought is -- if each office hour-er picks a recurring, dependable time that works for them, then they could be all over the place.  I.e. no set time for the "whole team", but rather some good coverage.
15:13:08 <mattmceuen> were you thinking a combined office hour for everyone?
15:13:12 <mattmceuen> (or two)
15:13:32 <portdirect> i though thats what this was - but your propsal makes sense
15:13:35 <portdirect> wfm
15:13:45 <srwilkers> i think it should be everyone honestly
15:14:16 <mattmceuen> would you be willing to try both, simultaneously :-D
15:14:20 <srwilkers> nope
15:14:34 <mattmceuen> get your thumbs then, it's time to wrestle
15:15:11 <mattmceuen> If we can find an hour that works for everyone, I'm happy to try that
15:16:41 <mattmceuen> Since we're good in principle with this, let's keep on moving for now, and sort out the deets separately.  Let's plan on implementing office hours next week
15:17:07 <mattmceuen> #topic PTG Agenda
15:17:10 <portdirect> i think we should deceide in the meeting
15:17:23 <portdirect> or punt the decision to next week?
15:17:32 <mattmceuen> #topic Office Hours Remix
15:18:06 <portdirect> can we do a vote?
15:18:09 <mattmceuen> Yup
15:18:18 <portdirect> 1 - combined or seperate office hours
15:18:54 <portdirect> then depending on outcome - timeslot or timeslots
15:19:03 <mattmceuen> (or both combined and separate)
15:19:09 <portdirect> is there a quorum here?
15:20:21 <portdirect> think theres only 50% of cores here
15:20:29 <mattmceuen> We have 4 cores (who would bear the brunt of the responsibility) and I'm interested in votes from everyone else (who would be getting the value)
15:20:52 <mattmceuen> Let's vote and then seek feedback offline from folks not here.
15:21:34 <alanmeadows> If separate hours, is it possible we would increase our time coverage?
15:21:47 <mattmceuen> for me - I vote separate office hours, and I'm open to "all of the above"
15:21:55 <mattmceuen> Yep, that's what I was thinking alanmeadows
15:22:02 <srwilkers> i vote combined
15:22:26 <alanmeadows> i vote the opposite of steve just to be contrary
15:22:41 <roman_g> Vote separate hours
15:22:44 <powerds0111> i vote separate hours :)
15:22:47 <portdirect> I vote for two combined - one in the USA, and one in ASIA tz
15:23:00 <alanmeadows> and because I worry combined might be a burden given some of us share external responsibilities
15:23:01 <mattmceuen> always the consensus builder, portdirect
15:23:02 <portdirect> as an ex euopean i expect to be left out ;)
15:23:02 <srwilkers> alanmeadows: fried cheese for lunch today? :)
15:23:39 <alanmeadows> srwilkers: oh boy
15:23:50 <roman_g> portdirect two combined sounds good
15:23:59 <mattmceuen> Here's what we'll do
15:24:01 <powerds0111> oh two combined looks better
15:24:07 <mattmceuen> We'll try to cluster
15:24:34 <mattmceuen> I'll send out one of those calendar voting things in the ML, and drop a note in IRC
15:25:01 <mattmceuen> Of times that "in general work for me" as a office hour-er
15:25:03 <alanmeadows> even better, less group think
15:25:12 <mattmceuen> Then we'll try to pick some times that give us good coverage
15:25:14 <mattmceuen> Sound good?
15:25:40 <mattmceuen> If it's just two - that would be the target number
15:26:52 <mattmceuen> #action mattmceuen to send out schedule gathering thing to get office hours clustered
15:27:01 <mattmceuen> #topic PTG Agenda
15:27:18 <mattmceuen> https://etherpad.openstack.org/p/openstack-helm-ptg-rocky
15:27:45 <powerds0111> can we talk about armada at PTG?
15:28:07 <portdirect> powerds0111: ++
15:28:08 <mattmceuen> Please add things you'd like to discuss to this! ^  Or, things you'd like to be discussed in your absence if you're not able to come
15:28:22 <mattmceuen> Yup let's do that powerds0111
15:28:31 <powerds0111> yeap
15:28:40 <mattmceuen> Please add it to the agenda
15:29:48 <mattmceuen> Anything else on this topic - would you like to discuss any of the agenda items, or just take a look / add offline?
15:30:04 <srwilkers> mattmceuen: have you reached out to whomever required for getting official space for us at the PTG?
15:30:23 <srwilkers> now that we're official, we should have access to a specific room that'll appear on the schedule
15:30:23 <mattmceuen> Yep, we will be good to go - thanks for bringing that up srwilkers
15:30:30 <srwilkers> awesome
15:30:31 <mattmceuen> We'll be Monday and Tuesday
15:31:03 <mattmceuen> Which will give us the opportunity to also participate in other project team meetings
15:31:34 <mattmceuen> So we'll want to capitalize on that - looking for opportunities to involved project teams / get feedback on the different charts
15:32:34 <mattmceuen> Alright - your move, srwilkers!
15:32:37 <mattmceuen> #topic Adding Armada fullstack check
15:33:07 <srwilkers> ive been working on getting a check running to deploy OSH + the infra bits via armada
15:33:33 <srwilkers> just another change or two, and it should be good to go.  watching it run in the gate currently
15:33:52 <srwilkers> for now, it's aiming for parity with the multinode deployments we do in the gate where applicable
15:34:27 <mattmceuen> That's fantastic - can you paste the PS in for posterity?
15:34:29 <srwilkers> yep
15:34:46 <srwilkers> https://review.openstack.org/#/c/535972/
15:34:57 <srwilkers> that gives us a manifest for OSH and the logging and monitoring components
15:35:32 <srwilkers> i'd like to see this maintained going forward, because it's pointed out a few issues with armada along the way
15:35:49 <srwilkers> but thats it :)
15:36:03 <mattmceuen> I added this to the Needs Reviews list.  Thanks srwilkers!
15:36:46 <mattmceuen> On that segueway -- we have a hefty list of PS that need eyes this week:
15:36:52 <mattmceuen> https://www.irccloud.com/pastebin/nhf4jFc7/
15:37:05 <mattmceuen> #topic PS needing reviews
15:37:27 <mattmceuen> Anyone like to discuss any of those in particular?
15:37:34 <srwilkers> yeah, a quick note on a few
15:38:11 <srwilkers> https://review.openstack.org/#/c/536383/ this one tunes the Prometheus intervals and block durations, which seems to calm Prometheus down a bit in regards to resource consumption
15:38:26 <srwilkers> it moves the defaults for those values to the prometheus service defaults
15:39:36 <srwilkers> also
15:40:20 <srwilkers> https://review.openstack.org/#/c/535780/ and https://review.openstack.org/#/c/535222/ remove the RWM requirement for alertmanager and prometheus
15:40:45 <srwilkers> alertmanager doesnt need RWM now that the chart uses peer meshing
15:41:13 <srwilkers> and as long as multiple prometheus replicas contain the same targets, they also wont require a shared pvc
15:41:35 <srwilkers> thats it from me
15:41:37 <mattmceuen> Remind me, what's RWM?
15:42:20 <srwilkers> readwritemany
15:42:29 <mattmceuen> gotcha
15:42:42 <mattmceuen> that's fantastic
15:43:16 <mattmceuen> Team - let's spend some time over the next couple days getting solid review and feedback on this list, please.
15:43:44 <mattmceuen> #topic Topics for future meetings
15:44:20 <mattmceuen> Is there anything that was brought up today that piqued anyone's interest, that they'd love to learn more about next time?   Or any other corners of OSH that could use some illumination
15:45:47 <mattmceuen> Sounds good - if anything comes to mind we'll get it on the schedule for next time.
15:45:51 <mattmceuen> #topic Roundtable
15:45:59 <mattmceuen> Thanks srwilkers for covering for me last week :)
15:46:03 <mattmceuen> That's all I got
15:46:25 <srwilkers> no problem mattmceuen
15:46:48 <roman_g> OSH docs list 2 installation paths; I would like to have something like operations and upgrade guides
15:47:56 <mattmceuen> +1
15:48:22 <roman_g> That's common for OS software to have only install guides
15:48:35 <mattmceuen> That'll become more important as we become increasingly productionalized
15:48:56 <roman_g> whereas majority of problems you get during long time operations and upgrades/migrations
15:49:37 <mattmceuen> roman_g, could you please create a blueprint in launchpad detailing what you'd expect/need out of the documentation?  Would be great to capture "requirements" ahead of time
15:50:13 <roman_g> Will do.
15:50:21 <mattmceuen> awesome - thanks!
15:51:25 <mattmceuen> Any other topic y'all would like to discuss today?
15:51:47 <gmmaha> the ceph multi-osd per node patch has gone through too many iterations. any suggestions on how to brinng to a wuivk closure would help
15:52:56 <gmmaha> the patch is working as expected now thanks to dave and renmak
15:53:27 <gmmaha> s/wuivk/quick/
15:53:44 <mattmceuen> Agree.  Did you add that PS into the list of ones to get review gmmaha?
15:53:53 <mattmceuen> I haven't looked at all of them individually yet :)
15:53:55 <gmmaha> mattmceuen: i did not.. will do
15:54:22 <gmmaha> it is there now. thanks.
15:55:12 <portdirect> gmmaha: Id also invite you to look at https://review.openstack.org/#/c/536215/
15:55:18 <mattmceuen> Perfect - thanks.  Let's get reviews on that one quick.  Thanks gmmaha, dave, renmak, and portdirect who have all put a lot of effort into the ceph chart recently
15:55:34 <gmmaha> portdirect: will do.
15:55:57 <gmmaha> thanks mattmceuen portdirect
15:56:24 <mattmceuen> Ok folks - if there are no more topics, we can call it a day.  Keep up the good work. :)
15:56:43 <mattmceuen> #endmeeting