15:00:13 <mattmceuen> #startmeeting openstack-helm
15:00:14 <openstack> Meeting started Tue Feb 13 15:00:13 2018 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:17 <openstack> The meeting name has been set to 'openstack_helm'
15:00:20 <mattmceuen> #topic rollcall
15:00:23 <d|k> o/
15:00:27 <mattmceuen> hello everyboty
15:00:32 <mattmceuen> everybody rather
15:00:42 <d|k> <- not a bot, honest.
15:00:44 <mattmceuen> off to a great start here spelling-wise
15:00:50 <mattmceuen> I'm not a bot, a bot could spell :)
15:00:56 <portdirect> *smelling
15:01:00 <srwilkers> o/
15:01:13 <roman_g> o/
15:01:17 <mattmceuen> Here's our agenda for today, please add in anything addn'l you'd like to discuss https://etherpad.openstack.org/p/openstack-helm-meeting-2018-02-13
15:02:28 <mattmceuen> #topic Office Hours reminder
15:02:51 <mattmceuen> Just a quick reminder -- we just finished a weekly office hour session, and we have one more in seven hours :)
15:03:14 <mattmceuen> We currently have three per week and they're on our team wiki.  Thanks to everyone who helps facilitate (and who asks questions)
15:03:35 <mattmceuen> do we have jayahn today by chance?
15:04:29 <mattmceuen> He was going to try to find an additional time that worked for SK folks, I'll circle back w/ him later
15:05:02 <mattmceuen> #topic Mascot voting results
15:05:05 <mattmceuen> https://etherpad.openstack.org/p/openstack-helm-mascot
15:05:21 <mattmceuen> I must say that the Ratel made quite a showing!
15:05:50 <mattmceuen> It tied "everything else put together"
15:06:28 <portdirect> http://i0.kym-cdn.com/photos/images/newsfeed/000/140/324/honey-badger-it-just-takes-what-it-wants-t-shirts_design.png
15:07:08 <mattmceuen> We'd like to maintain consensus on top of voting supremecy if possible.  So: speak now or forever hold your peace with the Ratel as our Mascot?
15:07:35 * mattmceuen voted for Sea Otter, but is happy to adopt the inspirational Ratel
15:08:26 <srwilkers> inspirational indeed
15:09:11 <srwilkers> im inspired to learn to run backwards too
15:09:24 <mattmceuen> Since I believe the majority of folks who voted for alternative candidates are not present, let us make the Ratel our Mascot-Elect, and revisit one final time to affirm consensus.
15:10:13 <mattmceuen> Any more thoughts on this topic
15:10:46 <mattmceuen> #topic Values YAML ordering
15:11:17 <mattmceuen> I know we've discussed this in various forums with various folks, but I wanted to discuss here before moving on it
15:11:26 <mattmceuen> Steve has a PS out: https://review.openstack.org/#/c/542279/
15:12:08 <portdirect> I like this, but i think each chart should be hit seperately
15:12:30 <mattmceuen> The idea is that we'd like to have a standard ordering to our values YAMLs across charts, and  the most objective way to to this is is simply to alphabetize all the keys
15:12:31 <portdirect> and the sort should aslo go through all the keys, not just top level
15:12:40 <portdirect> *also
15:12:48 <srwilkers> portdirect: that's sane
15:13:10 <mattmceuen> Is there a tool that would do this for us (or would it be easier to make a tool vs by hand)?
15:13:15 <portdirect> For this to have value, can we also add this to the linting gate
15:13:22 <srwilkers> mattmceuen: depends on whatever text editor youre using
15:13:25 <srwilkers> portdirect: ++
15:13:25 <mattmceuen> Yeah, and if it can be linted it can be printed!
15:13:44 <portdirect> atom has a load of plugins, though they all strip comments
15:13:53 <portdirect> which we should keep
15:14:10 <portdirect> so doing this the 1st time will be labourious
15:14:35 <portdirect> but a great bit of low hanging fruit for a new contrib to get under there belt
15:14:42 <mattmceuen> So I am not convinced on this approach.  I think we are sacrificing readability for consistency.
15:14:47 <portdirect> *their
15:15:06 <mattmceuen> I have heard a lot from portdirect and srwilkers on this and I'm happy to bow to team concensus
15:15:31 <portdirect> fair, though in the interests of democracy, we are but two voices.
15:15:32 <mattmceuen> Can you guys please pitch the benefits and why it's worth the readability drop?
15:15:33 <d|k> sort of a strawman reaction: i think alphabetical organization makes some sense (and a standard ordering makes a TON of sense), but might it on the other hand be useful to have the things users might be most likely to edit at the top?
15:15:55 <alanmeadows> Also, are there other simple consistencies beyond this we’d like to enforce at the same time?
15:16:01 <srwilkers> thats a fair point, but that quickly becomes subjective djk
15:16:05 <d|k> strooth
15:16:08 <alanmeadows> Even outside of values
15:16:17 <portdirect> alanmeadows: yes
15:16:30 <portdirect> but this is just one step on the road to helm8 ;)
15:16:37 <srwilkers> and id like to have something consistent we can easily enforce, else we'll start seeing drift between the charts i think
15:16:52 <portdirect> its already happened
15:17:07 <portdirect> and we have a large number of charts, and contribs now
15:17:12 <srwilkers> knowing where to find something chart to chart makes working with them easier, instead of having to run find on whatever key youre looking for between charts
15:17:20 <d|k> i guess my point could be better addressed by just ensuring that values/charts are well-commented.
15:17:24 <roman_g> Attributes are not in alphabetic order, for ex. Here https://review.openstack.org/#/c/542279/7/calico/values.yaml
15:17:25 <portdirect> that without some formal schema we will start to drown in minor deltas
15:18:08 <roman_g> line 70: CALICO_NETWORKING_BACKEND and line 72 ETCD_CA_CERT_FILE and line 78 CALICO_DISABLE_FILE_LOGGING
15:18:21 <srwilkers> roman_g: right.  we're proposing to order them alphabetically
15:18:42 <mattmceuen> Revisiting the idea of "top level keys alphabetized" vs "all keys alphabetized" -- do we 90% of what you're after srwilkers with just the top level, while preserving most of the readability?
15:19:01 <srwilkers> i think we need to order everything, as portdirect mentioned
15:19:39 <mattmceuen> Yep that was not my question though
15:20:44 <mattmceuen> You'd brought up the problem of having to Ctrl+F as a pain point -- wondering whether you'd have to Ctrl+F substantially less if we just organized the top level?
15:21:16 <srwilkers> we'd have to ctrl+f less if everything was ordered, id say
15:21:20 <srwilkers> top keys and subkeys
15:21:40 <portdirect> some of our charts have 15K lines in the values
15:21:51 <mattmceuen> Let's do this please -- can we have something concrete to look at here -- maybe do the full depth alpha on your PS, and then let's look at it next team meeting?
15:22:00 <roman_g> I would make it all alphabetical in distro, but not would enforce it for users.
15:22:01 <mattmceuen> (^srwilkers)
15:22:06 <srwilkers> mattmceuen: sure
15:22:15 <roman_g> http://yamllint.readthedocs.io/en/latest/rules.html#module-yamllint.rules.key_ordering yawl alphabetical linter
15:22:20 <roman_g> *yaml
15:22:25 <srwilkers> ill hit the prometheus chart as an example
15:22:45 <mattmceuen> oo good find roman_g
15:23:00 <mattmceuen> thanks srwilkers
15:23:22 <mattmceuen> #action Revisit YAML value ordering next time with prometheus as example
15:23:23 <alanmeadows> roman_g: it has to be enforced on commit
15:23:31 <alanmeadows> or there is no point to the refactoring now
15:24:12 <roman_g> alanmeadows, I agree, it must be done on commit. But let's not enforce alphabetical order for users.
15:24:42 <srwilkers> roman_g: not sure i follow
15:24:52 <alanmeadows> in fact I see a number of things from yamllint should be implemented
15:24:52 <mattmceuen> by users do you mean e.g. overrides roman_g?
15:25:06 <roman_g> yes.
15:25:53 <roman_g> Someone takes stock yaml, and modifies it. It should be applied w/o any problems, without warnings about non-alphabetical order of keys
15:26:03 <mattmceuen> agree - overrides are often going to be pets, and when not, should be up to the user to enforce what they want
15:26:24 <srwilkers> roman_g: that's outside the scope of osh -- whatever a user applies as overrides get's validated by helm, not the charts themselves
15:26:26 <mattmceuen> all linting should be done at commit time, not runtime
15:27:23 <mattmceuen> Alright - anything else before we move on?
15:27:46 <mattmceuen> #topic Ceph changes merged
15:27:54 * mattmceuen woooooooooooooooooooooooooooooooooooooooooooooo!!
15:28:26 <d|k> what. he. said.
15:28:39 <portdirect> next step is gonna be to split the chart out
15:28:58 <portdirect> and see how that effects upgrades
15:29:03 <mattmceuen> Big thanks to portdirect for getting this PS past the finish line, and to all the folks whose work this builds on (d|k renis ganesh and anyone else I missed)
15:29:29 <d|k> portdirect: is there a plan for supporting device naming by [i]scsi IDs, or should we just use the fact that there are symlinks for those?
15:29:51 <d|k> portdirect: also, you REWL for dragging this thing to the finish.
15:30:59 <portdirect> d|k: yes to scsi
15:31:03 <d|k> kewl
15:31:14 <alanmeadows> also what about scrubbing, i.e. clean redeploy
15:31:15 <portdirect> can you add your awesome work in here?
15:31:35 <gmmaha> portdirect: split the chart out meaning, just the ceph piece or helm-toolkit also goes along i presume?
15:31:37 <alanmeadows> a script is a decent half measure, but long-term?
15:31:49 <portdirect> alanmeadows: do we want to support that?
15:32:12 <alanmeadows> at the very least is our script a tools/ helper?
15:32:17 <portdirect> i suspect we do, but want consensus before people say portdirect you killed my cat pic collection.
15:32:31 <d|k> i'd be happy to put up a change with my little physical-to-logical mapping thing and then that can be cleaned up/improved
15:32:43 <portdirect> d|k: sounds great
15:33:07 <alanmeadows> It shouldn't be super easy to tap into but it should be there, ephemeral clouds are the wave of the future
15:33:10 <portdirect> alanmeadows: I could add a oldschool "REALLY_ZAP_OSDS" flag?
15:33:35 <alanmeadows> I think thats fine, I think it may also go along with maybe what we would do for PVCs on statefulsets
15:33:45 <portdirect> roger, wfm
15:33:46 <alanmeadows> REALLY_OBLITERATE_ALL_MY_DATA_ON_PURGE
15:34:21 <portdirect> gmmaha: the plan is to try splitting the mons, osds, and clients into seperate charts
15:34:40 <portdirect> to allow them to be upgraded in sequence
15:35:24 <gmmaha> portdirect: aaah.. that sounds like fun.. feel free to rope me in on the work
15:36:07 <portdirect> gmmaha: will do - the split will be easy, the validation less so :)
15:36:20 <mattmceuen> you have the best definition of the word "fun" gmmaha :-D
15:36:30 <gmmaha> portdirect: true dat... (now how all can we make this fail)
15:36:43 <gmmaha> mattmceuen: :D
15:36:57 <mattmceuen> that is the real fun part... torture the thing
15:37:22 <mattmceuen> ok - next topic
15:37:28 <gmmaha> portdirect: is this split planned afgter we move it to ceph-helm or prior?
15:37:31 <gmmaha> sorry mattmceuen
15:37:34 <mattmceuen> d'oh
15:37:36 <gmmaha> slow typer here
15:37:38 <mattmceuen> Nope my bad go for it
15:37:43 <portdirect> gmmaha: the last step before moving
15:37:53 <portdirect> the day is approaching fast now
15:38:16 <gmmaha> portdirect: cool. guess it's time to cue t
15:38:21 <gmmaha> the music and get coffee
15:38:28 <gmmaha> thanks portdirect mattmceuen :)
15:38:34 <mattmceuen> thanks gmmaha!
15:39:00 <mattmceuen> #topic Let's get the PS in good shape!
15:39:28 <mattmceuen> uno momento - copy paste fail
15:39:47 <mattmceuen> https://review.openstack.org/#/c/538419/ - Add template for Fluent logging index - 1 week
15:39:47 <mattmceuen> https://review.openstack.org/#/c/537800/ - Change the check method for the ceph ods version - 2 week
15:39:47 <mattmceuen> https://review.openstack.org/#/c/539477/ - Change osd pool default size set 1 - 1 week
15:39:47 <mattmceuen> https://review.openstack.org/#/c/539019/ - Managing generic loopback devices for testing
15:39:47 <mattmceuen> https://review.openstack.org/#/c/528488/ - LMA documentation
15:39:48 <mattmceuen> https://review.openstack.org/#/c/540938/ - Deep merge functionality for Helm-Toolkit
15:40:11 <mattmceuen> Some of these have been languishing as we've been busy with some big efforts
15:40:30 <mattmceuen> But let's try to get some solid feedback and/or merges on these guys in the next 2 days please
15:41:01 <mattmceuen> also     https://review.openstack.org/#/c/535699/ - Use ceph-admin-keyring to execute storage_init script in Cinder.
15:41:25 <portdirect> would also be awesome to expand the active reviewers
15:41:31 <srwilkers> portdirect: ++
15:41:33 <mattmceuen> +1
15:41:49 <portdirect> asl currently 60% is done by three people: http://stackalytics.com/?module=openstack-helm
15:42:48 <mattmceuen> Does anyone have any suggestions for how we can keep reviews moving?  Lessons learned from other projects?
15:42:53 <mattmceuen> "one simple trick"?
15:43:27 <portdirect> pointing out that a +/-1 is worth as much as a +/-2 is a big part of it i think
15:43:29 <srwilkers> it'd be great to see more active reviewers over the next cycle so we can revisit core team makeup and membership
15:43:35 <portdirect> we really need more cores
15:43:38 <srwilkers> ^
15:43:45 <mattmceuen> yep
15:43:51 <portdirect> but to get to that point people need to put the work in.
15:44:48 <mattmceuen> +/-2s are a lot easier for cores to give once other team members have given strong reviews and +/-1s  -- agree portdirect
15:45:18 <portdirect> its how I was brought up in OSS
15:45:25 <portdirect> get stuck in :D
15:45:31 <srwilkers> :p
15:45:37 <mattmceuen> well you did alright :)
15:45:43 <portdirect> (and grow thick, loos skin)
15:45:59 <portdirect> ^^ Like a certain mascot
15:46:06 <mattmceuen> that's deep, man, deep
15:46:40 <mattmceuen> Alrighty
15:46:48 <mattmceuen> #topic Roundtable
15:47:03 <mattmceuen> Any topics you all would like to discuss next time that might need some prep work, or things to bring up today?
15:47:43 <srwilkers> im good i think
15:47:53 <mattmceuen> #action The hardy Ratel is Mascot-Elect
15:48:06 <mattmceuen> btw I learned it's pronounced RAY-tel
15:48:31 <mattmceuen> that's all I got
15:48:42 <mattmceuen> good meet peeps -- thanks for all your hard work.
15:48:49 <srwilkers> funny, i thought it was pronounced "honey badger"
15:48:58 <mattmceuen> UHHHHWWHAAAAAT????
15:49:04 <mattmceuen> #endmeeting