15:00:05 <mattmceuen> #startmeeting openstack-helm
15:00:06 <openstack> Meeting started Tue Jul  3 15:00:05 2018 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <openstack> The meeting name has been set to 'openstack_helm'
15:00:09 <mattmceuen> #topic Rollcall
15:00:18 <srwilkers> o/
15:00:23 <mattmceuen> GM all
15:00:28 <mattmceuen> Agenda today:  https://etherpad.openstack.org/p/openstack-helm-meeting-2018-07-03
15:00:31 <tdoc> hi
15:00:36 <mattmceuen> Please add antyhing you'd like to discuss in there
15:01:14 <mattmceuen> We will be a little light today as a lot of folks in the US are taking off due to Independence Day being tomorrow
15:01:37 <mattmceuen> o/ tdoc srwilkers
15:03:44 <mattmceuen> do we have jayahn yet?
15:03:49 <portdirect> Or back in their homelands ;)
15:03:59 <srwilkers> !
15:04:06 <srwilkers> a wild portdirect appears!
15:04:18 <mattmceuen> you know you're 100% american by now portdirect
15:04:31 <portdirect> Be warned, the letter of today is WHISKY
15:04:51 <mattmceuen> see, you're celebrating july 4th remote
15:05:16 <srwilkers> i think the letter of the day is `E` -- the one the whiskey made you forget to include
15:05:25 <mattmceuen> LOL
15:05:25 <portdirect> https://usercontent.irccloud-cdn.com/file/4yGIWfC3/irccloudcapture485639533655189030.jpg
15:05:36 <mattmceuen> portdirect is winning today
15:05:45 * srwilkers grumbles
15:06:00 <mattmceuen> we'll come back to jayahn's topic and start with srwilkers
15:06:02 <mattmceuen> #topic Progress on values standardization
15:06:17 <mattmceuen> tell us about chart testing!
15:06:20 <srwilkers> was just curious if there had been any progress on the work to standardize our values.yaml format
15:06:40 <srwilkers> as it's been targeted as a 1.0 requirement, and working across multiple charts lately has made me realize how much i really want this
15:06:44 <tdoc> I ~.
15:06:46 <mattmceuen> The spec for that is still under review
15:07:02 <mattmceuen> So there is plenty of opportunity to get good ideas into it :)
15:07:05 <srwilkers> okay
15:07:07 <portdirect> Not that I have seen, the spec has been languishing in review
15:07:24 <srwilkers> ill take a peek at it today then
15:07:36 <portdirect> I've started making an attempt to get docstring like comments for helm toolkit
15:07:47 <srwilkers> portdirect: yeah, huge fan. :)
15:07:52 <srwilkers> portdirect: looks clean and nice
15:07:54 <portdirect> And would really like to see us start to unit test the toolkit properly
15:07:57 <mattmceuen> https://review.openstack.org/#/c/552485/
15:08:31 <srwilkers> was mostly curious because itd be nice to potentially use something like https://github.com/kubernetes-helm/chart-testing to be able to lint values
15:08:54 <srwilkers> it sounds like you can define the schema expected with it, but haven't verified that for certain beyond a precursory glance
15:09:02 <mattmceuen> Can be used with Helm 2 right?
15:09:05 <srwilkers> but would help enforce the structure we want
15:09:08 <srwilkers> yeah
15:09:12 <mattmceuen> Neat
15:09:29 <portdirect> I'd like to look into it, but between this and the unit testing plugin
15:09:41 <portdirect> I think we could shore up things a lot
15:09:44 <srwilkers> me too
15:09:44 <mattmceuen> ++
15:10:11 <srwilkers> if you want to action item me mattmceuen, ill spend some free time this week poking at the chart-testing bits
15:10:16 <srwilkers> and at least see what it's capable of
15:10:42 <portdirect> It would be great to get a summary of what it gives us
15:10:58 <srwilkers> word
15:11:14 * mattmceuen looks up meetbot docs
15:11:47 <portdirect> https://www.irccloud.com/pastebin/wTTAqDns
15:11:49 <mattmceuen> #action srwilkers to look into chart-testing for helm and values.yaml order standards and enforcement
15:12:09 <portdirect> Is powerds0111 still working this at all?
15:12:26 <srwilkers> not sure
15:12:42 <portdirect> Or would it make sense for srwilkers to take over the spec?
15:12:51 <mattmceuen> a few weeks ago he said he still wanted to contribute to it but has been tied up and/or on vacation
15:13:00 <mattmceuen> I will reach out, but I'm sure he wouldn't mind some help with it
15:13:16 <srwilkers> mattmceuen portdirect: whatever works.  happy to help if required
15:13:46 <mattmceuen> Let's plan to circle back next week with a plan to close it out
15:13:51 <srwilkers> works for me
15:14:26 <mattmceuen> alright - do we have jayahn in the house by chance?
15:15:24 <mattmceuen> #topic Progress on documenting setting up bridges (hooking up provider network) in the multi-node manual?
15:15:30 <mattmceuen> Thanks vadym for adding this
15:15:46 <mattmceuen> We have added the first batch of multinode doc updates in: https://review.openstack.org/#/c/576342/
15:15:58 <mattmceuen> This one cleans up a lot of the little things
15:16:22 <portdirect> Is rwellum about?
15:16:46 <mattmceuen> Next big change will be to split out the kubernetes setup into its own sub-guide, with appropriate verbiage around picking a production-grade k8s installer
15:16:55 <vadym> thanks guys!
15:17:37 <mattmceuen> for hooking up a provider network -- I haven't added anything to the guide for that yet, although it would be a good add.  At the bottom of the multinode guide we now basically punt out to the openstack configuration guide for site-specific config
15:17:56 <mattmceuen> To set expectations that "things still need to be configured right"
15:18:21 <mattmceuen> But, an example provider network setup is still something I think would be good to add to the end of the multinode guide
15:18:48 <tdoc> yup
15:18:52 <portdirect> Yeah, we do need to also cover cases without a provider net as well
15:19:54 <portdirect> Using somthing like we have in the AIO guide for people with a single gateway node, or the mirad of other fun things people come up with
15:20:03 <mattmceuen> vadym - if you'd like to add the provider net example, that would be much appreciated as well!
15:20:14 <portdirect> ++
15:20:44 <vadym> ok, I'll look into it
15:21:00 <mattmceuen> awesome - thanks!  Please ping me if/when you have any q's
15:21:37 <mattmceuen> Anything else on the doc front, team?
15:22:07 <mattmceuen> #topic Is "nginx" a good default for namespace ingress class?
15:22:12 <mattmceuen> Take it away tdoc
15:22:37 <tdoc> well, this is something i kinda ran into...
15:22:52 <tdoc> we deploy a 'default' nginx ingress controller
15:23:14 <tdoc> which means it does not set an ingress class for that controller
15:23:44 <tdoc> which means it will pick up those namespace ingress objects, as 'nginx' is the default class
15:24:04 <tdoc> or at least that's my understanding so far...
15:24:26 <tdoc> So it made me wonder if using "nginx" is a sensible default?
15:26:26 <mattmceuen> sorry tdoc my boss tapped me on the shoulder :)  I'm back
15:28:06 <mattmceuen> so functionally, it would be a no-op to make that change, but it would be more explicit if we set nginx as the default?  Am I understanding right?
15:29:31 <tdoc> well, for the cluster ingress 'nginx-cluster' is used, but for the namespace 'nginx'...
15:30:26 <tdoc> that all works fine, but if there is another ingress controleller deployed, which is setup without a specific class, it uses 'nginx'
15:31:21 <tdoc> so it seems to me something like 'nginx-openstack' (or maybe even 'nginx-$namespace'?) might make more sense?
15:31:57 <portdirect> $namespace might make sense
15:32:14 <portdirect> But we would need to be careful with it
15:32:59 <portdirect> Could you make a ps, so we could explore this?
15:33:17 <mattmceuen> I may be missing the point, apologize - is there a conflict if the two different ingresses both have nginx class?  They'd both be in different namespaces, right?
15:33:21 <mattmceuen> +1
15:33:36 <mattmceuen> A line of code is worth a thousand words :D
15:34:57 <tdoc> well, I'm not a 100% sure, but I think it is a problem, because that class is how a ingress object inside a namespace can be picked up by a controller in another namespace
15:37:52 <mattmceuen> I think you may be onto something then
15:38:11 <portdirect> We specifically limit the controllers to listen in only their ns dir this reason tdoc
15:38:25 <portdirect> *dir/for
15:39:03 <tdoc> hmm, i may have missed this part then...
15:39:16 <portdirect> https://github.com/openstack/openstack-helm/blob/master/ingress/templates/bin/_ingress-controller.sh.tpl#L26
15:40:08 <tdoc> aha, ok...
15:41:18 <tdoc> still though, i would argue that using 'nginx' is a somewhat unfortunate default?
15:41:54 <mattmceuen> What would you recommend as a sane default?
15:42:05 <mattmceuen> The $namespaced version still, or something else?
15:42:33 <tdoc> anything but 'nginx' really ;)
15:42:37 <mattmceuen> hahaha
15:42:51 <mattmceuen> Put in a PS with what you think is good -- I for one am not wedded to it :)
15:43:25 <tdoc> ok (will look into how to do so)
15:44:03 <mattmceuen> awesome - ping me in the osh channel or on the side if you run into any issues
15:44:37 <mattmceuen> #topic Roundtable Discussion
15:44:39 <tdoc> ok, thanks
15:44:55 <mattmceuen> What else is on your mind, guys
15:45:12 <mattmceuen> The fact that tomorrow's a holiday? :)
15:45:50 <srwilkers> ++
15:46:00 <tdoc> i have another question on fqdn overrides, but can also ask on the main channel..
15:46:12 <mattmceuen> Go for it - you have eyeballs now
15:46:23 <srwilkers> we've still got 14 minutes yet -- fire away
15:47:16 <tdoc> so, when I specify those fqdn overrides, I can see that domain appear in ingress rules.. but shouldn't it also change entries in keystones endpoint lists?
15:47:32 <tdoc> or do i need to override those separately?
15:49:20 <lamt> is the public endpoint in ks not using the fqdn overrides?
15:49:59 <tdoc> that's kinda what I expected, but not what seems to happen for me...
15:51:37 <mattmceuen> Let me take that one back and poke at it a bit
15:51:50 <mattmceuen> Ok if we revisit next week with an answer?
15:53:23 <tdoc> sure, thanks
15:53:50 <tdoc> i'll keep poking on my end as well ;)
15:54:01 <mattmceuen> Deal :)
15:54:21 <mattmceuen> Alright guys - thanks much and have a great rest of the week!
15:54:32 <mattmceuen> #endmeeting