15:00:00 <mattmceuen> #startmeeting openstack-helm
15:00:01 <openstack> Meeting started Tue Aug 14 15:00:00 2018 UTC and is due to finish in 60 minutes. The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:04 <openstack> The meeting name has been set to 'openstack_helm'
15:00:05 <mattmceuen> Hello everybody
15:00:10 <mattmceuen> #topic Rollcall
15:00:18 <mattmceuen> Welcome to ye olde osh team meeting
15:00:46 <mattmceuen> Our agenda may be found here -- I'll give a couple minutes for folks to add additional topics if they'd like
15:00:46 <mattmceuen> https://etherpad.openstack.org/p/openstack-helm-meeting-2018-08-14
15:00:53 <srwilkers> hello
15:02:13 <portdirect> o/
15:05:05 <mattmceuen> Alright let's get started
15:05:13 <mattmceuen> #topic Congrats to our new PTL
15:05:38 <mattmceuen> Congratulations to portdirect -- he has been voted in as our next leader!
15:05:44 <john_W> Whoo Hoo!!
15:06:06 <portdirect> not so fast mattmceuen - you're still ptl atm
15:06:13 <mattmceuen> I'm sure I speak for all of us when I say I'm looking forward to working with you as PTL
15:06:26 <mattmceuen> portdirect and I will be working closely to ensure a smooth transition
15:06:37 * mattmceuen throws PTL hat at portdirect and runs
15:06:42 * mattmceuen juuuuuust kidding
15:07:21 * portdirect as his 1st act declares tuesday helm day, everyone gets a day off work.
15:07:35 <mattmceuen> Happy helm day everybody.
15:07:41 <jamesgu> congrats, portdirect!
15:08:06 <portdirect> thx guys, honestly following in mattmceuen 's footsteps will be a hard act to follow
15:08:31 <portdirect> and I'm really looking forward to leaning on his experience
15:08:31 <mattmceuen> I could go on and on about how qualified portdirect is for this, but since I sit next to him it would just get awkward
15:08:38 <portdirect> sometimes literally, if i can find him
15:08:57 <mattmceuen> TY portdirect, and it's been a pleasure and an honor serving as PTL this cycle
15:09:02 <srwilkers> cue the bromance music
15:09:13 * srwilkers plays a pennywhistle solo
15:09:14 * mattmceuen queasy
15:09:16 <portdirect> i think the only major change i'd like to see - is moar stickers
15:09:28 <mattmceuen> #denver
15:09:37 <john_W> like lethal weapon - all over again
15:09:37 <portdirect> and also lets try and get the 1.0 release done this cycle
15:09:44 <mattmceuen> ++
15:09:45 <evrardjp> o/
15:09:47 <portdirect> ^ how many times will we say this
15:10:05 <mattmceuen> this time it's for real
15:10:05 <portdirect> hey evrardjp o/
15:10:12 <mattmceuen> Ok
15:10:22 <mattmceuen> #topic Galera - where we at
15:10:29 <mattmceuen> Take it away srwilkers
15:10:37 <portdirect> thats me i think?
15:10:50 <srwilkers> yeah thats portdirect
15:10:52 <portdirect> (etherpad is being funny today)
15:10:54 <srwilkers> i hijacked his color somehow
15:11:00 <mattmceuen> good work srwilkers
15:11:04 <mattmceuen> portdirect all you
15:11:11 <portdirect> so - I've been working away on galera for some time
15:11:20 <portdirect> trying to use upstream mariadb image
15:11:29 <portdirect> and to be honest, it not working out
15:11:45 <portdirect> we can do it - but its a super ugly system of bind mounts and gaffer tape
15:11:53 <portdirect> (duct tape to you yanks)
15:12:15 <portdirect> as a result, I'd like to build an image with python and the k8s client in it
15:12:29 <portdirect> as this is honestly the only sane way to do it
15:12:50 <portdirect> ironicly, we started with a similar approach back in 2016
15:13:02 <mattmceuen> would you base it off the upstream mariadb image, or from scratch?
15:13:04 <portdirect> are people ok with using an 'osh' mariadb image?
15:13:12 <portdirect> would be based off upstream i think
15:13:20 <evrardjp> portdirect: that's more thing to carry
15:13:22 <portdirect> and then i'd try and push those changes up there
15:13:30 <portdirect> evrardjp: i know :(
15:13:37 <evrardjp> portdirect: I am curious if kolla or loci could help out there?
15:13:53 <portdirect> this is where loci would actually be great - but I think that convo belongs in the loci channel evrardjp
15:13:58 <portdirect> ++ lol
15:14:24 <portdirect> mariadb in bindep, kebernetes in python packages
15:14:29 <evrardjp> I think loci should be restricted to openstack building, but I meant both those tools must have the same issues.
15:14:44 <evrardjp> sorry for the interruption, go ahead
15:14:45 <srwilkers> i think rolling a sane image would be a better approach than what we had explored before (something like proxysql)
15:14:47 <portdirect> well we have been looking at building infra images with loci
15:15:04 <portdirect> SamYaple has done most of the groundwork there
15:15:05 <srwilkers> id rather maintain an image than have something like an extra chart helping out
15:15:30 <mattmceuen> I suppose it's technical debt either way
15:15:35 <srwilkers> it is
15:15:35 <mattmceuen> So better to do it "right"
15:15:39 <portdirect> yeah - I feel the overhead of managing an image, and sane chart is less than managing an insane chart...
15:15:51 <srwilkers> can confirm: did proxysql chart, was insane
15:15:53 <evrardjp> agreed there
15:16:30 <portdirect> ok - I'll get a poc up this week - and we can hash it out in gerrit?
15:16:54 <srwilkers> portdirect: yep
15:17:04 <evrardjp> I am fine with that -- please ping for reviews if need be
15:17:18 <portdirect> will do
15:17:28 <portdirect> would be great to get your eyes on it evrardjp
15:17:34 <mattmceuen> Thanks portdirect, evrardjp
15:18:06 <evrardjp> portdirect: I will probably eventually need to build images for it, so better know it the earlier, that's not really free : p
15:18:08 <evrardjp> hahah
15:18:56 <mattmceuen> Any other Galera thoughts before we move on?
15:19:42 <mattmceuen> ok
15:19:47 <mattmceuen> #topic Do we want to move the weekly team meeting to #openstack-helm ?
15:20:04 <mattmceuen> I believe I've heard this is the direction many projects are going
15:20:15 <mattmceuen> And it would be one less chat room to juggle
15:20:20 <portdirect> im on the fence here
15:20:28 <portdirect> but perhaps im just oldskool
15:20:29 <mattmceuen> What's the con, portdirect?
15:20:31 <evrardjp> if you have no problem with this room and timings, I'd say keep it
15:20:43 <portdirect> just noise
15:20:48 <mattmceuen> I'm fine with it either way
15:20:57 <evrardjp> yeah -- the more ppl you'll have, the more noise
15:21:28 <portdirect> and gerrit etc, whats quite nice is being able to chart to evrardjp in three places on diff topics at the same time
15:21:39 <mattmceuen> ahh, gotcha
15:21:53 <portdirect> *chat - charts on the brain
15:21:56 <evrardjp> also different logging
15:22:46 <srwilkers> yeah. i like having the meetings here, as it prevents off-topic conversations from popping up during the meeting
15:22:56 <mattmceuen> Yeah, we'd have to set up the meeting bot in #openstack-helm -- sounds like "a little bit of work" plus "not a lot of gain"
15:23:29 <mattmceuen> #agreed OSH <3 #openstack-meeting-5
15:23:49 <evrardjp> mattmceuen: the meetbot setup is not that hard. But I think it's better to keep things here :)
15:24:01 <evrardjp> just my opinion, and it's already agreed anyway!
15:24:06 <mattmceuen> Do not underestimate my laziness, evradjp
15:24:08 <mattmceuen> :D
15:24:31 <srwilkers> a fools folly
15:25:01 <mattmceuen> Alright moving on:
15:25:06 <mattmceuen> #topic Is there appetite for an ocata based armada gate?
15:25:32 <srwilkers> oh hey, this is me
15:25:56 <srwilkers> i was wanting to see if there was appetite for introducing an armada gate for deploying ocata
15:26:20 <srwilkers> largely because i want a gate that shows us running the oslo log fluentd handler/formatter for the openstack services
15:27:05 <portdirect> ^^ YES!
15:27:21 <mattmceuen> I am starving for an Ocata armada gate srwilkers
15:27:46 <srwilkers> this accomplishes two things: shows how we can use the handler/formatter with our LMA stack instead of relying on fluentbit picking up pod logs, and we can also use it to further refine the filters we run in fluentd (ie: tag specific log level events, remove duplicate entries, throw away tagged events we may not care about)
15:27:51 <mattmceuen> I think it pairs well with Ocata default images
15:27:56 <evrardjp> srwilkers: for the fluentd that's nice :)
15:28:32 <portdirect> srwilkers: i thinkl this would be great
15:28:48 <portdirect> it also shows a clear path to how you can use osh in a more production like way
15:28:51 <srwilkers> cool -- glad the receptions positive. been chewing on it for a few days
15:28:54 <portdirect> which we are really lacking atm
15:28:55 <srwilkers> portdirect: yeah, it does
15:29:32 <evrardjp> more gating is always positive when it doesn't block flows of commits
15:29:41 <evrardjp> :)
15:30:03 <srwilkers> i also hope to use this as an opportunity to explore using the logging components to gather the logs from this gate, as expanding the filters in fluentd can potentially make this easier
15:30:45 <srwilkers> so its a win/win in my mind (ie: here's how to use this in a more production oriented way, and here's what the LMA stack can provide you in the form of tangible output as part of the post-run jobs)
15:30:49 <srwilkers> anyway, that's all i really had
15:31:26 <mattmceuen> That's awesome
15:31:56 <mattmceuen> The gate scripts are good for learning and testing in isolation, but the armada manifst will be a much more reusable reference
15:32:15 <mattmceuen> Thanks srwilkers
15:32:40 <mattmceuen> Alright:
15:32:52 <mattmceuen> #topic PS needing review
15:33:12 <mattmceuen> Here are a few patchsets that would appreciate some careful scrutiny:
15:33:12 <mattmceuen> https://review.openstack.org/#/c/591730/ - Elasticsearch ingress
15:33:12 <mattmceuen> https://review.openstack.org/#/c/581152/
15:33:12 <mattmceuen> https://review.openstack.org/#/c/543958/ - Prometheus auth to multinode armada
15:34:18 <mattmceuen> Any others we'd like to add?
15:34:40 <srwilkers> yeah, one second
15:35:00 <srwilkers> actually, nevermind
15:35:08 <srwilkers> will rebase these and call out in the openstack-helm chat
15:35:46 <mattmceuen> Cool - we can add them retroactively to the agenda in case some folks check there
15:36:04 <mattmceuen> #topic Roundtable
15:36:57 <mattmceuen> Any additional topics all?
15:38:06 <mattmceuen> OK!
15:38:18 <mattmceuen> Thanks everyone - have a great day and see you back in #openstack-helm
15:38:21 <mattmceuen> #endmeeting