15:04:18 <portdirect> #startmeeting openstack-helm
15:04:19 <openstack> Meeting started Tue Sep  4 15:04:18 2018 UTC and is due to finish in 60 minutes.  The chair is portdirect. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:22 <openstack> The meeting name has been set to 'openstack_helm'
15:04:41 <portdirect> ok - think it's gonna be a quite one this week in the build up to the PTG
15:04:57 <evrardjp> o/
15:05:05 <portdirect> the agenda is here: https://etherpad.openstack.org/p/openstack-helm-meeting-2018-09-04
15:05:07 <jayahn> do we have a meeting schedule somewhere?
15:05:17 <jayahn> ptg meeting
15:05:26 <evrardjp> jayahn: an important clarification :)
15:05:42 <portdirect> jayahn: we have three days - wed to friday
15:05:49 <mattmceuen> https://web14.openstack.org/assets/ptg/Denver-map.pdf
15:05:52 <srwilkers> mattmceuen had an etherpad started with topics i think
15:05:55 <portdirect> https://www.openstack.org/assets/ptg/PTG-Dulin-Schedule.pdf
15:06:17 <portdirect> lol whould help if google cached the right one - thx mattmceuen
15:06:48 <evrardjp> do we know how many will show up?
15:07:02 <evrardjp> (guesstimate)
15:07:18 <jayahn> i am leaving on Friday, so I will be able to attend wed and thur
15:07:21 <mattmceuen> So far on the etherpad we have
15:07:21 <mattmceuen> Attendance:
15:07:21 <mattmceuen> Matt McEuen (mattmceuen)
15:07:21 <mattmceuen> Rich Wellum (rwellum)
15:07:21 <mattmceuen> Pete Birley (portdirect)
15:07:21 <mattmceuen> James Gu (jamesgu)
15:07:30 <mattmceuen> But I know that's not the full list :)
15:07:35 <portdirect> I think probably 5-10 people throughout the duration based on previous exp evrardjp
15:08:10 <portdirect> will you be able to spare some time from OSA?
15:08:11 <evrardjp> I'll try to come, but I will be spread very thin, so if we have a schedule, that would help me :)
15:08:31 <evrardjp> portdirect: OSA, Loci and others :)
15:08:40 <portdirect> #action portdirect to work out a schedule and send out by thurs this week
15:08:48 <evrardjp> thanks portdirect
15:09:23 <evrardjp> still on the PTG topic, what about having dinner together -- maybe hosted at the same location as OSA's team dinner?
15:09:40 <evrardjp> the more the merrier -- war stories to share
15:09:43 <portdirect> evrardjp: that would be great, do you have a venue yet?
15:09:56 <evrardjp> nope, previous one closed, but we have a short list.
15:10:42 <evrardjp> Will probably do that on Wednesday, as there is an activity planned by the foundation on Thursday (game night)
15:10:45 <evrardjp> iirc
15:11:01 <portdirect> that sounds great - I'll certainly try to make it regardless
15:11:03 <jayahn> what is OSA?
15:11:10 <srwilkers> jayahn: openstack-ansible
15:11:15 <jayahn> ah..
15:11:25 <evrardjp> jayahn: :)
15:11:29 <portdirect> we stole their abbreviation ;)
15:11:51 <jayahn> certainly
15:12:05 <evrardjp> We are not into fancy names, we are just caring about our stuff working and improving :p
15:12:17 <portdirect> ++
15:12:18 <SamYaple> so many names it went through
15:12:26 <evrardjp> SamYaple: :)
15:12:40 <evrardjp> SamYaple: final one is official!
15:12:50 <evrardjp> anyway
15:12:54 <SamYaple> agreed, its the best one. /derail
15:13:07 <evrardjp> sorry for the interruption. I have said everything I wanted to say on this topic :)
15:13:07 <portdirect> mattmceuen: you want to talk about the fun topic of copyright?
15:13:30 <mattmceuen> yessir
15:13:32 <mattmceuen> ok
15:14:04 <mattmceuen> So as I mentioned last week I changed the copyright assigned to the "OpenStack-Helm Authors" to the OSF
15:14:27 <mattmceuen> We'd discussed and I had it on good authority that that was the right path
15:14:41 <mattmceuen> However the larger OSF found some issues with that approach
15:14:44 <mattmceuen> So we reverted
15:15:18 <mattmceuen> We are back to OpenStack-Helm Authors, and everyone please follow your corporation's or your personal copyright policy as applicable when editing files going forward
15:15:28 <mattmceuen> that is all
15:15:58 <portdirect> honestly - I wish we did not have a (c) header in everyfile, as they are virtually meaningless - but such is life
15:16:02 <portdirect> thx mattmceuen
15:16:07 <srwilkers> portdirect: agreed
15:16:59 <evrardjp> mattmceuen: ideally we should review with -1 new files that don't hold the proper ownership
15:17:30 <portdirect> evrardjp: in your understanding should all files have the licence, and a (c) applied?
15:17:41 <mattmceuen> maybe - but, I think the idea of "proper ownership" differs depending on the author
15:17:53 <mattmceuen> i.e. certain companies have rules and others don't care?
15:17:54 <evrardjp> yes, with the individual (if individual work) or company name
15:18:07 <evrardjp> mattmceuen: one or the author, we cannot validate that
15:18:13 <evrardjp> or the other*
15:18:39 <evrardjp> but something that looks like having signed either a ICLA, or a company's equivalent
15:18:50 <evrardjp> well I am not a lawyer
15:19:01 <evrardjp> :p
15:19:04 <portdirect> thankfully none of us are
15:19:12 <portdirect> though mattmceuen's getting close :P
15:19:22 <mattmceuen> you take that back....
15:19:23 <evrardjp> but that's my understanding :) Maybe we should point to the foundation wiki
15:19:34 <evrardjp> portdirect: :)
15:19:39 <portdirect> we should prob have an effort to point to the wiki/docs in our own
15:19:50 <portdirect> you ok with getting that in the appropriate place mattmceuen ?
15:20:37 <mattmceuen> I will take a look and see if I can find it - if not I will seek evrardjp out since he is even closer to being a lawyer than me
15:21:09 <portdirect> awesome
15:21:26 <portdirect> ok to move on?
15:21:50 <evrardjp> ok
15:22:04 <portdirect> #topic LMA - Hows it going?
15:22:11 <portdirect> srwilkers: think the floors yours
15:22:16 <srwilkers> oh hey
15:22:23 <srwilkers> LMA's coming along -- have a few things in flight
15:22:50 <srwilkers> now that ceph is living on openstack-helm-infra, we can properly exercise the work ive been doing with getting elasticsearch to use the ceph radosgw s3 api for snapshots
15:22:58 <srwilkers> patchset can be seen here: https://review.openstack.org/#/c/559417/
15:23:23 <srwilkers> notably: http://logs.openstack.org/17/559417/46/check/openstack-helm-infra-dev-deploy-ceph/6405246/primary/pod-logs/osh-infra/elasticsearch-register-snapshot-repository-rphtk/register-snapshot-repository.txt
15:23:28 <srwilkers> so that's exciting
15:23:47 <srwilkers> also
15:24:35 <srwilkers> we've still got the changes in flight for pruning the metrics we gather with prometheus by default -- would like to get these shored up properly next week in denver, along with getting some in-person feedback on the docs ive been writing up
15:24:47 <srwilkers> along with the list requested wrt the exporters and metrics we've got across the platform
15:25:00 <srwilkers> jayahn: i know you mentioned you all would look at prometheus
15:25:11 <srwilkers> jayahn:  any luck there yet?
15:25:15 <jayahn> yes, we do
15:25:46 <mattmceuen> that's awesome srwilkers
15:25:56 <jayahn> we reviewed list of metrics from most of exporter, and now reviewing some of alert rules..
15:26:16 <srwilkers> any feedback yet?  or still in the process of reviewing it?
15:26:51 <jayahn> I have documents on wiki, can share if I can find a place to copy "wiki docs" to
15:27:14 <srwilkers> jayahn: awesome
15:28:02 <srwilkers> im looking forward to talking more about it at the PTG next week
15:28:10 <srwilkers> that's most of what i've got for the LMA stuff
15:28:10 <jayahn> sure thing
15:28:20 <portdirect> would having a dedicated LMA session at ptg help here?
15:28:30 <portdirect> say a half day?
15:29:04 <srwilkers> portdirect: it would
15:29:23 <srwilkers> portdirect: ill work on getting topics added to the etherpad as a starter if that helps
15:29:37 <mattmceuen> Setting aside a half day on our schedule might also help bring in anyone outside the team who wants to talk LMA
15:30:19 <portdirect> #action srwilkers: Set aside 0.5 days for LMA review and planning at ptg (also produce outline for topics/structure)
15:30:59 <srwilkers> i know there's some talk on the ML wrt fluentd and triple-o
15:31:12 <srwilkers> but can deal with that later
15:31:39 <portdirect> lets find out what time they are free, always good to get some extra input/help
15:31:44 <portdirect> we done here?
15:31:50 <srwilkers> portdirect: yep
15:32:20 <portdirect> #topic push for 1.0
15:32:32 <portdirect> (i added this cheekily)
15:32:52 <mattmceuen> keep on pushing!
15:33:05 <portdirect> there is a lot of low-hanging, but disruptive items on out 1.0 list of tasks
15:33:12 <portdirect> eg moving charts to the correct repos
15:33:25 <portdirect> I started this, but it would be great if someone could give me a hand
15:33:37 <portdirect> i think its pretty much essential that we have this done by monday
15:34:05 <portdirect> any volunteers to help?
15:34:52 <srwilkers> portdirect: i'll help
15:35:18 <srwilkers> portdirect: ceph moved pretty quick.  if we can get ceph moved quickly, i can't imagine anything else being super painful
15:35:44 <portdirect> great - thanks srwilkers
15:35:59 <portdirect> lets get that done tonight/tomorrow
15:36:04 <srwilkers> portdirect: works for me
15:36:19 <portdirect> so - and moving full circle
15:36:31 <portdirect> #topic Reminder:  PTG Etherpad
15:36:34 <portdirect> ;)
15:36:42 <portdirect> https://etherpad.openstack.org/p/openstack-helm-ptg-stein
15:37:14 <portdirect> please can people add anything they want discussed here by wed
15:37:34 <portdirect> and I'll try and get a slot (at least penciled) in
15:38:36 <srwilkers> yep.  i'll flesh out the particulars for the LMA stuff.  i've got some basics up there for placeholders
15:40:46 <portdirect> and with that, im fresh out of topics
15:41:10 <portdirect> as always we have a few reviews that could do with some eyes:
15:41:25 <portdirect> https://www.irccloud.com/pastebin/7YRs6Fku/
15:41:39 <portdirect> please go forth and click
15:42:03 <portdirect> any more people want to add?
15:42:10 <evrardjp> missing a line?
15:42:31 <evrardjp> sorry my bad
15:43:01 <portdirect> ok
15:43:08 <portdirect> #topic Roundtable
15:43:37 <portdirect> I've got one
15:44:16 <portdirect> I'm currently looking at security in OSH - and comparing this to the openstack security guide
15:45:03 <portdirect> a lot of this is not quite applicable in a k8s world
15:45:37 <portdirect> evrardjp: (or anyone else) how have you handled deltas from the 'canonical' source in practice?
15:46:08 <portdirect> I had thought of making some patches over there - or would they best be kept 'in tree' as amendments to the guide?
15:46:42 <evrardjp> portdirect: could you further explain what you mean?
15:47:28 <portdirect> yeah - for example there is a standard mask requested for config files
15:47:45 <portdirect> to prevent modifiction and being read by non-service users
15:47:49 <evrardjp> even if the technical aspects might be different, some ideas of the security guide still applies
15:47:52 <portdirect> ^ this is hard to do in k8s
15:48:07 <portdirect> but we can (and do) mount the config files read-only
15:48:33 <portdirect> and also enforce only the service user to be able to run things in the container (this is in flight atm)
15:49:01 <portdirect> so if we had an audit that followed the 'letter' or the security guide, we would fail
15:49:12 <evrardjp> I think the project can come up with a series of internal procedures for reviewing and code submitting -- and that's up to the project. We can then align with the evolution of the technology or expertise?
15:49:12 <portdirect> though we would meet the intent i think.
15:49:55 <evrardjp> portdirect: oh many projects would probably fail,but failure is not a problem, the idea is to go forward
15:50:43 <evrardjp> I am not sure if we should debate this in the meeting, but I am pretty sure some deltas can be documented in the project, and we iterate?
15:50:57 <portdirect> sounds great evrardjp
15:51:11 <portdirect> I'll try and formulate my thoughts better, and bring them to the ptg ;)
15:51:15 <evrardjp> for the technicalities, I am still new, and I will be focusing on that in the future, I just don't know when yet.
15:51:38 <portdirect> any one else have anything they want to bring up?
15:52:06 <srwilkers> im godo
15:52:08 <srwilkers> *good
15:52:19 <portdirect> nice
15:52:27 * portdirect goes to find endmeeting command
15:52:52 <portdirect> #endmeeting