15:06:33 <portdirect> #startmeeting openstack-helm
15:06:35 <openstack> Meeting started Tue Sep 25 15:06:33 2018 UTC and is due to finish in 60 minutes.  The chair is portdirect. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:36 <jamesgu__> o/
15:06:38 <openstack> The meeting name has been set to 'openstack_helm'
15:07:09 <portdirect> so this week is pretty light on the agenda: https://etherpad.openstack.org/p/openstack-helm-meeting-2018-09-25
15:07:19 <portdirect> feel free to add to it :)
15:07:32 <portdirect> #topic rollcall
15:07:35 <portdirect> o/
15:07:47 <mattmceuen> o/
15:07:55 <srwilkers> o/
15:08:09 <lamt> o/
15:09:05 <portdirect> #topic Docs Repo
15:09:30 <portdirect> so I'm a bit behind on this, but I'll be getting a ps up to infra today/tomorrow to kick of the docs repo
15:09:31 <evrardjp> o/
15:09:48 <evrardjp> great news
15:09:51 <portdirect> and then the work can begin :)
15:10:01 <mattmceuen> nice
15:10:20 <portdirect> jay is not here today but I'm hoping to get another name for the korean editors
15:10:39 <evrardjp> portdirect: did you ask ianychoi ?
15:10:42 <portdirect> and both mattmceuen and srwilkers 's expert eyes will initially take care of the engish side
15:10:57 <evrardjp> he would be great help with the knowledge of korean + zanata
15:10:57 <portdirect> evrardjp: that is an EXCELLENT idea
15:11:06 <portdirect> I'll hound him straight after this
15:11:32 <evrardjp> probably at the end of your day too, as he might be sleeping during those hours
15:11:36 <portdirect> #action portdirect to pester ianychoi about becoming a documentation editor
15:11:38 <mattmceuen> ++
15:12:12 <portdirect> ok - so i think the path is clear here? any further comments?
15:12:18 <evrardjp> sorry I didn't want to enroll him without asking him, I just mean he could be a great person/asset in this case
15:12:44 <portdirect> evrardjp: all good, I'm just being opportunistic ;)
15:14:16 <portdirect> #topic Gates
15:14:46 <portdirect> so we have made a tiny bit of progress on the gates
15:15:13 <portdirect> but i wonder if this week we may want to grab some of the low hanging fruit
15:15:29 <portdirect> and without changing the gate too much
15:15:43 <portdirect> get some of the horrible ansible rats nest un check
15:16:02 <evrardjp> so I am sorry on that part
15:16:09 <portdirect> i made a quick wip here: https://review.openstack.org/#/c/602682/
15:16:10 <evrardjp> I said I wanted to work on that this week
15:16:27 <portdirect> evrardjp: no worries dude
15:16:32 <evrardjp> I realise with my upcoming holidays and my current work I couldn't help (yet!)
15:16:52 <portdirect> now your just being mean, what are these holidays of which you speak?
15:17:24 <portdirect> anything else to add on this?
15:17:27 <mattmceuen> If you're visiting saint louis for any reason we have an office + desk you can visit >:-)
15:17:42 <srwilkers> :O
15:17:47 <evrardjp> haha
15:18:07 <portdirect> evrardjp: they told me the same thing. Its a trap!
15:18:08 <evrardjp> I will review this patch and suggest things, but this is indeed a good start
15:18:23 <evrardjp> portdirect: duely noted
15:18:25 <srwilkers> portdirect: i mean, i wasnt going to be the one to say it
15:18:42 <portdirect> ok - move on?
15:18:46 <evrardjp> yup
15:18:58 <evrardjp> oh
15:19:01 <portdirect> #topic Mariadb, the saga continues
15:19:04 <evrardjp> next time don't hesitate to add me to reviews
15:19:17 <evrardjp> for these kind of things -- and ping. I don't mind :)
15:19:28 <portdirect> will do
15:19:41 <portdirect> so I've finally got round to having a look at the mariadb chart
15:19:59 <portdirect> and ended up pretty much completely redoing it: https://review.openstack.org/#/c/604556/
15:20:14 <portdirect> was nice to write my 1st python again in two years
15:20:32 <portdirect> it uses a configmap to store state of the cluster
15:20:59 <srwilkers> its pretty nifty - no complaints thus far
15:21:09 <portdirect> https://www.irccloud.com/pastebin/e9lXRUCY/
15:21:46 <portdirect> and ive been hammering it with mysqlslap
15:21:52 <mattmceuen> that's awesome
15:21:59 <portdirect> theres a few more things i need to account for
15:22:14 <portdirect> * setup vars for timers and set sane nyquest ratios between them
15:22:14 <portdirect> * get xtrabackup back up
15:22:14 <portdirect> * deal with potential for split brains (in follow up ps)
15:22:14 <portdirect> * deal with chart upgrade senario
15:22:14 <portdirect> * deal with chart removal and redeploy senario
15:22:14 <portdirect> * add sigterm handler
15:22:28 <portdirect> but i think its ready for some gentle test rides and reviews
15:23:09 <evrardjp> great work
15:23:11 <portdirect> dealing with the potential for split brains will require some work on the proxy infront of the cluster
15:23:17 <portdirect> so i think that will come as a follow up
15:25:03 <portdirect> i know there is a wip on it, but my python is so rusty - feel free to provide any course correction
15:25:21 <portdirect> and with that
15:25:37 <portdirect> #topic open discussion
15:27:08 <evrardjp> I have a topic for open discussion
15:27:21 <portdirect> the floor is yours
15:28:21 <evrardjp> should we care about reducing the packages installed on host? If I am the only one to care, I can deal with it differently.
15:29:05 <portdirect> evrardjp: we certainly should
15:29:09 <evrardjp> ok
15:29:10 <mattmceuen> for doing the kubeadm-based install / gates, or something else evrardjp?
15:29:39 <evrardjp> I am assuming everywhere we do things on hosts.
15:29:40 <portdirect> ^^ by packages i assume you mean python ones for kubeadm playbooks?
15:29:56 <portdirect> (and the support for them)
15:29:59 <evrardjp> I should not have said packages as this is confusing
15:30:10 <evrardjp> let me rephrase
15:30:36 <evrardjp> In gates we have to do what we have to do -- i.e. setting k8s up, and maybe set storage up with ceph.
15:31:04 <evrardjp> I assume this can be done as "gating" functions, and convenience for users
15:31:21 <evrardjp> so shouldn't the rest be contained, or limited?
15:31:46 <evrardjp> My point would be reducing the writes to /tmp, reducing the pip packages installed, and others I have yet to see
15:32:09 <portdirect> ah gotcha
15:32:10 <evrardjp> if we say it's a guideline of something we must avoid in the future, we can regularily clean things up when something shows up
15:32:25 <portdirect> yeah I hope that improved docs will go a long way towards this
15:32:25 <evrardjp> it has a positive impact on host maintenance and security
15:32:38 <portdirect> as our docs essentially only describe what we do in the gates atm
15:32:47 <evrardjp> correct
15:32:58 <portdirect> and we have nothing that covers a 'production' deployment
15:33:25 <portdirect> I would never deploy OSH as we desribe today in a real senario
15:33:28 <evrardjp> I think that's what gates should be testing :D
15:33:40 <portdirect> agreed - to a point
15:33:43 <evrardjp> that is interesting and I'd like to discuss this in the channel
15:33:51 <portdirect> we need the gates to both cover basic functional testing
15:34:01 <portdirect> and richer ones that bring up realistic deployment
15:34:19 <evrardjp> my point in this open discussion was to know the alignment on the "avoid installing things on host"
15:34:20 <mattmceuen> where "richer" = "bigger"? :)
15:34:48 <portdirect> mattmceuen: not always :) I;m thinking more using armada to decalre the deployment
15:34:48 <evrardjp> portdirect: agreed there -- maybe I should have said testing.
15:34:55 <portdirect> and having things like tls in place
15:34:55 <mattmceuen> gotcha
15:35:22 <portdirect> what im getting out of this
15:35:23 <evrardjp> but we are generally in agreement, so the technical details can go into each review
15:35:29 <mattmceuen> ++
15:35:58 <portdirect> should we get an etherpad to jot down this, so by next meeting we can dicuss a path forward?
15:36:17 <portdirect> i think we are all aligned, just need to work out how to articulate it
15:36:58 <evrardjp> yeah it doesn't matter it can be in the docs and we'll slowly move towards it, we can keep that in mind in reviews
15:37:21 <portdirect> wfm
15:37:49 <evrardjp> thanks
15:38:01 <portdirect> any other topics?
15:38:13 <portdirect> srwilkers: you scare me when you are quite
15:38:19 <srwilkers> >:)
15:38:46 <portdirect> ok to wrap up
15:39:16 <portdirect> thanks everyone, dont spend the next 21 mins to recklessly
15:39:17 <portdirect> #endmeeting