15:02:41 <portdirect> #startmeeting openstack-helm
15:02:42 <openstack> Meeting started Tue Jan 22 15:02:41 2019 UTC and is due to finish in 60 minutes.  The chair is portdirect. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:45 <openstack> The meeting name has been set to 'openstack_helm'
15:02:51 <portdirect> lets give it a few mins for people to join
15:02:54 <mattmceuen> o/ GM
15:03:03 <howell> o/
15:03:03 <portdirect> Agenda here: https://etherpad.openstack.org/p/openstack-helm-meeting-2019-01-22, add away :D
15:04:14 <georgk> o/
15:04:33 <dimitris_> o/
15:04:58 <dwalt> o/
15:05:06 <nick_kar> o/
15:05:53 <portdirect> ok - lets kick off
15:06:06 <portdirect> #topic docs-repo
15:06:38 <portdirect> so theres been some great work tring to the the docs repo up and running - though im wondering if we are trying to run, before we walk
15:06:49 <portdirect> I have given this a -2 https://review.openstack.org/#/c/625853/5
15:07:03 <portdirect> though am prepared to be told thats not appropriate
15:07:47 <portdirect> i thought we would do this in a phased approach 1) bring over exisiting docs un altered, 2) restructure
15:07:57 <portdirect> though this attempts to do both in one pass
15:08:18 <portdirect> which makes it very hard (at least for me) to see whats changed etc
15:08:27 <portdirect> so more process than intent ;)
15:08:55 <portdirect> not sure if any of the people working on that are here, so i may just be shouting incoherently atm :D
15:09:04 <mattmceuen> +1 for splitting to two steps - that makes sense to me too
15:10:21 <portdirect> ok - lets move on unless anyone else has anything to add - seems bad to discuss to much without Jaesang Lee around - whos put a lot of effort into this
15:10:41 <portdirect> #topic Helm 3
15:10:56 <portdirect> so howell has been doing some poc work with helm 3
15:11:09 <portdirect> and doing cool things like deploying memcached with it
15:11:21 <evrardjp> portdirect: mmm
15:11:28 <portdirect> howell: you able to give a update on where helm3 is? eg lua etc
15:11:46 <howell> Sure
15:12:08 <howell> last i checked, it's stil quite a ways down the road
15:12:16 <evrardjp> on previous topic I believe it's easier to do the things right in the proper place first, then increase the amount of content to match the proper structure
15:12:30 <evrardjp> but ok
15:12:51 <howell> the lua library API is still being developed, so lua hooks aren't working at all yet
15:12:58 <howell> https://github.com/helm/helm/issues/5084
15:13:46 <jayahn> o/
15:13:51 <howell> further, there isn't much of a timeline on when things will start to be useable :/
15:14:11 <mattmceuen> that's interesting howell - does that mean helm 3 is not usable at all now, or just usable in more simple use cases?
15:14:15 <mattmceuen> o/ jayahn!
15:14:39 <howell> it's usable. it is pretty limited though
15:15:21 <portdirect> howell: at this point is the same (or greater) sprig version supperted as helm2?
15:15:35 <portdirect> *supported
15:16:01 <howell> i beleive so, but i'd have to double check
15:16:38 <portdirect> i think that would be awesome - then once a alpha binary starts being published we could explore again
15:16:46 <mattmceuen> evrardjp: given the state of helm 3, sounds like doing this POC-style is the right way/ right place to do this, if it's not ready to introduce into OSH.  Do you disagree?
15:16:55 <portdirect> though I think you are planning on getting much more involved upstream there? ;)
15:17:12 <howell> planning on it :)
15:18:10 <evrardjp> mattmcemaI was talking about previous topic, I can't judge on that helm3 part. Did you really want to ping me there? :)
15:18:30 <evrardjp> mattmceuen: *
15:18:45 <portdirect> i think we can circle back to that (docs) at the end of the meeting if jayahn is around?
15:18:53 <evrardjp> portdirect: lgtm
15:19:02 <jayahn> i will be around
15:19:19 <portdirect> nice - all done on helm3 - aka the future of OSH
15:19:23 <evrardjp> mattmceuen: helm-tng interests me though :)
15:19:34 <mattmceuen> Ah - I gotcha now evrardjp.  Mis-parsed ya :)
15:20:03 <portdirect> so onwards to the next topic - this meeting should perhaps be renamed the howell show this week
15:20:11 <evrardjp> :)
15:20:13 <howell> haha :)
15:20:19 <portdirect> #topic kubernetes-entrypoint - whats going on there?
15:20:37 <howell> so I've been making some updates to kubernetes-entrypoint
15:20:37 <portdirect> howell: i think you have been doing some k8s-entrypoint work recently?
15:20:56 <howell> Firstly, the tool now supports Custom Resource Dependencies.  Custom Resource Depedendencies use arbitrary key and "desired" value pairs.
15:21:38 <howell> Secondly, I've added an option to print all unresolved dependendencies as machine-readable JSON.
15:21:58 <portdirect> ok - so lets peel that back a bit
15:22:07 <portdirect> CRD support, what and why?
15:22:09 <evrardjp> howell: "the tool" is not easy to understand for people without context, but that's maybe because I am new to this project
15:22:14 <howell> right. getting ahead of myself
15:22:17 <srwilkers> o/
15:22:19 <srwilkers> sorry im late
15:22:28 <portdirect> howell: i think evrardjp has a good point
15:22:42 <portdirect> we have been in osh so long - we forget the very basic concepts
15:22:51 <portdirect> lets start with what is k8s-entrypoint
15:22:58 <portdirect> and how do we use it today in osh
15:23:01 <howell> so kubernetes-entrypoint is used to wait on dependencies
15:23:39 <howell> that is, if a pod A is dependendent on pod B, kubernetes-entrypoint will prevent A from starting until B is finished
15:24:00 <portdirect> we use this concept to orchestrate everything in osh
15:24:16 <portdirect> driven by the dependences section and a helm toolkit function
15:24:31 <portdirect> lets take a simple service - eg keystone
15:24:52 <portdirect> https://github.com/openstack/openstack-helm/blob/master/keystone/values.yaml#L104-L114
15:24:53 <evrardjp> yup I've seen it around, but I think the important part is that it's our own thing, and that we have to maintain things forward. If deployers need to be aware of changes,we need to notify those in meetings, which is what's happening here
15:25:04 <evrardjp> correct?
15:25:10 <portdirect> evrardjp: its not our own thing
15:25:15 <portdirect> its intels
15:25:20 <evrardjp> ok
15:25:37 <srwilkers> it's been around awhile, we just take advantage of it and provide updates along the way
15:25:37 <evrardjp> thanks for the clarification!
15:25:40 <portdirect> we, stackentes, and kolla-k8s all uses it as the foundation for openstack on k8s
15:25:50 <howell> up until recently, the tool has supported pods, services, daemonsets, and a handful of other kubernetes builtins
15:25:53 <portdirect> anyway back to the 101
15:26:13 <portdirect> in the link i put above, you see the deps for the keystone api service
15:26:45 <portdirect> it needs: a migrated db, and a lod of other things done - which we do via k8s jobs
15:27:12 <portdirect> and also some services to be up and ready - which are, suprise sprise, services in a k8s
15:27:14 <portdirect> world
15:27:35 <portdirect> the container runs as in init container in each osh pod
15:27:48 <portdirect> and waits for the jobs to be complete, and services to be up before exiting
15:27:56 <portdirect> thus orchestrating across the cluster
15:28:02 <portdirect> back to you howell
15:28:11 <evrardjp> thanks for that :)
15:28:39 <howell> anyway, i've recently added support for CRDs
15:29:05 <howell> that is, "wait until some arbitrary key has some arbitrary value"
15:29:12 <howell> *of a crd
15:29:53 <portdirect> for those that may not know - what produces/works with crds in k8s?
15:30:00 * portdirect buzzword incomming
15:30:06 <howell> operators
15:30:34 <howell> so it will work with operators such as rook
15:30:35 <evrardjp> :)
15:30:50 <portdirect> and anything else ;D
15:30:52 * mattmceuen imagines movie preview voice saying "operators"
15:30:55 <georgk> one quick question in this regard:
15:31:04 <evrardjp> howell: good job there
15:31:06 <georgk> does this not overlap with Armada in some functionaly?
15:31:16 <georgk> also: noob question
15:31:20 <jayahn> howell: that would be helpful!
15:31:28 <howell> it'll also work nicely with creatign DAGs with argo
15:31:35 <howell> thanks :)
15:31:56 <portdirect> and howell is planning to prototype that for openstack service management :D
15:32:01 <evrardjp> howell: I will ask a lesson on argo in the #openstack-helm channel, I took enough time already.
15:32:15 <portdirect> so it will be pretty exciting to see that progess, and if it has legs
15:33:32 <evrardjp> sorry to ask one more question there howell: What is the idea behind bringing that? I mean it's obviously a very positive change, but there is probably something you have on your mind that I cannot see on the roadmap
15:34:20 <howell> it's not on the roadmap, because we aren't sure if it's a good idea or not yet
15:34:50 <evrardjp> ok, for the moment it's just opening possible doors
15:34:56 <portdirect> exactly
15:34:58 <howell> yes
15:35:12 <evrardjp> should that change, I think it's worth mentioning in a meeting
15:35:22 <portdirect> oh - 100% it would be a big change
15:35:36 <portdirect> but also - untill we try it - have no idea if it will be any good
15:35:57 <portdirect> so very early days - and i think best to do these things fully in the open
15:36:20 <evrardjp> agreed
15:36:24 <portdirect> so we can collectivly evaluate approaches
15:36:33 <portdirect> k8s is still young, and evolving fast
15:36:44 <jayahn> we are talking about trying argo? (just want to followup)
15:37:03 <portdirect> talkign about a very simple poc
15:37:13 <portdirect> i think 'pre-trying' at this stage
15:37:19 <jayahn> okay, :)
15:37:37 <portdirect> one thing that has come out of this though that we clearly need to do a better job on
15:37:38 <portdirect> #action anyone document k8s-entrypoint
15:38:28 <howell> i can work on documentation if needed
15:38:54 <portdirect> howell: i think you would be a great person to do that
15:39:10 <portdirect> alon with evrardjp, as he gets openstack requirements like very few people i know
15:39:20 <portdirect> *along
15:39:41 <evrardjp> I am fine with helping on that side with you howell
15:39:54 <portdirect> georgk: not forgotten your question
15:40:11 <georgk> portdirect: that´s fine, we can take it later
15:40:14 <portdirect> none of this really overlaps with armada
15:40:48 <portdirect> as they have two different objectives, k8s entrypoint deals with deps etc within a chart, while armada orchestrates charts themselves
15:41:35 <portdirect> its this loose coupling, that allows osh (and those that came before it) to both be very resilient and self contained at a service level
15:42:01 <georgk> portdirect: ok, got it. Thanks
15:42:05 <portdirect> while armada allows the deployment and configuration of these serices to be tied together in a chohertent fasion
15:42:25 <evrardjp> very good patterns
15:42:30 <portdirect> (and once you are there, the rabbit hole opens - deckhand alows the config to be managed etc...)
15:43:13 <jayahn> yeah.
15:43:19 <portdirect> howell: one last thing - you also added machine readable output to k8s entrypoint
15:43:51 <howell> yes. k8s-entrypoint currently has some human-readable logging output on stdout
15:44:00 <portdirect> the hope here is that tooling - eg lma will be able to tap into this and give faster/simpler insight into the state of the cluster
15:44:57 <evrardjp> that's interesting
15:45:03 <portdirect> so operators can at a glance see why a service, such as say glance, is not working
15:45:48 <srwilkers> i see what you did there
15:45:59 * portdirect is here all week
15:46:06 <howell> booo
15:46:12 <portdirect> ok to move on?
15:47:04 <georgk> :q
15:47:16 <portdirect> #topic Reminder: Open Infra Summit talk  submissions due 11:59 PT tomorrow!
15:47:29 <mattmceuen> ^^
15:47:30 <portdirect> thanks mattmceuen for reminding us
15:47:35 <jayahn> yeah, thank for the reminder.
15:48:24 <evrardjp> there should be forum sessions to organise after the call for summit presentations, right?
15:48:40 <evrardjp> then ofc the ptg sessions
15:48:44 <jayahn> usually, i remember
15:48:46 <srwilkers> yeah
15:48:53 <jayahn> 6 days..
15:48:54 <portdirect> evrardjp: yup
15:49:05 <portdirect> really happy to see the events back to back
15:49:12 <srwilkers> me too
15:49:20 <portdirect> almost like the forum
15:49:26 <portdirect> though i better not say that out loud
15:49:35 <srwilkers> hush hush
15:50:05 <portdirect> i'm planning on submitting a workshop with alanmeadows
15:50:33 <jayahn> first week of May.. really worst timing ever for Korean...
15:50:38 <portdirect> where we use some airship components along with osh to bring up and a small cloud
15:50:44 <portdirect> jayahn: how come?
15:51:03 <evrardjp> I guess holidays?
15:51:15 <jayahn> first week of May involves labor day (holiday) and children's day (also holiday)
15:51:40 <evrardjp> we have labor day too here. We can complain together there jayahn
15:51:41 <jayahn> usually k-12 gives short vacation for the children
15:51:49 <portdirect> jayahn: bring them
15:51:59 <evrardjp> I will give you a beverage of your choice to forget it
15:52:08 <jayahn> lol
15:52:24 <portdirect> anyway - should we revisit docs for a bit?
15:52:27 <srwilkers> i'm looking forward to the timing -- i thought about passing on flying out there and riding a motorcycle out there instead
15:52:32 <srwilkers> and taking a few days to ride around the rockies
15:52:46 <jayahn> docs
15:52:52 <portdirect> #topic docs round 2
15:53:10 <jayahn> i thought restructuring was an important priority on doc-repo.
15:53:18 <portdirect> so - the original plan i thought was to work on struture, then bring content over from the existing repo,a nd the great stuff skt has done
15:53:30 <jayahn> and, somewhat agree on evrardjp
15:53:32 <portdirect> it looks like thigs have jumped right in
15:54:00 <portdirect> so this morning i proposed that if the desire is to get a large body of content in - this should be done as it
15:54:05 <portdirect> *as is
15:54:11 <portdirect> and then resutureing in a follow on ps
15:54:40 <portdirect> an alternative approach would be to have a ps laying out the struture, and then populating with content once we have that down
15:55:07 <portdirect> im just worried that as it stands today - theres too many parts moving at once to sanly review
15:55:11 <portdirect> *sanely
15:55:38 <jayahn> okay, that probably true. (theres too many parts moving at once to sanly review)
15:56:20 <portdirect> so - are you ok with getting a ps up to simply define the desired layout
15:56:29 <evrardjp> so what I did when I refactored large chunks of content in the docs of a project, I pretty much did the structure with no document in it, then quickly add, topic by topic, in the right place
15:56:31 <portdirect> and once we have that - start filling it with content?
15:56:48 <portdirect> evrardjp: i think that approach makes most sense
15:56:57 <jayahn> okay, i do agree on that
15:57:13 <jayahn> having ps up to define the desired layout first
15:57:32 <evrardjp> on top of that all your downstream content would be easily importable patch per patch...
15:57:46 <evrardjp> jayahn: you want me to push that structure up?
15:58:23 <jayahn> evrardjp: yeap, that would be great :)
15:58:27 <evrardjp> I'd rather let you do it:p
15:58:28 <evrardjp> oh ok
15:58:35 <evrardjp> I guess I am volunteer then
15:58:37 <jayahn> ah.. we can do it as well,
15:59:06 <jayahn> but i guess anyone available to do it can do it.
15:59:07 <evrardjp> let's sync on the chan then
15:59:15 <portdirect> hey - about to run out of time
16:00:04 <portdirect> see you all in the channel
16:00:08 <portdirect> #endmeeting