15:00:09 <srwilkers> #startmeeting openstack-helm
15:00:09 <openstack> Meeting started Tue Feb 19 15:00:09 2019 UTC and is due to finish in 60 minutes.  The chair is srwilkers. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:13 <openstack> The meeting name has been set to 'openstack_helm'
15:00:20 <srwilkers> o/
15:00:44 <MegHeisler_> \o
15:00:51 <todin> hi
15:00:55 <georgk> hi
15:01:08 <srwilkers> hey everyone -- let's give it a few minutes for folks to roll in
15:01:11 <srwilkers> here's the etherpad for today: https://etherpad.openstack.org/p/openstack-helm-meeting-2019-02-19
15:01:28 <srwilkers> feel free to fill it in this morning -- portdirect is a little under the weather today, so i'm going to stand in for him
15:04:39 <srwilkers> let's go ahead and get started
15:04:57 <srwilkers> #topic request for input on ovs-dpdk
15:05:04 <srwilkers> georgk: floors yours
15:05:13 <georgk> thanks
15:05:28 <georgk> I'd like to get some feedback on best practises for the following
15:05:51 <georgk> I am working on DPDK support for OVS and as part of that, the OVS pod needs to do some host OS config
15:06:02 <georgk> like binding and unbinding NICs, loading drivers, etc
15:06:19 <georgk> kolla-ansible already has a script for this in place
15:06:29 <georgk> https://github.com/openstack/kolla-ansible/blob/master/tools/ovs-dpdkctl.sh
15:06:37 <mattmceuen> o/
15:06:49 <dwalt> o/
15:06:49 <georgk> however, this script installs a systemd daemon on the host OS which doies this
15:06:55 <GregWaines> o/
15:07:07 <georgk> my opinion is that this should be avoided and instead only be done from within the init container
15:07:55 <georgk> so, this is basically it
15:08:08 <georgk> I wanted to get feedback from the community before going forward with the implementation
15:08:21 <georgk> I hope my question became clear
15:09:18 <srwilkers> i think that's the correct approach, but full disclosure -- im not a great source of information for the networking stuff like dpdk.  however, for handling things at the host level, an init container makes the most sense in my mind
15:09:46 <srwilkers> i'd say move forward with it, put it up for review, and those who are more familiar with it can weigh in
15:10:06 <srwilkers> since we're a bit light on attendance today, i don't want to hold up your work any more pending discussions
15:10:18 <georgk> :-)
15:10:34 <georgk> make sense, I'll push a patch
15:11:03 <srwilkers> awesome
15:11:36 <srwilkers> anything else here georgk? or anyone else?
15:11:53 <todin> I could review the patch, I know quite a bit about dpdk
15:12:16 <srwilkers> that'd be awesome todin :)
15:12:29 <GregWaines> I have a quick topic / request
15:13:18 <georgk> todin thank you!
15:13:25 <srwilkers> okay GregWaines
15:13:29 <GregWaines> I am interested in getting some openstack-helm cores to review a new spec
15:13:35 <GregWaines> https://review.openstack.org/#/c/636223/
15:13:42 <srwilkers> #topic spec for private registry use
15:13:43 <GregWaines> Spec: Support docker registry with authentication turned on
15:14:04 <GregWaines> Looking for input on the proposed approach
15:14:16 <srwilkers> awesome - thanks for bringing this up GregWaines
15:15:18 <GregWaines> ( realize that this would be for T release ... but interested in getting some feedback sooner rather than later )
15:16:04 <GregWaines> are there some specific openstack-helm members/cores that I should specifically invite for the review ?
15:16:13 <srwilkers> GregWaines: absolutely -- i'll add this to my review list today
15:16:21 <GregWaines> perfect thanks
15:16:26 <alanmeadows> I'll take a look as well
15:16:35 <GregWaines> :)
15:16:45 <roman_g> I've seen it and overall liked it
15:17:18 <GregWaines> thanks for the help
15:17:21 <srwilkers> no problem
15:17:47 <srwilkers> anything else on this topic?
15:17:57 <GregWaines> nope i'm good
15:18:10 <srwilkers> #topic reviews
15:18:31 <srwilkers> not sure who listed the first point here, as there's no corresponding handle in the attendees section
15:19:44 <srwilkers> this is related to the mailing list thread found here: http://lists.openstack.org/pipermail/openstack-discuss/2019-January/002248.html
15:21:53 <srwilkers> i'd like to read through this and follow up next week with a discussion when we're a bit more attendee-heavy, so we can put our heads together and work on a path forward here that's more inclusive, both of the current core reviewer team and of those who requested feedback
15:22:34 <srwilkers> #action srwilkers to follow up next week with mailing list discussion thread wrt review turnaround
15:23:14 <srwilkers> todin: i see you've also got a request for reviews for https://review.openstack.org/#/c/567468/48
15:23:21 <srwilkers> thanks for resurrecting that change
15:23:30 <todin> no prolbem.
15:23:50 <todin> are there more low hanging fruit which I could pick?
15:24:13 <srwilkers> i'll add this to my list for the day as well and provide some feedback -- looks good for the most part though :)
15:25:04 <todin> srwilkers: great
15:25:33 <srwilkers> todin: i'm sure there's some more low hanging items to tackle, but none are jumping to the front of my mind right now
15:25:53 <srwilkers> i'll give you a shout in the openstack-helm channel as they start coming back to me today
15:26:28 <todin> srwilkers: that would be great, maybe we should compile a list for newbies. to get an easy start.
15:26:34 <srwilkers> does anyone else have any requests for reviews?
15:26:40 <srwilkers> todin: yeah, that'd be great
15:27:46 <srwilkers> moving on then
15:27:49 <srwilkers> #topic round table
15:28:04 <srwilkers> any round table items anyone would like to discuss today?  we've still got about 30 minutes left
15:30:04 <srwilkers> okay, let's go ahead and wrap things up then
15:30:16 <srwilkers> #endmeeting