15:03:29 <srwilkers> #startmeeting openstack-helm
15:03:30 <openstack> Meeting started Tue Mar 19 15:03:29 2019 UTC and is due to finish in 60 minutes.  The chair is srwilkers. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:33 <georgk> hi
15:03:34 <openstack> The meeting name has been set to 'openstack_helm'
15:03:37 <itxaka> o/
15:03:41 <mattmceuen> GM all
15:03:49 <srwilkers> #topic rollcall
15:03:49 <srwilkers> o/
15:04:02 <srwilkers> here's the etherpad for today: https://etherpad.openstack.org/p/openstack-helm-meeting-2019-03-19
15:04:09 <srwilkers> let's give it a few minutes to let others roll in
15:06:37 <srwilkers> alright, let's get rolling
15:06:49 <srwilkers> #topic Multi distro support
15:06:54 <srwilkers> take it away evrardjp
15:07:36 <evrardjp> ok
15:07:37 <evrardjp> so
15:07:48 <evrardjp> #link https://etherpad.openstack.org/p/openstack-helm-container-distro-support
15:08:07 <evrardjp> I think there is enough things written there to start writing the spec.
15:08:22 <evrardjp> I have hoped that we'll get to discuss this before this meeting to speed up the process.
15:08:33 <evrardjp> Anyway
15:08:37 <evrardjp> Input required on location of values. I think the rest can go for spec time, and then we can move on in gerrit from now on.
15:08:40 <srwilkers> i agree -- i'd say that etherpad is full and ready to go
15:09:12 <evrardjp> Before I propose that spec, I would like to have input on L104.
15:09:17 <srwilkers> i'd think we can handle where those values land in the spec itself and discuss it there, as that's bound to have differing opinions
15:09:22 <srwilkers> would be nice to address that via gerrit
15:09:36 <evrardjp> If I don't get input for Friday, I will just propose in gerrit, and we'll address comments there
15:09:43 <evrardjp> ok
15:09:46 <evrardjp> that's fine then
15:09:52 <evrardjp> I will propose in gerrit.
15:10:06 <srwilkers> cool -- it's time to get this train rolling :)
15:10:18 <evrardjp> I don't want this to turn value definition turn into bikeshed though. Please keep in mind we are in a rush, that's it :)
15:10:53 <evrardjp> any questions?
15:11:20 <srwilkers> none from me
15:11:28 <evrardjp> next?
15:11:32 <roman_g> next
15:12:00 <evrardjp> srwilkers: can you do the topic mojo? :p
15:12:08 <srwilkers> yep
15:12:12 <evrardjp> it's your meeting :D
15:12:16 <srwilkers> #topic Image building user experience/user interface
15:12:26 <evrardjp> for me again :)
15:12:41 <srwilkers> yep -- carry on, my man
15:12:42 <evrardjp> So, I have reviews up.
15:12:56 <evrardjp> it's Building as much as we can based on upstream roles to reduce the amount of code to maintain
15:13:18 <evrardjp> however, our user interface "build.sh" in osh-images/openstack/loci/ is not used anymore in ci
15:13:36 <evrardjp> we now have 3 different interfaces: zuul's image building, the build.sh scripts and makefiles
15:13:46 <evrardjp> just for the openstack image building process
15:13:58 <evrardjp> So... what are you using?
15:14:05 <evrardjp> Should I delete the build scripts?
15:14:42 <evrardjp> it's just passing arguments to loci after all...
15:15:25 <evrardjp> it seems nobody cares?
15:15:43 <srwilkers> right -- i've got no strong feelings on this one.  maybe we can throw up a change to remove the build.sh scripts as an RFC and see what people say
15:15:54 <srwilkers> and if there's no strong feelings about keeping them, we remove them
15:16:12 <jsuchome> well, we are currently using  build.sh wrappers, do you propose to use loci directly?
15:16:19 <evrardjp> jsuchome: yes
15:17:01 <evrardjp> removing code is my favorite hobby
15:17:35 <evrardjp> wow people aren't even receptive to jokes?
15:17:45 <portdirect> as long as we have some mechanism that makes it easy to build outside of zuul - im good with it
15:17:58 <evrardjp> isn't that what loci does?
15:18:23 <evrardjp> we can keep what we do for now
15:18:38 <evrardjp> it's just it's 3 different interfaces, they WILL get out of sync
15:19:16 <evrardjp> but ok, understood
15:19:20 <evrardjp> like we did in the past then!
15:19:28 <evrardjp> next topic
15:19:29 <evrardjp> ?
15:19:31 <jsuchome> I think you have a point, it's just some refactoring on our side is needed
15:20:04 <jsuchome> of course everybody loves removing code
15:20:07 <srwilkers> sounds good jsuchome
15:20:23 <srwilkers> if someone tells you they dont, they're lying
15:20:30 <srwilkers> anything else here?
15:21:08 <srwilkers> moving on
15:21:12 <srwilkers> #topic Python3 support
15:21:17 <srwilkers> evrardjp: carry it away
15:21:30 <evrardjp> things are broken for now
15:21:54 <evrardjp> #link https://review.openstack.org/#/c/641643/
15:22:07 <evrardjp> this is a first step.
15:22:17 <evrardjp> Question for the community:
15:23:05 <evrardjp> should we care about python3 only going forward? I don't know when 1.0 is due, but it wouldn't it be better to release with python3 in it?
15:23:31 <evrardjp> It seems there is no strong opinion there -- but carrying two versions seems a hassle
15:23:53 <srwilkers> i'm a fan of moving to python3, but i'm just one person
15:24:03 <itxaka> python3 is the future and the future is now!
15:24:08 <mattmceuen> ++
15:24:08 <srwilkers> :D
15:24:12 <roman_g> I'm not a developer, but I hear from every corner and kettle, that Python 2 is out of business starting from 2020
15:24:16 <itxaka> well, 2020 more like it, when python2 support is off
15:24:19 <srwilkers> yep
15:24:33 <roman_g> So I'm for Python 3
15:24:39 <itxaka> ++
15:24:41 <srwilkers> won't hear any complaints from me
15:24:58 <evrardjp> roman_g: indeed 2020. Sorry I didn't write it.
15:25:25 <itxaka> we should then start making zuul jobs python3 asap so we dont get any code that is at least py2+3 compatible
15:25:46 <itxaka> like 10 days ago some aliveness probes got in which already break in python3
15:25:48 <evrardjp> itxaka: I agree.
15:26:12 <evrardjp> itxaka: I believe we should try it with the current PTI
15:26:18 <evrardjp> exercise the code*
15:26:33 <evrardjp> which means python3.6 is something that matters
15:27:04 <evrardjp> but ok, we agree that if we see things, we'll get that appropriately fixed/prioritized.
15:27:10 <evrardjp> That's all I had on this topic
15:27:39 <srwilkers> sounds good, let's move on
15:27:46 <srwilkers> #topic Participation in Google Summer of Code and Season of Docs
15:27:50 <srwilkers> roman_g: i think this one's you
15:28:22 <roman_g> Well. portdirect , are you here?
15:28:43 <roman_g> Bot didn't work on the past meeting, but we got positive feedback from Pete
15:28:47 <srwilkers> or itxaka -- sorry, those blue colors are hard for my eyes to differentiate between
15:29:06 <roman_g> He wanted to follow-up on hwether we would be able to find some work for technical writers
15:29:21 <roman_g> and what would be efforts from our side to get into the program
15:30:19 <roman_g> If no other comments from you all, let's move to the next topic, and I will move topic to the next meeting
15:30:28 <srwilkers> i'm sure there's something we can dig up, but probably need him to chime in here -- we may need to poke him in the channel later
15:30:34 <srwilkers> alright, moving on
15:30:44 <evrardjp> I like the idea like I said last week
15:30:52 <srwilkers> yeah, it's a good idea
15:31:08 <srwilkers> #topic Reviews
15:31:30 <srwilkers> we've got a few reviews listed here:
15:31:47 <srwilkers> https://review.openstack.org/#/c/642422/
15:31:47 <srwilkers> https://review.openstack.org/#/c/641643/
15:31:47 <srwilkers> https://review.openstack.org/#/c/643958/
15:31:47 <srwilkers> https://review.openstack.org/#/c/644573/
15:31:47 <srwilkers> https://review.openstack.org/#/c/639961/
15:31:48 <srwilkers> https://review.openstack.org/#/c/643940/
15:31:58 <evrardjp> you forgot #link to all of those! :p
15:32:11 <evrardjp> that's fine, dont' worry :)
15:32:44 <srwilkers> heh
15:33:09 <roman_g> The pen is mightier than the sword.
15:33:19 <jsuchome> https://review.openstack.org/#/c/644573/ seems to be critical, as other zuul jobs are failing without it
15:33:59 <itxaka> plus the author of the patch seems like a cool person
15:34:22 <jsuchome> +1 :-)
15:34:26 <evrardjp> spanish names for coolitude are overrated itxaka
15:34:46 <evrardjp> but yeah, totally needed.
15:34:54 <srwilkers> looks good to me
15:35:21 <evrardjp> just need a super +w
15:35:52 <srwilkers> https://review.openstack.org/#/c/643940/ this moves the pod security policy job in osh-infra back to a nonvoting check, as it was accidentally moved back to a voting check and gating job in a subsequent unrelated change
15:36:48 <srwilkers> any other requests for reviews that arent listed here?
15:37:22 <evrardjp> nope
15:37:49 <srwilkers> cool
15:37:52 <srwilkers> #topic roundtable
15:37:57 <srwilkers> we've got about 20 minutes left
15:38:08 <evrardjp> question about ptg
15:38:10 <srwilkers> any round table items anyone wants to chat about while we're here?
15:38:12 <srwilkers> fire away
15:38:46 <evrardjp> it seems the airship/osh squad share the same room during PTG. Some people might be interested in some conversations and not to some others
15:38:54 <evrardjp> do you have a plan on how to split days?
15:39:19 <srwilkers> not at the moment, but i've got a personal preference because i messed up my return flight
15:39:22 <evrardjp> if not, we should :)
15:39:27 <evrardjp> haha
15:39:30 <srwilkers> i'm due to fly out saturday morning at 7:00am
15:39:37 <srwilkers> because i forgot the PTG ran through saturday this time
15:39:52 <evrardjp> I am stretched very thin, so agenda will matter a lot.
15:40:06 <srwilkers> yeah, i think this is something we need to solidify quickly
15:40:38 <srwilkers> #action srwilkers to follow up in regards to osh/airship PTG schedule
15:41:03 <srwilkers> i'll get the discussion started with the appropriate parties and get something out on the ML within the next 24 hours
15:41:19 <roman_g> question (1/2): what are the low-hanging fruits, if I'd want to help openstack-helm? How do I find them? (so far I'm mostly chatting here and there)
15:41:38 <roman_g> question (2/2): where is the mailing list? :)
15:41:48 <srwilkers> roman_g: those are good questions
15:42:32 <roman_g> I've actually searched for the mailing list info, and couldn't find it
15:42:42 <srwilkers> for 1: i don't think we've made it particularly easy to find those.  in my opinion, the lowest hanging fruit to pick would be things like making sure all of our chart templates are as close to uniform as possible
15:43:35 <roman_g> would that be like openining chart templates in 2 windows, and seeing if structure matches?
15:43:37 <srwilkers> by that, i mean:  are we using helm-toolkit macros appropriately across all charts?  are all indentations following the same standards?  do we have disparity between how the values files are laid out (ie: different key names for the same sections for things like volumes, dependencies, etc)
15:43:42 <srwilkers> roman_g: yep
15:44:09 <roman_g> ahha, +/- got it
15:44:48 <srwilkers> in terms of the mailing list, this should be a good resource to use: https://wiki.openstack.org/wiki/Mailing_Lists
15:44:50 <evrardjp> srwilkers: that starts with an explanation of the htk exposes
15:45:02 <evrardjp> of what the htk exposes*
15:45:13 <evrardjp> We should increase documentation around it
15:45:32 <srwilkers> evrardjp: agreed, which would be another great low hanging fruit item for anyone who's got some familiarity with helm
15:45:51 <srwilkers> that's generally the first place i try and point people when they reach out to me
15:46:34 <roman_g> What would be an easy way to pass all rendered shell scripts trough shell linter? Is there a need in such a gate? Which linter?
15:48:05 <srwilkers> that's a great question -- we had chatted long ago about using something like yamllint to try and enforce structure in all charts' values.yaml files
15:48:41 <srwilkers> oh, i misread that
15:48:59 <srwilkers> i wouldn't be opposed to the idea of something like a shell linter
15:50:05 <evrardjp> bashate or shellshock are generally used
15:50:05 * srwilkers is afraid to admit how many times he's botched up a shell script
15:50:29 <evrardjp> I would totally love having time to write a linter that works for our needs.
15:50:39 <itxaka> so that would go helm template -> shell linter??
15:50:57 <evrardjp> ?
15:50:58 <itxaka> because we need to template it first for the values to be rendered
15:51:23 <evrardjp> it's still doable
15:51:24 <srwilkers> itxaka: yeah, would need to use helm template to render the script templates, then feed the output into whatever linter we decided to use
15:51:59 <itxaka> sounds good to me, we could do the same with the yaml files and python files (thinks about python3 compatibility....)
15:52:37 <evrardjp> itxaka: good plan
15:52:54 <srwilkers> also good low hanging fruits for someone to tackle :)
15:53:40 <roman_g> Thank you all.
15:53:47 <srwilkers> no problem roman_g
15:54:06 <roman_g> One last Review: https://review.openstack.org/644604 Fix: update merge to mergeOverwrite
15:54:07 <srwilkers> anyone have anything else?
15:54:29 <roman_g> I've just found that we missed this merge/mergeOverwrite
15:54:39 <srwilkers> oh, so we did
15:54:42 <roman_g> I have absolutely no idea if it's correct or not
15:55:00 <roman_g> but we didn't change this one in the patch we have had
15:56:28 <roman_g> that's it
15:56:29 <srwilkers> we definitely want to remain consistent where possible
15:56:31 <srwilkers> cool
15:56:46 <srwilkers> alright, if nobody has anything else, let's wrap it up then
15:56:50 <srwilkers> thanks for coming today everyone
15:57:01 <srwilkers> #endmeeting