14:59:49 <portdirect> #startmeeting openstack-helm
14:59:50 <openstack> Meeting started Tue Mar 26 14:59:49 2019 UTC and is due to finish in 60 minutes.  The chair is portdirect. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:53 <openstack> The meeting name has been set to 'openstack_helm'
15:00:04 <portdirect> lets give it 5 mins for people to arrive
15:00:06 <srwilkers> o/
15:00:16 <jayahn> o/
15:00:17 <portdirect> Agenda is here: https://etherpad.openstack.org/p/openstack-helm-meeting-2019-03-26
15:00:21 <srwilkers> Welcome back jayahn
15:00:22 <evrardjp> o/
15:00:23 <portdirect> please feel free to add to it
15:00:28 <dwalt> o/
15:00:33 <portdirect> yeah - great to see you here jayahn :D
15:00:47 <georgk> hi
15:00:54 <jayahn> yeah, i was kept by network operation team for the last several weeks
15:01:08 <evrardjp> must be interesting
15:01:53 <portdirect> jayahn: is that what the bar you go to is called ;P
15:01:59 <jayahn> did a small size production vnf w/ osh & armada & .
15:02:06 <jayahn> yeap. you got it.
15:02:13 <portdirect> nice - thats awesome dude
15:02:20 <howell> o/
15:02:47 <portdirect> are you still using armada directly? or via api?
15:02:57 <jayahn> directly
15:03:57 <portdirect> ok - think we got enough people here to kick off
15:04:09 <portdirect> #topic multi-os spec
15:04:17 <portdirect> evrardjp: your taking the charge here :D
15:04:27 <evrardjp> so
15:04:35 <evrardjp> spec is up
15:04:41 <evrardjp> https://review.openstack.org/#/c/645142/
15:04:58 <evrardjp> thanks lamt for the feedback already
15:05:31 <portdirect> i also think some of Jiri Suchomel's comments are excellent
15:05:31 <evrardjp> Could you please all review, so we can move on with our lives? I would like to merge this for next tuesday at latest.
15:06:06 <portdirect> from my 1st pass over it, i think from a technical perspective this is looking good, though we probably need to work on the wording a bit
15:06:47 <evrardjp> Fine with rewording things. As long as it's not becoming a ping-pong game.
15:07:11 <evrardjp> That's all I had to say for today
15:07:20 <evrardjp> on this topic
15:07:24 <portdirect> agreed - i think we just need to remvoe the red rags ;)
15:07:50 <portdirect> ok
15:07:54 <portdirect> #topic images publication using upstream infra roles
15:08:01 <portdirect> evrardjp: you again :D
15:08:17 <evrardjp> portdirect: sorry if others don't have added items in the agenda :p
15:08:24 <portdirect> seriously - thanks for all your work on driving this forward
15:08:54 <evrardjp> on this -- we are now almost completely relying on infra. Which means max tens of lines of code to maintain for the process.
15:09:10 <evrardjp> it's working, and already exercised
15:09:23 <evrardjp> Removal of other images in the different repos will be handled soon
15:09:32 <evrardjp> I will tackle this
15:09:58 <portdirect> nice - thx dude
15:09:58 <evrardjp> #action evrardjp remove remnants of old images in osh{,-infra} repos
15:10:08 <evrardjp> Some images might be missing, so please propose patches
15:10:12 <portdirect> we should also make sure that we dont miss anything in this
15:10:37 <portdirect> the next step would presumably be an audit to ensure we are targetting the -infra built images by default in the charts/scripts
15:10:38 <evrardjp> removal should always be compared to the publication of existing ones indeed.
15:10:47 <evrardjp> portdirect: that's correct.
15:10:50 <portdirect> and then working on automation of testing
15:10:55 <evrardjp> which is not the case here.
15:11:11 <evrardjp> indeed, next step would be to have some kind of end to end testing
15:11:31 <portdirect> this sounds like a great thing for us to work through at ptg
15:11:54 <evrardjp> we will need infra too, if we want to speed up things. It can totally be done during PTG.
15:12:04 <portdirect> yeah - this is what im thining
15:12:39 <jayahn> hm, i probably need to catch up with this image stuff. I will bug you two guys after.
15:12:40 <evrardjp> nothing more to say. Thanks for being patient with me, asking all the times for reviews.
15:12:45 <portdirect> #action portdirect start drawing up ptg agenda, so it can be published as etherpad next week
15:13:12 <portdirect> ok - lets move on
15:13:20 <evrardjp> jayahn: sure thing. I think it would be better if we had docs though
15:13:33 <portdirect> #topic python3 effort
15:13:49 <evrardjp> so. We'll only run OSH on python3 at SUSE
15:13:57 <portdirect> so - there have been some great contributions recently to add python 3 support
15:13:57 <evrardjp> we found a few issues.
15:14:05 <evrardjp> https://review.openstack.org/#/q/intopic:osh_suse_python3
15:14:11 <evrardjp> oh sorry portdirect
15:14:16 <portdirect> the obvious thing here, is we should work towards gaing py3 images
15:14:20 <portdirect> *gating with
15:14:47 <portdirect> as these fixes, are fantasic but only help as point in time
15:14:53 <portdirect> untill we fix that
15:15:02 <portdirect> i think this very much ties in with the image gating above
15:15:05 <evrardjp> if SUSE is gated, wouldn't that help?
15:15:06 <portdirect> thoughts?
15:15:11 <portdirect> exactly
15:15:28 <evrardjp> It is fine for me, but we need the multi os spec for that
15:15:34 <portdirect> though python shoudl be distro independant ;)
15:15:49 <evrardjp> it is, but it's on the critical path basically
15:16:03 <portdirect> understood - but its clear to make the distinction
15:16:13 <evrardjp> except if you mean lint testing of python3 after templating the helm charts?
15:16:40 <portdirect> no - im just making the point that python3 is not a prerequsite for running on openSUSE
15:17:01 <portdirect> but understand the desire from the SUSE developers to get this effort moving
15:17:29 <evrardjp> portdirect: it kinda is. We won't ever run this on python2
15:18:19 <evrardjp> if you want openSUSE, then you need the latest and greatest(TM) python
15:18:45 <evrardjp> joke aside ... python2 is not covered by our efforts
15:18:59 <portdirect> I get that
15:19:05 <portdirect> the point im now directly making
15:19:07 <evrardjp> but we are further from main conversation :)
15:19:35 <portdirect> is that OSH as a whole should support python3 - regardless of distro, though its fantastic that SUSE is looking to fund that effort
15:19:56 <evrardjp> oh yes, I totally see the future where other images are moved to python3
15:20:24 <portdirect> yup
15:20:36 <evrardjp> if possible before 2020 :)
15:21:14 <portdirect> yeah - lets make sure we get there accross the board
15:21:28 <portdirect> ok lets move on: docs
15:21:31 <portdirect> #topic docs
15:21:32 <jayahn> 2020, at the 10 years anniversary of openstack, we finally go to python3
15:21:48 <portdirect> so - I need to hold my hands up here
15:21:56 <jayahn> docs.. i probably too
15:22:02 <portdirect> as I've stalled in this effort
15:22:11 <portdirect> jayahn: no worries we are both as bad as each other
15:22:29 <portdirect> I'll try to get the contents fleshed out this week
15:22:43 <portdirect> so from next week we can start on content porting/creation
15:23:07 <jayahn> since ianychoi is back to i18n PTL, he said he will help us more.
15:23:17 <portdirect> nice
15:23:24 <portdirect> please keep an eye on: https://review.openstack.org/#/c/634944/
15:23:32 <portdirect> i PROMISE to get it moving again :)
15:23:55 <evrardjp> promises only bind those we believe in them :p
15:24:40 <srwilkers> ?
15:25:10 <evrardjp> srwilkers: caustic sense of humor, don't mention it
15:25:39 <portdirect> think it translates to `If you believe that, you'll believe anything.`
15:25:43 <portdirect> thx evrardjp ;)
15:25:47 <portdirect> I'll try
15:25:52 <jayahn> it sounds like Shakespeare thing
15:27:40 <portdirect> ok - lets move on
15:27:44 <portdirect> #topic reviews
15:27:44 <evrardjp> indeed
15:28:20 <portdirect> antyhign that needs attention atm, other than the images-specs?
15:29:15 <jayahn> i will have something next week. :)
15:29:34 <evrardjp> great news jayahn
15:30:49 <jayahn> I actually have a news. Everyone is invited to Korea https://www.openinfradays.kr/index_en.html
15:31:47 <jayahn> if you want speak, just tell me. I am a chair of program committee. I will overuse my power.
15:32:14 <evrardjp> haha :)
15:33:34 <angiewang> Hi, can help to review https://review.openstack.org/#/c/641144/ - Add panko chart and https://review.openstack.org/#/c/641518/ - Add aodh chart? :) Really looking for approval
15:33:48 <srwilkers> sure angiewang
15:34:29 <angiewang> Thanks!
15:35:07 <portdirect> will do angiewang
15:35:18 <evrardjp> thanks angiewang already
15:37:50 <portdirect> ok - lets wrap up for this week, unless anyone has anything for the parkinglot?
15:41:34 <evrardjp> I have nothing else, thanks for the meeting
15:42:07 <jayahn> thanks everyone
15:42:15 <portdirect> thanks peeps!
15:42:18 <portdirect> #endmeeting