01:00:36 <Daisy> #startmeeting OpenStack I18n Meeting
01:00:36 <openstack> Meeting started Thu Jul 4 01:00:36 2013 UTC. The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:00:37 <fifieldt> ok!
01:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:00:40 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
01:00:58 <Daisy> nice. Let's start!
01:01:15 <Daisy> first, I think, we need to know each other. Please give a simple introduction.
01:01:21 <Daisy> Daisy, from China
01:01:32 <Steff00> Stephane, from France
01:01:35 <fifieldt> Hi, I'm Tom - Openstack Community Manager from Melbourne, Australia
01:01:39 <ujuc> ujuc, from korea
01:01:43 <amotoki> I'm Akihiro from Japan
01:01:51 <Daisy> Great !
01:02:10 <Daisy> We have France, Australia, Korea, Japan and China.
01:02:22 <Daisy> #topic Action items from the last meeting
01:02:33 <fifieldt> #link https://wiki.openstack.org/wiki/Meetings/I18nTeamMeeting#Agenda_for_next_meeting
01:02:43 <Daisy> Fifieldt to decide the meeting time
01:02:58 <fifieldt> So, yes, we have a meeting time now :)
01:03:01 <Daisy> I think it's done. If you have any problems with the meeting time, please let fifieldt and me know.
01:03:11 <Daisy> Daisy to write the wiki page
01:03:30 <fifieldt> #link https://wiki.openstack.org/wiki/I18nTeam
01:03:30 <Daisy> https://wiki.openstack.org/wiki/I18nTeam
01:03:48 <Daisy> It's the first version. We can continue to improve it in the future.
01:03:53 <Daisy> ok. next topic.
01:04:03 <Daisy> #topic Teaming
01:04:25 <Daisy> Please look into "Roles in I18n Team" in the wiki page.
01:05:07 <Daisy> Besides coordinators, translators, reviewers, I'm thinking of introduce a new role: project manager, who will response for the progress of a specific translation task.
01:05:19 <Daisy> like the translation of a project, or the translation of a document.
01:05:33 <Steff00> sorry I got disconnected
01:05:34 <Daisy> My question is do you think it is helpful to introduce such a new role?
01:05:50 <fifieldt> no problem Steff00, we're just looking at the "Roles in I18N Team" section on the wiki
01:05:52 <Daisy> It's all right, Steff00 . We are talking about the roles in a translation team.
01:06:32 <Daisy> My question is "do you think it is helpful to introduce project manager in translation team?"
01:06:53 <fifieldt> amotoki, may I ask, when you've been working on the operations guide, have you had someone 'leading' the effort?
01:07:33 <amotoki> a couple of persons are leading translations not one person.
01:08:15 <Steff00> I agree with amotoki, we are planning to work this way in the french team
01:08:20 <fifieldt> so ... should "Project Manager" be an individual person, or more like a "Project Management Team" ...
01:08:33 <Daisy> amotoki: can you explain in more details?
01:08:43 <amotoki> the tasks are mainly split into two parts:
01:09:00 <amotoki> one is promote other members to tranlate (member assignment or spliting the translation into parts)
01:09:35 <amotoki> the other is more technical part. how can we translate or review efficiently or some other thinigs.
01:10:37 <Daisy> amotoki: will you do the translation one document by one document?
01:11:15 <amotoki> at now, we are focusing on one document.
01:11:30 <amotoki> but it is just a case.
01:11:47 <Daisy> amotoki: what is the people who onw technical part do?
01:12:56 <fifieldt> Daisy, check out the table in https://github.com/openstack-ja/openstack-manuals/wiki/Operations-Guide-%E7%BF%BB%E8%A8%B3%E5%88%86%E6%8B%85
01:13:00 <amotoki> for example, analyzing po file issue, prepare the translated document for check,...
01:13:01 <fifieldt> which shows the assignment process
01:14:02 <Daisy> Maybe we don't need project manager, but we need one people who can be responsible to manage the progress, like the first part metioned by amotoki .
01:14:24 <Daisy> I'm not able to read Japanese.
01:14:36 <amotoki> we can use google translation :-)
01:14:41 <fifieldt> 翻訳 校正1 校正2
01:14:43 <Daisy> hehe
01:14:46 <amotoki> hehe
01:14:51 <ujuc> :)
01:14:52 <fifieldt> translation | proofread/correct | proofread/correct | Transifex
01:14:56 <amotoki> translation review1 review2
01:15:28 <Daisy> Let's say: when there is a translation task, people can sign up which languages they want to translate into.
01:16:03 <Daisy> and then, the people who sign up will be the owner of the translation of this language, and will be responsible for the progress.
01:16:59 <fifieldt> It sounds ok to me, perhaps we can use some of the details amotoki provided to explain further
01:17:07 <Daisy> then we don't need a people with the title of PM.
01:17:20 <Daisy> ok.
01:17:28 <amotoki> "project manager" per language? or for I18N project as a whole?
01:17:28 <fifieldt> Steff00, you mentioned a similar style before ... any comments?
01:18:18 <Daisy> I don't have clearly answer. If there is no PM, I may be the PM for the whole I18n project.
01:18:18 <Steff00> French people can't admitt someone can be able to lead the project when not leaving in Paris
01:18:37 <fifieldt> :D
01:18:55 <fifieldt> Daisy, perhaps there is need for both - but there will likely be some overlap
01:18:57 <Steff00> So I personnaly live in bordeaux, and keep daily contact whis someone in Paris who is my eyes and ears in the "real world"
01:19:18 <Daisy> yes.
01:19:46 <Daisy> I think we can try a method for some days, and then we improve it little by little.
01:19:51 <fifieldt> I think translation activities may have two forms - 'sprints' around specific tasks/documents, and ongoing translation of documents that get updated
01:20:03 <fifieldt> both require recruitment of translators and other 'management' activities
01:20:18 <amotoki> agree
01:20:24 <Steff00> agree too
01:20:39 <Daisy> ok.
01:20:41 <fifieldt> so having some people for the 'language' and some people for the 'sprint' ...
01:20:42 <ujuc> agree too
01:21:12 <fifieldt> Steff00, know how you feel - I use to live in Saint Genis ;)
01:21:47 <Steff00> I won't give up me seat :)
01:22:16 <fifieldt> so I guess to make it more acceptable to share the management is good for the language as well ? as in it's OK to have >1 "coordinator" role?
01:22:30 <fifieldt> (I'll be quiet now, talking too much - sorry)
01:22:33 <Daisy> sure, we can have several coordinators for one language.
01:22:42 <Daisy> No, fifieldt . I like your ideas.
01:23:20 <Daisy> Shall we move to next topic?
01:23:25 <Daisy> Time passes very quickly.
01:23:33 <Steff00> ok
01:23:35 <amotoki> In my understanding, now in transifex only coordinator have a right to mark "reviewed". right?
01:23:44 <Daisy> Not right, amotoki
01:24:00 <Daisy> You can assign reviewers. Reviewers can mark reviewed.
01:24:20 <amotoki> i see. I'll check it.
01:24:26 <Daisy> great.
01:24:28 <Steff00> ok . i was thinking as amotoki
01:24:36 <fifieldt> maybe there is a need to communicate the instructions to create reviewers and how to review, Daisy?
01:24:48 <Daisy> Good idea, fifieldt .
01:24:50 <Daisy> I can do it.
01:25:00 <fifieldt> (eg #action Daisy to email out instructions about reviewing in transifex)
01:25:19 <Daisy> #action Daisy to write instructions in the wiki about creating reviewers and how to review
01:25:57 <fifieldt> #action Daisy to update roles on the wiki based on discussion
01:26:00 <fifieldt> next topic? :)
01:26:04 <Daisy> Good news: all contributions to the translation will be recognized same as code /document contribution. I18n team members will also have free registration code for the Summit. If you have contribution to the translation, and you want to attend HongKong summit, please let me know.
01:26:23 <Daisy> hehe, then we can go to next topic.
01:26:32 <fifieldt> awesome news, Daisy!
01:26:40 <Daisy> #topic Translation progress report by Daisy
01:26:44 <ujuc> :D
01:27:22 <Daisy> I will think the translation of Nova, glance, keystone, swift, cinder and quantum are high priority.
01:27:38 <Daisy> In document, I will regard "operation guide" as the top priority, as required by Doc team.
01:27:51 <Daisy> Here are some data about the translation progress:
01:28:03 <Daisy> Nova French 84% Italian 83% Chinese(China) 82% Chinese(Taiwan) 82% Japanese 82% Korean (Korea) 82% Portuguese (Brazil) 82% Spanish 82%
01:28:16 <Daisy> Keystone - French 0% Italian 88% Chinese(China) 83% Chinese(Taiwan) 87% Japanese 0% Korean (Korea) 82% Portuguese (Brazil) 0% Spanish 90% German 87%
01:28:29 <Daisy> Horizon - French 36% Italian 3% Chinese(China) 17% Chinese(Taiwan) 9% Japanese 100% Korean (Korea) 23% Portuguese (Brazil) 44% Spanish 98% German 0% Finnish(Finland) 100% Hungarian 69%
01:28:41 <Daisy> Glance - Korean (Korea) 73% French 72% Chinese (China) 71% Chinese (Taiwan) 71% German 71% Italian 71% Japanese 71% Portuguese(Brazil) 71% Spanish 71%
01:28:53 <Daisy> Cinder - Japanese 83% Chinese (China) 82% Chinese (Taiwan) 82% French 82% German 82% Italian 82% Korean (Korea) 82% Portuguese (Brazil) 82% Spanish 82%
01:29:03 <Daisy> Quantum - Chinese(Taiwan) 90% Italian 90% Japanese 90% Spanish 90% German 89% Chinese (China) 86% French 86% Korean (Korea) 86% Portuguese (Brazil) 84%
01:29:21 <Daisy> Ceilometer - French 63% Korean(Korea) 17% Danish 14% Italian 6% Japanese 4%, others are 0.
01:29:41 <Daisy> Manuals: OpenStack Operation Guide -Japanese 100% Vietnamese (Viet Nam) 15% Korean (Korea) 7%, other country are less than 1%.
01:30:47 <Daisy> so, I think, before next release, we need to pick out some languages, and try our best to complete all the message translations. And the test in the specified language environment. Then we can declare: OpenStack can support XX language.s
01:31:13 <fifieldt> the progress in several languages is very impressive
01:31:31 <Daisy> Japanese team is the top one.
01:31:33 <amotoki> regarding message translations, AFAIK, translations of openstack components (nova, cinder, neutron, ...) are not widely used in Japan.
01:31:37 <amotoki> many operators prefer english logs since it can be easily "grep"-ed.
01:31:38 <Daisy> Thank you, amotoki .
01:32:09 <amotoki> :-)
01:32:11 <fifieldt> though I imagine Horizon is very important everywhere ...
01:32:13 <Daisy> It's a widely discussion, amotoki .
01:32:25 <amotoki> Yes. Horizon is an exception.
01:32:47 <Steff00> French community has started slowly but I think message translations will be ok for the end of july
01:33:31 <Steff00> And we are currently negociating free professional translation for the operation guide
01:33:34 <Daisy> I think, Chinese people prefer to translate some user facing messages, even the command line messages.
01:33:52 <fifieldt> also, I wanted to let people know that the documentation is undergoing a big restructure - so it might be best to wait for a while
01:34:01 <fifieldt> #link https://wiki.openstack.org/wiki/Blueprint-restructure-documentation
01:34:04 <Daisy> There is a Chinese version of operation guide, but it's not in PO format.
01:34:08 <fifieldt> except, of course, the operations guide
01:34:49 <amotoki> ops-guide now has a separate repository..
01:35:07 <Daisy> I remember, during the last summit, Oslo guys are thinking of splict the translation domain into two, one is for Command Line messages, the other is for log messages.
01:35:15 <Daisy> I don't know their progress.
01:35:33 <fifieldt> yes, amotoki, just an artefact of talking to publishers to determine if we can get them to publish the book
01:35:37 <Daisy> amotoki: are you OK with the command line messages' translation?
01:36:21 <amotoki> Daisy: command line translation is okay.
01:36:54 <amotoki> but i am not sure that attracts Japanese community. all people are volunteers.
01:37:16 <fifieldt> it seems to me to be in this order: operations guide, horizon, nova/keystone/swift/cinder/quantum CLI messages (high priority: cn, lower elsewhere), nova/keystone/swift/cinder/quantum log messages (high priority: cn, lower elsewhere)
01:37:42 <fifieldt> and on other docs: wait for them to stabilise to avoid wasted effort
01:37:44 <Daisy> so I will check with Oslo team about the progress of domain seperation.
01:38:04 <Daisy> #action Daisy to check with Oslo team about the progress of domain seperation.
01:38:22 <fifieldt> the next meeting agenda item seems relevant ...
01:38:39 <Daisy> so next topic
01:38:54 <Daisy> #topic Operation guide translation plan and publish plan
01:39:11 <Daisy> So we will set the Operation guide as the first priority.
01:39:31 <Daisy> The Japanese translation are finished.
01:39:37 <Daisy> How is the plan of other languages?
01:39:42 <fifieldt> amotoki, has moving the repository for the guide made things more difficult?
01:39:56 <amotoki> fifieldt: i don't think so.
01:40:01 <fifieldt> ok, good to know
01:40:03 <fifieldt> I was worried
01:40:24 <amotoki> i am familiar with git or other tools and can coordinate it.
01:40:30 <fifieldt> legend :)
01:40:58 <fifieldt> just a quick update - we are currently talking with O'Reilly about publishing this book 'properly'
01:41:07 <fifieldt> I am trying to ensure that translated versions are considered in this
01:41:15 <amotoki> great!
01:41:15 <Daisy> As I said, some Chinese people have done some translation, but they are not using Transifex. So there might be some workload to convert.
01:41:17 <fifieldt> but it might be a timing or funding issue
01:41:19 <Daisy> Thank you, fifieldt
01:41:34 <fifieldt> indeed, Daisy
01:41:42 <Daisy> ujuc: do you have any plan to translate operation guide?
01:41:48 <Daisy> how about you, Steff00 ?
01:42:55 <Steff00> I have a meeting next week with people from Cloudwatt, who can be able to translate operation guide in a professional way
01:43:10 <fifieldt> very cool
01:43:15 <Steff00> at no cost, because they need these documents
01:43:27 <Daisy> how about the copyright?
01:43:53 <ujuc> only Transifex.... but need other things...
01:43:58 <Steff00> Cloudwatt is already using openstack so they will let their work opensource
01:44:05 <Daisy> fifieldt: I don't know any about the copyright issue if we translate them and publish them in website? or in book?
01:44:30 <fifieldt> I think it should be under the same license
01:44:41 <fifieldt> As Steff00 says, Cloudwatt is already an OpenStack contributor
01:44:45 <fifieldt> so it should be possible for them
01:45:00 <Daisy> ok then.
01:45:09 <fifieldt> FYI, the original license is: http://creativecommons.org/licenses/by/3.0/us/
01:45:26 <fifieldt> it's quite permissive
01:45:35 <fifieldt> so we do need to ask nicely :)
01:45:43 <fifieldt> because they do have the right to do otherwise
01:46:19 <Steff00> Two members of the french transalation team are cloudwatt employees
01:46:28 <Steff00> They will be nice
01:46:31 <Steff00> :)
01:46:33 <fifieldt> :D
01:46:39 <ujuc> :) ~
01:46:43 <Daisy> ok.
01:47:19 <Steff00> If we agree with them, everything should be translated in september
01:47:30 <Daisy> Great !
01:47:59 <Daisy> So I think, we need to publish Japanese version in the website firstly.
01:48:10 <Daisy> Then maybe Chinese version or French version.
01:48:44 <fifieldt> Documentation team is ready to help :)
01:48:45 <amotoki> Tom suggest me docs.openstack.org is a good place to publish and i agree.
01:48:50 <Daisy> Any problems, fifieldt and amotoki ?
01:48:54 <fifieldt> no problems
01:48:55 <Daisy> ok. good.
01:49:00 <amotoki> no problem.
01:49:11 <Daisy> #action Daisy to check with Doc team about the Japanese version's publish.
01:49:19 <Daisy> so many action items to me. :))
01:49:28 <Daisy> so next topic
01:49:30 <amotoki> thanks daisy :-)
01:49:43 <Daisy> #topic Statistic data in Transifex
01:49:55 <Daisy> I think we don't need to speed much time on this topic.
01:49:57 <Daisy> Just let you know.
01:50:25 <Daisy> I cannot find any tool to get statistics from Transifex, like who contribute how many translations.
01:50:27 <Daisy> I think, we may need to develop such a tool by ourselves.
01:50:49 <fifieldt> is there an API?
01:51:00 <Daisy> I think there should be an API.
01:51:10 <Daisy> Need somebody to do an investigation.
01:51:22 <fifieldt> I can talk with Stefano about this
01:51:25 <Daisy> amotoki: I wonder if any of technical people from your team can help.
01:51:41 <fifieldt> #link https://github.com/transifex/transifex/tree/devel/transifex/api
01:52:06 <Daisy> We need to know how many each translators contribute, and the top contributors should be recognized.
01:52:19 <amotoki> Daisy: I usually support japanese trans but i am afraid i have more time to work on it.
01:52:34 <Daisy> ok.
01:52:40 <fifieldt> perhaps the bitgera people can help?
01:52:48 <fifieldt> it seems like this should be part of the activity board
01:52:49 <Daisy> what is bitgera?
01:53:02 <fifieldt> #link http://activity.openstack.org/
01:53:04 <fifieldt> they make that
01:53:17 <Daisy> yeah, perhaps.
01:53:23 <Daisy> Who can help to talk with bitgera?
01:53:26 <fifieldt> Stefano
01:53:32 <Daisy> ok.
01:53:39 <fifieldt> I am happy to email him
01:53:59 <fifieldt> unless you want to :)(
01:54:08 <Daisy> #action fifieldt to mail to Stefano about the statistics in Transifex.
01:54:15 <Daisy> no, I'm happy you can do it.
01:54:27 <fifieldt> ok
01:54:30 <Daisy> so next one
01:54:32 <Daisy> #topic Percent sign (%) issue
01:54:40 <Daisy> https://bugs.launchpad.net/openstack-manuals/+bug/1192091
01:54:43 <uvirtbot> Launchpad bug 1192091 in openstack-manuals "'%' in the translation strings will cause an error in Transifex" [Medium,Confirmed]
01:54:56 <Daisy> The bug is reported by Japanese team. I find replacing % with %% in the original PoT file is very time consuming. All the strings need to be check one by one. I hope to find a better way to disable the automatic check in Transifex, but no progress till now.
01:55:24 <Daisy> any comments, amotoki ?
01:55:40 <amotoki> nothing at now.
01:56:18 <Daisy> ok. I guess there should be a way to disable the automatic check. If I fail, maybe I have to convert % to %% and then convert back when generating HTML.
01:56:21 <amotoki> i was suggested % should be escaped from Transifex.com.
01:56:27 <Daisy> I don't like this solution.
01:56:37 <amotoki> yeah.
01:56:49 <Daisy> I mean, I don't like to convert to %% and convert back.
01:57:12 <Daisy> so next topic
01:57:24 <Daisy> #topic public discussion
01:57:41 <Daisy> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-i18n
01:57:53 <fifieldt> we have a mailing list!
01:58:03 <Daisy> Our new mailing list just get ready ! Thanks, fifieldt .
01:58:16 <ujuc> :ㅇ lol
01:58:24 <fifieldt> ^_^
01:58:26 <uvirtbot> fifieldt: Error: "_^" is not a valid command.
01:58:27 <Daisy> Please sign up the new mailing list and distribute it to your team.
01:58:42 <Steff00> ok
01:58:44 <amotoki> nice
01:58:53 <Daisy> We can do more communication in the mailing list.
01:59:07 <Daisy> any other things to talk?
01:59:09 <amotoki> horizon team has a problem of source lang in transifex.
01:59:12 <amotoki> https://bugs.launchpad.net/openstack-manuals/+bug/1192091
01:59:13 <uvirtbot> Launchpad bug 1192091 in openstack-manuals "'%' in the translation strings will cause an error in Transifex" [Medium,Confirmed]
01:59:52 <fifieldt> was that the one where English and US English weren't the same, or something?
02:00:00 <Daisy> amotoki: what's link?
02:00:24 <amotoki> https://www.transifex.com/projects/p/horizon/
02:00:40 <amotoki> we see "English" as a translation lang.
02:00:51 <fifieldt> interesting!
02:00:56 <amotoki> it is automatically created...
02:01:20 <amotoki> "English" is the source lang in OpenStack hub but not in Horizon.
02:01:42 <amotoki> we need to address this situation.
02:01:55 <Daisy> can it bring any problems?
02:02:31 <amotoki> A month ago English translation had Georgian characters and it breaks the unit tests in Hoirzon.
02:02:55 <amotoki> I investigated the problem and noticed it.
02:03:16 <amotoki> Do we have an official channel to talk with transifex.com?
02:03:30 <amotoki> we cannot change the source lang though web site or API.
02:04:30 <Daisy> I wonder if I can delete it.
02:05:14 <Daisy> I will take a look at it.
02:05:39 <Daisy> #action Daisy to take a look at the source lang in Horizon.
02:05:59 <amotoki> thanks. gabriel also knows this situation.
02:06:15 <Daisy> ok.
02:06:28 <Daisy> any other topics?
02:06:40 <Daisy> if no, we will close the meeting.
02:06:44 <fifieldt> I think we should thank Steff00 for staying up so late!
02:06:58 <Steff00> it's 4 am in France :)
02:07:00 <amotoki> very midnight in franc!
02:07:01 <Daisy> Thank you, Steff00 .
02:07:18 <ujuc> Thanks, Steff00 ~~~ :D
02:07:23 <Daisy> I think you can attend the meeting in the other time slot for your convience.
02:07:38 <fifieldt> yes, next week is 0900 for Steff00
02:07:47 <Steff00> yes It will be better
02:07:55 <Daisy> so next meet will be held next Thursday, in the other time slot.
02:08:02 <Steff00> ok
02:08:02 <Daisy> Thanks guys.
02:08:12 <Daisy> I will close the meeting now.
02:08:15 <fifieldt> thanks Daisy
02:08:16 <amotoki> thank everyone!
02:08:28 <Daisy> #endmeeting