07:00:21 <Daisy> #startmeeting OpenStack I18n Meeting
07:00:22 <openstack> Meeting started Thu Aug 1 07:00:21 2013 UTC and is due to finish in 60 minutes. The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:25 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:00:31 <Daisy> Hello everyone. Nice to meet you again.
07:00:42 <Daisy> We have new friend today. May you have a simple introduction, Giang?
07:00:59 <Giang> yes, thanks Daisy
07:01:17 <Giang> my name is Giang. I am working for DTT.
07:01:47 <Giang> DTT is a IT company from Vietnam.
07:01:47 <Daisy> Now we have ujuc from Korean, Fdot from France, fifieldt from Australia, and Daisy from China.
07:02:03 <Daisy> any friends from Japanese?
07:02:26 <Daisy> ok.
07:03:04 <Daisy> amotoki from Japan said that the daytime meeting is not so convenient for them, because they are doing translation using their spare time.
07:03:06 <Giang> DTT provides many IT solution for Vietnam and other countries including US, Singapore, ...
07:03:18 <fifieldt> hi Giang!
07:03:42 <Giang> Hi fifieldt. how are you!
07:03:53 <fifieldt> well thanks Giang, it's good to meet you :)
07:04:01 <ujuc> :))
07:04:03 <Daisy> How do you feel datatime meeting, Giang, ujuc and Fdot ?
07:04:21 <Daisy> daytime meeting
07:04:25 <Giang> one of DTT's solution is based on OpenStack which is eGovPlatform
07:04:28 <Fdot> Daisy I really enjoy it :)
07:04:36 <Daisy> thanks, Fdot .
07:04:38 <ujuc> I fine~~.. :))
07:05:00 <Giang> i am fine with the meeting time.
07:05:01 <Daisy> I'm fine too. I don't like night meeting. :)
07:05:05 <Daisy> ok.
07:05:15 <Daisy> #topic Action items from the last meeting
07:05:17 <Fdot> 9am is always better than 3am ;)
07:05:26 <Daisy> Daisy to update the wiki page to change the meeting frenquency
07:05:34 <Daisy> Done. The wiki page is changed.
07:05:44 <Daisy> gabrielcw to take a look at Transifex API to see if it's able to get the translators information.
07:05:53 <Daisy> That's done too. Gabriel sent out a mail yesterday.
07:06:04 <Daisy> The translator stastics will be a future feature in Transifex.
07:06:14 <Daisy> Gabriel will keep an eye on it.
07:06:25 <Daisy> Are you ok with the answer, fifieldt ?
07:06:44 * fifieldt reads
07:06:55 <fifieldt> it seems good progress
07:07:14 <Daisy> http://support.transifex.com/customer/portal/questions/1326867-translators-statistics
07:07:28 <Daisy> ok.
07:07:38 <fifieldt> cool
07:07:39 <fifieldt> very good news
07:07:40 <Daisy> ujuc to follow up why Korean characters cannot be shown in the generated PDF.
07:07:49 <Daisy> I think we have the answer to ujuc 's problem.
07:08:13 <Daisy> If we want to print Korean document, we need Korean font packaged in maven build plug in.
07:08:22 <ujuc> clouddoc-maven-plugin not import korean font.
07:08:33 <ujuc> yes
07:08:54 <fifieldt> did david reply yet?
07:09:02 <Daisy> so at last, we will need korean font, Japanese font, Chinese font, Vietnamese font.
07:09:07 <ujuc> i study maven build plugin…. :(
07:09:15 <Daisy> Does we need special font for French?
07:09:40 <Daisy> so I wonder if it is possible to access the systen font, other than packaged font.
07:09:52 <Daisy> or else, David will be busy to import so many fonts.
07:09:57 <Daisy> I have no idea.
07:10:06 <fifieldt> I don't know how it works either :s
07:10:28 <ujuc> :s
07:10:34 <Daisy> so we need David's help to solve the font issue. Daisy will track.
07:10:39 <fifieldt> but actually
07:10:44 <fifieldt> soon the doc framework
07:10:50 <fifieldt> will be under the openstack-infra repository
07:10:51 <Giang> I do not think you will need vietnamese font 'cos we use unicode
07:10:55 <fifieldt> so we can modify it without david
07:11:04 <Daisy> #action Daisy to track the font problem with David.
07:11:48 <Daisy> Giang, I will suggest you to do a test.
07:11:59 <Daisy> test whether there is font issue.
07:12:13 <Giang> ok, no problem
07:12:47 <Daisy> it's related with document translation. After translation, when generating document, some special font cannot be printed.
07:13:03 <Daisy> #topic Progress with Japanese doc site
07:13:25 <Daisy> Since there is no Japanese people, I will introduce the progress.
07:13:27 <Daisy> cannot be displayed.
07:13:54 <Daisy> Now amotoki has developed the website.
07:13:55 <Daisy> http://openstack-ja.github.io/openstack-manuals/ja/
07:14:06 <Daisy> It's under reviewed by Japanese team now.
07:14:34 <Daisy> He ( or she? ) will report a bug to openstack-manuals, and requested to add the new index page.
07:15:12 <Daisy> Documents are published using Jenkins's job. So we also need a job definition.
07:15:25 <Daisy> There is one, but I don't know if it works.
07:15:49 <Daisy> Japanese team created one draft. I have forwarded to CI team and asked for review.
07:15:58 <Daisy> no response yet.
07:16:40 <Daisy> The publish job will be a little difficult for us, because we don't have much understanding of CI infrastructure.
07:17:00 <Daisy> fifieldt: do you have any suggestion for such situation?
07:17:03 <fifieldt> I can take a look
07:17:10 <fifieldt> do you have the review #
07:17:10 <fifieldt> ?
07:17:38 <Daisy> no, I think it's very rough, I don't submit for review.
07:17:51 <Daisy> Japanese team have a mail sent to i18n mailing list with the job definition.
07:17:52 <fifieldt> I have written publish jobs before sucessfully
07:18:13 <Daisy> Great !
07:18:30 <Daisy> can I new a bug for CI team about this publish job?
07:18:42 <Daisy> we need your help.
07:18:43 <Daisy> I wonder if it is suitable to new a bug , because it may be a new requirement.
07:18:56 <fifieldt> is it a new requirement? can you forward me the email ?
07:19:01 <fifieldt> I haven't caught up with my email
07:19:02 <Daisy> not a bug.
07:19:09 <fifieldt> if it is easy I can do it tomorrow
07:19:14 <fifieldt> and ask in #openstack-infra for approval
07:19:25 <fifieldt> maybe we can discuss offline
07:19:29 <fifieldt> to keep the meeting going
07:19:42 <Daisy> ok.
07:19:45 <Daisy> I forwarded to your openstack mail.
07:19:57 <Daisy> #topic Progress with glossary table in Transifex
07:20:25 <Daisy> Fdot: would you like to introduce the progress?
07:20:44 <Daisy> Fdot's team is collecting the glossary now.
07:20:54 <Fdot> Daisy we have started to backport the glossary form the wiki into transifex
07:21:07 * Fdot looking for the url
07:21:20 <Fdot> #url :
07:21:26 <Fdot> #url : https://www.transifex.com/projects/p/openstack/glossary/l/en/
07:21:48 <Daisy> where is the wiki link?
07:21:49 <Daisy> can you share with us?
07:21:55 <Fdot> of course :)
07:22:02 * Fdot is looking for the url
07:22:22 <Fdot> #url : https://wiki.openstack.org/wiki/Glossary
07:22:51 <Daisy> Are you delete all the old glossarys in Transifex?
07:23:17 <Fdot> No and i have a question about this
07:23:27 <Fdot> There is 2 glossary in transifex
07:23:41 <Fdot> One for all the Openstack hub
07:23:51 <Fdot> and one for the manual part
07:24:07 <Fdot> we have started to works on the openstack hub
07:24:08 <fifieldt> we use the glossary in the openstack-manuals repo for several of the books
07:24:15 <Daisy> and maybe there are glossarey for Keystone, Horizon and so on.
07:24:27 <Fdot> yes
07:24:42 <Fdot> so maybe it would be better to use the manuals 's one
07:25:06 <Daisy> I think we should use the one in the hub.
07:25:42 <Daisy> fifieldt is taking about the glossary defined in github.com/openstack/openstack-manuals , right?
07:25:43 <Giang> Daisy, you mean this one https://wiki.openstack.org/wiki/Glossary?
07:25:55 <fifieldt> yes Daisy
07:26:09 <Daisy> right, Fdot 's team si importing the glossary in the wiki to Transifex.
07:26:25 <fifieldt> https://github.com/openstack/openstack-manuals/tree/master/doc/src/docbkx/common/glossary
07:26:41 <Fdot> Giang we are importing into https://www.transifex.com/projects/p/openstack/glossary/l/en/
07:26:42 <Daisy> fifieldt: have you done any comparation between these two glossary?
07:27:03 <Fdot> but we would like to know if we use this one or this onr : https://www.transifex.com/projects/p/openstack-manuals-i18n/glossary/l/en/
07:27:06 <fifieldt> unfortunately not, Daisy - I just fixed the one in the openstack-manuals repo when we wrote the operations guide
07:27:19 <fifieldt> it had too many terms that weren;t 100% relevent
07:27:21 <Daisy> Fdot: if we define the hub glossary, can we use it when we are translating openstack-manuals?
07:27:22 <fifieldt> so did some removing of terms
07:27:41 <Fdot> need to test :)
07:27:48 * Fdot is looking
07:28:26 <Daisy> fifieldt: "it had too many terms that weren;t 100% relevent", which one? the wiki one, or the manuals one?
07:28:31 <fifieldt> the manuals one
07:28:39 <Daisy> so you removed a lot?
07:29:06 <Fdot> in the manual part it is using the manual glossary
07:29:25 <fifieldt> quite a few Daisy, mainly the very generic ones
07:29:31 <fifieldt> which were more about general computers
07:29:36 <fifieldt> rather than OpenStack
07:30:01 <Daisy> I think some of the wiki glossary are not 100% relevent too. My question is where does the wiki glossary come.
07:30:41 <Daisy> Fdot: manuals in OpenStack cannot use the hub glossary definition?
07:30:44 <fifieldt> I think they are originally the same source
07:31:06 <fifieldt> I believe the wiki may be the original and it was introduced into the manuals repo but never removed from the wiki, so both kept being updated :)
07:31:09 <Daisy> Fdot: I think we need to do a check. I think probably yes.
07:31:33 <Fdot> daisy i don't understand your question :)
07:31:56 <Daisy> Fdot: to check whether openstack-manuals can use the glossary defined in openstack hub.
07:32:18 <Daisy> do I make sense?
07:32:25 <Fdot> Daisy yes
07:32:39 <Daisy> thanks.
07:32:49 <Fdot> into a manual project I have made some tests on some works
07:33:13 <Daisy> #action Fdot to check whether openstack-manuals can use the glossary defined in openstack hub.
07:33:18 <Daisy> Hi, there comes amotoki .
07:33:22 <Fdot> into the glossary part (bottom right) the definition are from the manual gloassry and not from the hub glossary
07:33:24 <amotoki> hi
07:33:35 <ujuc> hi :)
07:33:46 <Daisy> fifieldt: there are two glossary files in common/glossary
07:33:51 <Fdot> maybe it can be configurate into the hub or the project configuration
07:33:51 <Daisy> glossary-terms.xml
07:33:57 <Daisy> openstack-glossary.xml
07:34:05 <Daisy> which one are you using?
07:34:26 <fifieldt> openstack-glossary.xml is just an introduction
07:34:32 <fifieldt> the actual entries live in glossary-terms.xml
07:34:32 <Daisy> Fdot: if you need my help, I can. I'm the administrator of openstack hub.
07:34:42 <Daisy> ok. thanks.
07:35:06 <Fdot> Daisy : can you check if we can define into the configuration if we can force the hub glossary ?
07:35:24 <Daisy> sure. I can do offline.
07:35:39 <Daisy> #action Daisy to check if we can define into the configuration if we can force the hub glossary.
07:35:40 <Fdot> thanks a lot :)
07:36:17 <Daisy> Fdot: there are two glossary, one is in the wiki, the other is in manuals repository. Some of them may be same, and some of them may be different.
07:36:45 <Daisy> Do you have any suggestions for such situation?
07:37:00 <Fdot> Daisy : I have asked to one person of my team to check the difference
07:37:10 <Fdot> he is in holiday this week
07:37:14 <Daisy> which one should we use? Or we merge them? How can we track them automatically? Can we do it by program?
07:37:17 <Fdot> I am going to check with him
07:37:33 <Fdot> and to contact you back about what he has seen
07:37:48 <Fdot> I think they are close
07:37:54 <Daisy> thanks, Fdot . I remember Transifex can import from some format of files into glossary table.
07:37:54 <Fdot> we should merge them
07:38:39 <Daisy> Maybe the file importing can ease this work.
07:39:12 <Fdot> could be easier
07:39:23 <Fdot> than copying and pasting each words
07:39:27 <Daisy> right. not sure if there are any API support.
07:40:22 <Daisy> Glossary mantainance will be a problem for us in future, when our glossary table grows, and when doc team and other team change the glossary.
07:40:51 <Daisy> Anyway, let's do the import first.
07:40:52 <Daisy> ok.
07:41:06 <Daisy> I have finished all the topics I want to cover.
07:41:13 <Daisy> #topic Open discussion
07:41:14 <Daisy> we can move to the open discussion now.
07:41:24 <Fdot> I have a quick question :)
07:41:53 <Fdot> We are currently looking for working with a translation company for translating the manuals
07:42:09 <Fdot> but we can ask to this company to work on transifex
07:42:28 <Fdot> first we have decided to send them the Pdf for working
07:42:44 <Fdot> but it is going to be hard after for backporting into transifex
07:42:52 <Fdot> the works is going to be important
07:43:01 <Daisy> Fdot: you cannot ask them to work on Transifex?
07:43:05 <Fdot> have you got any advice on how we vcan proceed
07:43:27 <Fdot> unfortunatly no
07:43:32 <Fdot> they use their own tools
07:43:34 <Giang> why don't you ask it to work on Transifex?
07:43:36 <Daisy> Do they mind to translate po files directly? Then you can import po files to Transifex.
07:44:03 <amotoki> we experience Transifex is not a good platform to review the big documents too.
07:44:08 <Daisy> Fdot asks professional translation company to help on the translation.
07:44:22 <Giang> ok, i see
07:44:26 <Fdot> how did you do amotoki ?
07:44:29 <amotoki> we edit po file directly and upload po files to Transifex.
07:44:29 <Daisy> I agree with amotoki to some extend, actually.
07:45:10 <Fdot> the problem with Po file is that it is difficult to understand the context
07:45:38 <Fdot> you don't see the whole page
07:45:43 <Daisy> Generally speaking, when generating po files, the paragraph sequences are kept the same with source xml files.
07:45:59 <Fdot> so sometime it is difficult to understand what you are translating
07:46:09 <Daisy> but when the source xml files are changed, the sequence will not be kept exactly same.
07:46:23 <Daisy> The updated one will be appended at the end.
07:46:29 <Giang> Fdot, i have the same issue.
07:46:30 <Daisy> The old one will be deleted.
07:46:50 <Daisy> amotoki: how is your team feeling when translating po files?
07:47:18 <amotoki> Daisy: During the review, it is not a problem.
07:47:48 <amotoki> as an advice, we execute "msgfmt --statistics -o /dev/null <PO file>" to check the format.
07:47:53 <Daisy> What editor do you use, amotoki , to translate po file?
07:48:19 <amotoki> it depends on translators. I prefer to emacs po-mode.
07:48:20 <Daisy> I think there are some po editors that can help translation.
07:48:29 <Daisy> emacs?
07:48:34 <Daisy> what's this?
07:48:38 <amotoki> yeah
07:48:51 <amotoki> emacs is a very common editor in Unix world :-)
07:49:30 <Daisy> Fdot and Giang, will you try if your translators are ok to translate po files directly, other than using Transifex, but using some po editors.
07:50:01 <Fdot> Daisy I already know the answer they don't really want to work on Po file :(
07:50:09 <Fdot> They prefere Pdf
07:50:12 <Daisy> thanks for the answer, Fdot.
07:50:42 <Giang> i have no idea for now
07:50:57 <Giang> i am working on Transifex and it is ok for me
07:51:00 <Daisy> If the paragraph sequence are same, if the po editor can display the english string and translation string well, I personally think po files are all right.
07:51:02 <Giang> however ...
07:51:30 <Daisy> however what? Giang?
07:51:49 <Giang> we may have the same issue with Fdot when we want to hire any profressionals to do this job
07:52:10 <Daisy> you are so rich that you can hire professional translators.
07:52:14 <Daisy> :))
07:52:27 <Fdot> Daisy :D
07:52:28 <amotoki> I think translation work consists of two phase: the one is to translate, tranlate, tranlate... and the other is a review and feedback phase.
07:52:40 <Giang> OpenStack Vietnam team have an idea to ask students to help us
07:52:59 <Daisy> Good idea, Giang.
07:53:02 <amotoki> in the translation phase, Transifex is good to some extent, but Transifex.
07:53:20 <amotoki> Transifex is not so good in the review phase...
07:53:37 <Giang> however, we will not pay them by money but ...
07:53:47 <Daisy> we have a long way to go to make our translation tools better and better.
07:54:11 <Giang> by some award for active contributors
07:54:39 <Daisy> I'm open if soembody can propose new tools and new websites.
07:55:13 <Giang> In my case, Transifex is ok
07:55:17 <Fdot> Transifex is a nice tool
07:55:40 <Fdot> maybe we should just send some feedback to their team
07:55:48 <amotoki> I think so too.
07:55:48 <Fdot> maybe they will include them ;)
07:56:05 <Daisy> what I want to maintain is a good translation system, good usibility, good maintainance, and easy to syncronize with source strings.
07:56:36 <Daisy> I think Openstack community have some relationship with Transifex community.
07:56:47 <Daisy> fifieldt may know some.
07:57:02 <fifieldt> yeah, we're chjatting with transifex guys
07:57:10 <fifieldt> reed used to work with one of them :)
07:57:28 <Daisy> I remember our CI team offer to help us to set up our own transifex website if we want.
07:58:06 <Daisy> but I don't think we need to main our own transifex website till now.
07:58:19 <Daisy> maintain.
07:58:20 <Giang> yes, right
07:58:46 <ujuc> yes.
07:58:56 <Daisy> so let's summarize a wish list to Transifex and send to them through some channel?
07:59:09 <Daisy> agree?
07:59:16 <Giang> yes
07:59:21 <Fdot> +1 \o_
07:59:31 <fifieldt> sounds good
07:59:32 <Daisy> amotoki ?
07:59:47 <Giang> for now, i have only one issue is we do not see the whole context when translating.
07:59:52 <amotoki> Daisy: agee
07:59:58 <ujuc> +1~
08:00:00 <Daisy> ok. so there is an action item to all of the team.
08:00:25 <amotoki> I am summarizing our experience during the translation of ops-guide now.
08:00:35 <Daisy> #action each team collect the wish list of Transifex and Daisy to combine them.
08:01:09 <Daisy> amotoki: when you finish, please let i18n team know. It will be a great reference for all the team.
08:01:21 <Daisy> any other topics? Time pass very quickly.
08:01:21 <amotoki> Daisy: sure.
08:01:38 <Daisy> no topics?
08:01:39 <amotoki> Daisy: do you have any progress on the source lang in Horizon Transifex?
08:01:52 <Daisy> sorry no.
08:02:07 <Daisy> I will update with you through email.
08:02:24 <Giang> ok, thanks
08:02:29 <Daisy> #action Daisy to track the source lang in Horizon
08:02:30 <amotoki> thanks.
08:02:43 <Daisy> so I will close the meeting now.
08:02:55 <Giang> ok. see you all
08:02:56 <Daisy> Thank you all for your attendance.
08:03:00 <fifieldt> thanks!
08:03:03 <amotoki> thank you all!
08:03:04 <Daisy> #endmeeting