01:02:36 <Daisy> #startmeeting OpenStack I18n Meeting
01:02:37 <openstack> Meeting started Thu Aug 15 01:02:36 2013 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:02:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:02:40 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
01:03:02 <Daisy> #topic Action items from the last meeting
01:03:04 <fifieldt> hi
01:03:18 <gabrielcw> hello
01:03:21 <Daisy> Good morning, fifieldt !
01:03:32 <Daisy> we just starts.
01:03:37 <Daisy> Daisy to track the font problem with David.
01:03:41 <Daisy> It's done.
01:04:08 <Daisy> Korean team has sent the font file to David, David will cut a release
01:04:27 <Daisy> So the Korean font issue can be resolved. I don't know if the same issue will happen to other language.
01:04:45 <Daisy> But David agreed to change his plugin to enable people to set the font path.
01:04:57 <Daisy> Fdot to check whether openstack-manuals can use the glossary defined in openstack hub.
01:05:00 <Daisy> Fdot is not there.
01:05:08 <Daisy> Daisy to check if we can define into the configuration if we can force the hub glossary.
01:05:21 <Daisy> It's done. But I'm going to cover it in the following topic.
01:05:32 <Daisy> each team collect the wish list of Transifex and Daisy to combine them.
01:05:59 <Daisy> I only got feedback from Giang Duong, the Vietnamese team. I will also cover it in the following topic.
01:06:09 <Daisy> Daisy to track the source lang in Horizon
01:06:36 <Daisy> Sorry I don't get more information. Per my understanding, there is no progress with this issue. I don't have the right to change Horizon project. I think Gabriel Hurley is the key person and I will continue to reach him.
01:06:58 <Daisy> ok. that's all of the action items last meeting.
01:07:06 <Daisy> we will move to next.
01:07:15 <Daisy> #topic Progress with Japanese doc site
01:07:15 <gabrielcw> nice
01:07:32 <Daisy> fifieldt: I see there is progress with https://review.openstack.org/#/c/39846
01:07:43 <fifieldt> yes
01:07:44 <Daisy> what's left in your mind?
01:07:46 <fifieldt> it now passes tests
01:07:51 <fifieldt> it needs to be merged
01:08:02 <fifieldt> I'm also not sure whether we merged the docs.openstack.org/ja page
01:08:05 <fifieldt> did that happen yet?
01:08:20 <Daisy> I didn't see the page yet.
01:08:40 <fifieldt> I know the basic design exists
01:08:46 <Daisy> I will check with Akihiro MOTOKI offline.
01:08:48 <fifieldt> maybe we just need to turn it into a patch
01:08:48 <fifieldt> ok
01:08:55 <Daisy> Right.
01:09:32 <Daisy> fifieldt: do you think it is possible to enable a parameter in https://review.openstack.org/#/c/39846, so that when we want to add Chinese site, we can simply change the parameter?
01:10:11 <fifieldt> yes, it can likely be modified for this
01:10:15 <fifieldt> is it OK to iterate?
01:10:21 <fifieldt> I'm not 100% sure this patch will work
01:10:26 <fifieldt> so plan to keep it simple first
01:10:30 <fifieldt> then make it better later
01:10:31 <Daisy> ok.
01:10:38 <Daisy> got your point.
01:10:54 <Daisy> #topic Glossary defined in Transifex
01:11:05 <Daisy> I checked Transifex.
01:11:07 <Daisy> A user can create multiple glossaries and attach them to the projects he owns, as long as the project and the glossary share the same source language. The glossaries can be bootstrapped by uploading a CSV file.
01:11:31 <Daisy> It looks like it's able to define a glossary and associate all the openstack projects with it. But this action needs an account with all the full access to the hub project Openstack and its related projects. I don't know if there is such account.
01:11:54 <fifieldt> don't you have access?
01:12:14 <Daisy> I did test within my account. I'm able to create a glossary and associate it with all the project (with same source language) I own.
01:12:40 <Daisy> Although I'm the maintainer of OpenStack, I'm not able to manage the glossary defined within OpenStack.
01:12:49 <fifieldt> mmm, odd
01:13:02 <fifieldt> can we create a support request with transifex?
01:13:04 <Daisy> I'm not able to manage other projects, like Nova, Horizon, and etc. Because I'm not the owner.
01:13:26 <fifieldt> oh, right
01:13:26 <fifieldt> so there is only ever one owner?
01:13:53 <Daisy> It looks like owner is the one who create such project.
01:13:59 <fifieldt> argh, damn
01:14:02 <lifeless> the maintainer can be a team
01:14:25 <lifeless> oh, sorry, transifex, I dunno.
01:14:28 <Daisy> right. But it looks like the team don't have the right to manage glossary.
01:14:29 <lifeless> I was thinking LP.
01:14:40 <Daisy> Hi, lifeless
01:14:55 <fifieldt> np
01:16:22 <Daisy> so I will continue to follow up with this issue. If we fail to do, we can ask help from Transifex. Let's see.
01:16:36 <fifieldt> ok
01:16:39 <gabrielcw> Hello?
01:16:54 <Daisy> BTW, I find there are several project setting the source language as en_US.
01:17:07 <fifieldt> oh no
01:17:10 <fifieldt> hi gabrielcw!
01:17:23 <Daisy> The source language of Cinder, Glance, Horizon,and Nova are en_US, and others are en.
01:17:27 <gabrielcw> oh, some delay here...nevermind
01:17:38 <Daisy> Now we only meet with problem in Horizon.
01:17:52 <Daisy> I don't know if this issue will cause problems in other projects.
01:18:23 <gabrielcw> sorry, i`m not aware of this problem, can you explain shortly?
01:18:28 <Daisy> And, if the source language are different, it's not able to share a same glossary among them, because glossary can only share among projects with same source langauge.
01:18:51 <Daisy> so...anyway, we need to change the issue.
01:19:20 <Daisy> I hope I can have the higher right than I have now.
01:19:55 <yosshy> Sorry, I'm late. Hello all.
01:19:59 <Daisy> It looks like projects of openstack translations are made by different people.
01:20:02 <Daisy> Hi, yosshy
01:20:13 <gabrielcw> hi
01:20:25 <Daisy> created by different people.
01:20:42 <Daisy> any comments?
01:21:29 <Daisy> #action: Daisy to continue to track the glossary and source language issue.
01:21:36 <Daisy> let's move on.
01:21:44 <Daisy> #topic Transifex requirements/bugs collection
01:22:02 <Daisy> Stefano Maffulli suggested us to collect our requirements to translation tool, not only specific to Transifex.
01:22:18 <Daisy> If we are not so satisified with Transifex, we can change to other tools.
01:22:36 <Daisy> I looked in my old mails and found this:
01:22:46 <Daisy> https://docs.google.com/spreadsheet/ccc?key=0Aqevw3Q-ErDUdFgzT3VNVXQxd095bFgzODRmajJDeVE#gid=0
01:23:20 <Daisy> It was the original discussion when the community was going to select a translation management tools other than Launchpad.
01:24:20 <gabrielcw> Besides some minor issues, I like to use Transifex, even the web client
01:24:29 <Daisy> I don't know your opinion to Transifex. Do you like it? Do you use it? Do you think it can satisy you?
01:24:34 <Daisy> satisfy you?
01:24:50 <Daisy> how about you, yosshy ?
01:24:59 <yosshy> Yes.
01:25:04 <fifieldt> the web client is nice (especially when it has suggestions from the translation memory) but it doesn't show context of the string
01:25:06 <gabrielcw> they are very helpful when bugs are found
01:25:22 <gabrielcw> yeah, true
01:25:33 <yosshy> We found that Transfex is not good for review.
01:25:36 <gabrielcw> I miss the context too
01:25:53 <Daisy> What do you mean, yosshy ?
01:26:28 <Daisy> Yeah, maybe when reviewer does the review, they want to review a whole document, not paragraph.
01:27:02 <Daisy> That's to documents. not to messages.
01:27:14 <fifieldt> it would be good to have the whole document be displayed, but be able to mark certain paragraphs OK as you go
01:27:21 <Daisy> I think, Transifex is all right as to message translation.
01:27:56 <yosshy> Yes, but no for long sentences.
01:28:24 <Daisy> maybe we can look for better tool for document translation.
01:28:45 <Daisy> but the translation memory share will be a problem if we move documents to other tools.
01:29:04 <yosshy> I hear that each review is closed if somebody push "reviewed" button on Transfex.
01:29:14 <fifieldt> yeah - recently I've been translating AskBot, which has excellent translation memory already and it's a lot more fun
01:29:28 <Daisy> in Transifex?
01:29:37 <fifieldt> yeah
01:29:40 <Daisy> AskBot don't have document translation.
01:29:45 <fifieldt> true
01:29:50 <fifieldt> it's just good for strings
01:29:55 <fifieldt> just sharing experience :)
01:29:56 <Daisy> correct.
01:30:35 <Daisy> let's continue the discussion with our translation team through mailing list.
01:31:18 <Daisy> Again, Transifex is a good tool to translate strings. Even it's not open source, in my opinion, I think it's acceptable.
01:31:52 <Daisy> I don't know if the community agrees or not if Transifex is not open source any more.
01:32:18 <Daisy> any other comments? If no, we move to next topic.
01:32:33 <gabrielcw> they think they are :) http://help.transifex.com
01:32:34 <Daisy> #topic Open discussion
01:32:34 <yosshy> It looks that amotoki is absent today. He can describe problems to work on Transfex.
01:33:15 <Daisy> https://github.com/transifex/transifex/issues/206#issuecomment-15243207
01:33:30 <Daisy> gabrielcw: Transifex is going to not be open source any more.
01:34:19 <gabrielcw> oh
01:34:45 <Daisy> I'd like to say something about progress with translation.
01:34:58 <yosshy> As a report, japanese team doesn't start the next translation work.
01:35:55 <Daisy> Chinese team is setting up the team now, and then we will start the translation of operation guide.
01:36:20 <Daisy> I'm going to look for another coordinator in China, yet I didn't find. :)
01:36:35 <fifieldt> ask openstack is now in chinese too: https://ask.openstack.org/zh/
01:36:52 <Daisy> Thanks, fifieldt .
01:37:00 <Daisy> As to the priority, I will set Operation guide as the top priority during this period. Do you have opposite opinion?
01:37:08 <gabrielcw> nope
01:37:13 <Daisy> When we set the priority, I hope the whole translation team can follow it.
01:37:28 <Daisy> So we focus on one job, when it is finished, we start another one.
01:37:33 <gabrielcw> yeah, that's good!
01:37:51 <Daisy> ok.
01:38:38 <Daisy> I'm going to write an update to the whole community. Here is a draft:
01:38:40 <Daisy> https://etherpad.openstack.org/WhatupI18nTeam
01:39:07 <Daisy> Please let me know your opinion to expose your name and email in the mailing list. I write down the list of our contact information because I think there may be some people in your country to contact with you in order to understand more about openstack translations.
01:39:31 <yosshy> amotoki wrote japanese dashboard page of doc.
01:39:43 <fifieldt> I saw that yosshy, it looks good
01:39:51 <Daisy> yosshy: where is the link?
01:39:52 <gabrielcw> I agree,
01:39:52 <yosshy> yeah.
01:39:56 <fifieldt> does he plan to submit a patch?
01:40:04 <fifieldt> or should we help to submit the patch?
01:40:47 <yosshy> I'm now looking for the mail with the link...
01:40:59 <Daisy> oh. I think I know the link. Sorry I just did not understand what was dashboard. :)
01:41:12 <fifieldt> http://openstack-ja.github.io/openstack-manuals/ja/
01:41:29 <yosshy> oh, thank you.
01:41:42 <fifieldt> my pleasure
01:42:11 <yosshy> That's a draft now and we are in review.
01:42:49 <Daisy> yosshy: is it the first time you join the meeting? I don't see this id before.
01:43:34 <fifieldt> ok
01:43:34 <fifieldt> then after the review it will be submitted as a patch
01:43:34 <fifieldt> sorry, I didn't completely read the emails :)
01:43:36 <yosshy> No. I joined the last meeting.
01:44:30 <fifieldt> 吉山?
01:44:33 <yosshy> but perhaps I have another id. I'm new for webchat.
01:44:51 <yosshy> Yeah. I'm Akira Yoshiyama (吉山).
01:44:57 <fifieldt> :)
01:45:10 <Daisy> I know this name: Akira Yoshiyama.
01:45:24 <Daisy> Thank you, yosshy. I just want to make sure I understand who you are. :)
01:45:58 <Daisy> so any other topics?
01:46:47 <Daisy> if no, we will close the meeting.
01:46:49 <gabrielcw> I'm still watching the Tx API for the translators stats
01:46:55 <gabrielcw> just a heads up
01:46:55 <yosshy> ok.
01:46:57 <Daisy> Thanks, gabrielcw .
01:47:01 <gabrielcw> sure
01:47:24 <Daisy> Our next meeting will be hosted next Month, 5th, Sep
01:47:28 <gabrielcw> nothing new yet, but they fixed a bug I found recently very quickly
01:47:42 <yosshy> I see.
01:47:42 <gabrielcw> will you guys attend the summit btw?
01:47:44 <Daisy> Yes, I see your email.
01:48:03 <Daisy> I will. Will you, gabrielcw ?
01:48:13 <fifieldt> I will be there :)
01:48:24 <Daisy> Surely you will, fifieldt .
01:48:29 <gabrielcw> Oh, I won't...:(
01:48:38 <gabrielcw> it's very far from here :)
01:49:07 <yosshy> I hope to join it but...
01:49:14 <gabrielcw> There will be some people from hp, but not me
01:49:22 <fifieldt> I went to the venue
01:49:22 <Daisy> maybe next time, the summit can be hosed in a city near Brazil.
01:49:24 <fifieldt> it's awesome :)
01:49:33 <gabrielcw> in fact this is my off work hours, so...
01:49:49 <gabrielcw> we hope so!
01:50:18 <Daisy> anything else to discuss?
01:50:30 <gabrielcw> quick question
01:50:42 <gabrielcw> do we have a deadline for the translations?
01:50:51 <Daisy> not exactly deadline.
01:51:25 <Daisy> I know many people do the translation in their spare time, so there is no deadline in my mind.
01:51:36 <Daisy> I don't want to push...
01:51:56 <gabrielcw> yeah, but is there a target date, to try to finish
01:52:04 <Daisy> But, I think, there should be a deadline within a translation team.
01:52:09 <gabrielcw> losse date
01:52:17 <gabrielcw> *loose
01:52:28 <gabrielcw> I understand
01:52:37 <Daisy> the deadline can be discussed within a translation team, the team can decide, depending on their situation.
01:52:52 <yosshy> I agree.
01:53:12 <Daisy> The top priority work for us are operation guide (documentation ) and Horizion.
01:53:34 <gabrielcw> right, will you update the priorities in the Tx?
01:53:36 <Daisy> As to documentation, I don't have an overall deadline, I want each team to decide. When the document is ready, we can publish to website.
01:54:04 <Daisy> But as to the Horizion, when the code strings are frozen, there should be a deadline before the product release.
01:54:19 <gabrielcw> right
01:55:07 <Daisy> So when the code strings are frozen, I hope each translation team can focus their time on the Horzion transaltion. Again, this is not mandatory. Which team can finish on the time, which translation can be merged in the product release.
01:55:32 <fifieldt> sounds reasonable
01:56:00 <Daisy> :)
01:56:08 <Daisy> I haven't talked with Horzion team yet.
01:56:22 <yosshy> I see. We'll discuss about it in the next week because we have a week vacation in Japan.
01:56:31 <Daisy> I'm going to attend their meeting next week, it's in the early moring, hard for me to catch.
01:56:39 <fifieldt> enjoy it yosshy :D
01:56:46 <yosshy> Thank you.
01:57:30 <Daisy> I will repor to you after I talk with Horizon team, about the string forzon time and release time.
01:57:48 <Daisy> anything else?
01:58:03 <Daisy> no?
01:58:05 <gabrielcw> not for me :)
01:58:08 <Daisy> I will end up the meeting then.
01:58:23 <Daisy> Thank you for joining !
01:58:29 <Daisy> #endmeeting