00:00:32 <Daisy> #startmeeting OpenStack I18n Meeting
00:00:33 <openstack> Meeting started Thu Sep 19 00:00:32 2013 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:36 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
00:00:50 <Daisy> Good morning, ujuc_phone and fifieldt .
00:00:51 <gabrielcw> Hi!
00:01:00 <Daisy> Good evening, gabrielcw !
00:01:14 <gabrielcw> good evening!
00:01:30 <Daisy> anybody else? Akihiro will be several minutes late.
00:01:53 <Daisy> ok. we will start.
00:02:06 <Daisy> #topic Action items from the last meeting
00:02:15 <Daisy> Daisy to add diango_openstack_auth to Transifex.
00:02:16 <Daisy> done
00:02:25 <Daisy> Daisy to get another tester for Horizon I18n.
00:02:55 <Daisy> Akihiro and I wrote the wiki page "How to test Horizon with DevStack", and broadcasted to the mailing list. There were some people who responsed and would like to test.
00:03:17 <Daisy> I see somebody else is reporting I18n bugs to Horizon yesterday. So I will mark this one as done.
00:03:34 <Daisy> Fdot is going to see with the Cloudwatt horizon team if they can help on testing the french translation with Daisy
00:03:55 <Daisy> Fdot is not here. I don't see his response. I can check with him next meeting.
00:04:00 <gabrielcw> nice, I will test this weekend I hope
00:04:09 <gabrielcw> in Portuguese
00:04:12 <Daisy> Great, gabrielcw !
00:04:33 <Daisy> I find it's very easy to verify the translation when I run Horizon. :)
00:04:52 <gabrielcw> I agree, I used to do some small changes in the django code
00:05:05 <gabrielcw> in an HP project
00:05:16 <Daisy> BTW, I like DevStack very much, when I set up OpenStack in a half day in my locale machine.
00:05:18 <gabrielcw> devstack is very handy
00:05:26 <gabrielcw> yeah :)
00:05:39 <Daisy> next one: Daisy to track the progress of ja document website.
00:05:51 <Daisy> Sorry I'm a little lost with this work. I see the job is ready in Jenkins. I don't know the website progress.
00:06:22 <Daisy> I will leave this work item to next meeting.
00:06:40 <Daisy> #action: Daisy to track the progress of ja document website.
00:06:48 <Daisy> Daisy to send the glossary cvs file to Fdot
00:07:10 <Daisy> It's done. The glossary can be downloaded and uploaded as a CVS file. If there are other teams who would like to translate the glossary in CVS format, feel free to contact with me.
00:07:38 <gabrielcw> What`s the size of the glossary?
00:08:01 <Daisy> Let me check.
00:08:20 <gabrielcw> oh, I check it later, just tell me where it is
00:08:49 <gabrielcw> I ask because now I have more people helping, and I can ask them. I cannot do it right now
00:09:19 <Daisy> ok. I guess it's around 200-300.
00:09:25 <fifieldt> I find it useful to update the glossary as I find a word that gets used frequently
00:09:27 <Daisy> I don't know the exact number.
00:09:33 <fifieldt> it's quite simple through the interface to do this
00:09:34 <Daisy> Agree, fifieldt .
00:09:46 <gabrielcw> ok, thanks and where can I download it?
00:10:27 <Daisy> When I do the translation, I feel there may be two kinds of glossarys. One are those doc team summarized.  The others are those translators summarized.
00:11:11 <Daisy> https://www.transifex.com/projects/p/horizon/glossary/l/en/
00:11:23 <Daisy> All openstack projects are sharing a same glossary.
00:11:47 <gabrielcw> very nice
00:12:10 <Daisy> can we move to next topic ?
00:12:22 <Daisy> #Horizon translation progress report
00:12:28 <gabrielcw> yes
00:12:30 <Daisy> https://www.transifex.com/projects/p/horizon/
00:12:39 <yoshiyama> ok.
00:12:55 <Daisy> From the dashboard, we can see:
00:12:56 <Daisy> 5 languages completed: Japanese, Portuguese (Brazil), Chinese (China), English (Australia), Korean (Korea).
00:13:08 <Daisy> yoshiyama:you are just in time. :)
00:13:22 <yoshiyama> Hi all.
00:13:29 <gabrielcw> Hi!
00:13:30 <ujuc_phone> Hi~
00:13:30 <Daisy> Thanks very much to the these langauge teams.
00:13:40 <Daisy> 6 languages have completed more than a half: French 70%, Polish (Poland) 64%, Spanish 64%, Chinese (Taiwan) 61%, Czech 61%, Finnish (Finland) 49%
00:13:51 <Daisy> Yet not all of these 6 languages are active, because the completion rate 60% may be caused by the old version (Grizzly) of Horizon translation importing to the new version (Havanna).
00:14:36 <Daisy> I looked into the translation log each team by each team. I see the active languages are: French, Polish (Poland), Spanish, Russian, German, Portuguese.
00:15:03 <Daisy> No team have completed the review. Portuguese (Brazil), French, and Russian team make good progress in the review.
00:15:45 <Daisy> any comments?
00:15:54 <yoshiyama> Motoki-san built a test site to check messages of Horizon. It's very helpful.
00:16:26 <Daisy> Can people access this website?
00:16:42 <gabrielcw> great idea
00:16:48 <yoshiyama> Perhaps yes.
00:17:20 <ujuc_phone> Yes
00:17:43 <Daisy> Hi guys. Do you have any thoughts to push the translation ?
00:18:32 <gabrielcw> I believe the stuck languages don`t have active coordinators, right?
00:18:46 <Daisy> right, gabrielcw
00:19:01 <fifieldt> I was thinking maybe we could contact the existing translators for these languages and ask if anyone wants to be a coordinator?
00:19:03 <gabrielcw> we could maybe ask if the still want the role, and then announce we are looking for people.
00:19:06 <Daisy> and in some language team, maybe only the coordinator is working.
00:19:24 <gabrielcw> this won't solve this release but at least for the next one we can have progress...
00:19:47 <gabrielcw> Well I was in this case
00:20:03 <Daisy> ujuc_phone: are there any people helping you to do the translation?
00:20:04 <gabrielcw> but then I got to go after people to help out after all
00:20:19 <ujuc_phone> Yes,
00:20:21 <yoshiyama> I found the topic: https://groups.google.com/forum/#!topic/openstack-ja/B30jewdeVEk
00:20:21 <Daisy> great !
00:20:29 <ujuc_phone> ;)
00:20:48 <gabrielcw> in fact only in review time I got help, it was when the translation got visible with some Tom emails on the lists...
00:21:15 <Daisy> so after Horizon release, we should ask for more cooridnators.
00:21:17 <yoshiyama> It contains the url and accounts.
00:21:42 <gabrielcw> IIMHO
00:22:15 <Daisy> yoshiyama: I feel if there is a live Horizon for people to see their translation, it will defintely promote the quality. :)
00:22:32 <Daisy> I have this idea too, but I'm not able to find a host.
00:22:47 <Daisy> find a machine to host Horizon.
00:22:51 <fifieldt> how much resource do you need?
00:23:07 <Daisy> fifieldt: ?
00:23:14 <fifieldt> eg is 1 cpu enough
00:23:25 <Daisy> I think all in one is enough.
00:23:29 <Daisy> 1 cpu
00:23:50 <fifieldt> so, we might be able to create a new machine in the #openstack-infra system
00:23:52 <Daisy> I remember there is a trystack?
00:23:55 <fifieldt> which uses their existing devstack scripts
00:24:04 <fifieldt> and updates it every day or so
00:24:08 <fifieldt> with translations
00:24:15 <Daisy> great idea, fifieldt !
00:24:18 <fifieldt> it would be tricky to set up initially
00:24:25 <fifieldt> but once it was running it should be good
00:24:37 <gabrielcw> devstack requirements are very low
00:24:59 <fifieldt> the alternate, if you wanted something more quickly, is to use the rackspace free offer for openstack developers
00:25:38 <Daisy> I think I want it to set up, but not in a hurry, because we are very reach the end of Havanna release now.
00:25:40 <yoshiyama> Motoki-san's devstack environment to review messages of Horizon: http://v157-7-133-23.myvps.jp:13580/
00:25:50 <Daisy> we may not be able to use it in this release.
00:26:42 <Daisy> fifieldt: who is operating the trystack?
00:26:54 <fifieldt> trystack.org is operated by Dan Radez at RedHat
00:26:58 <Daisy> ok.
00:27:03 <fifieldt> trystack.cn is operated by Du YuJie at 99 cloud
00:27:23 <Daisy> How can I start the converstaion with rackspace free offer?
00:27:42 <Daisy> I may need to check with them one by one to see who would like to help.
00:27:53 <oubiwann> Daisy: ping jesse.noller@rackspace.com
00:27:54 <fifieldt> I think it is http://iopenedthecloud.com/
00:28:06 <oubiwann> and, yes -- what fifieldt said
00:28:19 <oubiwann> but if you need any help, jesse's you guy
00:28:31 <oubiwann> *your
00:28:38 <Daisy> thank you, oubiwann .
00:28:45 <oubiwann> you bet!
00:28:51 <Daisy> Let me try if I can find the good guy.
00:28:58 <Daisy> find a good people. :)
00:29:43 <gabrielcw> yoshiyama: can we use this Horizon to check other languages?
00:30:32 <Daisy> ok. so in a summary, there are two things we need to do after these busy days: check the unactive teams to see if someone else would like to be the coordinators; look for a place to run a live Horizon to verify the translation.
00:30:38 <yoshiyama> I think yes, but I have to confirm it to Motoki-san.
00:31:15 <Daisy> may we move to next topic ?
00:31:23 <yoshiyama> ok.
00:31:25 <Daisy> #The merging time and criteria of Horizon translations
00:31:33 <Daisy> From the wiki page, I see the first RC date is Sep 26, and the final release date is Oct 17.
00:31:45 <Daisy> First, the merging time.
00:31:53 <Daisy> yoshiyama: your thoughts?
00:32:51 <Daisy> actually, I don't know if there are RC2, or RC3.
00:33:16 <yoshiyama> Motoki-san said that Sep. 24th looked the limit to translate.
00:33:49 <Daisy> maybe nobody can tell that before RC1. Julie Pichon told me whether there are RC2 and RC3 depends.
00:34:17 <gabrielcw> yeah, generally depends on the quality and issues of RC1
00:34:26 <Daisy> right, gabrielcw
00:34:57 <Daisy> I suggest we do a merge before each release?
00:35:23 <fifieldt> and we should make sure to have the attention of reviewers
00:35:23 <fifieldt> so they can easily approve
00:35:25 <fifieldt> we don't want to miss out :D
00:35:28 <Daisy> We need help from Horizon team. Horizon team will know exactly the release date, and they will do a merge maybe 2 days before each release.
00:35:56 <Daisy> good idea, fifieldt .
00:35:58 <gabrielcw> iDo we have something to translate on the openstack_auth?
00:36:22 <Daisy> We have two developers from Horizon development team to support us. I think we won't miss out.
00:36:41 <Daisy> openstack_auth is used by the log in page.
00:37:32 <Daisy> we need to translate it, but the openstack_auth owner needs to merge our translation and deliver a binary release.
00:37:55 <gabrielcw> sure! I wasn't linking the name Daisy
00:37:56 <Daisy> openstack_auth is a binary dependent library to OpenStach Dashboard.
00:38:34 <Daisy> so next one: the criteria
00:39:12 <Daisy> Since the review progress is slow, I think, maybe we should use 100% translation as the criteria.
00:40:02 <gabrielcw> I think it's great to have as many languages as possible available, but on the other hand I wonder if som low quality translation with typos, won't generate a bad image and critics
00:40:30 <gabrielcw> I think that typos are worse than incomplete.
00:40:51 <fifieldt> maybe a test on the dashboard for each language can more easily review the most common strings
00:40:59 <Daisy> right, fifieldt .
00:41:03 <fifieldt> there are many strings which people might not see
00:41:15 <fifieldt> so they are slightly less critical than the ones eg on the login page
00:41:25 <fifieldt> and I guess if the "always visible" strings are correct
00:41:28 <Daisy> I don't review those translation one by one, but I run it and see the strings from the UI. I correct the strings I feel not correct.
00:41:29 <fifieldt> then criticism is unlikely
00:41:34 <gabrielcw> I found during review that some old strings even had the inverse meaning! like can instead of can't
00:41:51 <fifieldt> ouch :D
00:42:24 <Daisy> we need a responsible coordinator. :))
00:42:34 <Daisy> we need responsible coordinators.
00:42:45 <yoshiyama> sure.
00:42:47 <gabrielcw> Maybe we could ask the team coordinators of those not complete
00:43:05 <gabrielcw> if he/she thinks it`s already ready to ship
00:43:43 <Daisy> Let's say, we merge 100% translation before RC1, and then we ask the coordinators of these language team to verify the strings from the web page.
00:44:09 <Daisy> We still have time to correct those wrong strings before the final release.
00:44:15 <gabrielcw> yes
00:44:38 <Daisy> So we need a live Horizon urgently now. Thus the coordinators can find a place to check the translations.
00:44:39 <fifieldt> sounds good
00:44:51 <yoshiyama> Good morning, Motoki-san.
00:45:04 <Daisy> how can I quickly get a live Horizon running?
00:45:04 <gabrielcw> at least we would have a go from someone who knows better the languages
00:45:05 <amotoki> sorry. deleayed...
00:45:14 <Daisy> amotoki: good morning.
00:45:22 <gabrielcw> Hi amotoki
00:45:36 <Daisy> we are discussing about the merging time and criteria of Horizon translations now.
00:45:38 <ujuc_phone> Hi amotoki
00:45:50 <amotoki> hi all
00:46:46 <Daisy> about the merging time, our agreement is:  Horizon team will know exactly the release date, and they will do a merge maybe 2 days before each release.
00:46:46 <yoshiyama> We discussed that we need help from horizon delelopers.
00:47:03 <Daisy> do you have comments to this one?
00:47:57 <amotoki> i am not sure the exact date
00:48:13 <amotoki> but rc1 release date can be determined by each project.
00:48:24 <Daisy> about the criteria, we merge 100% translation before RC1, and then we ask the coordinators of these language team to verify the strings from the web page. It will be better if we can set up a live Horizon website.
00:49:12 <Daisy> Is RC1 determined?
00:49:12 <amotoki> japanese team has horizon check site. i can pull all languages from transifex.
00:49:36 <Daisy> Is the date of RC1 decided?
00:49:44 <amotoki> perhaps we will discuss it in the next horizon meeting.
00:49:56 <amotoki> not yet on the date.
00:50:12 <Daisy> ok. Can you help to pull the 100% translation and merge them before each release?
00:50:23 <amotoki> sure
00:50:28 <Daisy> nice.
00:50:30 <gabrielcw> great
00:51:21 <Daisy> amotoki: can I assign an action item to you: pull all languages from transifex in the Japanese horizon check site?
00:51:40 <amotoki> Daisy: okay
00:51:43 <Daisy> thanks.
00:51:58 <Daisy> #action amotoki pull all languages from transifex in the Japanese horizon check site
00:52:14 <Daisy> ok. we can move to next topic now.
00:52:23 <Daisy> #Icehouse design summit session proposals in I18n areas
00:52:33 <Daisy> There is no specific track about I18n in the design summit till now. So we may need to raise those topics in other tracks.
00:52:39 <Daisy> Here is the design summit link: http://summit.openstack.org/
00:52:46 <Daisy> Who will go to the summit?
00:52:55 * fifieldt waves
00:53:04 <Daisy> Anne Gentle has submitted a proposal "Publishing translated documentation".
00:53:26 <Daisy> Do you have any ideas in your mind?
00:54:09 <Daisy> I have two: Separate the log message domain and the user facing message domain (Oslo);  Consider translation and I18n test in the release lifecycle (Release management)
00:54:35 <Daisy> If you have, please submit.
00:55:32 <Daisy> we have 5 minutes left.
00:55:50 <Daisy> let's go to next topic?
00:55:53 <Daisy> #Open discussion
00:55:56 <gabrielcw> yes
00:56:04 <yoshiyama> ok.
00:56:11 <Daisy> #topic Open discussion
00:56:13 <ujuc_phone> Ok...
00:56:40 <Daisy> we have 5 minutes left.
00:57:16 <Daisy> if no addtional discuss, we can close the meeting.
00:57:18 * fifieldt has nothing
00:57:37 <gabrielcw> I don't have nothing today
00:57:42 <amotoki> nothing from me. i will catch up the discussion later from the log.
00:57:48 <gabrielcw> What about the next meeting hours?
00:57:49 <Daisy> good, gabrielcw
00:57:57 <Daisy> Thank you, amotoki !
00:58:04 <gabrielcw> I meant, on this time slot
00:58:07 <Daisy> Which one do you prefer, gabrielcw ?
00:58:11 <gabrielcw> this one :)
00:58:15 <Daisy> I'm good to both.
00:58:20 <Daisy> how about others?
00:58:22 <gabrielcw> 9PM for me
00:58:27 <gabrielcw> better than 10PM
00:58:35 <Daisy> agree, gabrielcw
00:58:58 <Daisy> if there is no opposition, we will use the new time?
00:59:10 <Daisy> ok. we use the new time.
00:59:17 <gabrielcw> :)
00:59:22 <Daisy> great !
00:59:41 <ujuc_phone> :)
00:59:48 <gabrielcw> thanks!
00:59:54 <Daisy> I will start my holidays from today: the Mid-Autumn Festivals in China.
01:00:04 <Daisy> I will be back to office next Monday.
01:00:20 <gabrielcw> have a nice holiday!
01:00:22 <fifieldt> 中秋节快乐
01:00:25 <Daisy> Thanks.
01:00:34 <amotoki> :) thanks
01:00:36 <yoshiyama> Have a good horiday!
01:00:39 <Daisy> Yes, fifieldt ! I believe you will feel the happiness in China these days.
01:00:51 <fifieldt> indeed :)
01:01:00 <Daisy> so I close the meeting.
01:01:01 <fifieldt> time to eat mooncake
01:01:03 <yoshiyama> FYI: I and Hasegawa-san were selected to push for OpenStack Ambassador in JOSUG board members.
01:01:49 <Daisy> #endmeeting