07:01:53 <Daisy> #startmeeting OpenStack I18n Meeting
07:01:54 <openstack> Meeting started Thu Dec 5 07:01:53 2013 UTC and is due to finish in 60 minutes. The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:01:57 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:02:16 <Daisy> Hello, everybody
07:02:23 <ujuc> Hello :)
07:02:27 <Daisy> We have chandankumar, ujuc, epico.
07:02:29 <Daisy> Welcome
07:02:42 <epico> Hello
07:02:50 <Daisy> Welcome, epico.
07:03:01 <Daisy> I guess we have smaller and smaller people who join the meeting.
07:03:04 <epico> :)
07:03:08 <jpich> Hey, Daisy :)
07:03:12 <chandankumar> yes
07:03:16 <Daisy> Hi, jpich! Welcome.
07:03:19 <chandankumar> jpich, Hello
07:03:32 <Daisy> Let
07:03:35 <Daisy> Let's start.
07:03:40 <Daisy> #topic Horizon translation update
07:04:14 <Daisy> I got confirmation of Polish translation team that they updated horizon translation.
07:04:23 <amotoki> hi
07:04:29 <Daisy> Any other team who update Horizon translations?
07:04:32 <Daisy> Hi, amotoki.
07:04:47 <jpich> Hi, amotoki! I was hoping you were around :)
07:04:55 <chandankumar> Daisy, right now , but will be update soon for hindi :)
07:05:21 <Daisy> chandankumar, I think Horizon dev team will do the translation merge most recently.
07:05:41 <Daisy> amotoki and jpich, when are you going to submit a patch to update translation?
07:05:46 <amotoki> There are some srting changes in horizon stable/havana and I pushed the lastest POT files to Transifex.
07:06:02 <Daisy> are there any strings remaining not translated?
07:06:05 <jpich> The temporary stable branch was cut yesterday - the stable release will be tomorrow morning
07:06:29 <jpich> Sorry - ignore the first part, I meant the stable branch will be frozen tomorrow
07:06:29 <Daisy> amotoki, I noticed several langauges changed to be 99%
07:06:33 <amotoki> jpich: what is "temporary stable branch"?
07:06:38 <jpich> so that's our deadline to propose a patch
07:06:58 <jpich> amotoki: I'm sorry, I got confused with icehouse-1 for a minute, ignore this comment
07:07:11 <amotoki> there are a few proposed patches with string updates to stable/havana.
07:07:14 <jpich> There is only stable/havana and it will be frozen... today actually
07:07:24 <amotoki> i am not sure it will be merged or not for 2013.2.1.
07:07:27 <Daisy> amotoki, how many times left for translation team to complete those translations? I know there may be a very small update. But the translation team needs to be notified.
07:07:28 * jpich just woke up, brain still a bit slow
07:08:09 <Daisy> sorry, amotoki. How many time left for translation team to complete translation?
07:08:26 <Daisy> it's ok, jpich.
07:08:34 <jpich> amotoki: Thanks for pushing the latest string changes to Transifex
07:08:34 <amotoki> it depends on you all :-)
07:08:36 <Daisy> Please check when you are going to raise a patch.
07:08:50 <Daisy> When you are going to submit a new patch
07:08:51 <amotoki> regarding translation upadte patch, i can write mail to feature freeze exception to allow translators to have time to work on it.
07:09:11 <jpich> amotoki: I think we will have to
07:09:13 <Daisy> Thank you, amotoki.
07:09:42 <Daisy> #action amotoki will write a mail to i18n list and inform the pot file updated
07:10:02 <amotoki> Daisy: sure
07:10:03 <Daisy> please write the deadline in the mail too.
07:10:39 <Daisy> I think it won't cost a long time for translators to work on the update. But I don't know how many teams can response on time.
07:10:58 <Daisy> Let's see, amotoki. I will try to push them to complete the translation on time.
07:11:10 <amotoki> first I need to discuss it with stable team. I will write a mail to stable-maint list.
07:11:25 <Daisy> ok.
07:11:55 <Daisy> So we don't need to ask for teams confirmation about their update. Because pot file is updated, so the patch should include all langauges.
07:12:22 <Daisy> amotoki and jpich: any questions or concerns about Horizon translation?
07:12:32 <DeeJay1> when I checked yesterday there were 3 new strings for translators to update (I'm late so updating the info from before)
07:12:35 <amotoki> fyi there are three patches under review with string update:
07:12:41 <amotoki> https://review.openstack.org/#/c/58139/
07:12:47 <amotoki> https://review.openstack.org/#/c/58103/
07:12:52 <amotoki> https://review.openstack.org/#/c/59916/
07:13:06 <amotoki> (The last one is less important.)
07:13:51 <Daisy> They are not merged yet.
07:14:06 <amotoki> yes. *under review*
07:14:42 <Daisy> got it. I guess, we will wait for these patch merged and then amotoki will send a mail and notify translators, right?
07:15:05 <amotoki> I am not sure they wil be mergd or not, but if merged we need to have time to catch up.
07:15:19 <Daisy> ok.
07:15:44 <amotoki> The process and timing related to translation and stable backports are difficult to handle.
07:15:45 <Daisy> anything to discuss for Horizon translation?
07:16:16 <chandankumar> Daisy, how much time is left to submit horizon translations?
07:16:17 <amotoki> we need to look for better way to handle it in the future.
07:16:56 <jpich> chandankumar: We're not sure yet, but not a lot of time. amotoki will send an email to the i18n list when we know the date
07:17:01 <Daisy> Yes, amotoki. That need to be investigate. There is a very short discussion in summit in the release plan meeting.
07:17:12 <amotoki> in my plan, if feature freeze exception is accepted, i will propose a patch on Sunday or around.
07:17:27 <amotoki> if not accepted, I will propose a patch as-is.
07:17:41 <Daisy> I think we can find a way to notify translators automatically when PoT is updated.
07:18:04 <amotoki> transifex notifies it when POT files are updated.
07:18:12 <amotoki> i usually receive notifications.
07:18:14 <Daisy> I don't get the notification.
07:18:22 <Daisy> Is it a setting in Transifex?
07:18:36 <amotoki> yes. traisifex settings.
07:18:55 <Daisy> ok. Thanks for the information.
07:18:55 <amotoki> if you "watch" a project, notification will be sent if the project has some update.
07:19:23 <amotoki> let's move on the next topic.
07:19:26 <Daisy> I will figure it out after the meeting.
07:19:28 <Daisy> ok.
07:19:38 <Daisy> #topic Document translation plan
07:20:03 <Daisy> I think we can work on document translations while Icehouse is still developing.
07:20:28 <Daisy> I hope fifield can be there. He knew the doc development plan very clear.
07:20:47 <Daisy> amotoki: which document are your team working on now?
07:21:06 <Daisy> I heard that operation guide will be upgrade too.
07:21:40 <amotoki> security-guide is being translated now.
07:22:04 <Daisy> chandankumar, ujuc, and DeeJay1
07:22:13 <ujuc> ?
07:22:14 <amotoki> I am catching up with the update of ops-guide, but there is a few progress :-(
07:23:04 <Daisy> I'd like to understand if we plan to translate operation guide, will your team start to work on the translation?
07:23:34 <Daisy> I mean, do you want me to make a specific plan for document translation and a deadline too?
07:23:40 <DeeJay1> ok, if the plan is to translate the ops guide I can do that
07:23:42 <Daisy> or do you want to manage the schedule yourself.
07:23:46 <Daisy> ?
07:23:56 <ujuc> um...
07:24:01 <Daisy> thank you, DeeJay1.
07:24:08 <chandankumar> Daisy, not started
07:24:36 <Daisy> if there is a plan to translate ops guide, will you follow it, chandankumar?
07:24:51 <chandankumar> Daisy, yes i can follow
07:24:56 <ujuc> training-guides translated now ... me... :)
07:25:02 <Daisy> I think Chinese team can work on the ops guide translation too.
07:25:12 <Daisy> ok. Thank you, ujuc.
07:25:32 <Daisy> Are you translating in Transifex, ujuc?
07:25:42 <ujuc> yes :)
07:25:50 <Daisy> ok.
07:26:21 <DeeJay1> BTW is anyone working on a live page with WIP translated docs?
07:26:30 <Daisy> Then I will make a plan for ops-guide translation, but each translation team can decide whether they will follow.
07:26:36 <Daisy> What is WIP? DeeJay1?
07:26:57 <DeeJay1> work in progress, sorry for the shortcut
07:26:59 <Daisy> ujuc, are you working on training translation yourself? or you have a team to work on it?
07:27:17 <DeeJay1> eg a site with the docs updated daily/hourly from transifex
07:27:21 <ujuc> myself :)
07:27:36 <Daisy> DeeJay1, I'm thinking that each translation team have a wiki page to introduce the work they are working on.
07:28:07 <amotoki> when reviewing, transifex is hard to check translations across paragraphs.
07:28:11 <Daisy> There is no overall WIP page.
07:28:25 <amotoki> it is better we have converted page (HTML or PDF) to check translatiosn.
07:28:39 <amotoki> i think what DeeJay1 is talking. right?
07:28:43 <DeeJay1> amotoki: right
07:28:43 <Daisy> I know that, amotoki.
07:29:02 <Daisy> ok. I misunderstand.
07:29:23 <DeeJay1> ok, so nobody's working on that, I'll take a look into it, when I checked two weeks ago, the process was pretty convoluted though
07:29:34 <amotoki> when translting ops-guide in ja, I and katotomo volunteered to convert it and it was hosted on github pages.
07:29:45 <Daisy> DeeJay1, didn't you raise your hand to work on it?
07:29:58 <amotoki> i heard docs team has a staging server. it may help us.
07:30:07 <Daisy> Yes, staging server.
07:30:20 <Daisy> I think somebody registered to work on the staging server in the mail list.
07:30:40 <DeeJay1> I did, but had to stop due to being sick for the last 3 weeks
07:30:49 <amotoki> in addition, we need to use Ubuntu 12.04 to convert transltiaon docs.
07:30:53 <DeeJay1> I get back to it though
07:31:08 <amotoki> On Ubuntu 13.04 , some sentences are not translated.
07:31:35 <Daisy> oh, I'm sorry to hear it, DeeJay1.
07:31:49 <amotoki> perhaps it was a bug of i18n doc tool, but we dont have a fix yet.
07:32:14 <Daisy> #action Daisy to make a plan for ops guide translation and call for team to work on it.
07:33:00 <Daisy> #action DeeJay1 to take a look at the staging server usage in document reviewing
07:33:16 <Daisy> amotoki, which document?
07:33:34 <Daisy> "On Ubuntu 13.04 , some sentences are not translated."
07:33:41 <Daisy> Can you explain more, amotoki?
07:33:58 <amotoki> Daisy: let me check.
07:34:25 <Daisy> If it's a bug, please report it in i18n bug tracking page, in the launchpad.
07:34:39 <Daisy> ok. Then we move to next topic.
07:35:11 <Daisy> #topic Wiki page review
07:35:39 <Daisy> I plan to have each translation team to make a wiki page to introduce themselves in the wiki.
07:36:00 <Daisy> Like: https://wiki.openstack.org/wiki/I18nTeam/zh_cn
07:36:36 <Daisy> Many times, I got mail from people asking how to start translation contribution.
07:37:23 <Daisy> So I think, we need to have pages to clearly list translation team and their contact information, their focus work items and how to join them.
07:37:57 <Daisy> ujuc, with such page, maybe you can get more people to help you on the training guide translation.
07:38:28 <ujuc> :)
07:39:23 <Daisy> amotoki, I know ja team have your own website. I think you can put simple information there, and have a link here to link to ja translation website.
07:40:26 <Daisy> so we will have unique entrance for people who want to join the translation teams.
07:40:33 <amotoki> i am back now.
07:40:36 <Daisy> agree?
07:41:32 <DeeJay1> agreed
07:41:37 <amotoki> sounds good.
07:41:40 <ujuc> +1 :)
07:41:43 <Daisy> thank you, DeeJay1.
07:41:46 <Daisy> ok. pass.
07:42:12 <Daisy> # Daisy to send a mail to I18n and ask translation team to create their own wiki page.
07:42:20 <Daisy> #action Daisy to send a mail to I18n and ask translation team to create their own wiki page.
07:42:27 <Daisy> #topic Open discussion
07:42:42 <Daisy> Anything else to discuss today?
07:43:03 <Daisy> all
07:43:11 <Daisy> How do you think the IRC meeting help?
07:44:01 <Daisy> Is it helpful to host bi-weekly meeting? I know some team join monthly because of the time differences.
07:44:05 <ujuc> write wiki page .. first line add [[Category:I18n]] :)
07:44:17 <Daisy> thanks, ujuc.
07:44:32 <DeeJay1> Daisy: IMHO it is, although it is my first meeting I usually read through the logs
07:44:46 <Daisy> Thank you, DeeJay1.
07:44:59 <Daisy> I don't want to make you feel that the meeting is a waste of time. :)
07:45:08 <Daisy> I know there are many things we can discuss in the mail list.
07:45:24 <epico> yes, the meeting is helpful. :)
07:45:57 <Daisy> ok. If you have some thoughts about how to host meeting more efficiently, contact with me.
07:46:02 <DeeJay1> maybe we could do a wiki page with possible topics for the next meeting so everyone can prepare?
07:46:06 <jpich> Daisy: Personally I think it's good to keep some momentum (I can attend only once a month, but I also read the logs for the other one)
07:46:23 <Daisy> Yes, I agree, jpich.
07:46:41 <Daisy> People who attend the meeting are all very active contributors. :)
07:47:00 <jpich> DeeJay1: There is an agenda up at https://wiki.openstack.org/wiki/Meetings/I18nTeamMeeting usually, does that help?
07:47:16 * jpich suddenly notices the agenda is for the last meeting
07:47:29 <Daisy> Yes, only the last meeting.
07:47:30 <DeeJay1> ah, I forgot about that page, sorry
07:48:09 <Daisy> I plan to make I18n team to be an official openstack program.
07:48:42 <Daisy> it's a secret and only a few people know.
07:49:03 <jpich> Woohoo :)
07:49:06 <DeeJay1> well, after you put it in the logs it isn't ;)
07:49:21 <Daisy> I want to make it an official program, then there will be more people actively to join it.
07:49:52 <chandankumar> Daisy, i also know the secret :)
07:49:57 <Daisy> And our active contributors can get more recognization.
07:50:15 <Daisy> we can have core members too.
07:50:29 <amotoki> Another merit for the official program is that it makes it easier to coordinate and arrage the schedule of translations for release and update.
07:50:49 <epico> amotoki, great
07:50:51 <Daisy> Exactly, amotoki.
07:51:06 <ujuc> lol
07:51:09 <DeeJay1> what I'd really like is to have a gerrit hook looking for all gettext calls, and especially in stable branches requiring an ACK from the i18n team
07:51:11 <Daisy> so I hope to get your support. :)
07:51:27 <Daisy> I'm with you, DeeJay1.
07:51:34 <Daisy> That's my thought too.
07:52:04 <Daisy> I want to category all strings in openstack.
07:52:31 <jpich> We were talking about a TranslationImpact commit tag at the summit - it would notify the i18n during the RC period and possibly also for stable updates, if we can make it work there as well
07:52:59 <Daisy> can we make a blueprint for that?
07:53:52 <Daisy> I think there is a doc impact now.
07:53:57 <jpich> Yes it would be similar
07:54:00 <Daisy> Maybe the translation impact is a similar one.
07:54:01 <Daisy> Yes.
07:54:05 <jpich> I'll investigate the next steps
07:54:12 <Daisy> Thanks, jpich.
07:54:43 <Daisy> ok. If nothing to talk, we can close the meeting.
07:54:56 <ujuc> :) Ok
07:55:15 <Daisy> I really love to talk with you. There are so many "sparkles" during our talk.
07:55:23 <Daisy> #endmeeting