00:00:26 <Daisy> #startmeeting OpenStack I18n Meeting
00:00:27 <openstack> Meeting started Thu Jan 16 00:00:26 2014 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:31 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
00:00:41 <Daisy> Good morning/evening !
00:00:53 <gabrielcw> Hello everyone
00:00:54 <ujuc> Good moning :))
00:01:00 <epico> good morning
00:01:00 <gabrielcw> good night ;)
00:01:28 <Daisy> Hello everyone. It's the first time meeting in 2014.
00:01:52 <Daisy> I hope you have a good time in new year days.
00:02:24 <Daisy> Today we will look at the progress of installation guide translation and collect issues if we have.
00:02:44 <gabrielcw> ok
00:02:51 <ujuc> ok :)
00:02:58 <Daisy> #topic Installation guide translation progress and issues
00:03:24 <Daisy> From Transifex, we can see:
00:03:27 <Daisy> Japanese translation is completed finished. very good work.
00:03:52 <Daisy> Korean and German have more than 50% completed. Thank you for your hard work, ujuc.
00:03:58 <ujuc> hu  ;)
00:04:03 <Daisy> Russian, Chinese and Portuguese have certain progress.
00:04:17 <Daisy> As our plan, we will start to publish translations since today.  :)
00:04:41 <Daisy> It's OK that some teams have not finished. We can publish those who has completed.
00:04:58 <Daisy> We can publish those translations when complete.
00:05:03 <gabrielcw> we will have better progress for pt_BR soon, I was short in time
00:05:18 <Daisy> Thank you, gabrielcw .
00:05:30 <Daisy> Our Chinese team will do too. :)
00:05:45 <Daisy> Since string forzen will start from the beginning of March. I will suggest we complete document translation by the end of February. Or else, the workload in March will become too big.
00:06:15 <Daisy> I mean, after string frozen, we will move to messages translations.
00:06:30 <Daisy> so we'd better to conclude our document translation work in Feb.
00:06:45 <ujuc> ok :)
00:06:55 <Daisy> Again, please record the names of conributors. Community should recognize them. I will collect contributors' names from you after we finish this work. Please pay attention too. Thank you.
00:07:26 <Daisy> ujuc: do you have people to help you in installation guide translation?
00:07:39 <ujuc> yap
00:07:43 <Daisy> good.
00:07:44 <ujuc> :)
00:08:42 <Daisy> Community will send free registration codes to those contributors. I know maybe some people won't have chance to fly to US to attend. But it's a kind of recognization.
00:09:22 <Daisy> #topic translation publish script
00:09:37 <Daisy> While the team is translating, we need somebody to take a look at the publish job in Jenkins.
00:10:03 <Daisy> We have one to manage operation guide in Japanese's publishing:
00:10:05 <Daisy> https://jenkins.openstack.org/view/Openstack-manuals/job/openstack-operations-guide-ja/
00:10:11 <Daisy> But it doesn't work well now.
00:10:25 <Daisy> We need to have the similar jobs for installation guide and for several languages.
00:11:09 <Daisy> I'm working it now. I know Tom Fifield is also taking an eye on it too.
00:11:31 <Daisy> oh. Sorry, forget to mention one important thing in the first topic.
00:11:56 <Daisy> There are some contents in "installation guide" in the "common" folder.
00:12:20 <Daisy> https://www.transifex.com/projects/p/openstack-manuals-i18n/resource/common/
00:12:50 <Daisy> Some of the contents of "installation guide" are in the resource of "common" in Transifex.
00:12:54 <Daisy> some XML files.
00:13:17 <ujuc> Ummm~~ T.T
00:13:55 <Daisy> I will get the name list of XML files and send to ML. So after we translate the strings in "installation guide", we also need to take care of those XMLs in "common".
00:14:10 <gabrielcw> right
00:14:20 <Daisy> #action Daisy to get the name list of XML files in common and send to ML.
00:14:35 <ujuc> yep
00:14:36 <ujuc> :)
00:15:08 <Daisy> I have finished what I want to talk. :) very quick.
00:15:15 <Daisy> #topic free discussion
00:15:33 <ujuc> :0 hhh
00:15:50 <Daisy> do you have anything to discussion?
00:16:18 <gabrielcw> nothing special here, but about the jenkins, i'm no specialist, but I can help maybe
00:16:34 <ujuc> nothing :) :)
00:16:42 <Daisy> thank you, gabrielcw .
00:17:05 <gabrielcw> i am looking at the code, if I figure it out I'll let you know so I can be useful
00:17:22 <Daisy> Now the question blocking me is that I don't know how to invoke a script in repository "doc-tools" from our publish Jenkins job.
00:17:58 <Daisy> We have some scripts called translation tools.
00:18:17 <Daisy> You know doc team have several repositories for their contents.
00:18:51 <Daisy> At the beginning, we put translation tools to every repository.
00:18:52 <gabrielcw> translation-jobs.yaml?
00:19:25 <Daisy> Now the translation tools have been moved to a new repository: doc-tools.
00:19:29 <Daisy> No, gabrielcw
00:19:33 <Daisy> Let me find a link.
00:19:46 <ujuc> oh :)
00:19:48 <gabrielcw> oh, ok
00:21:05 <Daisy> https://git.openstack.org/cgit/openstack/openstack-doc-tools/tree/bin
00:21:39 <gabrielcw> ok
00:21:45 <Daisy> You see: generatedocbook and generatepot there?
00:21:49 <gabrielcw> yes
00:23:17 <Daisy> https://git.openstack.org/cgit/openstack/operations-guide/tree/tools
00:23:40 <Daisy> https://git.openstack.org/cgit/openstack/openstack-manuals/tree/tools
00:24:03 <Daisy> you can also find generatedocbook and generatepot under the above two links to.
00:24:31 <Daisy> I think, now there should only be one place to put "generatedocbook and generatepot"
00:24:44 <Daisy> The others should be removed.
00:24:47 <gabrielcw> I see
00:25:20 <Daisy> Then I don't know if the others are removed, how to invoke them under operations-guide?
00:25:51 <Daisy> Maybe I'm wrong. Maybe the others should not be removed. :)
00:26:13 <gabrielcw> but who in fact calls them?
00:26:32 <Daisy> There is a job in Jenkins. Let me find the link.
00:26:51 <gabrielcw> that one?
00:26:51 <gabrielcw> https://jenkins.openstack.org/view/Openstack-manuals/job/openstack-operations-guide-ja/
00:28:09 <Daisy> https://git.openstack.org/cgit/openstack-infra/config/tree/modules/openstack_project/files/jenkins_job_builder/config/manuals.yaml
00:28:22 <Daisy> See the end of this file: manuals.yaml
00:28:39 <Daisy> - job:
00:28:41 <Daisy> name: openstack-operations-guide-ja
00:29:15 <gabrielcw> yes
00:29:45 <Daisy> We should have similar ones: installation-guide-pt-br, installation-guide-zh-cn
00:30:13 <gabrielcw> understood
00:30:20 <Daisy> but at first, we need to have openstack-operations-guide-ja running well. :)
00:30:36 <gabrielcw> oh, what's wrong?
00:30:57 <Daisy> I don't know yet, actually.
00:31:48 <Daisy> https://bugs.launchpad.net/bugs/1216153
00:31:51 <uvirtbot> Launchpad bug 1216153 in openstack-i18n "ops guide japanese build fails" [High,Confirmed]
00:32:13 <Daisy> There is a bug to track it.
00:33:09 <gabrielcw> oh
00:33:23 <gabrielcw> that's seems a large change
00:33:56 <gabrielcw> moving repos around
00:34:33 <Daisy> I'm going to have a chat with Tom Fifield about it. He can help me to catch the current status.
00:34:59 <gabrielcw> nice
00:35:39 <Daisy> I don't think it's a big problem. But it's a problem that many projects and many people evolved.  That's reason why it is complex.
00:35:40 <gabrielcw> meanwhile I will tinker with the manuals.yaml
00:35:54 <Daisy> nice.
00:35:58 <gabrielcw> yes, that`s what I think too
00:36:19 <Daisy> thank you, gabrielcw.
00:36:35 <Daisy> If we don't have topics, I'm going to close the meeting.
00:36:54 <ujuc> yes :)
00:37:58 <gabrielcw> ok!
00:38:04 <Daisy> I leave 20 minutes to us. You can go back to your work. I can drive to office then.
00:38:10 <Daisy> :)
00:38:15 <Daisy> So see you next meeting.
00:38:19 <Daisy> Thank you.
00:38:26 <Daisy> Let's keep contact through email.
00:38:35 <gabrielcw> thanks
00:38:40 <Daisy> #endmeeting