07:00:33 <Daisy> #startmeeting OpenStack I18n Meeting
07:00:34 <openstack> Meeting started Thu Feb  6 07:00:33 2014 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:38 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:00:59 <Daisy> Hello! Who are around there to attend I18n meeting?
07:01:08 * jimidar here
07:01:10 <jpich> Hi Daisy o/
07:01:36 <Daisy> Good moring/afternoon/evening.
07:01:50 <jimidar> Good Afternoon from India Daisy
07:02:15 <Daisy> Let's start.
07:02:37 <Daisy> #topic Update on log messages translation plan
07:02:59 <Daisy> I raised the request to Oslo in Icehouse design summit: seperate log messages from other messages.
07:03:10 <Daisy> With the help of Doug Hellmann ( PTL of Oslo ), the log translation plan is discussed in openstack release meeting, where most project PTLs joined.
07:03:29 <Daisy> Oslo team is working on the technical support. The goal is to add separate translation marker functions similar to _() with names like _LE and _LW to allow us to extract the messages into different catalogs.
07:03:44 <Steff00> hello everybody sorry to be late
07:03:51 <Daisy> We are going to skip debug messages, for this phase of the project, and focus only on messages at INFO or higher levels.
07:04:00 <Daisy> Good evening, Steff00 .
07:04:10 <Daisy> The _() marker should only be used for end-user messages from exceptions and API calls.
07:04:32 <Daisy> Steff00: we are on the first topic: log messages translation plan
07:04:46 <Steff00> ok thank you
07:05:00 <Daisy> When Oslo team make sure their technical support well and there is no issues, they will broadcast it in the dev ML.
07:05:16 <Daisy> I will work together with Oslo team to pick up a project as a prototype and have a try.
07:05:31 <Daisy> Then the syncronization scripts and resources in Transifex will be updated based on this change. We will find a resource only containing exceptions and API calls.
07:05:48 <Daisy> Then it depends on each translation team to decide whether to translate these end-user messages in their languages in Icehouse releasy cycle.
07:06:40 <Daisy> In Icehouse release cycle, maybe not all projects have this update ready. But I hope to find at least one project.
07:06:59 <Daisy> questions? comments?
07:07:53 <jpich> Great to see progress on this :)
07:07:54 <Steff00> no questions for me
07:08:31 <Daisy> In Havana code, there are 7000+ messages in total.
07:08:35 <DeeJay1> I spent some time yesterday with ajeager who's handling the doc builds and we've run into some problems with building the translated documentation through tox in a seperate build environment, right now we stuck to using the generatedocbook script from the manuals package instead of the doc-tools one due to xml2po not being available in a tox virtualenv
07:08:51 <Daisy> After separation, I think, the real end-user messages would be less than a half.
07:09:38 <Daisy> DeeJay1: thank you for working on it. Could we discuss it in a following topic?
07:09:44 <DeeJay1> (ok, now my screen refreshed and I feel silly ;)
07:09:53 <Daisy> :)
07:10:02 <Daisy> Next topic
07:10:14 <Daisy> #topic Push on the translation of "installation guide"
07:10:20 <Daisy> :)
07:10:27 <Daisy> I think there is just a reminder.
07:10:54 <Daisy> I see DeeJay1 is working on a website to display the installation guide in many languages.
07:11:00 <Daisy> It's a wonderful job, DeeJay1 .
07:11:20 <DeeJay1> yup, but I'd like for the teams to look at the build status, there are a few issues with some of the translations
07:11:39 <Daisy> As we discussed before, in HK summit, infra team agreed to use a staging server for the draft translation review.
07:12:12 <Daisy> so I think they will agree to move your work to openstack infra.
07:12:37 <Daisy> We just need to make sure it run well and most issues can be resolved.
07:12:42 <DeeJay1> I don't know if it's feasible, right now I have more room to pull the translations from transifex without commiting the po files to the repo
07:13:09 <Daisy> What issues do you have now?
07:14:09 <DeeJay1> https://bugs.launchpad.net/openstack-manuals/+bug/1275499 - some guides will have missing chars in the PDF documents without that
07:14:12 <uvirtbot> Launchpad bug 1275499 in openstack-manuals "clouddocks-maven-plugin and Polish language support" [Undecided,New]
07:14:26 <Daisy> "pull the translations from transifex without commiting the po files to the repo", do you mean the translations are from Transfiex , not git repo? I think it's just what we want. We want to get the latest translation, whether it is committed or not?
07:14:58 <DeeJay1> Daisy: yes, but AFAIR getting the translations isn't possible on all jenkins nodes right now
07:15:03 <Daisy> I think that's a known issue. We could work with Doc team to resolve it.
07:15:27 <Daisy> why "AFAIR getting the translations isn't possible on all jenkins nodes right now"?
07:16:23 <DeeJay1> Daisy: transifexrc is only on a subset of them, but I'd have to double check that
07:17:04 <Daisy> Do we need transifexrc to be installed on all nodes? I think we only need to install it on the relevant nodes.
07:17:17 <Daisy> And I remember there is a way to config to install transifexrc.
07:17:54 <DeeJay1> yes, but I don't know how the infra team feels about putting the credentials to transifex on all the nodes
07:18:39 <Daisy> I think they are open minded if we really need it.
07:19:17 <DeeJay1> anyway I'll take a second look at it
07:20:31 <DeeJay1> so feel free to assign that task to me
07:20:32 <Daisy> DeeJay1: how about you send a summary and the issues you need help to Infra team, when you feel comfortable. Then we can start the discussion with them.
07:20:39 <Daisy> Sure, I will.
07:21:20 <Daisy> as to the previous issue you raised, "we stuck to using the generatedocbook script from the manuals package instead of the doc-tools", I know this situation.
07:21:59 <DeeJay1> I'd like to take a look at using itstool for that
07:22:04 <Daisy> But what's the meaning of "xml2po not being available in a tox virtualenv"? Why we need tox virtualenv?
07:22:29 <DeeJay1> Daisy: well, it's something the docs team seems to want
07:22:47 <Daisy> I don't understand the background.
07:23:10 <Daisy> So if we could use doc-tools, this issue can be fixed?
07:24:22 <DeeJay1> well, it seems that the background is to use a similar process like for other software, eg all the required build tools are installed in a virtualenv not to require changes to the build infrastructure if any new dependencies are added
07:24:40 <Daisy> ok.
07:24:48 <DeeJay1> so if you need tool X to build the manual you only change tox.ini in the openstack-manuals repo without any intervention from the infra team
07:25:02 <Daisy> got your point.
07:25:29 <Daisy> does our I18n use a separate config file with doc team, or we use a same tox.ini?
07:26:01 <DeeJay1> well, as for recently we didn't have a build infrastructure at all
07:26:13 <Daisy> I think, they may want us to use a same tox virtualbox. That is a same tox.ini
07:26:28 <Daisy> ok. Got your point.
07:26:55 <Daisy> If you need any of help, send email to I18n ML.
07:27:51 <DeeJay1> of course, the only thing I'd need right now is some feedback on mail recent email, about building all the docs in openstack-manuals at once vs building the docs separate
07:28:02 <DeeJay1> so I could forward that to the docs team
07:28:06 <Daisy> In my last talk with ajeager , he wanted me to summary our requirements, and then we together initiate the discussion with Infra team, in order to use doc-tools.
07:28:11 <ujuc> oh... sorry.. ;(
07:28:24 <Daisy> welcome, ujuc.
07:28:46 <ujuc> hi :)
07:29:25 <Daisy> So I will continue the discussion with ajeager about how to use doc-tools directly, when I'm back to office.
07:30:18 <Daisy> Sorry for my late response, DeeJay1. I'm on vacation now and don't check email frequently.
07:30:40 <Daisy> I think it's a wonderful work you did.
07:30:46 <DeeJay1> Daisy: n/p - I for one can only do stuff outside of work, so durin EU buisness hours I'm out of the loop anyway
07:31:16 <Daisy> So let's continue the discussion in ML, and improve your work together.
07:31:35 <Daisy> can we move to next topic ?
07:31:40 <DeeJay1> yes
07:31:46 <Steff00> ok
07:31:59 <Daisy> #topic Work items in Feb
07:32:35 <Daisy> In this topic, we list the work items together, and find the assignees. :)
07:32:45 <Daisy> Finish installation guide translations.
07:33:34 <Daisy> I think, coordinators should be the assignee. The end of Feb would be a good time to stop this work. In March, we would be very busy in the messages translation.
07:34:09 <Daisy> Set up Horizon messages translation environment in Transifex
07:34:12 <Daisy> I will take this work.
07:34:22 <Daisy> #action Daisy Set up Horizon messages translation environment in Transifex
07:34:58 <Steff00> ok for France wa try to go with the installation guide, it will be hard because I think I've lost a great part of the team, even me sometimes
07:35:13 <Daisy> It's under processing.
07:35:51 <Daisy> How many people are working on the translation together with you, Steff00 ?
07:36:37 <Steff00> almost nobody anymore . I lost control one month because of work and it seems nobody does translation anymore
07:36:49 <Daisy> :) understand.
07:36:52 <Steff00> I'll get new ones I hope
07:37:20 <Daisy> Actually, the document translation has no deadline, no hard stop.
07:37:26 * DeeJay1 is still alone on the PL team also
07:37:40 <Daisy> You can continue this work even you miss the time.
07:38:01 <Daisy> But anyway, in march, we have to focus on the message translation because of the release cycle won't wait for us.
07:38:23 <Steff00> no problem, I do my best on the focuses topics
07:38:40 <Daisy> Thank you. Steff00 .
07:39:11 <Daisy> Write scripts and create jobs to publish these installation guides in different languages.
07:39:33 <Daisy> I think, DeeJay1 has do a good job, and it's very similar to what he has finished now.
07:40:27 <Daisy> DeeJay1 may want to focus on his current work. So are there anybody else who would like to work on it?
07:40:53 <Daisy> Or how can we leverage DeeJay1's work ?
07:41:35 <Daisy> What we need to do is to publish our translations in docs.openstack.org.
07:41:57 <Daisy> If nobody, I can take it too.
07:42:20 <Steff00> I try  to do it for french
07:42:47 <Daisy> #action Daisy and Steff00 to publish the translations to docs.openstack.org.
07:43:26 <Daisy> Yes, I definitely need your help, Steff00 . At least, each of you need to write a page in your own language as an index page of your language.
07:43:54 <Steff00> It will be apleasue DAisy :)
07:43:59 <Daisy> Just like what Japanese team has done: http://docs.openstack.org/ja/
07:44:39 <Steff00> I'll take a look today at the japanese page
07:44:54 <Daisy> Yes, Steff00 . After we do it, it will be a great success, which we can broadcast in next summit.
07:45:35 <Steff00> I think I won't be at the Atlanta Summit, hard to get the money for the fly
07:45:56 <DeeJay1> hmm, I'd like to take a look if we can leverage the main docs page and just make it translatable
07:46:18 <DeeJay1> IMHO the language pages should provide links to the English docs in case the docs in <language> aren't provided
07:46:27 <Daisy> Steff00: if you want, many be you can apply for a travel sponsor program.
07:46:32 <DeeJay1> so in the end we could just point browsers to specific versions
07:46:56 <Steff00> Daisy : Why not
07:47:04 <Daisy> DeeJay1: I don't know if we really want to "links to the English docs in case the docs in <language> aren't provided"
07:48:20 <Daisy> If we only translate the main page, and provide English doc links, the help we provide to the readers is only the translation of main page. If readers cannot understand English main page, how can they understand English doc?
07:49:03 <Steff00> they won't
07:49:09 <Daisy> Currently, we only provide links to locale language documents in locale page.
07:49:14 <DeeJay1> Daisy: ok, let me put it this way - right now you have to be on the English page first just to be able to select the Japanese page
07:49:28 <Daisy> Yes.
07:51:04 <Daisy> DeeJay1: do you want me to assign you a task: move your website to OpenStack Infra? You don't need to finish it in Feb, but it can be a clear goal for you. Is that OK with you?
07:51:46 <amotoki> hi, i just backed from the meeting.
07:51:49 <DeeJay1> Daisy: yeah, I'll work with Andreas to put it up on docs-draft somehow
07:52:09 <Daisy> Thank you, DeeJay1.
07:52:29 <Daisy> #action DeeJay1 to move the document publish website to docs-draft
07:53:04 <Daisy> amotoki: we are going to move to open discussion now.
07:53:09 <Daisy> #topic Open discussion
07:53:20 <Daisy> anything to discuss here?
07:53:48 <amotoki> Daisy: what does "Set up Horizon messages translation environment in Transifex" mean?
07:53:56 <Daisy> DeeJay1: besides to publish the draft translation documents, do you have further plan to improve it, as a way for translators to easily do the review?
07:54:36 <Daisy> amotoki: it's to set up the resources, make sure the synchronization scripts running well before March, then we can start the translation after string freeze.
07:54:41 <ujuc> install guide end in Feb 28???
07:55:17 <DeeJay1> Daisy: frankly, I'd like to get rid of the code fragments in the po files
07:55:23 <Daisy> no deadline ujuc. But it's a good date to close the document translation, because we have to focus on the message translation in order to catch the release date.
07:55:32 <DeeJay1> Daisy: it's just needles copy&paste IMO
07:55:34 <amotoki> Daisy: i see. I start to think it may be okay to import from transifex to master automatically too.
07:55:56 <ujuc> Daisy: ok :)
07:56:10 <amotoki> Daisy: what do you think?
07:56:29 <Daisy> DeeJay1: then you may need to improve two scripts in doc-tools.
07:56:43 <Daisy> Agree, amotoki .
07:56:49 <Daisy> I like automation too.
07:57:01 <DeeJay1> Daisy: yeah, but I wonder if someone has a need for them to exist...
07:57:22 <amotoki> After milestone-proposed is cut, we need to do it manually, so we can control the quality of the release I believe.
07:58:41 <Daisy> DeeJay1: in my mind, if we want to use your website as a review tool, I think we need to a way to facilitate reviewers to report the errors to translators they find.
07:59:31 <Daisy> amotoki: even we automatically import from Transifex to master, there is a review job created in gerrit.
07:59:53 <Daisy> It's not 100% automation. Is this what you want?
08:00:20 <Daisy> Now nova, glance and etc are using this way to import translations.
08:00:29 <amotoki> Daisy: yes, but the patch of translation import is not checked from the content point of view...
08:00:38 <Daisy> somebody must approve before it finally gets merge.
08:00:58 <DeeJay1> Daisy: there's a report bug on every page I think, maybe I could switch it to do the reporting against openstack-i18n instead of manuals
08:01:11 <Daisy> nice thinking, DeeJay1
08:01:55 <Daisy> amotoki: after milestone-proposed, who do you plan to do the merge manually?
08:01:55 <amotoki> +1 for bug link to i18n site.
08:02:14 <Daisy> somebody who can take reponsible for the content review?
08:02:28 <amotoki> i think so now. milestone-proposed is very tricky, so it is not easy to automate.
08:02:53 <amotoki> Daisy: it is expected to be done on Transifex.
08:03:11 <Daisy> so we only import reviewed contents?
08:03:50 <amotoki> IMO it is okay to import all contents.
08:04:09 <jpich> Even if the language is not at 100%?
08:04:17 <amotoki> because we upload final translation for milestonr-proposed.
08:04:34 <amotoki> and we can drop non-100% lang at this stage.
08:04:51 <Daisy> amotoki: if we follow Nova and glace and etc, the importing is being done daily, which will generate a review job in gerrit.
08:05:13 <Daisy> As our first plan, some coordinators should be included as the reviewer to vote +1.
08:05:15 <amotoki> yeah.
08:05:22 <Daisy> But now, I don't think the coordinators are involved.
08:05:41 <Daisy> so the approval is being done by technical developers.
08:05:59 <Steff00> Sorry I have to leave .
08:06:02 <amotoki> The meeting time is over. Can we continue the discussion in #openstack-translation?
08:06:14 <Daisy> Sure. sorry I don't notice the time.
08:06:32 <Daisy> Thank you all for your attending!
08:06:35 <Daisy> #endmeeting