08:01:08 <Daisy> #startmeeting OpenStack I18n Meeting
08:01:09 <openstack> Meeting started Thu Jul  3 08:01:08 2014 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:12 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
08:01:27 <Daisy> Meeting starts. Who's around?
08:01:35 <Fdot> hello Daisy :)
08:01:52 <jpich> Hi!
08:01:54 <epico> hello
08:01:59 <pleia2> hey
08:02:03 <Daisy> Hi, Fdot, jpich, epico
08:02:15 <Daisy> pleia2 is from Infrastructure team.
08:02:30 <Daisy> She is helping us to set up Zanata demo server.
08:02:36 <AJaeger> Hi Daisy ! pleia2 great that you could make it!
08:02:46 <Daisy> Now it's too late for her. So we will discuss this topic firstly.
08:02:52 <pleia2> thank you Daisy
08:02:55 <Daisy> #topic: New translation tool and new I18n library update
08:03:12 <epico> great! :)
08:03:19 <Daisy> I have to say, now we are meeting a big issue with Transifex.
08:03:24 <camunoz> hi Daisy, Carlos here from the Zanata team in case you guys have any questions
08:03:34 <Daisy> meeting with a big issue with Transifex.
08:03:38 <Daisy> thanks, camunoz
08:03:48 <pleia2> I recently updated the -infra mailing list with some progress from the Zanata work we're doing: http://lists.openstack.org/pipermail/openstack-infra/2014-July/001471.html
08:03:56 <Daisy> https://bugs.launchpad.net/openstack-i18n/+bug/608725/comments/6
08:03:57 <uvirtbot> Launchpad bug 608725 in openstack-i18n "swift should be internationalized/translated" [High,Confirmed]
08:04:12 <pleia2> most importantly, mordred followed up here with what we'd need to get Zanata going: http://lists.openstack.org/pipermail/openstack-infra/2014-July/001471.html
08:05:10 <Daisy> We cannot create any new projects in Transifex now, because openstack organization in Transifex has English team, and Transifex changed its policy suddenly: if the organization have English team, you cannot create project with source language setting as En.
08:05:41 <Daisy> The worst thing is that I cannot delete English team from Transifex, so we cannot create any new projects with source language setting as en.
08:05:52 <Daisy> The issue is found several weeks ago.
08:06:09 <Daisy> AJaeger and I had several email communication with Transifex.
08:06:49 <jpich> That's pretty bad :(
08:06:53 <Daisy> They are supporting us, but not efficient.
08:06:53 * pleia2 nods
08:07:53 <Daisy> so I think, from this thing, we definitely want our own instance running on our own infrastructure.
08:08:17 <pleia2> I'd like to acknowledge camunoz's help, he's been great helping us with zanata, but the license issue is outstanding and the free, modern application server isn't quite ready to run it, so we're stalled on some things here
08:08:18 <Daisy> Pootle and Zanata are two candidates.
08:08:30 <pleia2> we do still have the pootle demo running here: http://translate-dev.openstack.org/
08:09:00 <pleia2> pootle is maintainable and we can run it now, it's just a matter of how the translations team feels about where we stand now and if pootle will work
08:09:08 * fifieldt wanders in
08:09:10 <Daisy> Pootle is a purely open source software. Zanata is a translation platform used and developed by Redhat.
08:10:05 <Daisy> Zanata has dependencies to JBoss. Zanata runs well with JBoss Enterprise edition, but not with open source edition.
08:11:15 <hashar> (sneaking in, if you are still looking for potential candidates: Wikimedia uses http://translatewiki.net/ which is fully open source and based on Mediawiki    I think I mentioned it a few months ago)
08:12:11 <Daisy> We had meeting with Zanata dev team before Atlanta summit. They showed us a demo. The function demonstrated is good. I did a compare of Pootle and Zanata.
08:13:11 <Daisy> For me, the most attractive things of Zanata is (1) version management (2) strong support.
08:13:37 <pleia2> the pootle community has been quite supportive as well from the infra side
08:14:05 <Daisy> I don't have relation set up with Pootle community.
08:14:30 <pleia2> I've been chatting with some of their devs, we bumped into busy translations time + summit last cycle before I could firm up a demo
08:14:44 <pleia2> I can reach out this week if we still want that
08:15:11 <Daisy> pleia2: good. I hope the translation tool selection could be a team decision.
08:15:46 <pleia2> Daisy: ok, I'll keep working on the JBoss side of things for Zanata, and contact pootle devs for a demo then
08:15:59 <Daisy> Thanks, pleia2.
08:16:08 <pleia2> hopefully between the two we can get something going for you all soon :)
08:16:38 <Daisy> pleia2: from your point of view, how do you think if we accept a enterprise license donated from Redhat ?
08:16:53 <Daisy> I just want to explore all possibilities.
08:17:08 <ujuc> sorry, i late.
08:17:42 <pleia2> Daisy: as with the rest of the team, I'm uncomfortable with it because it means that portion of our infrastructure isn't reproducable by other projects as we'd like, but I agree with mordred that it may be possible to accept it as a temporary measure until we get the WildFly running
08:17:43 <AJaeger> Daisy, the license is something that I guess the infra team as a whole needs to comment on - and looking at the mails, this is not the preferred option
08:18:04 <camunoz> Daisy: I think that someone put out the idea of using an enterprise license to begin with, until Wildfly support is finished
08:18:16 <Daisy> ok.
08:18:22 <Daisy> got the point.
08:18:23 <camunoz> I thought this might be a good interim solution
08:18:24 <AJaeger> If it's indeed a temporary thing and there'S a commitment for Wildfly
08:18:28 <Fdot> Daisy, so why changing a proprietary tool to an another ?
08:18:29 <fifieldt> ujuc, you can catch up on conversation using http://eavesdrop.openstack.org/irclogs/%23openstack-meeting/%23openstack-meeting.2014-07-03.log
08:18:47 <ujuc> Thanks, fifieldt
08:19:04 <pleia2> Fdot: it's open source, just requires enterprise licensing to run on a modern, secure application server
08:19:11 <Daisy> So let's wait for Pootle's response, and then we do a compare among the whole team. Then we decide.
08:19:22 <pleia2> Daisy: sounds great
08:19:24 <Daisy> pleia2: do you have live Zanata website now?
08:19:34 <Fdot> pleia : yes we have strong dependence
08:19:42 <Fdot> with this solution
08:19:52 <fifieldt> should we also submit bugs to pootle and zanata for the missing features, just to get that process started asap ? :)
08:20:00 <pleia2> if you want to poke around, I have one running on my own hpcloud account here: http://15.126.233.162:8080/zanata/
08:20:04 <fifieldt> eg query by filename
08:20:42 <pleia2> but I make no stability guarantees on that instance :)
08:21:07 <pleia2> for a proper demo we'll want to run it out of openstack infra proper
08:21:30 <Daisy> I'm quite familiar with the pootle instance running on openstack infrastructure now.
08:21:38 <Daisy> Maybe pootle has new features now.
08:21:51 <pleia2> yeah, we should do a refresh of that pootle instance with the latest software
08:21:52 <Daisy> Thank you for your work, pleia2 .
08:21:56 <pleia2> adding that to my list too
08:22:04 <camunoz> jsut fyi, the Zanata team is already working on wildfly compatibility, which would make it completely open source and you'd ve able to replicate it anywhere without any licensing issues... if this is a big must, we can raise the priority on that work
08:22:23 <Daisy> Thanks, camunoz .
08:22:33 <pleia2> camunoz: thanks, I think it is pretty important to us
08:22:43 <AJaeger> camunoz, for me a commitment for WildFly would be important.
08:23:27 <Daisy> pleia2: do you think if it is an issue that Zanata is using java?
08:23:59 <camunoz> I understand
08:23:59 <pleia2> Daisy: no, both gerrit and jenkins are java as well so we already have it in our infrastructure
08:24:19 <Daisy> Great. Thanks.
08:24:31 <Daisy> Could we stop here now, as to this topic?
08:24:38 <pleia2> yes, thanks everyone
08:25:09 <Daisy> pleia2: you could go back to sleep then. If you need, I could attend infrastructure meeting too.
08:25:33 <Daisy> Now I will update the status of lib: olso.i18n
08:25:35 <pleia2> Daisy: thanks, I'll follow up via email if that's needed
08:26:15 <Daisy> olso.i18n will be released too.
08:26:21 <Daisy> http://docs.openstack.org/developer/oslo.i18n/guidelines.html
08:26:25 <epico> cool
08:26:30 <AJaeger> Daisy, oslo.i18n was released yesterday
08:26:42 <Daisy> oh. I missed.
08:26:53 <Daisy> From here, you could read the guideline.
08:26:56 <AJaeger> http://lists.openstack.org/pipermail/openstack-dev/2014-July/039217.html
08:27:13 <Daisy> The goal of this new lib, is to separate log messages from user facing messages.
08:28:01 <Daisy> Each translation team has the freedom to decide what kind of messages you want to translate, and which log levels you want to translate.
08:28:42 <Daisy> Nova has adopted this new lib, right, AJaeger ?
08:28:51 * AJaeger checks...
08:29:29 <Daisy> I think we need to update Transifex to reflect the changes. Now we have several message pot files under Nova.
08:29:30 <AJaeger> Daisy, doesn't look like it
08:29:49 <AJaeger> The several message pot fiels are correct - that's the log level files
08:30:01 * AJaeger double checks
08:30:04 <Daisy> AJaeger: I'm quite sure there are several different pot files under Nova.
08:30:54 <Daisy> I'm not sure whether all of nova log messages are moved into different log level files.
08:30:55 <AJaeger> Daisy, yes - nova-log-critical-translations, nova-log-error-translations etc are the log level files
08:31:05 <AJaeger> Those are correct!
08:31:22 <Daisy> So nova.pot is the file where all user facing messages are.
08:31:34 <epico> Daisy, will it support gettext context call and plural forms?
08:31:36 <AJaeger> Correct.
08:31:47 <AJaeger> Daisy, see my email from 25th of May - "Openstack-i18n] Translation of log messages"
08:31:51 <Daisy> and nova-log-error.pot, nova-log-info.pot are files where log messages are.
08:32:11 <AJaeger> exactly
08:32:27 <Daisy> If we don't want to translate log messages, we could focus on nova.pot.
08:33:52 <Daisy> Then we could have a localized command line interface if we want.
08:34:23 <AJaeger> fifieldt, should we wait for the common client and translate that one? ;)
08:34:36 <fifieldt> the common client is a myth :)
08:35:16 <epico> Daisy, I mean "Use ungettext for pluralisation" and "Use contextual markers on short strings to avoid ambiguousness".
08:35:24 <epico> https://wiki.openstack.org/wiki/I18n/TranslatableStrings
08:35:59 <Daisy> epico: I'm not able to answer your question. You could check the document or the code directly.
08:36:22 <epico> Daisy, okay
08:36:25 <Daisy> That's all of my updates.
08:36:36 <Daisy> Any questions?
08:36:36 <epico> Daisy, thanks
08:36:43 <Daisy> any comments?
08:37:12 <Daisy> No? let's move on.
08:37:19 <Daisy> #topic Document translation discussion
08:37:41 <Daisy> I checked openstack-manuals in Transifex.
08:38:07 <Daisy> Korean and Chinese translation have api-quick-start 100% translated now.
08:38:27 <Daisy> So one thing we could do is to create website for Korean and Chinese.
08:38:52 * AJaeger has some infra jobs under review to publish the guides to docs.openstack.org
08:39:00 <Daisy> Thanks, AJaeger .
08:39:16 <AJaeger> Once they're live, I'll add them to http://docs.openstack.org/draft-i18n-manuals.html
08:39:47 <Daisy> Then ujuc and I should provide localized main page for documents, right?
08:40:06 <AJaeger> Yeah
08:40:16 <Daisy> If we want more documents translated, we could do more.
08:40:23 <Daisy> api-quick-start : 1077words
08:40:25 <Daisy> api-ref-guides: 211words
08:40:26 <Daisy> cli-reference: 1,672words
08:40:28 <Daisy> api-ref: 3,358words
08:40:29 <Daisy> high-availablity-guide: 6,940words
08:40:31 <Daisy> user-guide-admin: 7,479
08:40:32 <Daisy> image-guide:9,704words
08:40:34 <Daisy> user-guide: 11,498words
08:40:35 <Daisy> install-guide: 20,201words
08:40:43 <Daisy> These are the small documents, not big ones.
08:41:34 <AJaeger> Note: api-ref-guides uses information from api-ref...
08:41:37 <Daisy> AJaeger and fifieldt : please help to take a look at these small documents. Among them, are there any frequently changed docs recently or in this release lifecycle?
08:42:06 <Daisy> If there are, I would remove them from top priority.
08:42:13 <AJaeger> image-guide changes rarely -so good to translate
08:42:15 <fifieldt> the HA guide is static, but to be honest the content is quite outdated
08:42:15 <Fdot> Daisy if we want to prioritize, we could focus more on end users guides. What do you think about this ?
08:42:26 <AJaeger> cli-reference I would not translate
08:42:34 <Fdot> AJaeger: +1
08:42:53 <Daisy> In the last release, we spend a lot of time on installation guide translation. But it changed a lot during our translation, which make our progress shrinked.
08:43:14 <AJaeger> and it's currently stil lchanging a lot...
08:43:16 <fifieldt> translation guide is stable for icehouse now
08:43:22 <fifieldt> the master is changing towards juno
08:43:28 <fifieldt> it's changing much more than I expected
08:43:37 <fifieldt> sorry installation guide
08:43:38 <fifieldt> I mean
08:43:39 <fifieldt> :)
08:43:45 <Daisy> I know, fifieldt
08:44:03 <fifieldt> I suspect install guide will continue to change
08:44:11 <fifieldt> at least for the next few months
08:44:34 <Daisy> AJaeger: why you don't translate cli-reference?
08:44:54 <fifieldt> actually, cli-reference is mostly automatically generated from the code
08:45:03 <Daisy> ok.
08:45:16 <Daisy> That's interesting.
08:45:37 <AJaeger> Daisy, once you translate the nova client, we can autotranslate the cli-reference
08:45:55 <Daisy> So if I want to have translated cli-reference, I should add localized comments to codes. Very interesting, but hard to touch at this time.
08:46:00 <AJaeger> The cli guide consists basically of the output of "nova --help COMMAND"
08:47:02 <Daisy> How about user-guide and user-guide-admin?
08:47:19 <fifieldt> These will always expand, but probably not contract
08:47:56 <AJaeger> I suggest to take the user-guide as end user facing
08:48:35 <Fdot> Daisy, I think there is an important subject about which documents to translate. I think there is too many things that are not relevant to translate. We should focus more on UI and End users guides (API, User guide, ...) and to freeze more the content
08:49:00 <Fdot> Not usre it is relevant to translate admin guide for example
08:49:15 <Daisy> So the docs we could easily translate are: api-quick-start, api-ref-guides, api-ref, high-availablity-guide and image-guide.
08:50:34 <Daisy> Fdot, I understand your point. But there are some people who are beginners to translation work, they want to start from easy translations.
08:51:24 <Fdot> daisy : I am agree, end user guide are more easier to translate than the admin guide :)
08:51:40 <Fdot> daisy : the other problem is the documentation is moving to much
08:51:44 <Daisy> Which one, do you mean?
08:53:00 <Fdot> for exemple api-quick-start is easier to translate than the high-availablity-guide for exemple
08:53:07 <Daisy> Fdot: I agree, revolution of documents is too quick.
08:53:24 <Daisy> That's true.
08:54:22 <Daisy> aui-quick-start is developer facing. ha-guide is admin facing.
08:54:26 <Fdot> because of the revolution of documents and the amount of strings to translate it is difficult to motivate translators
08:54:35 <Daisy> Both developers and admin could be regarded as users.
08:54:57 <Daisy> Yes, Fdot, you catch the point. I cannot agree with you more.
08:55:16 <Fdot> maybe we could thing about a categorization of the documentation
08:55:32 <Daisy> So that's why I prefer to start from small documents. Translators could finish them in 1 week, and then they could see it is published. That could motivate our translators.
08:55:35 <Fdot> what has to be translate and what is not
08:55:55 <Fdot> and the has to be translate don't change too much
08:56:51 <Fdot> now when i go into transifex I have 3 pages of ressources which is too much
08:57:05 <Daisy> I could try, Fdot. To tell you the truth, it's hard.
08:57:37 <Fdot> daisy i know :)
08:57:46 <fifieldt> I also think it's important to comment on this to the docs team
08:57:51 <Daisy> Firstly, we need the criteria of the category. Then we need to understand docs status. Then we put each doc to a category.
08:57:56 <fifieldt> they seem to be constantly "restructuring"
08:58:04 <fifieldt> which is disruptive to translation
08:58:53 <Fdot> Daisy: +1
08:58:57 <Fdot> fifieldt: +1 too :)
08:59:13 <Daisy> Fdot: let's try.
08:59:22 <ujuc> both +1
08:59:29 <Fdot> fifieldt: just need to stay to stay on the irc doc chan to see this ;)
08:59:39 <Fdot> it is changing all the time :/
08:59:47 <Daisy> #action Daisy summarize criteria of document categories
09:00:12 <Fdot> daisy we can define the goal and the target for each documentations
09:00:26 <Fdot> daisy maybe some documentations are now useless
09:00:28 <Daisy> Fdot: I don't want to be strict to translation team. :)
09:01:02 <Fdot> Daisy: yes but maybe we should coordinate more the priorites
09:01:06 <Daisy> I prefer to let translators to make their own decision and plans.
09:01:20 <Daisy> Yes, we could give a priories suggestion.
09:01:49 <Daisy> When a translator or a new translation team jump in, they may feel lost before a long document list.
09:02:00 <Daisy> We could give them suggestions of priorites.
09:02:01 <Fdot> daisy : we could start with this suggestions
09:02:30 <Daisy> When they become familiar, they may decide their own work based on their special situations.
09:02:44 <Daisy> OK. We have to close the meeting.
09:02:54 <Daisy> We don't have time to cover the following topics.
09:03:00 <Fdot> Daisy: yes but i think we need a base
09:03:11 <Fdot> of documentations which need to be translate
09:03:14 <Fdot> by default
09:03:40 <Daisy> Fdot: I will keep my opinion. But we are in the same line that we start from the suggestions.
09:03:48 <Fdot> we could define what needs to be translate by default and then leave the teams what they want to do after
09:04:08 <Fdot> Daisy: ok :)
09:04:45 <Daisy> Fdot, we could. we could do like suggestions. If Russian team don't have time to work on it, we could not force them to do.
09:05:08 <Daisy> Documents are not like codes. They don't have specific release time lines.
09:05:33 <Fdot> daisy i am agree with you we must not force translation teams
09:05:57 <Daisy> Thanks all for joining. Let's keep contact off line.
09:06:14 <Fdot> but a priority suggestion list could be very helpful for all the translatores communities
09:06:33 <Daisy> Agree, Fdot
09:06:48 <Fdot> sometime alignment is nice :)
09:06:51 <Daisy> Let's do it together.
09:06:55 <fifieldt> thanks Daisy :")
09:07:16 <Fdot> thanks Daisy for this discussion :)
09:07:30 <Daisy> I will draft the criteria, then you revise it, Fdot. :)
09:07:54 <Fdot> Daisy: no problem :)
09:08:00 <Daisy> Thanks.
09:08:04 <Daisy> Close the meeting now.
09:08:06 <Daisy> #endmeeting