08:00:53 <Daisy> #startmeeting OpenStack I18n Meeting
08:00:54 <openstack> Meeting started Thu Sep  4 08:00:53 2014 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:57 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
08:01:08 <Daisy> Good afternoon, Fdot, DeeJay1
08:01:15 <DeeJay1> Morning :)
08:01:20 <Fdot> Morning :)
08:01:23 <epico> good afternoon, Daisy.
08:01:31 <Daisy> Hi, good afternoon, epico
08:01:39 <ygbo> Hi all,
08:01:51 <Daisy> Hi, ygbo
08:01:56 <Daisy> Nice to see you all.
08:02:05 <Daisy> We will talk about Horizon translation today.
08:02:21 <Daisy> Let's see if jpich or amotoki would join us.
08:02:37 <jpich> I'm here, although I have an overlapping meeting in 30min
08:02:38 <Daisy> Before they come, we could talk about our translation tools.
08:02:50 <Daisy> jpich, it's ok.
08:03:01 <Daisy> You could jump in while we are talking about Horizon translation.
08:03:14 <amotoki> i am here, but am in the other f2f meeting.
08:03:14 <Daisy> #topic translation tools update
08:03:14 <jpich> I'll try!
08:03:47 <Daisy> Hi, amotoki. If we need you, I will type your name. :)
08:04:13 <Daisy> we have pootle at http://23.253.231.198/projects/ and zanata at http://15.126.226.230:8080/
08:04:29 <Daisy> You could register and have a try now.
08:05:14 <Daisy> I planned to move OpenStack glossary to these two website before the meeting, yet I failed.
08:05:32 <Daisy> Things are difficult than I thought.
08:05:53 * Fdot creating his accounts
08:05:59 <Daisy> So I will continue to move OpenStack glossary to these two website as translation projects.
08:06:29 <Daisy> As to pootle, you need to register. But as to Zanata, you could use your OpenID in Launchpad to log in directly.
08:07:08 <Daisy> I had a talk with Doc team last week about OpenStack glossary.
08:08:13 <Daisy> So OpenStack glossary could be published as a single document. Now it is published in a hidden way: http://docs.openstack.org/glossary/
08:08:49 <Daisy> If we translate glossary, we could have non-English glossary published in each language website.
08:09:24 <Daisy> Although the terms would be sorted in English alphabetical order.
08:09:40 <Daisy> So glossary is a separate one, it's not big, it's stable.
08:10:04 <Daisy> I'm going to use glossary as a test project in our two translation test server: pootle and Zanata.
08:10:58 <Daisy> I will separate glossary into two parts, and upload one part to each test server.
08:11:42 <Daisy> We could try to translate glossary and try to see how well these two tools support our translation work.
08:12:06 <Daisy> We could feel which tool is better during translation.
08:12:43 <Fdot> Daisy, I have 2 questions about this :)
08:12:50 <Daisy> Yes, Fdot ?
08:13:05 <Fdot> 1- Can we send the url to our translators communities ?
08:13:12 <Daisy> Sure, we could.
08:13:37 <Fdot> Ok this what we are going to do in France :)
08:13:56 <Daisy> the second question?
08:14:11 <Fdot> I am going to send a message to all our community for asking to some translators want to test the 2 tools and to make a feedback :)
08:14:38 <Fdot> 2- Do you plan to install a poll tool for voting for the tools ?
08:14:39 <Daisy> Great ! I would suggest you send such message after I upload the glossary files.
08:14:54 <Fdot> Or how is the decision is going to be taken ?
08:15:18 <Daisy> I'm that clear to answer this question.
08:15:46 <Daisy> I discussed with pleia2 from infra team who helped us to set up these demo servers.
08:16:03 <Daisy> I don't think I get the clear answer.
08:16:28 <Daisy> infra team will help us to do anything we want to test these two tools.
08:16:39 <Daisy> We could collect data during our testing.
08:16:55 <Daisy> We could have our own preference if we make a vote.
08:17:22 <Daisy> We could send our testing data, our vote result to openstack community
08:18:09 <Daisy> But I'm not clear who will make the final decision.
08:18:17 <DeeJay1> it would be great if we could create a wiki page, where everyone involved would just leave their opinions via a +/- list
08:18:36 <Daisy> Good suggestion, DeeJay1.
08:18:51 <Fdot> DeeJay1: +1
08:19:11 <Daisy> Let me create an action.
08:19:56 <Daisy> #action Daisy to create a wiki page, to get two websites ready for translators to test.
08:20:09 <ygbo> DeeJay1's idea is good, can be a wiki or etherpad
08:20:43 <Daisy> Etherpad is a good choice too.
08:21:05 <Daisy> OK I have done my update on translation tools.
08:21:09 <Daisy> Any other suggestions ?
08:21:13 <Daisy> questions?
08:21:45 * DeeJay1 wonders how can we make translators interact more on the general mailing list
08:22:15 <Daisy> a good question
08:23:39 <DeeJay1> silence ensued ;)
08:23:45 <Fdot> :)
08:23:59 <Daisy> hard to answer. :)
08:24:12 <mariantb> yes, it is quite tricky. I have been using the Spanish mailing list. Yesterday I sent a quick message to encourage translators to work in the Juno project and then saw quite a difference in Transifex
08:24:52 <Daisy> what is the difference ?
08:25:19 <mariantb> nothing apparently, just insisting I guess
08:25:23 <mariantb> :)
08:26:28 <Fdot> In France we are using the Transifex messaging tool
08:26:28 <DeeJay1> hmm, maybe we could prepare a survey about communication methods and send it to all the registered translation teams on transifex?
08:27:10 <Daisy> Hi, I'm lost.
08:27:48 <Daisy> Are we talking about the communication among all translators, or  among each translation team?
08:28:26 <DeeJay1> all translators, from reviewing the archives it's mostly the people who attend here who are writing on the openstack-i18n list
08:29:00 <Daisy> mariantb: are you talking about the same ?
08:29:36 <Daisy> DeeJay1: it's true and it's correct. People who are active here, are active in I18n ML.
08:30:57 <Daisy> If we want to encourage more translators to join general ML, I think, let's use the translation tool discussion as a start .
08:31:36 <mariantb> all translators
08:32:07 <Daisy> Fdot will distribute what we are doing now to the French transaltors ML. We could do the same and invite translators to come and talk.
08:32:15 <mariantb> yes, that coule be a start
08:32:34 <mariantb> I will do the same with Spanish
08:32:46 <Daisy> mariantb: how many active translators now in Spanish team ?
08:32:47 <mariantb> I am trying to send updates to the ES mailing list
08:32:59 <Daisy> A update is a good idea too.
08:33:38 <DeeJay1> ok
08:33:52 <Fdot> Daisy : I wanted to send a message to the french community trough transifex
08:34:01 <Daisy> DeeJay1: how many active translators do you have ?
08:34:08 <mariantb> There are 37 translators officially registered in Transifex for ES, but I'd say that around 15-20 are actually translating
08:34:19 <Fdot> and to ask then asking them to post their comment there
08:34:43 <DeeJay1> Daisy: really hard to tell, probably just me and on or two others
08:34:43 <Daisy> 15-20 is a big number.
08:34:45 <Fdot> I will write a resume of the full discussion
08:35:06 <mariantb> yes, well 15-20 in a big span of time though
08:35:07 <Fdot> It will be easier to get feedbacks from translators in their own language
08:35:20 <mariantb> if I think the last week, less than 10
08:35:45 <Daisy> In Chinese, less than 10 active transaltors.
08:36:11 <Daisy> If I call for help, I have the confidence that I will get enough help.
08:36:46 <Daisy> I mean, in general, less than 10. But if I need, I would get more active people.
08:37:33 <Daisy> Anyway, I will think about how to make our translators more active, and we could think about it together.
08:37:51 <mariantb> Fdot is right, when using own language, there is more activity
08:37:52 <mariantb> ok
08:38:19 <Daisy> Let's move to Horizon translation, the most important part.
08:38:31 <Daisy> #topic Kick off Juno Horizon translation
08:38:41 <Daisy> Some updates from me.
08:39:13 <Daisy> 1. All Horizon message catalogs from Juno (master) branch are synced to Transifex regularly.
08:39:28 <Daisy> I checked Transifex. The last update was yesterday.
08:39:56 <Fdot> Daisy it was an important update
08:40:20 <Fdot> 90 strings
08:40:26 <Fdot> with a lot of things
08:40:41 <Fdot> is it going to move again in the next weeks ?
08:40:47 <Daisy> I don't know if string freeze happened or not.
08:41:00 <Fdot> that was my next question ;)
08:41:13 <Daisy> In the schedule, string freeze is Sep 4th. That means, today.
08:41:14 <ygbo> I have a silly question: when we have patches such as https://review.openstack.org/#/c/91338/ which change translation methods in the code, would it be possible to have dedicate "test" catalogue on the translation tool to have translators feedback on the patch to know if it improves there translations quality or not? What do you think?
08:41:43 <Daisy> ygbo, let's talk about your question later.
08:41:48 <ygbo> sure
08:42:01 <Daisy> call for jpich's help.
08:42:20 <jpich> (sorry, in another call now)
08:42:26 <jpich> (back in a few)
08:42:33 <Daisy> ok.
08:42:38 <Daisy> So continue my update.
08:43:17 <Daisy> Data processing (Sahara) Dashboard is a big newcomer in Juno. It is not small and it may take time to translate. It sometimes needs a domain expert of Hadoop to find appropriate terms.
08:43:56 <Daisy> I see in Transifex, there are more than 600 new strings in Juno.
08:44:12 <Daisy> It's not a small work.
08:44:21 <Daisy> So try to get more people to help on the translation.
08:45:14 <Daisy> 2. Previously, we had a translation check site owned by amotoki.
08:46:36 <Daisy> In this version, amotoki might not provide us such check site, because his machine is not that powerful to run   all OpenStack components including Trove, Sahara or Ceilometer.
08:46:58 <DeeJay1> Daisy: hmm, I have a machine which I could give him access to
08:47:15 <Daisy> I think, we need a translation check website to test our translation.
08:47:39 <Daisy> He also doesn't have enough spare time too.
08:47:46 <jpich> I think it would be worthwhile having the infra folks manage such a system
08:48:07 <Daisy> Yes.
08:48:39 <Daisy> I don't know if we have enough time to set the system up.
08:48:50 <Daisy> We have only 1 month.
08:49:06 <Daisy> jpich: we want to know the status of string freeze.
08:49:27 <DeeJay1> amotoki: could you give me some hints how did you set it up? was it a usual devstack instance?
08:49:39 <jpich> Feature freeze is meant to happen later today, though the gate is backlogged at the moment so it might be tomorrow morning
08:50:01 <jpich> There's a couple of feature freeze exceptions for feature already accepted for Horizon, that will bring additional strings so I don't think it is very big
08:50:18 <Daisy> a couple of feature freeze exception?
08:50:32 <Daisy> If the strings is not big, it's acceptable.
08:50:37 <jpich> Daisy: Yes, for new features - so they will have a few new strings
08:51:20 <Daisy> Will the existing string in Horizon being updated after string freeze ?
08:52:05 <jpich> Daisy: I believe the exceptions are mostly new strings but I haven't been able to check closely yet
08:52:33 <Daisy> jpich: who will own the merge of translations in this release ?
08:52:50 <Daisy> who will manage the merge of translation, I mean.
08:52:55 <jpich> Daisy: I believe it's automated now?
08:52:58 <Daisy> is it you or amotoki ?
08:53:08 <Daisy> ok.
08:53:11 <jpich> When the RC branch are created later we might need manual updates
08:53:14 <jpich> we can talk about it then
08:53:23 <Daisy> ok.
08:53:27 <jpich> For now master branch translations are updated automatically
08:53:41 <Daisy> Got it.
08:54:15 <Daisy> any other questions about horizon translation for jpich ?
08:55:07 <Daisy> When is the last day for translation commit, jpich?
08:55:18 <Daisy> in Juno release cycle.
08:55:58 <jpich> For the first Release Candicate would be good I think. From https://wiki.openstack.org/wiki/Juno_Release_Schedule it looks like Sept 25th
08:56:07 <jpich> but I'm sure we can have exceptions for translations
08:56:23 <jpich> October 9th may be works better so there is a month to translate all the new strings
08:56:51 <Daisy> Great. I think 1 month is a good time period.
08:57:09 <Daisy> So we have a tough task for translation team now.
08:57:38 <Daisy> We need to start the translation as soon as possible.
08:57:51 <Daisy> I will send to ML to call for participation.
08:58:22 <Daisy> #action Daisy to send email calling for the participation of Juno translation.
08:58:37 <Daisy> Thanks, jpich.
08:58:51 <Daisy> #open discussion
08:58:56 <Daisy> #topic open discussion
08:59:14 <jpich> Daisy: Will you contact the infra folks about setting up a test website for translations?
08:59:33 <Daisy> I will, jpich
08:59:45 <Daisy> I will look for any help I can get.
08:59:54 <jpich> Cool :)
09:00:06 <Daisy> DeeJay1 has a machine. amotoki has experience to set up.
09:00:39 <Daisy> infra folks is another choice, but I don't know if time is enough.
09:01:44 <Daisy> I'm looking at ygbo's patch link now: https://review.openstack.org/#/c/91338/
09:01:55 <amotoki> DeeJay1: let me share infromation later.
09:02:29 <Daisy> ygbo: it's a big patch.
09:02:38 <Daisy> ygbo: what help do you need from I18n team?
09:03:16 <Daisy> ygbo: could we talk among I18n ML? Time is over. I have to close the meeting
09:03:18 <ygbo> Daisy: Well, I changed the way some strings are translated, so I would like feedback to know if the strings are easyer to translate
09:03:26 <Daisy> Ok. I see.
09:03:27 <amotoki> DeeJay1: it is just a normal devstack setup + custom bash script to fetch translation from transifex.
09:03:34 <Daisy> You want to create a test project.
09:04:13 <ygbo> before, a translator had to translate (subject)s (verb)s and the subject and verb where in diferent strings
09:04:14 <Daisy> I could help to create a test project in Transifex, but I don't know how to test if the translation quality could be improved or not.
09:04:20 <DeeJay1> amotoki: oh, ok, so I think I'll manage
09:04:45 <ygbo> the issue was that the conjugation was not working in all languages.
09:04:56 <Daisy> Yes, I agree.
09:05:01 <ygbo> so this patch proposes to have the full string instead.
09:05:29 <Daisy> ygbo: let's discuss in I18n ML about your patch.
09:05:36 <ygbo> sure
09:05:54 <Daisy> Could you start a mail thread in ML about your work?
09:06:13 <ygbo> Ol
09:06:16 <ygbo> Ok
09:06:23 <Daisy> I could work together with you to see how could we test the new patch.
09:06:29 <Daisy> Thanks.
09:06:38 <Daisy> Thank you all for attending.
09:06:49 <Daisy> I will close the meeting now.
09:07:02 <DeeJay1> thanks all
09:07:04 <Daisy> #endmeeting