08:00:27 <Daisy> #startmeeting OpenStack I18n Meeting
08:00:28 <openstack> Meeting started Thu Nov 20 08:00:27 2014 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:31 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
08:00:40 <Daisy> who is around ?
08:00:59 <jpich> Hello Daisy
08:01:03 <epico> Hello Daisy
08:01:12 <Daisy> Hi, jpich
08:01:17 <Daisy> Hi, epico
08:01:20 <Daisy> Nice to see you
08:01:30 <epico> Nice to see you, too. :)
08:01:42 <ujuc> hi ~ :)
08:01:49 <Daisy> hi, ujuc
08:01:59 <Daisy> OK. Then let's start the meeting
08:02:09 <Daisy> There was a translators meet-up in Paris.
08:02:34 <Daisy> epico and ujuc were not there.
08:02:49 <Daisy> I wrote an email to ML after the meeting
08:03:02 <Daisy> http://lists.openstack.org/pipermail/openstack-i18n/2014-November/000871.html
08:03:22 <Daisy> Today, we will figure out some actions and assign owners if we could.
08:03:35 <Daisy> I hope you have time to look at this email. :)
08:03:41 <chandankumar> hello Daisy epico
08:03:49 <Daisy> Hi, chandankumar
08:03:57 <epico> hello chandankumar
08:04:06 <Daisy> I have figure out some possible actions.
08:04:12 <Daisy> We could go through them 1 by 1.
08:04:31 <Daisy> 1. Actions to promote the team
08:05:08 <Daisy> I think, some translation teams may have only a few numbers. We hope to enroll more people to join translation teams.
08:05:14 <Daisy> We may want to promote it.
08:05:56 <Daisy> There are some discussions, like use blogs, meet-ups to promote translation team.
08:06:08 <Daisy> They are good suggestions.
08:06:36 <Daisy> Some actions we could do it now, I think, include
08:07:40 <Daisy> prepare for a formal deck to introduce translation team, and coordinators could use this deck to present how we are working in translation areas in the local meet-ups.
08:08:36 <Daisy> chandankumar and I did a presentation to introduce translation management in FUEL conference last Saturday
08:08:46 <Daisy> We could share this deck.
08:09:18 <Daisy> chandankumar: I think, the only thing I want to improve the deck is how new comers could start their contributions.
08:09:19 <chandankumar> Daisy, The hangout video of presentation will be available soon on youtube
08:10:01 <Daisy> another action we could do now is to create a mailing list for each translation team.
08:10:06 <chandankumar> Daisy, i will add that part how new comers can start their contribution
08:11:57 <Daisy> chandankumar: I don't have MS office, so I use an office provided by a Chinese local provider. I think the interoperability maybe not good with MS office. So I have changed it into pdf. If you want add this part, you could use a ppt to add the content, then I could merge it into my version.
08:12:22 <chandankumar> sure :)
08:12:31 <Daisy> get back to the mailing list
08:13:16 <Daisy> If any translation team wants to create their own dedicated mailing list, other than I18n, please let me know. I will send an email to I18n mailing list about the information.
08:13:44 <Daisy> #action Daisy to follow up with the creation of dedicate mailing lists for translation teams.
08:14:24 <Daisy> #action chandankumar to add contents about how new comers start contributions.
08:14:50 <Daisy> 2. Actions to improve wiki pages.
08:15:08 <Daisy> There were a lot of discussion like:
08:15:26 <Daisy> A clear start point to guide new comers
08:15:51 <Daisy> Guidance to bug report
08:16:14 <Daisy> A clear goal and timelines for all translation team
08:16:37 <Daisy> Clearly describe translation priorities
08:16:49 <Daisy> So we need to improve our wiki page to cover these.
08:17:38 <Daisy> chandankumar: would you like to write a wiki page to guide new comers to join and contribute? I think it should be same as the deck.
08:17:50 <chandankumar> yes
08:18:02 <Daisy> a wiki page under https://wiki.openstack.org/wiki/I18nTeam
08:18:04 <Daisy> Thanks.
08:18:10 <Daisy> Then I will take other parts.
08:18:58 <Daisy> #action Daisy & chandankumar to write wiki pages to cover guidance to new comers, bug reporters, translation work items, and etc.
08:19:14 <Daisy> 3. Add translators contribution into stackalytics.com
08:19:53 <Daisy> OpenStack uses this website: http://stackalytics.com/ to track the contributions. All kinds of contributions.
08:20:05 <Daisy> We want to include our translators contributions there too.
08:20:29 <Daisy> It's a more technical work.
08:20:31 <ujuc> lol ~~
08:20:48 <Daisy> epico: I hope you might have interests to this work item.
08:21:41 <Daisy> After we go to Zanata, Zanata will provide a serials of API to return each person's contributions, like how many words he/she translated, how many words he/she reviewed.
08:22:03 <epico> Daisy: let me ask my manager.
08:22:22 <epico> or ask zanata team?
08:22:54 <Daisy> What we need to do, is to collect those data, understand how stackalytics show these data in charts, and show them.
08:23:26 <Daisy> It take time, need collaboration with both Zanata team and stackalytics dev team.
08:23:30 <Daisy> ok, epico
08:24:36 <Daisy> anyway, I will describe this work item in i18n mailing list, and ask if anybody who want to take care.
08:25:22 <Daisy> #action Daisy to send to ML about the work to add translators contribution into stackalytics.com
08:26:00 <Daisy> 4. A common glossary could help to improve the quality.
08:26:16 <Daisy> chandankumar: how about your glossary table?
08:26:34 <chandankumar> Daisy, yes
08:26:49 <Daisy> Did you glossary table pass the review?
08:26:58 <chandankumar> Daisy, yes
08:27:11 <chandankumar> Daisy, at the end of this week it is released
08:27:24 <Daisy> It is very nice ! Congratulations.
08:27:31 <chandankumar> Daisy, Thanks :)
08:27:37 <Daisy> We could adopt it in openstack translation.
08:28:06 <chandankumar> :)
08:28:07 <Daisy> chandankumar: I need you to think about how to adopt it in openstack translation.
08:28:44 <Daisy> Now we are using Transifex. We need to import your glossary into Transifex.
08:29:06 <Daisy> I remember Transfix could import glossary from a cvs file.
08:29:21 <chandankumar> sure :)
08:29:42 <Daisy> we could do it with following steps:
08:30:41 <Daisy> export your table into a excel file, distribute the excel file to community, and invite translation teams to input their translations into this excel file.
08:31:01 <Daisy> And after we collect some translations, we could import it into Transifex, and Zanata in the future.
08:31:39 <Daisy> I think, some translators like offline translations more than on-line translations.
08:31:44 * chandankumar noted down the steps.
08:32:57 <Daisy> #action chandankumar & Daisy would take care of the glossary.
08:33:51 <Daisy> OK. The following two possible actions are:
08:34:06 <Daisy> 5. 9. keep on maintain "Horizon translatable strings rules"
08:34:19 <Daisy> 6. keep on maintain of doc priorities
08:35:23 <Daisy> as to this two actions, the appropriate people I should talk to are not in the meeting now.
08:35:49 <Daisy> so just leaving them there. I will follow up after the meeting.
08:35:56 <chandankumar> yes
08:36:12 <Daisy> I have done.
08:36:31 <Daisy> What else in your mind about improving our work? Any suggestions? Any comments?
08:37:47 <Daisy> #topic open discussions
08:38:16 <epico> hi jpich
08:38:22 <epico> https://review.openstack.org/#/c/134850/
08:38:37 <epico> how to re-trigger jenkins jobs?
08:38:56 <epico> or setup the test environments of gate-tempest-dsvm-neutron-src-oslo.i18n?
08:38:57 <jpich> leaving a comment with "recheck no bug" may be the fastest way
08:39:12 <jpich> if you're sure the failure isn't related to your patch
08:39:29 <epico> thanks, I will have a try.
08:39:51 <jpich> :)
08:40:31 <Daisy> anything else?
08:41:12 <Daisy> so I will close the meeting.
08:41:37 <Daisy> Thank you for attending. Let's keep contact through mailing list and IRC.
08:42:13 <Daisy> #endmeeting