08:01:56 <Daisy> #startmeeting OpenStack I18n Meeting
08:01:57 <openstack> Meeting started Thu Dec  4 08:01:56 2014 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:02:01 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
08:02:14 <Daisy> Hello, who is around for i18n meeting?
08:02:36 <ujuc> hi :)
08:02:39 * Fdot is here \o_
08:02:42 <Fdot> hello Daisy
08:02:45 <Daisy> Hi, ujuc and Fdot
08:02:49 <epico> hi
08:02:57 <Daisy> Hi, epico
08:03:05 <epico> :)
08:03:16 <ujuc> \o_ :)
08:03:38 <Daisy> Let's start.
08:03:41 <Daisy> #topic Review the status of TODO last time
08:04:02 <Daisy> Last meeting, there were a few TODO items.
08:04:07 <Daisy> Let's see the status.
08:04:32 <Daisy> 1. Daisy to follow up with the creation of dedicate mailing lists for translation teams.
08:05:12 <Daisy> I did some discussion off line with community people.
08:06:06 <Daisy> There is no concerns from technical perspective. Just we need to state clearly the reason why we need dedicate mailing list for each translation team, other than using the existing i18n mail list.
08:06:15 <Fdot> Daisy sorry i am late in my e-mails, i am answering to you about this ;)
08:06:21 <Daisy> ok.
08:06:28 <Daisy> What's your point? Fdot
08:07:01 <Fdot> I would prefere to have a dedicate mailing list for french translators
08:07:28 <Fdot> there is already a french openstack community list
08:07:41 <Fdot> but it is dedicated to the french openstack association
08:07:55 <Fdot> and i prefere to separate the subjects
08:08:14 <Fdot> this is not the same goals and the same people behing
08:08:18 <Daisy> how about using i18n mail list but with different tags?
08:08:28 <Daisy> just like openstack-dev
08:09:02 <Daisy> There are more developers than translators. They are using 1 mailing list, just with different tags.
08:09:45 <Fdot> Daisy: we can try like this, but i am afraid that translators are going to receive too many emails and so don't take care about the one concerning the french translation
08:10:03 <Fdot> but we can start like this
08:10:20 <Daisy> OK. Let's start from i18n but different tags.
08:11:21 <Fdot> Daisy: ok
08:11:30 <Daisy> Frankly speaking, I don't think i18n mailing list is active as developers mailing list. For now, i18n mailing list has no problems to support different translation teams.
08:12:12 <epico> Daisy, +1
08:12:13 <Daisy> There is another advantage to use i18n ML. We could have more translators to pay attention to the whole team discussions.
08:12:35 <ujuc> :)
08:12:35 <Fdot> Daisy: I understand, we can try like this and if it doesn't works we will create dedicate list ;)
08:12:45 <Fdot> Daisy: +1
08:12:45 <Daisy> ok. agree.
08:13:07 <Daisy> Fdot, so you could have your translators to register i18n ML. I will do the same.
08:13:16 <Daisy> ujuc, you take care of Korean transaltors.
08:13:50 <ujuc> yap
08:13:53 <Daisy> action #2.  chandankumar to add contents about how new comers start  contributions.
08:13:56 <Fdot> I am going to send an e-mail to our active french translator, on transifex et update our page on the wiki ;)
08:14:23 <Daisy> action 3. Daisy & chandankumar to write wiki pages to cover guidance to new comers, bug reporters, translation work items, and etc.
08:14:50 <Daisy> Sorry chandankumar and I didn't make much progress. I will follow up and keep your updated next week in ML.
08:15:13 <Daisy> action 4.  Daisy to send to ML about the work to add translators contribution into stackalytics.com
08:15:34 <Daisy> I tried a few people off line.
08:15:54 <Daisy> anish_ from China would like to take a look at it.
08:16:07 <Daisy> anish_ now is working on https://github.com/zanata/zanata-python-client.
08:16:39 <Daisy> he knows python and Zanata. He would be a good person to take care of this work item.
08:16:58 <Daisy> The blueprint is registered.  https://blueprints.launchpad.net/stackalytics/+spec/translators-contribution
08:17:26 <Daisy> Hope we could make some progress in this release.
08:17:47 <Daisy> action 5. chandankumar & Daisy would take care of the glossary.
08:17:55 <Daisy> Sorry no progress with this one also.
08:18:37 <Daisy> chandankumar is quite busy with his company project.
08:18:43 <anish_> Hi
08:18:53 <Daisy> Hi, anish_
08:19:19 * anish_ could not realize  i got disconnected from IRC
08:19:25 <Daisy> I just introduce you to the team.
08:19:29 <anish_> hi Daisy
08:19:38 <anish_> thank you
08:20:12 <Daisy> You are from Indian and Redhat. You are working on zanata-python-client. You will help us to take care of translators contribution in stackalytics.
08:20:25 <Daisy> We are going to move to next topic.
08:20:35 <Daisy> #topic Documentation translation plan in Kilo
08:20:36 <anish_> thanks!
08:20:40 <epico> anish_ :)
08:21:35 <Daisy> It's better to make a document translation plan in Kilo.
08:21:52 <Daisy> According to the table: https://wiki.openstack.org/wiki/I18nTeam/docs-translation
08:22:35 <Daisy> High priority:
08:22:37 <Daisy> api-quick-start
08:22:38 <Daisy> api-ref
08:22:41 <Daisy> glossary
08:22:42 <Daisy> Medium priority:
08:22:43 <Daisy> Common
08:22:45 <Daisy> install-guide
08:22:46 <Daisy> image-guide (9879)
08:23:14 <Daisy> The Chinese, French, Korean translations of api-quick-start are done and on-line now.
08:23:26 <Daisy> our next choice may be api-ref.
08:23:46 <Daisy> It's 4151 words.
08:23:47 <Fdot> Daisy the wiki page doesn't seems to be updated
08:24:06 <Fdot> I don't see the heat guides ;)
08:24:15 <Daisy> ok.
08:24:33 <Daisy> So Fdot, do you have time to update it?
08:24:50 <Fdot> Daisy: I am going to try to find it ;)
08:24:57 <Daisy> Thanks, Fdot.
08:25:23 <Daisy> anyway, api-ref could be our next work item.
08:25:47 <Daisy> or another more useful document ? like image-guide or install-guide?
08:25:57 <Daisy> Fdot, what's your opinion?
08:25:58 <Fdot> daisy : hot-reference
08:26:02 <Fdot> is important :)
08:26:21 <Daisy> hot-reference is not in the table.
08:26:32 <Fdot> Yes I am going to add it
08:26:47 <Daisy> Is it stable now?
08:27:28 <Fdot> To be honnest I don't know but it is seems to be
08:27:41 <ujuc> transfix status 'do-not-translate-yet'... hot-reference...
08:27:42 <Daisy> OK.
08:27:49 <Fdot> In the wiki page I have to add hot guide and upgrade guide
08:28:19 <Daisy> Thanks Fdot.
08:28:27 <ujuc> :)
08:29:16 <Daisy> Fdot, do you against we start the translation of api-ref ?
08:30:25 <Fdot> Daisy: no
08:30:27 <Daisy> If you prefer another document, I will take your opinion into consideration. I think you understand documents much more than me.
08:30:48 <Fdot> the only problem for api-ref is we can't translate everything
08:31:07 <Fdot> currently personnaly I am more focus on Heat documentation
08:31:16 <Fdot> because it is related to works
08:31:18 <Fdot> ;)
08:31:30 <Daisy> what will be left in api-ref?
08:31:37 <Daisy> table?
08:31:49 <Daisy> WSDL?
08:31:55 <Fdot> WSDL
08:31:57 <Daisy> ok.
08:32:00 <Daisy> It's all right.
08:32:14 <Fdot> in which you have a lot of things
08:33:09 <Daisy> Do you have better choices than api-ref?
08:33:42 <Fdot> api-ref and hot guide :)
08:33:57 <Fdot> unfortunatly the heat guide is not in transifex :(
08:34:05 <Fdot> could be a good choice too
08:34:28 <Daisy> why heat guide is not in transifex?
08:34:31 <Daisy> do you know the reason?
08:34:43 <Fdot> I don't know
08:34:54 <Daisy> #action Fdot to update the document table in wiki.
08:35:02 <Fdot> this is the first guide which is not based on docbook
08:35:06 <Fdot> but on RST
08:35:12 <Daisy> that might be the reason.
08:35:19 <Fdot> Daisy: probably ;)
08:35:56 <Fdot> Daisy: action done :)
08:36:14 <Daisy> So let's start with api-ref.
08:37:06 <Daisy> where is hot guide?
08:37:18 <Daisy> I don't see hot guide in the table.
08:37:47 <Daisy> hot guide means "Heat Orchestration Template (HOT) Reference " ?
08:37:48 <Fdot> hot-reference
08:37:58 <Fdot> :)
08:38:04 <Fdot> yes
08:38:28 <Daisy> I see.
08:38:38 <Fdot> I have just added 2 lines for hot reference et upgrade guide
08:38:56 <Daisy> ok.
08:39:04 <Daisy> I think installation guide is very useful.
08:39:24 <Daisy> What's your point to translate installation guide?
08:39:56 <Daisy> installation guide for juno should be stable, I think.
08:40:24 <Fdot> OpenStack is a very complicate product
08:40:28 <Fdot> to install
08:40:43 <Fdot> if you want to deploy OpenStack you a have to speak english
08:40:56 <Daisy> :)
08:41:00 <Fdot> because all the help you are going to search is in english
08:41:12 <Fdot> so it is better to keep the install guide in english
08:41:39 <Fdot> I spoke about this with a lot of developers and everybody is agree with that
08:42:19 <Daisy> ok. interesting point.
08:42:26 <Fdot> translating the guide is not doing a favor to the person who want to install it ;)
08:43:04 <Daisy> When I install openstack, I followed a blog written in Chinese.
08:43:54 <Fdot> I used a documentation in english ;)
08:44:12 <Daisy> anyway, let's start from api-ref.
08:44:20 <Fdot> Daisy: yes :)
08:44:33 <Daisy> I think it will take some time. After api-ref is done, let's figure out the next document together.
08:44:46 <Daisy> OK. I have done all topics now.
08:44:51 <Daisy> #topic open discussion
08:44:56 <Fdot> Daisy: could be nice to be able to works on : http://docs.openstack.org/developer/heat/getting_started/on_devstack.html
08:44:57 <Fdot> ;)
08:46:08 <Daisy> I could take a look at it. Discuss with Andreas.
08:46:18 <Fdot> Daisy: thanks a lot :)
08:46:28 <amotoki> is anyone working on trnasltaion check site by openstack infra?
08:46:53 <amotoki> s/by/on/ maybe
08:47:38 <Daisy> Since we are going to move to Zanata in this release, if supporting RST needs development work, I prefer to put it low priority. After we finish the migration to Zanata, of course, we need to support RST.
08:47:58 <Daisy> amotoki: I didn't follow up with it now.
08:48:22 <Daisy> amotoki: you mean to follow up with infra to support transaltion check site?
08:48:52 <amotoki> Daisy: yes.
08:49:06 <Daisy> ok. I could do it next week.
08:49:23 <amotoki> i can provide tools or configurations but i don't have time to work on it in this release.
08:49:27 <Daisy> #action Daisy to work on the translation check site by infra.
08:49:36 <amotoki> thnx Daisy
08:49:41 <Daisy> welcome, amotoki
08:49:57 <Daisy> https://blueprints.launchpad.net/openstack-i18n/+spec/enable-i18n-test
08:50:05 <Daisy> This is what I'm going to do in this release.
08:50:17 <amotoki> btw, Juno translation import has been merged several hours ago. it will be shipped this week.
08:50:17 <Daisy> I'm going to work on i18n test.
08:50:28 <Daisy> Thanks, amotoki.
08:50:50 <Daisy> Are some translations automatically filled from TM?
08:51:47 <Daisy> People who are interested in i18n test could work together with me on this blueprint.
08:52:23 <amotoki> re: i18n test, in horizon case, we check if message catalog can be generated in pep8 test
08:52:46 <amotoki> and translation message catalog validation is done through devstack now.
08:53:31 <amotoki> during stack.sh, horizon message catalogs are compiled in mo files, so if translation is bad devstack will fail.
08:53:33 <Daisy> amotoki: can you point me to the test codes ?
08:53:52 <amotoki> I believe so, but we need to check if devsatck fails in such cases.
08:54:28 <Daisy> amotoki: is it possible to "get html source codes of horizon pages, test if all strings are displayed as the mock translations." ?
08:54:30 <amotoki> Daisy: message catalog generation: http://git.openstack.org/cgit/openstack/horizon/tree/tox.ini#n25
08:55:05 <Daisy> amotoki: I mean, to test if all messages are wrapped with translation tags.
08:55:34 <amotoki> Daisy: got it.
08:55:59 <amotoki> IMHO this kind of things can be checked by tools in project repo rather than tempest.
08:56:41 <amotoki> Daisy: neutron has this kind of tool: http://git.openstack.org/cgit/openstack/neutron/tree/tools/check_i18n.py
08:56:53 <Daisy> One developer in my company complained to me the hard coded strings were found very near to juno release. they have to fix in a rush. They hope to find this kind of problems as early as possible.
08:57:19 <amotoki> but this tool generates many false positive, so it is not enabled in the gate.
08:57:56 <Daisy> thanks for these information. I will take a look at them.
08:59:07 <Daisy> Time is over.
08:59:25 <Daisy> I will close the meeting now. For further discussions, we could use #openstack-translation.
08:59:30 <Daisy> Thank you all for attending.
08:59:56 <Daisy> #endmeeting