06:02:01 <Daisy> #startmeeting OpenStack I18n Meeting
06:02:02 <openstack> Meeting started Thu Jun  4 06:02:01 2015 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:02:05 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
06:02:20 <Daisy> Good morning and good afternoon.
06:02:29 <Daisy> Welcome to I18n meeting.
06:02:42 <DeeJay1> +1 ;)
06:02:42 <ujuc> hello~
06:02:46 <Daisy> I see ujuc, katomo, adiantum, Fdot , DeeJay1
06:02:50 <Daisy> Nice to meet you.
06:02:51 <adiantum> Hello!
06:02:52 <Fdot> \o_
06:03:03 <epico> Hello
06:03:03 <ujuc> \o_ kk
06:03:08 <katomo> Hello
06:03:09 <Daisy> Hi, epico
06:03:16 <Daisy> Let's start the meeting.
06:03:40 <Daisy> #topic Briefing of I18n meetings in Vancouver summit
06:04:36 <Daisy> In Vancouver summit, there were 2 scheduled I18n meetings. DeeJay1 had a presentation to introduce translation tools and his experiences in translation .
06:05:47 <Daisy> In the 2 scheduled I18n meetings, we met with doc team, Horizon team, infra team. It was great to meet with them in our meetings. It showed that they all thought we were important.
06:06:22 <Daisy> Besides 2 scheduled meetings, we also had a ad hoc I18n team round table meeting.
06:06:34 <Daisy> I liked this ad hoc meeting very much.
06:06:48 <Fdot> +1 :)
06:06:51 <Daisy> https://etherpad.openstack.org/p/vancouver-translation-team-workshop
06:07:00 <Daisy> This was the meeting minutes.
06:08:07 <Daisy> We talked about glossaries, communications, string freeze, being more official and visible.
06:08:12 <Daisy> and etc.
06:08:18 <Daisy> We even made a picture.
06:09:05 <Daisy> About the communication, we decided to try "slack".
06:09:35 <Daisy> Fdot set up a "link" in slack: https://openstacki18nteam.slack.com
06:10:15 <Daisy> You can install a mobile app "slack", then you can communicate with the team any time you want.
06:11:34 <Daisy> Fdot: if a person want to join https://openstacki18nteam.slack.com, does he need invitation ?
06:11:34 <katomo> Fdot: To start using Slack, you'll need to be invited by your team administrator.
06:11:40 <Fdot> If you can't access to the group send give me your email and I will send you invitations
06:11:56 <katomo> got it.
06:12:16 <Daisy> DeeJay1: do you still have problem to join slack ?
06:12:18 <katomo> Thanks to set up.
06:12:25 <Fdot> katomo daisy: I am looking into the seetings for improving this ;)
06:12:37 <Daisy> ok.
06:12:56 <DeeJay1> Daisy: yes :(
06:13:07 <Daisy> What's your problem, DeeJay1  ?
06:13:32 <DeeJay1> I need the invite ;) I'll message Fdot
06:13:40 <Daisy> ok.
06:13:48 <Fdot> DeeJay1: anytime :)
06:14:13 <Daisy> great. slack can short the physical distance between us.
06:15:03 <Daisy> About the glossary, German, French, Japanese, Chinese have their own glossary. We decided to merge them together to make the first version of I18n "terminologies".
06:15:15 <Daisy> ujuc: do you have your own glossary ?
06:15:34 <ujuc> no, i made glossary...
06:15:44 <Daisy> What do you mean ?
06:15:52 <ujuc> https://wiki.openstack.org/wiki/%EB%8B%A8%EC%96%B4%EC%A7%91
06:15:57 <ujuc> slowly make....
06:16:44 <Daisy> ok. I didn't make out a merged version yet. I will do it next week.
06:17:13 <Daisy> We decided to use "terminologies" as the first trial project in Zanata. The first trial project will probably start from the end of June or the early of July.
06:17:53 <Daisy> DeeJay1 has a spec to infra team about translation check website. Thank you very much, DeeJay1
06:18:01 <Daisy> https://review.openstack.org/#/c/184559/
06:18:09 <Daisy> DeeJay1: how is the progress now ?
06:18:15 <DeeJay1> I'll refine it this weekend according to the comments
06:18:25 <Daisy> ok. Thank you.
06:18:34 <DeeJay1> it's been a pretty busy week after my vacation
06:19:39 <Daisy> I'm done about "Vancouver summit briefing". Do you have anything add, Fdot, DeeJay1, adiantum ?
06:20:12 <Daisy> adiantum: have you connected with Carlos, the Zanata developer ?
06:20:21 <Fdot> Daisy: it is ok for me :)
06:20:41 <adiantum> Daisy: not yet, i have no his contacts...
06:20:44 <Daisy> We need to make sure "translation metrics on stackalytis" happened in Liberty.
06:20:56 <Daisy> OK. I will connect you two.
06:21:11 <adiantum> Daisy: thank you.
06:21:20 <Daisy> Then let's move to next topic.
06:21:44 <Daisy> #topic Criteria of I18n core members and active members
06:22:24 <Daisy> During the Vancouver meeting, we decided to try "openstack official project". I tried. it turned out our contributions were well known by TC team. 11 people voted +1 to us.
06:23:21 <Daisy> So we passed. Now we are official project. In next design summit, we will have meeting rooms. Hurry!
06:23:32 <DeeJay1> yay!
06:23:49 <adiantum> Very good!
06:23:50 <Fdot> \o/
06:23:55 <ujuc> lol
06:24:47 <Daisy> If we want our active contributors to get "ATC" and the discount code sent by openstack officer, we have to do some extra steps.
06:25:32 <Daisy> Before that, let's set the criteria of our core members and active members.
06:25:59 <Daisy> First, let's discuss about the core member criteria .
06:27:34 <DeeJay1> I'd say: attends at least one meeting montlhy and is active on the mailing list and is a language coordinator
06:27:40 <Daisy> What in my mind are is "(1) coordinators of active translation team who has Horizon translation or at least 2 document translation (2) attend IRC meeting at least once per month“
06:27:41 <Fdot> Daisy: maybe we can use the transifex stats ?
06:28:30 <DeeJay1> Fdot: s/transifex/zanata/ - but that is for the active member statistic in my opinion
06:28:41 <Daisy> Fdot: Yes, Transifex stats could be used to name the active contributors.
06:29:24 <Daisy> DeeJay1: agree. Transifex/Zanata stats could be used to select active members. Not core members.
06:29:50 <DeeJay1> Daisy: adding a required Horizon/doc translation is a good point also
06:30:05 <Daisy> Fdot: I will send you the stats of French team.
06:30:13 <DeeJay1> this would weed out the coordinators which are there because they are there
06:30:23 <Daisy> DeeJay1: yes.
06:30:28 <adiantum> Daisy: and may i ask you about stats for russian team?
06:30:34 <Daisy> sure, adiantum
06:30:35 <Fdot> Daisy: thanks
06:30:48 <adiantum> Daisy, thank you
06:31:19 <adiantum> Horizon translation is a good point
06:31:51 <Daisy> OK. Nice. I think we will have our initial core team.
06:32:29 <katomo> Horizon and Docs are good.
06:32:45 <Daisy> Then we need to collect information of active translators. We need to have them sign  the ICLA ( it is individual contributor ?? agreement )
06:32:50 <adiantum> But i think we need to think about involvment to translation review process too
06:33:26 <adiantum> Individual Contributor License Agreement
06:33:41 <Fdot> +1 adiantum :)
06:33:42 <DeeJay1> adiantum: yeah, but we should get it from the stats
06:33:44 <Daisy> Exactly, Thank you, adiantum.
06:33:47 <katomo> adiantum: agree. review process is important.
06:34:12 <ujuc> +1 adiantum, :) review... important.
06:34:38 <Daisy> how to do that ? Do you have any idea ? adiantum
06:35:15 <adiantum> from stats, but no idea about correct criteria
06:35:56 <Daisy> review is another kind of contribution, the same important as translation.
06:36:11 <DeeJay1> adiantum: for current ATC criteria for the developers, you need to just fix a typo somewhere
06:36:22 <Daisy> I know Zanata stats will show the review contribution and translation contribution.
06:36:41 <adiantum> DeeJay1: sometimes not only typo :)
06:36:53 <Daisy> I don't know about Transifex yet. If it has, I will send to you together.
06:37:40 <adiantum> Daisy: so we can discuss this criteria after transfer to Zanata
06:38:27 <Daisy> who knows the criteria of current code ATC ?
06:38:37 <Daisy> 1 commit ?
06:38:52 <adiantum> as i remember 1 commit to official project
06:39:03 <DeeJay1> https://ask.openstack.org/en/question/45531/atc-pass-for-the-openstack-summit/
06:39:39 <Daisy> Do you agree that "1 word translation or review" could be the criteria of translation ATC ?
06:39:58 <ujuc> https://wiki.openstack.org/wiki/Manila/Program_Application#ATC_Status
06:40:06 <Fdot> Daisy: I think it is not enough
06:40:31 <Fdot> It is easier to translate 1 word than doing 1 commit
06:40:36 <DeeJay1> I'd say maybe 5% for a currently merged translation
06:40:58 <Daisy> "The program grants Active Technical Contributor (ATC) status to anyone completing a commit to any program repository during the previous two release cycles. Core project team members may grant ATC to significant, non code-contributors for two cycles. "
06:41:03 <ujuc> http://governance.openstack.org/reference/charter.html#voters-for-tc-seats-atc
06:41:09 <ujuc> this... link
06:41:19 <Daisy> Thanks, ujuc . They are useful.
06:42:05 <Daisy> I think 5% is a big number, maybe 5% would be 25 strings, around 250 words. I don't know.
06:42:40 <Fdot> Daisy: 25 strings is not so much and it start to be a contribution
06:42:40 <ujuc> to bic.....
06:42:40 <Daisy> In Kilo release, there were 500+ new strings to Horizon. 5% is 25 strings, around 250 words.
06:43:07 <ujuc> um...
06:43:41 <Daisy> 200 words translation during the previous two release cycles ?
06:43:52 <Fdot> Daisy: +1 \o_
06:44:07 <katomo> +1
06:44:07 <adiantum> sounds good
06:44:09 <ujuc> +1
06:44:25 <DeeJay1> +1
06:44:34 <Daisy> :)
06:44:46 <DeeJay1> we can refine it later on, when we start getting the stats
06:44:54 <Daisy> Nice.
06:45:03 <Daisy> Thank you.
06:45:04 <adiantum> DeeJay1: agreed
06:45:36 <Daisy> #action: Daisy to send Transifex stats to each language team.
06:46:38 <Daisy> Do you think we publish these stats or not ? I mean, not only send to the coordinator, send out to the whole mailing list ?
06:47:22 <Daisy> It's bad that Transifex stats can only be reviewed by a few people.
06:47:44 <Daisy> Only project maintainer could see the stats, I think.
06:48:29 <Daisy> Hello?
06:48:30 <adiantum> let publish it - i think it's good idea
06:48:33 <DeeJay1> it denends on how they are anonimized
06:48:38 <ujuc> plubish.
06:48:48 <Daisy> :)
06:49:05 <Daisy> ok. Let's publish them.
06:49:10 <Fdot> Daisy: +1
06:49:18 <katomo> +1
06:49:20 <adiantum> DeeJay: good point, but some people don't publish their names on Transifex
06:49:25 <DeeJay1> on transifex people didn't sign the ICLA, giving away they names/addresses so IMHO from a legal standpoint it would be wiser to anonimize the data
06:50:10 <Daisy> OK. Then.
06:50:16 <adiantum> We can ask people with significant contribution for agreement to publish
06:50:21 <Daisy> Firstly, I will only publish to the core team.
06:50:36 <Fdot> Daisy: ok :)
06:50:52 <Daisy> Let's see the data at first, then we decide whether to publish them.
06:50:54 <DeeJay1> Daisy: ok, when we see what the data include we can decide
06:51:06 <Daisy> DeeJay1: +1
06:51:11 <adiantum> +1
06:51:13 * DeeJay1 seems to have a typo day :/
06:51:17 <ujuc> +1 :)
06:51:21 <Daisy> OK. great !
06:51:31 <Daisy> I have done my work.
06:51:33 <Fdot> Daisy: +1
06:51:36 <Daisy> #topic open discussion
06:52:23 <Daisy> Anything to discuss ?
06:52:34 <DeeJay1> enyone else misses Vancouver? ;)
06:52:42 <adiantum> i find on launchpad blueprint in stacalytics project about translation support
06:52:54 <Daisy> Yes, adiantum . I made it.
06:53:03 <DeeJay1> o7 amotoki!
06:53:06 <Daisy> You can assign to youself, if you want.
06:53:49 <adiantum> it would be great
06:54:14 <adiantum> but i want to ask - is there any kind of spec or something?
06:54:20 <Daisy> adiantum: do you have connects with Ilya Shakhat ?
06:54:46 <Daisy> adiantum: no...I think Carlos has a API spec.
06:54:47 <adiantum> not yet, but i know guys from Mirantis who know him
06:55:36 <katomo> good
06:55:49 <Daisy> adiantum: you could connect with him if you need his help on stackalytics codes.
06:56:01 <Daisy> Carlos has a Zanata API spec.
06:56:02 <adiantum> i mean we need some requirements for spec as starting point, i can create first iteration and then i think wew need to discuss
06:56:39 <Daisy> adiantum: I could write a requirement document.
06:56:58 <adiantum> Daisy: kewl!
06:57:51 <Daisy> There was a discussion with Ilya Shakhat, Carlos, Anish (the previous voluteer developer) in last release. I still remembered it. I could write it down.
06:58:26 <adiantum> Daisy: it will be nice =)
06:58:30 <Daisy> #action Daisy to write the requirements for translation metrics
06:58:53 <Daisy> OK then.
06:59:00 <Daisy> anything else to talk ?
06:59:16 <DeeJay1> we're out of time anyway :)
06:59:23 <adiantum> DeeJay1: missed Stanly Park :-)
06:59:23 <katomo> none
06:59:29 <ujuc> none
06:59:37 <Daisy> So we will close the meeting. Thank you for your attending.
06:59:41 <Daisy> We are a wonderful team !
06:59:43 <adiantum> thank you =)
06:59:48 <Fdot> Daisy: +1 :)
06:59:49 <katomo> thanks
06:59:50 <DeeJay1> thx!
06:59:54 <Fdot> Thanks you all :)
07:00:02 <Daisy> #endmeeting