13:00:24 <Daisy> #startmeeting OpenStack I18n Meeting
13:00:25 <openstack> Meeting started Thu Oct 15 13:00:24 2015 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:28 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:00:31 <AJaeger> \o/
13:00:38 <Daisy> who is around ?
13:00:45 <eumel8> hello
13:00:49 * loquacities is here
13:00:51 <Daisy> I see many i18n team IDs here.
13:00:54 <doug-fish> \o
13:00:55 <katomo> hello
13:01:15 <Daisy> Then let's start.
13:01:30 <Daisy> We have 5 topics to go through in this meeting.
13:01:46 <Daisy> #topic Discussion: document translation plan
13:02:25 <Daisy> We have successfully finished Liberty translations, with 13 languages translated for Horizon.
13:02:38 <Daisy> So I'd like to make our next translation plan.
13:02:39 <AJaeger> congrats!
13:02:51 <katomo> yay!
13:02:59 <loquacities> well done :)
13:03:08 <Daisy> If you go to Zanata, https://translate.openstack.org/, I will put our plans/priorities here.
13:03:30 <AJaeger> having that at the front page is really cool, thanks!
13:03:52 <Daisy> AJaeger and katomo: I need your suggestions for document translation plan. Which documents are ready and which should be in high priorities ?
13:04:06 <Daisy> I don't know if Lana is here. :)
13:04:07 <katomo> install guides
13:04:08 <AJaeger> From your communities, what kind of audience needs translated documents best?
13:04:13 <loquacities> Daisy: i'm here :)
13:04:42 * loquacities is Lana
13:04:43 <AJaeger> 1) People running guests in a setup cloud, 2) admins setting up the cloud or 3) developers interacting with a cloud ?
13:04:44 <Daisy> Oh, I didn't recognise your ID, loquacities
13:04:54 <loquacities> no trouble :)
13:05:07 <loquacities> so, yes, katomo is correct: install guides are the main ones
13:05:29 <AJaeger> taht would be part of the 2) admins
13:05:32 <Daisy> I think 1 and 2 are high priorities, for me.
13:05:40 <Daisy> What is 1, AJaeger ?
13:05:54 <Daisy> So end users ?
13:05:56 <AJaeger> 1 would be Image Guide or the End User guide
13:06:00 <AJaeger> yes, end users
13:06:16 <AJaeger> Daisy: people using HOrizon and python clients ;)
13:06:17 <katomo> yeah, and "admin user guide"
13:06:52 <loquacities> +1
13:07:11 <loquacities> image guide is high on website hits
13:07:29 <katomo> hmmm
13:07:37 <Daisy> I know Chinese translators like to translate end user guide at first.
13:07:51 <loquacities> yes, i think end user guide is a good option
13:07:56 <Daisy> They have translated image guide, as far as I know.
13:08:14 <katomo> great
13:08:29 <AJaeger> Note that Install Guide is branched for Liberty, End User Guide and Admin User Guide are published always from trunk.
13:08:30 <Daisy> ujuc: are you there ?
13:08:47 <katomo> Japanese team have, too :)
13:08:49 <AJaeger> WE can handle translations on Liberty branch as well now thanks to Zanata (later topic AFAIR)
13:08:59 <ujuc> hi
13:09:02 <ujuc> sorry.;;;
13:09:13 <AJaeger> loquacities: do we want to push Image Guide first to RST before we put translation focus on it?
13:09:32 <loquacities> AJaeger: yes, that's probably a good idea
13:09:45 <loquacities> i don't think any speciality team has plans to do that at this stage, though
13:09:55 <loquacities> the next one to be converted is ops guide
13:10:05 <Ianychoi0> h
13:10:06 <loquacities> but i can ask at summit if people want to convert the image guide
13:10:08 <Daisy> You mean, Image Guide are still in DocBook format ?
13:10:13 <loquacities> probably could use some love ...
13:10:18 <Ianychoi0> sorry i am in outdisde
13:10:25 <AJaeger> Daisy, correct. Therefore let's not put focus on it for now...
13:10:32 <loquacities> +1
13:10:44 <loquacities> i think install guide + user guides is the best option
13:10:52 <Daisy> Ianychoi0 and ujuc: I want to understand which one is high priority for Korean team: 1) People running guests in a setup cloud, 2) admins setting up the cloud  ?
13:10:56 * AJaeger agree with loquacities
13:10:56 <katomo> +1
13:11:09 <ujuc> I think 2
13:11:23 <Daisy> 1 is for end users, and 2 is for admins.
13:11:39 <AJaeger> Install Guide also changes heavily with every release, so you're always behind ...
13:12:01 <Ianychoi0> i totally agree with ujuc
13:12:14 <ujuc> AJaeger +1 too hard
13:12:31 <Daisy> I think the admin to install Openstack will be behind
13:12:34 <Daisy> too.
13:12:50 <loquacities> translations will *always* be behind
13:12:54 <amotoki> hi
13:12:57 <Daisy> So guys, do you want us to put installation guide as high priority ?
13:12:58 <loquacities> it's a question of how far behind ...
13:13:22 <Daisy> If we want to translate installation guide, I hope we could finish it in 3 month.
13:13:36 <loquacities> installation guide is the most popular book we have
13:14:07 <Daisy> after Liberty officially release, till the first stable release made, I guess there will be some monthes.
13:14:42 <amotoki> As FYI, you can add your translated docs draft to http://docs.openstack.org/draft/draft-index.html
13:15:14 <amotoki> it would be helpful if translation progress reaches to some level.
13:16:15 <Daisy> ujuc and katomo: let's vote
13:16:39 <Daisy> installation guide as the high priority ?
13:16:45 <Daisy> agree or not ?
13:16:53 <ujuc> aggre!
13:16:56 <Daisy> :)
13:17:08 <Daisy> I think katomo will support too.
13:17:11 <katomo> +1 high
13:17:32 <Daisy> So I will add installation guide as high priority in the homepage of Zanata.
13:17:38 <loquacities> \o/
13:17:46 <katomo> yay
13:17:46 <Daisy> So we are done with the first topic
13:17:56 <amotoki> yay
13:18:02 <ujuc> yap
13:18:02 <Daisy> #topic Stackalytics (translation activity metrics) : Go Austin!
13:18:31 <Daisy> I have to say, I spent some time on the code dev, but don't have good progress.
13:18:45 <katomo> ohhh ...
13:18:51 <Daisy> I mean, the translation metric in Stackalytics
13:19:06 <Daisy> There is a issue with the current Zanata API.
13:19:28 <Daisy> The copied translations will not be included in translator's credit.
13:20:00 <katomo> hmmm
13:20:08 <katomo> not count?
13:20:38 <amotoki> what does "copied" mean?
13:20:46 <katomo> I think credit itself is not a matter.
13:20:49 <Daisy> During Liberty translations, do you remember we fixed Russian plural issue ? I created a empty version, and upload new Russian po files with the corrent plural setting, and copied the stable-liberty to the new version.
13:21:29 <amotoki> can we get statistics per version?
13:21:33 <Daisy> All copied translations from stable-liberty to the new version are not included in your translation credit.
13:21:48 <doug-fish> katomo: keeping accurate credit is important to me
13:21:58 <doug-fish> we work with other companies to complete translations
13:22:01 <amotoki> generally speaking, the current behavior sounds reasonable.
13:22:18 <Daisy> Yes, Zanata provide API per version, but we could accumulate them by program.
13:22:24 <doug-fish> having the work of a translator we are working with would be very disruptive
13:22:47 <doug-fish> that is.. having teh work of a translator we are working with not credited properly would be very disruptive
13:23:05 <Daisy> so the translator contribution numbers are not correct in Horizon now. But other projects are fine.
13:23:28 <katomo> hmmm
13:23:32 <Daisy> I have tested REST API, and ask katomo help to verify.
13:23:32 <amotoki> hmm...
13:23:41 <Daisy> The data for Horizon is not correct, but other projects are fine.
13:23:58 <Daisy> That is because I made a copy during Liberty translation.
13:24:06 <katomo> Unfortunately, we have already lost many many credits AFAIK.
13:24:23 <amotoki> most/half of horizon translations have been done in transifex and some of them are made in master version before branching.
13:24:35 <Daisy> Yes, katomo. Horizon is the most important project in Liberty translation.
13:25:08 <amotoki> can we collect trans stats for both master and stable-liberty?
13:25:22 <Daisy> I have asked Zanata team to provide more features to their statistic API , to return more data.
13:25:24 <Daisy> https://zanata.atlassian.net/browse/ZNTA-725
13:25:33 <amotoki> If we can gather stats for a specific period, i think it works.
13:25:40 <Daisy> Then we could calculate the correct data by program.
13:26:11 <Daisy> amotoki: You get it. Yes, I think I will calculate both master and stable, and add them together.
13:26:18 <doug-fish> Are the number of reviews/rejects already provided through the Zanata REST API?
13:27:35 <Daisy> Reviews and rejects are provided by Zanata API.
13:27:54 <Daisy> Approved number and rejected number are provided by Zanata REST API.
13:28:03 <doug-fish> oh super - I didn't know that!
13:28:16 <katomo> good news :)
13:29:01 <amotoki> Daisy and katomo and volunteers continue the discussion?
13:29:05 <Daisy> So I think the plan is to have stackalyatics feature in next release. and we need developers.
13:29:22 <Daisy> I need developers who know Python.
13:29:25 <Daisy> who could help ?
13:29:33 <Daisy> help to work on stackalyatics feature.
13:29:35 <katomo> yes.
13:30:04 <amotoki> i can help but no for near term (this month)
13:30:06 <katomo> how about continue at Tokyo Summit.
13:30:22 <Daisy> continue at Tokyo Summit ?
13:30:26 <Daisy> continue the discussion ?
13:30:29 <Daisy> Nice suggestion.
13:31:04 <Daisy> So let's close it for now.
13:31:20 <Daisy> #topic Translation check site (dashboard)
13:31:47 <Daisy> katomo: what do you want to talk here ?
13:32:11 <amotoki> btw, today's agenda is here https://wiki.openstack.org/wiki/Meetings/I18nTeamMeeting#Next_meetings  (it seems not announced at the beginning)
13:32:13 <katomo> I have completely lost the status
13:32:20 <katomo> someone know?
13:32:47 <Daisy> katomo: what I know is the spec is approved and infra people could start the real work.
13:32:52 <katomo> If no one, I will comfirm to infra team as action item.
13:33:01 <Daisy> katomo: please help.
13:33:03 <amotoki> katomo: +1
13:33:08 <katomo> ohhh. good job!
13:33:21 <katomo> Daisy: sure
13:33:27 <Daisy> katomo: Thank you.
13:33:59 <Daisy> #action katomo to follow up with the lastest status of translation check website.
13:34:01 <doug-fish> pleia2: clarkb any chance either of you are around and know of the translation check site progress?
13:34:32 <Daisy> While we are waiting for their response, let's go to next topic.
13:34:40 <doug-fish> sure
13:34:46 <Daisy> #topic Get rid of Openstack projects in transfix.com
13:34:55 <doug-fish> (I'm not sure they will response, I think this is an awkward time for them)
13:35:07 <Daisy> Do we want to git rid of OpenStack projects in transfix.com now?
13:35:09 <AJaeger> spec is here for the translation site http://specs.openstack.org/openstack-infra/infra-specs/specs/translation_check_site.html
13:35:17 <AJaeger> So, somebody needs to start doing it
13:35:28 <AJaeger> Assignee is "Łukasz Jernaś <deejay1@srem.org>"
13:35:36 <Daisy> There are tens of requests to join the team.
13:36:10 <Daisy> AJaeger: I cannot image deejay1 is the assignee.
13:36:28 <AJaeger> Daisy: That's what is written in the approved spec that he wrote...
13:36:33 <amotoki> do we need a new volunteer?
13:36:42 <AJaeger> If that'S wrong, we need to change it.
13:37:01 <Daisy> I think it's wrong, deejay1 should be the requestor.
13:37:33 <amotoki> "assignee" in the spec means who actually work on it. If he is not available, we need a volunteer to step up.
13:38:04 <Daisy> do we need a guy from infrastructure team ? or somebody from i18n team ?
13:38:04 <AJaeger> Daisy: best to discuss in Tokyo with infra team face to face!
13:38:11 <Daisy> Nice suggestion, AJaeger.
13:38:19 <katomo> +1
13:38:27 <AJaeger> Daisy: anybody can do that, if it'S somebody from i18n team, infra team will help.
13:38:29 <amotoki> sounds good.
13:38:39 <Daisy> ok.
13:38:53 <ujuc> +1
13:38:55 <ujuc> :)
13:39:18 <Daisy> we have set "not accept translations" for some active project in Transifex.
13:39:27 <amotoki> Daisy: could you send #undo? we are discussing the previous topic.
13:39:44 <Daisy> There are still tens of requests to join team in transifex.
13:39:55 <mariantb> Daisy there're many requests to join the Spanish team coming from Transifex, I always send the person a message telling him/her to go to Zanata. Not always works though...
13:40:21 * AJaeger rejects 1 or 2 requests for new languages every week with a friendly message to the requestor to join us on zanata
13:40:24 <Daisy> #undo katomo to follow up with the lastest status of
13:40:25 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x8f43d50>
13:40:29 <AJaeger> mariantb: thanks!
13:41:04 <Daisy> do you agree we remove projects from Transifex ?
13:41:14 <Daisy> vote +1 or -1 ?
13:41:24 <katomo> -1 ...
13:41:28 <Daisy> :)
13:41:37 <AJaeger> could you explain -1 votes, please?
13:41:42 <katomo> we lost translator credits...
13:41:46 <amotoki> -1 for at least Horizon, both ok for others.
13:41:51 <katomo> and history
13:41:57 <amotoki> history too.
13:42:15 <ujuc> -1......
13:42:16 <Daisy> Here is my plan for the pending requests: asking coordinators to send friendly emails to those requester.
13:42:28 <amotoki> at least I would like to have the previous release (kilo) for horizon.
13:43:17 <katomo> Daisy: okay. friendly :)
13:43:25 <amotoki> if your lang team and your local community has a ML or similar way, it is better to accounce.
13:44:00 <amotoki> *to announce Zanata migration to it.
13:44:08 <Daisy> AJaeger: maybe we could add the information some place in transifex project.
13:44:32 <Daisy> I will figure out where to add the information.
13:44:39 <AJaeger> tahnks, Daisy
13:44:50 <amotoki> what I am not sure is how new translators got information.
13:45:07 <Daisy> #action Daisy to handle Transfiex affairs.
13:45:56 <Daisy> we have to stop this topic here.
13:46:10 <Daisy> Let's move to next topic
13:46:20 <Daisy> #topic Versioning of installation guide
13:46:27 <Daisy> amotoki: it's your turn.
13:46:29 <amotoki> this topic is from katomo and me.
13:46:49 <amotoki> The installation guide has a branch in the upstream.
13:47:11 <amotoki> Do we have Zanata version for liberty for the installation guide?
13:47:20 <amotoki> s/Do/Can/
13:47:22 <Daisy> AJaeger: please help to answer.
13:47:23 <AJaeger> amotoki: not yet, since we haven't branched in git.
13:47:36 <AJaeger> amotoki: but we can do this - like we did for Horizon.
13:47:47 <amotoki> AJaeger: yes. We have branches for stable releases.
13:48:01 <AJaeger> happy to set this up.
13:48:06 <amotoki> liberty does not exist yet.
13:48:15 <Daisy> +1 for version management for installation guide.
13:48:42 <AJaeger> amotoki: Doc team will create a liberty branch in a few weeks.
13:48:50 <AJaeger> And then we add it in Zanta.
13:48:54 <Daisy> I believe we should have the same versioning management in documents, just as what we did with codes.
13:49:08 <amotoki> AJaeger: sounds perfect.
13:49:10 <AJaeger> Daisy: YES. But we branch *6 weeks* later than other projects ;)
13:49:21 <amotoki> Daisy: but most documentations are not branched.
13:49:22 <ujuc> :)
13:49:23 <katomo> great
13:49:29 <loquacities> yes, we take our time ;)
13:49:32 <Daisy> AJaeger: one question, installation guide is in openstack-manuals project
13:49:54 <AJaeger> We only branch install guides and config reference - and I advise not to translate the later
13:49:57 <AJaeger> Daisy: Yes, it is
13:50:14 <Daisy> ok.
13:50:43 <AJaeger> So, let's write down as action: Create a liberty branch in Zanata once the docs team created one and translate Install Guide only there.
13:51:04 <Daisy> action to you, AJaeger?
13:51:13 * AJaeger takes it
13:51:18 <loquacities> +1
13:51:26 <katomo> thanks!!
13:51:32 <amotoki> Agree. thanks AJaeger.
13:51:42 <AJaeger> So, for now continue translation Install Guide in *master* - it is still Liberty!
13:51:51 <Daisy> Create a liberty branch in Zanata once the docs team created one
13:52:10 <Daisy> #action AJaeger to create a liberty branch in Zanata once the docs team created one
13:52:31 <amotoki> Should we make the master version read-only when liberty branch is created?
13:52:38 <AJaeger> loquacities: I'll add this to our releases wiki as reminder ;)
13:52:39 <Daisy> good question.
13:52:47 <loquacities> thank you AJaeger, good idea :)
13:53:03 <AJaeger> amotoki: we cannot - since other guides like User Guide are only on master
13:53:03 <Daisy> amotoki: what's your idea ? do you want to make master read-only ?
13:53:32 <amotoki> AJaeger: I am talkng about Zanata branch (version).
13:54:01 <Daisy> I think, AJaeger means the master version in Zanata has other manuals.
13:54:09 <Daisy> not only intallation guide.
13:54:28 <AJaeger> Correct, Daisy .
13:54:39 <amotoki> ah... i see.
13:54:57 <Daisy> will it be an issue to you, amotoki ?
13:55:00 <amotoki> From my experience on Zanata in Liberty, if you focus on transaltions of liberty version of the installation guide, it is better to mark Zanata master version of the install guide read-only
13:55:16 <amotoki> until one or two months before mitaka release.
13:55:26 <amotoki> I am not sure we can do that.
13:55:26 <Daisy> We are not able to set read-only to a single document.
13:55:39 <amotoki> Daisy: got it.
13:56:03 <amotoki> If so, what we can do  is to do the best to announce it!
13:56:06 <Daisy> AJaeger: I see there are a lot of cookbook- repos in git now. Are you going to separate manuals into different repo ?
13:56:40 <Daisy> split openstack-manuals into different repo ?
13:56:47 <AJaeger> Daisy: cookbook are chef repos, nothing to do with manuals.
13:56:54 <Daisy> ok. got it.
13:57:02 <AJaeger> And no , there are no plans to split up openstack-manuals currently...
13:57:05 <Daisy> I think it's good to split them...
13:57:21 <Daisy> ok.
13:57:39 <Daisy> we have 3 minutes now.
13:57:42 <amotoki> The summary of this topic are: (1) create a version for liberty (mainly for installatuion guide translation)
13:57:49 <AJaeger> WE share a lot of files between manuals, if we split up we need to keep them in sync, this will soon become a mess.
13:58:06 <amotoki> and (2) we cannot mark the master version read-only because it is a per-project setting.
13:58:37 <Daisy> amotoki: I will ask Zanata team if it's able to set Readonly to a single document.
13:59:00 <amotoki> Daisy: thanks. we seem a heavy user of zanata now.
13:59:10 <katomo> :)
13:59:15 <Daisy> one of the two big users of Zanata.
13:59:28 <Daisy> the other one is fedora, I remember.
13:59:37 <amotoki> exactly
13:59:40 <katomo> yes
13:59:50 <Daisy> I have to close the meeting now. Time is up.
14:00:09 <Daisy> Thank you for attending. We had a good discussion in the last one hour.
14:00:22 <amotoki> if necessary let's continue in -i18n list or #-i18n channel.
14:00:30 <katomo> thanks all
14:00:33 <Daisy> Thank you, loquacities, for keeping awake in your late night.
14:00:37 <loquacities> thank you Daisy, everyone :)
14:00:39 <loquacities> no trouble
14:00:39 <mariantb> thanks Daisy and the rest
14:00:40 <ujuc> :)
14:00:44 <loquacities> iit's always nice to join you :)
14:00:48 <Daisy> #endmeeting