07:17:06 <ianychoi> #startmeeting OpenStack I18n Meeting
07:17:07 <openstack> Meeting started Thu Nov 3 07:17:06 2016 UTC and is due to finish in 60 minutes. The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:17:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:17:10 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:17:33 <ianychoi> Hello Daisy!
07:17:40 <Daisy> Hi, ianychoi !
07:17:47 <ianychoi> I met zzxwill last week :)
07:17:58 <Daisy> I heard that.
07:18:21 <Daisy> Nice to have your two meet at Barcelona
07:18:46 <ianychoi> Aha :)
07:19:16 <ianychoi> #topic Actions from Barcelona i18n contributor meetup
07:19:54 <ianychoi> And also yesterday zzxwill asked me about Zanata user list for releases..
07:20:42 <Daisy> ok
07:20:52 <Daisy> Are we able to have this information now?
07:21:08 <ianychoi> Regarding this, currently zanata_stats.py from Daisy and Stackalytics will partly address to calculate statistics
07:21:55 <ianychoi> Assuming Zanata users are just accumulated (no people deregister accounts), then zanata_stats.py can calculate stats for specific period
07:22:15 <Daisy> Yeah, I remember that.
07:22:26 <ianychoi> But IMO to use this tool would not be familiar with translators
07:23:15 <ianychoi> Receltly, I have found that Stackalytics stats with language filters for translations does not work
07:23:17 <ianychoi> #link http://stackalytics.com/?metric=translations&language=chinese%20(china)
07:24:12 <Daisy> wow, it's bad that it doesn't work.
07:24:23 <ianychoi> I asked Ilya from Stackalytics team to fix... :)
07:24:24 <Daisy> Do you know what is wrong?
07:24:28 <Daisy> ok.
07:25:06 <ianychoi> Not sure yet.. but IMO language filter name is full language name but data is locale name: zh_CN, ko_KR, ...
07:25:17 <ianychoi> Currently release filter is fine.
07:26:07 <ianychoi> If language filter is fixed, the the following url will work well:
07:26:09 <ianychoi> #link http://stackalytics.com/?metric=translations&language=chinese%20(china)&release=newton
07:26:56 <Daisy> ok.
07:27:23 <ianychoi> Including this, there were so many discussions on last i18n contributors meetup
07:27:25 <ianychoi> #link https://etherpad.openstack.org/p/barcelona-i18n-meetup
07:27:50 <ianychoi> I will read again and define actions :)
07:28:18 <ianychoi> #action ianychoi will review action items from Barcelona i18n meetup and define subsequent actions
07:29:09 <ianychoi> Regarding this, could you approve my request on openstack-18n launchpad team: https://launchpad.net/~openstack-i18n-core
07:29:36 <ianychoi> ? It is needed to set importance for bugs I think
07:30:44 <Daisy> ok
07:31:07 <Daisy> ianychoi: I will see if I can pass the team owner to you.
07:31:43 <ianychoi> Thank you but IMO I prefer your ownership, since you're i18n team initiator :)
07:32:36 <ianychoi> Anyway thanks :)
07:33:37 <ianychoi> #topic logs-* translation jobs for oslo
07:33:45 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-i18n/2016-October/002564.html
07:34:40 <ianychoi> #info Please write opinions on this mail. i18n will decide actions by the next week or sooner
07:35:03 <ianychoi> #topic how to indicate non-translatable identifiers
07:35:21 <ianychoi> Daisy, do you have some idea on http://lists.openstack.org/pipermail/openstack-dev/2016-November/106580.html ?
07:35:53 <Daisy> ianychoi: Let me go through the email.
07:36:06 <ianychoi> Daisy, thank you :)
07:39:11 <Daisy> ianychoi: I think using quotation mark is an easy way to mark the words which should not be translated.
07:39:36 <Daisy> But I'm not sure if there are some cases that words in quotation mark should be translated.
07:40:06 <ianychoi> Daisy, how about one suggestion from http://lists.openstack.org/pipermail/openstack-dev/2016-November/106598.html ?
07:40:49 <Daisy> Adding translation comments can pass more information to translators from developers.
07:41:20 <ianychoi> Yep but Doug Hellman said enhancing tool chains is needed.
07:41:33 <Daisy> what does he mean ?
07:42:46 <ianychoi> From my understanding, it would be much better if the original source describes notes for translators
07:43:28 <ianychoi> e.g., help=_("Authentication strategy ('keystone' or 'noauth').",note="'keystone' and 'noauth' is keywords")
07:44:12 <ianychoi> Then a tool which extracts po files from original sources need to understand "note=" argument and need to write po file with translation notes
07:44:22 <Daisy> I wonder if we can set any rules within the team, for example, don't translate any words in capital. If developers don't want to translate some words, write them in capital.
07:45:41 <ianychoi> Daisy, it means.. guideline for translation right?
07:45:56 <ianychoi> And documenting to i18n contributor guide
07:53:39 <ianychoi> Daisy, I will try to eumerage and list up several rules and/or guidelines :) Thank you today!
07:53:46 <ianychoi> s/eumerage/eumerage
07:53:49 <ianychoi> s/eumerage/eumerate
07:54:03 <ianychoi> s/eumerage/enumerate....
07:54:58 <ianychoi> #topic Open discussions
07:55:13 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-docs/2016-November/009294.html
07:56:01 <ianychoi> #info FYI: Please see more details on AUC (Active User Contributor)
07:56:39 <ianychoi> I think some i18n contributors satisfy some criteria for AUC
07:56:58 <ianychoi> Daisy, Thanks a lot today! I would like to finish the meeting :)
07:58:08 <ianychoi> #endmeeting